Add the seahaven towers game. This is yet another solitare games, but

this one makes you think.  While an implementation exists in pysol,
this one is better in many subtle ways.
This commit is contained in:
Warner Losh 1998-12-24 05:51:21 +00:00
parent 747178be68
commit 679ed33c5a
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=15550
7 changed files with 75 additions and 1 deletions

View File

@ -1,4 +1,4 @@
# $Id: Makefile,v 1.175 1998/12/14 21:44:03 jseger Exp $
# $Id: Makefile,v 1.176 1998/12/17 14:36:06 flathill Exp $
#
SUBDIR += 3dc
@ -69,6 +69,7 @@
SUBDIR += qstat
SUBDIR += quakeserver
SUBDIR += seabattle
SUBDIR += seahaven
SUBDIR += sokoban
SUBDIR += spellcast
SUBDIR += spider

19
games/seahaven/Makefile Normal file
View File

@ -0,0 +1,19 @@
# New ports collection makefile for: seahaven
# Version required: 1.04
# Date created: 23 Dec 1998
# Whom: imp
#
# $Id:$
#
DISTNAME= seahaven-1.04
PKGNAME= seahaven-1.04
CATEGORIES= games
MASTER_SITES= http://www.cinenet.net/users/spitzak/seahaven/
EXTRACT_SUFX= .tgz
MAINTAINER= imp@FreeBSD.ORG
GNU_CONFIGURE= yes
.include <bsd.port.mk>

1
games/seahaven/distinfo Normal file
View File

@ -0,0 +1 @@
MD5 (seahaven-1.04.tgz) = 8af5313ea9b27161acd6861772d1e4e8

View File

@ -0,0 +1,48 @@
diff -ru Makefile seahaven-1.04/Makefile
--- Makefile Tue Dec 22 11:07:19 1998
+++ seahaven-1.04/Makefile Wed Dec 23 14:00:23 1998
@@ -13,6 +13,8 @@
OBJECTS = $(CXXFILES:.C=.o)
+all: $(PROGRAM)
+
$(PROGRAM) : $(OBJECTS)
$(CXX) $(CXXFLAGS) -o $(PROGRAM) $(OBJECTS) $(LIBS) $(LDLIBS)
@@ -39,11 +41,11 @@
install: $(PROGRAM)
$(INSTALL) -s $(PROGRAM) $(bindir)/$(PROGRAM)
- $(INSTALL) $(PROGRAM).$(MANPAGE) /usr/man/man$(MANPAGE)/$(PROGRAM).$(MANPAGE)
+ $(INSTALL) $(PROGRAM).$(MANPAGE) $(mandir)/man$(MANPAGE)/$(PROGRAM).$(MANPAGE)
uninstall:
-@ rm -f $(bindir)/$(PROGRAM)
- -@ rm -f /usr/man/man$(MANPAGE)/$(PROGRAM).$(MANPAGE)
+ -@ rm -f $(mandir)/man$(MANPAGE)/$(PROGRAM).$(MANPAGE)
dist:
cat /dev/null > makedepend
diff -ru makeinclude.in seahaven-1.04/makeinclude.in
--- makeinclude.in Wed Nov 18 12:11:30 1998
+++ seahaven-1.04/makeinclude.in Wed Dec 23 13:59:49 1998
@@ -3,6 +3,7 @@
prefix =@prefix@
exec_prefix =@exec_prefix@
bindir =@bindir@
+mandir =@mandir@
includedir =@includedir@
libdir =@libdir@
srcdir =@srcdir@
diff -ru stack.C seahaven-1.04/stack.C
--- stack.C Thu Nov 19 23:59:27 1998
+++ seahaven-1.04/stack.C Wed Dec 23 13:58:55 1998
@@ -10,7 +10,6 @@
#include <sys/time.h> // For time()
#include <math.h> // For random()
-#include <malloc.h>
#include <stdlib.h>
#include <X11/cursorfont.h>

View File

@ -0,0 +1 @@
The classic, lightweight version of Seahaven Towers

2
games/seahaven/pkg-descr Normal file
View File

@ -0,0 +1,2 @@
seahaven is an X implementation of a solitaire game sometimes known as
Seahaven Towers.

2
games/seahaven/pkg-plist Normal file
View File

@ -0,0 +1,2 @@
bin/seahaven
share/man/man6/seahaven.6