Update to 2.4.98b.

This is done over PR ports/34472

PR:		ports/37130
Submitted by:	maintainer
This commit is contained in:
SADA Kenji 2002-05-10 20:30:14 +00:00
parent dd251bcde3
commit 6790d79e77
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=58882
6 changed files with 68 additions and 56 deletions

View File

@ -6,10 +6,9 @@
#
PORTNAME= elm+ME
PORTVERSION= 2.4.96${PATCHLEVEL}
PORTREVISION= 1
PORTVERSION= ${ELM_VERSION}.${ELM_REVISION}${ELM_PATCHLEVEL}
CATEGORIES= mail
DISTNAME= ${PORTNAME:S/+ME//}-${PORTVERSION:R}ME+${PORTVERSION:E:S|${PATCHLEVEL}||}
DISTNAME= elm-${ELM_VERSION}ME+${ELM_REVISION}
# here are the main repositories.
MASTER_SITES= ftp://ftp.ozone.fmi.fi/KEH/ \
@ -25,10 +24,9 @@ MASTER_SITES+= ftp://ftp.lip6.fr/pub/unix/mail/elm-me/ \
# MASTER_SITES+= ftp://ftp.unina.it/pub/Unix/pkgs/network/mail/elm-me+/ \
# ftp://ftp.rge.com/pub/mail/elm/elm-2.4ME+/ \
# ftp://ftp.uni-trier.de/pub/unix/network/mail/elm-me+/
PATCH_SITES= ${MASTER_SITES}
PATCHFILES= ${DISTNAME:S/+/+PL/}a.patch.gz \
${DISTNAME:S/+/+PL/}b.patch.gz
PATCHLEVEL= b
PATCHFILES= # see below.
PATCH_DIST_STRIP= -p1
MAINTAINER= cyrille.lefevre@laposte.net
@ -56,9 +54,6 @@ CONFIGURE_ARGS= -S -P ${PREFIX}
MAKE_ENV= MJ="FORMATTER=groff FORMATTER_OPTS=-Tlatin1"
ALL_TARGET= all documentation
# hack! don't know why but it's needed.
MAKEFILE= Makefile
INSTALLS_SHLIB= yes
LDCONFIG_DIRS= %%PREFIX%%/%%SHLIB_SUBDIR%%
@ -74,6 +69,20 @@ MLINKS= frm.1 nfrm.1 newmail.1 wnewmail.1
# Local variables
#
ELM_VERSION= 2.4
ELM_REVISION= 98
ELM_PATCHLEVEL= b
ELM_PATCHDONE= false
.for level in a b c d e f
.if ${ELM_PATCHDONE} == false
PATCHFILES+= ${DISTNAME:S/+/+PL/}${level}.patch.gz
.endif
.if ${ELM_PATCHLEVEL} == ${level}
ELM_PATCHDONE= true
.endif
.endfor
# evaluation should be protected 'til extraction to avoid noisy messages.
SO_REV= $$([ -f ${WRKSRC}/hdrs/patchlevel.h ] && \
${AWK} '/SHAREDTAG:/{print $$2}' ${WRKSRC}/hdrs/patchlevel.h)

View File

@ -1,3 +1,3 @@
MD5 (elm-2.4ME+96.tar.gz) = 512c4ab96eb13b95065396c93e2c5bdb
MD5 (elm-2.4ME+PL96a.patch.gz) = ed18d1113734874faf160f72e05be0e0
MD5 (elm-2.4ME+PL96b.patch.gz) = 1579052ae1e3adb3028b6876466587d5
MD5 (elm-2.4ME+98.tar.gz) = fa75d7ce8cf6fbbba864a029b846a2c5
MD5 (elm-2.4ME+PL98a.patch.gz) = fe7b89436aae9cb8d82ccb304d432ebe
MD5 (elm-2.4ME+PL98b.patch.gz) = 8f2aed9d2b27259203038adb16134882

View File

@ -1,5 +1,5 @@
--- nls/Makefile.orig Fri Dec 29 20:56:45 2000
+++ nls/Makefile Sat Jan 6 23:21:16 2001
--- nls/Makefile.orig Wed Mar 20 08:04:46 2002
+++ nls/Makefile Tue Apr 16 04:58:53 2002
@@ -3,7 +3,7 @@
#
LANGFILE=LANGS
@ -12,7 +12,7 @@
@@ -44,7 +44,7 @@
./Install $(LANGFILE) $(GENCAT) $(CATNAME)
$(HFILES): $(MFILES)
$(HFILES): $(MFILES) gencat/gencat
- gencat/gencat $(MSGCAT) "$(SDIR)/`basename $@ .h`".m -h $@
+ $(GENCAT) $(MSGCAT) "$(SDIR)/`basename $@ .h`".m -h $@

View File

@ -1,5 +1,5 @@
--- Configure.orig Fri May 10 09:26:47 2002
+++ Configure Fri May 10 09:29:55 2002
--- Configure.orig Sat Jan 19 01:18:12 2002
+++ Configure Sat Jan 19 17:19:40 2002
@@ -84,10 +84,10 @@
yes)
;;
@ -8,10 +8,10 @@
- echo "Say 'sh Configure', not 'sh <Configure'"
- exit 1
- fi
+# if test ! -t 0; then
+# echo "Say 'sh Configure', not 'sh <Configure'"
+# exit 1
+# fi
+# if test ! -t 0; then
+# echo "Say 'sh Configure', not 'sh <Configure'"
+# exit 1
+# fi
;;
esac

View File

@ -1,39 +1,39 @@
--- src/newmbox.c.orig Sun Aug 19 07:24:27 2001
+++ src/newmbox.c Sun Aug 19 07:25:50 2001
@@ -585,6 +585,36 @@
}
--- src/newmbox.c.orig Wed Mar 20 08:04:48 2002
+++ src/newmbox.c Tue Apr 16 05:02:54 2002
@@ -422,6 +422,36 @@
}
if (NULL != (tmphdr = locate_header_by_name(parsed_headers,
+ "Newsgroups"))) {
+ struct addr_item * addrs =
+ break_down_address(tmphdr->body,
+ !(current_header -> status &
+ NOHDRENCODING) &&
+ is_rfc1522(tmphdr->body),
+ current_header->header_charset);
+
+ if (addrs) {
+ if (current_header->to)
+ free_addr_items(current_header->to);
+ current_header->to = addrs;
+
if (NULL != (tmphdr = locate_header_by_name(parsed_headers,
+ "Newsgroup"))) {
+ struct addr_item * addrs =
+ break_down_address(tmphdr->body,
+ !(current_header -> status &
+ NOHDRENCODING) &&
+ is_rfc1522(tmphdr->body),
+ current_header->header_charset);
+
+ if (addrs) {
+ if (current_header->to)
+ free_addr_items(current_header->to);
+ current_header->to = addrs;
+
+#if DEBUG
+ if (Debug.active > 10) {
+ struct addr_item * p;
+ for (p = current_header->to; p->addr; p++) {
+ DPRINT(Debug,15,(&Debug,
+ "-- newsgroup[%d] addr='%s' comment='%S' fullname='%S'\n",
+ p - current_header->to,
+ p->addr,
+ p->comment,
+ p->fullname));
+ }
+ }
+#endif
+ }
+ if (Debug.active > 10) {
+ struct addr_item * p;
+ for (p = current_header->to; p->addr; p++) {
+ DPRINT(Debug,15,(&Debug,
+ "-- newsgroup[%d] addr='%s' comment='%S' fullname='%S'\n",
+ p - current_header->to,
+ p->addr,
+ p->comment,
+ p->fullname));
+ }
+ }
+#endif
+ }
+ }
+
+ if (NULL != (tmphdr = locate_header_by_name(parsed_headers,
"Cc"))) {
struct addr_item * addrs =
break_down_address(tmphdr->body,
+ if (NULL != (tmphdr = locate_header_by_name(parsed_headers,
"Cc"))) {
struct addr_item * addrs =
break_down_address(tmphdr->body,

View File

@ -307,6 +307,9 @@ suffix=''
packer=''
optimize='${CFLAGS}'
ccflags='${DEBUG}'
picflag='-fPIC'
nopic=''
shared_extra=''
cppflags=''
ldflags='-s'
cc='cc'