upgrade to 0.26
drop maintainership
This commit is contained in:
parent
5bac093e43
commit
676731ee70
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=46020
@ -7,31 +7,27 @@
|
||||
#
|
||||
|
||||
PORTNAME= genpak
|
||||
PORTVERSION= 0.25
|
||||
PORTVERSION= 0.26
|
||||
CATEGORIES= biology
|
||||
MASTER_SITES= http://www.bioinformatics.org/genpak/download/
|
||||
DISTNAME= gp-${PORTVERSION}
|
||||
EXTRACT_SUFX= .tgz
|
||||
|
||||
MAINTAINER= ijliao@FreeBSD.org
|
||||
MAINTAINER= ports@FreeBSD.org
|
||||
|
||||
LIB_DEPENDS= gd.2:${PORTSDIR}/graphics/gd \
|
||||
png.4:${PORTSDIR}/graphics/png
|
||||
|
||||
USE_GMAKE= yes
|
||||
MAKE_ENV= GMAKE="${GMAKE}" MANPREFIX="${MANPREFIX}"
|
||||
|
||||
MAN1= Genpak.1 gp_acc.1 gp_cusage.1 gp_digest.1 gp_dimer.1 gp_findorf.1 \
|
||||
gp_gc.1 gp_getseq.1 gp_matrix.1 gp_mkmtx.1 gp_pattern.1 gp_qs.1 \
|
||||
gp_randseq.1 gp_seq2prot.1 gp_slen.1 gp_tm.1 gp_trimer.1 gp_primer.1
|
||||
MAN1= Genpak.1 gp_acc.1 gp_adjust.1 gp_cdndev.1 gp_cusage.1 gp_digest.1 \
|
||||
gp_dimer.1 gp_findorf.1 gp_gc.1 gp_getseq.1 gp_matrix.1 gp_mkmtx.1 \
|
||||
gp_pattern.1 gp_qs.1 gp_randseq.1 gp_seq2prot.1 gp_slen.1 gp_tm.1 \
|
||||
gp_trimer.1 gp_primer.1
|
||||
|
||||
.if !defined(NOPORTDOCS)
|
||||
INSTALL_TARGET= install docs
|
||||
.endif
|
||||
|
||||
post-patch:
|
||||
@${PERL} -pi -e "s|%%PREFIX%%|${PREFIX}|g ; \
|
||||
s|%%MANPREFIX%%|${MANPREFIX}|g ; \
|
||||
s|%%DOCDIR%%|${PREFIX}/share/doc|g ; \
|
||||
s|%%CFLAGS%%|${CFLAGS}|g" ${WRKSRC}/Makefile
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
@ -1 +1 @@
|
||||
MD5 (gp-0.25.tgz) = 35bc282e2da3d5af24cf44ed01a04551
|
||||
MD5 (gp-0.26.tgz) = 34e2942ff6b27eeb6116b9dea87285b6
|
||||
|
@ -1,6 +1,6 @@
|
||||
--- Makefile.orig Tue Feb 13 22:41:12 2001
|
||||
+++ Makefile Wed Feb 28 01:01:15 2001
|
||||
@@ -5,15 +5,13 @@
|
||||
--- Makefile.orig Fri Aug 10 01:17:55 2001
|
||||
+++ Makefile Fri Aug 10 01:19:48 2001
|
||||
@@ -5,13 +5,11 @@
|
||||
######################################################################
|
||||
# Change the following to suit your needs
|
||||
|
||||
@ -10,42 +10,39 @@
|
||||
# If you make a personal installation, change it to your home directory
|
||||
# Default: /usr
|
||||
# uncomment the following line to install to the default directories...
|
||||
# TREE=/usr
|
||||
-TREE=/usr
|
||||
+TREE=${PREFIX}
|
||||
# ...or the following line to install into your home directory:
|
||||
-TREE=$(HOME)
|
||||
+TREE=%%PREFIX%%
|
||||
# TREE=$(HOME)
|
||||
|
||||
# if you don't have the gd graphic library installed, you have to comment out or
|
||||
# delete the following line. However, gp_map is such a nice program, so you
|
||||
@@ -25,7 +23,7 @@
|
||||
BINDIR=$(TREE)/bin
|
||||
|
||||
# directory to install the manual pages
|
||||
-MANDIR=$(TREE)/man
|
||||
+MANDIR=%%MANPREFIX%%/man
|
||||
+MANDIR=${MANPREFIX}/man
|
||||
|
||||
#directory to install the data directory
|
||||
DATADIR=$(TREE)/lib
|
||||
@@ -36,11 +34,11 @@
|
||||
@@ -36,11 +34,9 @@
|
||||
# A catalog will be created: $(DOCDIR)/gp
|
||||
# It will *not* be uninstalled automagically after a "make uninstall"
|
||||
|
||||
-DOCDIR=$(TREE)/doc
|
||||
+DOCDIR=%%DOCDIR%%
|
||||
+DOCDIR=${PREFIX}/share/doc
|
||||
|
||||
# Your favourite ANSI compiler and it's flags
|
||||
CC=gcc
|
||||
-CFLAGS=-ansi -pedantic -O3
|
||||
+CFLAGS=%%CFLAGS%%
|
||||
-CC=gcc
|
||||
-CFLAGS=-pedantic -O3 -Wall -g
|
||||
|
||||
######################################################################
|
||||
# Do not change anything below this line
|
||||
@@ -58,7 +56,7 @@
|
||||
@@ -58,7 +54,7 @@
|
||||
mporfs.seq
|
||||
|
||||
all:
|
||||
- cd src ; make PROGRAMS="$(PROGRAMS)" GDPROGRAMS="$(GDPROGRAMS)" CC=$(CC) \
|
||||
+ cd src ; gmake PROGRAMS="$(PROGRAMS)" GDPROGRAMS="$(GDPROGRAMS)" CC=$(CC) \
|
||||
+ cd src ; ${GMAKE} PROGRAMS="$(PROGRAMS)" GDPROGRAMS="$(GDPROGRAMS)" CC=$(CC) \
|
||||
LIBS="$(LIBS)" CFLAGS="$(CFLAGS)" ;
|
||||
@echo -e "\nAll programs compiled. \nType 'make install' to install all programs."
|
||||
|
||||
|
@ -1,10 +1,11 @@
|
||||
--- src/Makefile.orig Wed Feb 28 01:01:24 2001
|
||||
+++ src/Makefile Wed Feb 28 01:01:31 2001
|
||||
@@ -5,7 +5,6 @@
|
||||
--- src/Makefile.orig Fri Aug 10 01:20:01 2001
|
||||
+++ src/Makefile Fri Aug 10 01:20:17 2001
|
||||
@@ -5,8 +5,6 @@
|
||||
######################################################################
|
||||
# Change the following to suit your needs
|
||||
|
||||
-SHELL=/bin/bash
|
||||
CC=gcc
|
||||
-CC=gcc
|
||||
LIBS= -lz -lm
|
||||
#CFLAGS= -DNLS -DGZ
|
||||
|
||||
|
@ -1,4 +1,6 @@
|
||||
bin/gp_acc
|
||||
bin/gp_adjust
|
||||
bin/gp_cdndev
|
||||
bin/gp_cusage
|
||||
bin/gp_digest
|
||||
bin/gp_dimer
|
||||
@ -32,6 +34,8 @@ lib/genpak/standard.cdn
|
||||
%%PORTDOCS%%share/doc/gp/README.TXT
|
||||
%%PORTDOCS%%share/doc/gp/html/README.html
|
||||
%%PORTDOCS%%share/doc/gp/html/gp_acc.html
|
||||
%%PORTDOCS%%share/doc/gp/html/gp_adjust.html
|
||||
%%PORTDOCS%%share/doc/gp/html/gp_cdndev.html
|
||||
%%PORTDOCS%%share/doc/gp/html/gp_cusage.html
|
||||
%%PORTDOCS%%share/doc/gp/html/gp_digest.html
|
||||
%%PORTDOCS%%share/doc/gp/html/gp_dimer.html
|
||||
|
Loading…
Reference in New Issue
Block a user