New Port: security/p5-SHA

The SHA module allows you to use the NIST SHA message digest
	algorithm from within Perl programs.

	The final message digest value is returned by the digest
	operation as a 20-byte binary string. This operation delivers
	the result of operations since the last new or reset
	operation. Once the operation has been performed, the context
	must be reset before being used to calculate another digest
	value.

PR:		ports/43799
Submitted by:	Jim Geovedi <negative@toxic.magnesium.net>
This commit is contained in:
Edwin Groothuis 2003-02-04 23:59:39 +00:00
parent 89932ed0a8
commit 675b0f4d9c
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=74700
7 changed files with 52 additions and 0 deletions

View File

@ -215,6 +215,7 @@
SUBDIR += p5-Net-SSLeay
SUBDIR += p5-PGP
SUBDIR += p5-PGP-Sign
SUBDIR += p5-SHA
SUBDIR += p5-Safe-Hole
SUBDIR += p5-Tie-EncryptedHash
SUBDIR += pad

22
security/p5-SHA/Makefile Normal file
View File

@ -0,0 +1,22 @@
# New ports collection makefile for: p5-SHA
# Date created: Sep 30, 2002
# Whom: Jim Geovedi <jim@corebsd.or.id>
#
# $FreeBSD$
#
PORTNAME= SHA
PORTVERSION= 1.2
CATEGORIES= security perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= SHA
PKGNAMEPREFIX= p5-
MAINTAINER= jim@corebsd.or.id
PERL_CONFIGURE= yes
MAN3= SHA.3
MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
.include <bsd.port.mk>

1
security/p5-SHA/distinfo Normal file
View File

@ -0,0 +1 @@
MD5 (SHA-1.2.tar.gz) = fc23793219770f156d32fa676ab49be4

View File

@ -0,0 +1,11 @@
--- Makefile.PL.orig Mon Sep 30 04:33:16 2002
+++ Makefile.PL Mon Sep 30 04:34:51 2002
@@ -20,7 +20,7 @@ if (exists($Config{'byteorder'}) and def
print "Writing endian.h for SHA\n";
}
print "Do you want to use the original SHA or the new standard SHA-1?\nEnter 0 for the original or 1 for the new standard. [1]";
- $resp = <STDIN>;
+ $resp = 1;
if (defined($resp)) {
$resp =~ s/^\s+//;
$resp =~ s/\s+$//;

View File

@ -0,0 +1 @@
Perl5 interface to the SHA1 algorithm

View File

@ -0,0 +1,8 @@
The SHA module allows you to use the NIST SHA message digest algorithm
from within Perl programs.
The final message digest value is returned by the digest operation as
a 20-byte binary string. This operation delivers the result of
operations since the last new or reset operation. Once the operation
has been performed, the context must be reset before being used to
calculate another digest value.

View File

@ -0,0 +1,8 @@
lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/SHA.pm
lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/SHA.pod
lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/sha_driver.pl
lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/SHA/SHA.so
lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/SHA/SHA.bs
lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/SHA/autosplit.ix
lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/SHA/.packlist
@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/SHA