reimport ocaml-yaxi 0.5.2

Yet Another X* Implementation for OCaml
This commit is contained in:
Ying-Chieh Liao 2004-03-19 02:24:46 +00:00
parent 21279b9d3a
commit 675906fcb2
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=104569
6 changed files with 79 additions and 0 deletions

View File

@ -193,6 +193,7 @@
SUBDIR += nltk
SUBDIR += no-aspell
SUBDIR += ocaml-pxp
SUBDIR += ocaml-yaxi
SUBDIR += ocaml-yaxpo
SUBDIR += openfts
SUBDIR += openjade

View File

@ -0,0 +1,42 @@
# ex:ts=8
# Ports collection makefile for: yaxi
# Date created: Mar 17, 2004
# Whom: ijliao
#
# $FreeBSD$
#
PORTNAME= yaxi
PORTVERSION= 0.5.2
CATEGORIES= textproc
MASTER_SITES= http://mattam.ath.cx/progs/yaxi/releases/
PKGNAMEPREFIX= ocaml-
MAINTAINER= ports@FreeBSD.org
COMMENT= Yet Another X* Implementation for OCaml
BUILD_DEPENDS= ocamlc:${PORTSDIR}/lang/ocaml \
ocamlfind:${PORTSDIR}/devel/ocaml-findlib \
${OCAML_SITELIBDIR}/netstring/netstring.a:${PORTSDIR}/www/ocaml-net \
${OCAML_SITELIBDIR}/ulex/ulexing.a:${PORTSDIR}/devel/ulex \
${OCAML_SITELIBDIR}/camomile/camomile.a:${PORTSDIR}/devel/camomile
RUN_DEPENDS= ocamlc:${PORTSDIR}/lang/ocaml \
ocamlfind:${PORTSDIR}/devel/ocaml-findlib \
${OCAML_SITELIBDIR}/netstring/netstring.a:${PORTSDIR}/www/ocaml-net \
${OCAML_SITELIBDIR}/ulex/ulexing.a:${PORTSDIR}/devel/ulex \
${OCAML_SITELIBDIR}/camomile/camomile.a:${PORTSDIR}/devel/camomile
OCAML_SITELIBDIR= ${LOCALBASE}/lib/ocaml/site-lib
USE_GMAKE= yes
PLIST_FILES= bin/yaxsltproc
PKGDEINSTALL= ${PKGINSTALL}
post-install:
@${FIND} ${PREFIX}/lib/ocaml/site-lib/${PORTNAME} -type f | \
${SED} "s,^${PREFIX}/,," >> ${TMPPLIST}
@${ECHO_CMD} "@dirrm lib/ocaml/site-lib/${PORTNAME}" >> ${TMPPLIST}
@${ECHO_CMD} "@unexec ocamlfind remove ${PORTNAME} 2>/dev/null || true" >> ${TMPPLIST}
.include <bsd.port.mk>

View File

@ -0,0 +1,2 @@
MD5 (yaxi-0.5.2.tar.gz) = ea17a507207057e3489cf987a9a80b10
SIZE (yaxi-0.5.2.tar.gz) = 69067

View File

@ -0,0 +1,20 @@
--- Makefile.orig Thu Mar 18 09:56:55 2004
+++ Makefile Thu Mar 18 09:57:50 2004
@@ -3,7 +3,7 @@
export VERSION
# Where the binaries will go (yaxsltproc)
-BIN_DESTDIR = ${DESTDIR}/usr/bin/
+BIN_DESTDIR = ${PREFIX}/bin
DIST_FILES = Makefile OCamlMakefile AUTHORS README COPYING ChangeLog META.in TODO \
examples/Makefile examples/*.ml examples/*.x*l
@@ -41,7 +41,7 @@
install: all META
ocamlfind install yaxi META src/*.mli src/*.cm* src/*.a
- install -D src/yaxsltproc ${BIN_DESTDIR}/yaxsltproc
+ ${BSD_INSTALL_PROGRAM} src/yaxsltproc ${BIN_DESTDIR}/yaxsltproc
dist: clean
mkdir tmp/yaxi-$(VERSION)

View File

@ -0,0 +1,5 @@
Yaxi contains a (currently non-validating) XML parser (SAX, DOM methods, pull
parser in the works), a complete XPath implementation and a (still incomplete)
XSL implementation.
WWW: http://mattam.ath.cx/progs/yaxi.html

View File

@ -0,0 +1,9 @@
#!/bin/sh
if [ "$2" = "POST-INSTALL" ]; then
echo "${PKG_PREFIX}/lib/ocaml/site-lib/yaxi" >> ${PKG_PREFIX}/lib/ocaml/ld.conf
elif [ "$2" = "DEINSTALL" ]; then
mv ${PKG_PREFIX}/lib/ocaml/ld.conf ${PKG_PREFIX}/lib/ocaml/ld.conf.tmp
grep -v yaxi ${PKG_PREFIX}/lib/ocaml/ld.conf.tmp > ${PKG_PREFIX}/lib/ocaml/ld.conf
rm -f ${PKG_PREFIX}/lib/ocaml/ld.conf.tmp
fi