Update to 2.3.0 which fixes the build with GNOME 2.10.

This commit is contained in:
Joe Marcus Clarke 2005-03-19 20:01:06 +00:00
parent 233da59d09
commit 66fe3c4e21
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=131654
6 changed files with 82 additions and 59 deletions

View File

@ -6,8 +6,7 @@
#
PORTNAME= balsa
PORTVERSION= 2.2.6
PORTREVISION= 2
PORTVERSION= 2.3.0
CATEGORIES= mail gnome
MASTER_SITES= http://www.theochem.kth.se/~pawsa/balsa/
DISTNAME= balsa-${PORTVERSION}
@ -61,4 +60,7 @@ post-patch:
@${REINPLACE_CMD} -e 's|stdint.h|inttypes.h|g' \
${WRKSRC}/libbalsa/mailbox_imap.c
post-install:
-@gtk-update-icon-cache ${X11BASE}/share/icons/hicolor
.include <bsd.port.post.mk>

View File

@ -1,2 +1,2 @@
MD5 (balsa-2.2.6.tar.bz2) = 6179fadbfc5cca642dac081519acef25
SIZE (balsa-2.2.6.tar.bz2) = 2913847
MD5 (balsa-2.3.0.tar.bz2) = 1578d07b7a3563f8ec1562f92d706d8f
SIZE (balsa-2.3.0.tar.bz2) = 3001175

View File

@ -1,6 +1,24 @@
--- configure.orig Wed Jul 7 18:16:55 2004
+++ configure Wed Jul 7 18:16:55 2004
@@ -20976,13 +20976,13 @@
--- configure.orig Sat Mar 19 14:39:26 2005
+++ configure Sat Mar 19 14:40:24 2005
@@ -21821,7 +21821,7 @@
echo $ECHO_N "(cached) $ECHO_C" >&6
else
ac_check_lib_save_LIBS=$LIBS
-LIBS="-lldap -llber -lresolv $LIBS"
+LIBS="-lldap -llber $LIBS"
cat >conftest.$ac_ext <<_ACEOF
/* confdefs.h. */
_ACEOF
@@ -21885,7 +21885,7 @@
#define ENABLE_LDAP 1
_ACEOF
- LIBS="-lldap -llber -lresolv $LIBS"
+ LIBS="-lldap -llber $LIBS"
else
{ { echo "$as_me:$LINENO: error: *** You enabled LDAP but ldap library is not found." >&5
echo "$as_me: error: *** You enabled LDAP but ldap library is not found." >&2;}
@@ -22664,13 +22664,13 @@
else
@ -18,7 +36,7 @@
cat >conftest.$ac_ext <<_ACEOF
/* confdefs.h. */
_ACEOF
@@ -20996,11 +20996,11 @@
@@ -22684,11 +22684,11 @@
#endif
/* We use char because int might match the return type of a gcc2
builtin and then its argument prototype would still apply. */
@ -32,21 +50,3 @@
;
return 0;
}
@@ -23045,7 +23045,7 @@
echo $ECHO_N "(cached) $ECHO_C" >&6
else
ac_check_lib_save_LIBS=$LIBS
-LIBS="-lldap -llber -lresolv $LIBS"
+LIBS="-lldap -llber $LIBS"
cat >conftest.$ac_ext <<_ACEOF
/* confdefs.h. */
_ACEOF
@@ -23109,7 +23109,7 @@
#define ENABLE_LDAP 1
_ACEOF
- LIBS="-lldap -llber -lresolv $LIBS"
+ LIBS="-lldap -llber $LIBS"
else
{ { echo "$as_me:$LINENO: error: *** You enabled LDAP but ldap library is not found." >&5
echo "$as_me: error: *** You enabled LDAP but ldap library is not found." >&2;}

View File

@ -1,5 +1,5 @@
--- libbalsa/imap/imap-handle.c.orig Mon Jul 26 01:56:32 2004
+++ libbalsa/imap/imap-handle.c Mon Jul 26 02:08:48 2004
--- libbalsa/imap/imap-handle.c.orig Sun Feb 20 13:54:21 2005
+++ libbalsa/imap/imap-handle.c Sat Mar 19 14:40:45 2005
@@ -18,10 +18,13 @@
*/
#include "config.h"
@ -14,21 +14,3 @@
#include <netdb.h>
#include <glib.h>
#include <glib-object.h>
@@ -360,9 +363,17 @@
for (cur = res; cur != NULL; cur = cur->ai_next) {
fd = socket (cur->ai_family, cur->ai_socktype, cur->ai_protocol);
if (fd >= 0) {
+#ifdef __FreeBSD__
+ int sa_size = ((struct sockaddr_in *)cur->ai_addr)->sin_len;
+#else
int sa_size = sizeof (struct sockaddr_in);
+#endif
if (cur->ai_addr->sa_family == AF_INET6)
+#ifdef __FreeBSD__
+ sa_size = ((struct sockaddr_in6 *)cur->ai_addr)->sin6_len;
+#else
sa_size = sizeof (struct sockaddr_in6);
+#endif
if ((rc=connect(fd, cur->ai_addr, sa_size)) == 0) {
break;
} else {

View File

@ -1,21 +1,12 @@
--- libbalsa/misc.c.orig Mon Jul 26 02:12:16 2004
+++ libbalsa/misc.c Mon Jul 26 02:17:06 2004
@@ -23,7 +23,10 @@
--- libbalsa/misc.c.orig Fri Feb 18 18:05:54 2005
+++ libbalsa/misc.c Sat Mar 19 14:44:04 2005
@@ -23,7 +23,9 @@
#include "config.h"
#define _SVID_SOURCE 1
+#ifndef __FreeBSD__
#define _XOPEN_SOURCE 500
+#endif
+#include <sys/types.h>
#include <stdio.h>
#include <sys/utsname.h>
#include <ctype.h>
@@ -31,6 +34,7 @@
#include <errno.h>
#include <dirent.h>
#include <sys/file.h>
+#include <sys/stat.h>
#include <libgnomevfs/gnome-vfs-file-info.h>
#include <libgnomevfs/gnome-vfs-ops.h>
#include <errno.h>

View File

@ -3,6 +3,47 @@ bin/balsa-ab
etc/sound/events/balsa.soundlist
libdata/bonobo/servers/GNOME_Balsa.server
share/gnome/applications/balsa.desktop
share/gnome/balsa/hicolor/16x16/apps/balsa-encrypted.png
share/gnome/balsa/hicolor/16x16/apps/balsa-mark-all.png
share/gnome/balsa/hicolor/16x16/apps/balsa-mbox-draft.png
share/gnome/balsa/hicolor/16x16/apps/balsa-mbox-sent.png
share/gnome/balsa/hicolor/16x16/apps/balsa-mbox-tray-empty.png
share/gnome/balsa/hicolor/16x16/apps/balsa-mbox-tray-full.png
share/gnome/balsa/hicolor/16x16/apps/balsa-next-flagged.png
share/gnome/balsa/hicolor/16x16/apps/balsa-next-part.png
share/gnome/balsa/hicolor/16x16/apps/balsa-next-unread.png
share/gnome/balsa/hicolor/16x16/apps/balsa-next.png
share/gnome/balsa/hicolor/16x16/apps/balsa-postpone.png
share/gnome/balsa/hicolor/16x16/apps/balsa-previous-part.png
share/gnome/balsa/hicolor/16x16/apps/balsa-previous.png
share/gnome/balsa/hicolor/16x16/apps/balsa-reply-all.png
share/gnome/balsa/hicolor/16x16/apps/balsa-signature-bad.png
share/gnome/balsa/hicolor/16x16/apps/balsa-signature-good.png
share/gnome/balsa/hicolor/16x16/apps/balsa-signature-notrust.png
share/gnome/balsa/hicolor/16x16/apps/balsa-signature-unknown.png
share/gnome/balsa/hicolor/22x22
share/gnome/balsa/hicolor/24x24/apps/balsa-crypt-check.png
share/gnome/balsa/hicolor/24x24/apps/balsa-encrypt.png
share/gnome/balsa/hicolor/24x24/apps/balsa-encrypted.png
share/gnome/balsa/hicolor/24x24/apps/balsa-mark-all.png
share/gnome/balsa/hicolor/24x24/apps/balsa-marked-new.png
share/gnome/balsa/hicolor/24x24/apps/balsa-next-flagged.png
share/gnome/balsa/hicolor/24x24/apps/balsa-next-part.png
share/gnome/balsa/hicolor/24x24/apps/balsa-next-unread.png
share/gnome/balsa/hicolor/24x24/apps/balsa-next.png
share/gnome/balsa/hicolor/24x24/apps/balsa-postpone.png
share/gnome/balsa/hicolor/24x24/apps/balsa-preview.png
share/gnome/balsa/hicolor/24x24/apps/balsa-previous-part.png
share/gnome/balsa/hicolor/24x24/apps/balsa-previous.png
share/gnome/balsa/hicolor/24x24/apps/balsa-reply-all.png
share/gnome/balsa/hicolor/24x24/apps/balsa-sign.png
share/gnome/balsa/hicolor/24x24/apps/balsa-signature-bad.png
share/gnome/balsa/hicolor/24x24/apps/balsa-signature-good.png
share/gnome/balsa/hicolor/24x24/apps/balsa-signature-notrust.png
share/gnome/balsa/hicolor/24x24/apps/balsa-signature-unknown.png
share/gnome/balsa/hicolor/24x24/apps/balsa-trash-empty.png
share/gnome/balsa/hicolor/icon-theme.cache
@exec gtk-update-icon-cache %%X11BASE%%/share/icons/hicolor > /dev/null || /usr/bin/true
share/gnome/balsa/pixmaps/attachment.png
share/gnome/balsa/pixmaps/balsa-logo.png
share/gnome/balsa/pixmaps/balsa-top.png
@ -58,6 +99,7 @@ share/locale/lt/LC_MESSAGES/balsa.mo
share/locale/lv/LC_MESSAGES/balsa.mo
share/locale/ml/LC_MESSAGES/balsa.mo
share/locale/ms/LC_MESSAGES/balsa.mo
share/locale/nb/LC_MESSAGES/balsa.mo
share/locale/nl/LC_MESSAGES/balsa.mo
share/locale/nn/LC_MESSAGES/balsa.mo
share/locale/no/LC_MESSAGES/balsa.mo
@ -85,4 +127,10 @@ share/locale/zh_TW/LC_MESSAGES/balsa.mo
@dirrm share/gnome/help/balsa/C
@dirrm share/gnome/help/balsa
@dirrm share/gnome/balsa/pixmaps
@dirrm share/gnome/balsa/hicolor/24x24/apps
@dirrm share/gnome/balsa/hicolor/24x24
@dirrm share/gnome/balsa/hicolor/16x16/apps
@dirrm share/gnome/balsa/hicolor/16x16
@dirrm share/gnome/balsa/hicolor
@dirrm share/gnome/balsa
@unexec gtk-update-icon-cache %%X11BASE%%/share/icons/hicolor > /dev/null || /usr/bin/true