2011-04-17 lang/ocamlduce: has been broken for over a year

This commit is contained in:
Baptiste Daroussin 2011-08-16 05:54:55 +00:00
parent b0e7ef5f12
commit 66e571eca1
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=279796
7 changed files with 1 additions and 139 deletions

1
MOVED
View File

@ -2513,3 +2513,4 @@ www/wiliki||2011-08-14|Removed: depends on expired gauche-gdbm
mail/scmail||2011-08-14|Removed: depends on expired gauche-gdbm
x11-themes/fluxbox-sid-pack||2011-08-14|Has expired: No longer maintained by upstream
japanese/ical||2011-08-15|Removed
lang/ocamlduce||2011-08-16|Has expired: has been broken for over a year

View File

@ -189,7 +189,6 @@
SUBDIR += ocaml-examples
SUBDIR += ocaml-mode.el
SUBDIR += ocaml-nox11
SUBDIR += ocamlduce
SUBDIR += ocs
SUBDIR += ofc
SUBDIR += ohugs

View File

@ -1,37 +0,0 @@
# New ports collection makefile for: ocamlduce
# Date created: Feb 24, 2007
# Whom: Jaap Boender <jaapb@kerguelen.rg>
#
# $FreeBSD$
#
PORTNAME= ocamlduce
PORTVERSION= 3.11.1.0
CATEGORIES= lang
MASTER_SITES= https://forge.ocamlcore.org/frs/download.php/225/
MAINTAINER= jaapb@kerguelen.org
COMMENT= Library to integrate XML features into OCaml
BUILD_DEPENDS= ${NONEXISTENT}:${PORTSDIR}/lang/ocaml:extract
BROKEN= does not build
DEPRECATED= has been broken for over a year
EXPIRATION_DATE=2011-04-17
ALL_TARGET= prepare config/Makefile world world.opt
INSTALL_TARGET= installbyte installopt
.include <bsd.port.pre.mk>
OCAML_WRKSRC!= (cd ${PORTSDIR}/lang/ocaml && ${MAKE} -V WRKSRC)
USE_GMAKE= yes
USE_OCAML= yes
MAKE_ENV+= PORTSDIR="${PORTSDIR}" OCAML_SOURCE="${OCAML_WRKSRC}" BINDIR="${LOCALBASE}/bin" SA_DIR="${LOCALBASE}/lib/ocaml/site-lib"
OCAMLC_DEPEND= ocaml>=3.11.1:${OCAMLC_PORT}
USE_OCAML_FINDLIB= yes
USE_OCAML_LDCONFIG= yes
USE_OCAML_PLIST= yes
.include <bsd.port.post.mk>

View File

@ -1,2 +0,0 @@
SHA256 (ocamlduce-3.11.1.0.tar.gz) = fd1f92e80b36b1fae028c4d1119dd2ff567001ed09e0ce5634a3497027827d4e
SIZE (ocamlduce-3.11.1.0.tar.gz) = 138926

View File

@ -1,72 +0,0 @@
--- Makefile.orig 2009-06-13 01:49:38.000000000 +0200
+++ Makefile 2009-12-21 11:51:23.000000000 +0100
@@ -1,13 +1,12 @@
#-include config/Makefile
OCAML_VERSION := $(shell ocamlc -version)
-OCAML_SOURCE := /usr/src/ocaml-source-$(OCAML_VERSION).tar.bz2
OCAML_SRCDIR := ocaml-$(OCAML_VERSION)
DUCE_VERSION := $(shell head -n1 VERSION)
DUCE_SRCDIR := ocamlduce-$(DUCE_VERSION)
-DUCE_LIBDIR := $(LIBDIR)/ocamlduce
+DUCE_LIBDIR := $(SA_DIR)/ocamlduce
BASE_BYT := ocamlc ocamldoc/ocamldoc tools/ocamldep
BYT := ocaml $(BASE_BYT)
@@ -36,7 +35,7 @@
@echo "===> Please explicit what you want <==="
prepare:
- tar xf $(OCAML_SOURCE)
+ cp -PpR $(OCAML_SOURCE) $(OCAML_SRCDIR)
cp -PpR $(DUCEP_FILES) $(OCAML_SRCDIR)
cp -PpR ocamlduce $(OCAML_SRCDIR)/otherlibs
cd $(OCAML_SRCDIR) && for X in ../patches/*.diff; do patch -p1 < $$X; done
@@ -46,13 +45,13 @@
config/Makefile:
@echo "===> You should probably run ./configure yourself, trying on my own... <==="
- $(shell sed -ne '1s@^.*\(./configure.*\)$$@\1@p' $(shell ocamlc -where)/Makefile.config)
+ cd $(OCAML_SRCDIR) && $(shell sed -ne '1s@^.*\(./configure.*\)$$@\1@p' $(shell ocamlc -where)/Makefile.config)
world: config/Makefile
- MAKE="$(MAKE)" CFLAGS="$(CFLAGS)" ./mkocamlduce.sh
+ cd $(OCAML_SRCDIR) && MAKE="$(MAKE)" CFLAGS="$(CFLAGS)" ./mkocamlduce.sh
world.opt: config/Makefile
- MAKE="$(MAKE)" CFLAGS="$(CFLAGS)" HAS_NATIVE=y ./mkocamlduce.sh
+ cd $(OCAML_SRCDIR) && MAKE="$(MAKE)" CFLAGS="$(CFLAGS)" HAS_NATIVE=y ./mkocamlduce.sh
META: META.in
sed 's/%VER%/$(DUCE_VERSION)/' $< > $@
@@ -63,20 +62,20 @@
install -m 755 -d $(DUCE_LIBDIR)
install -m 755 ocamlducefind $(BINDIR)
install -m 644 META $(DUCE_LIBDIR)
- install -m 644 $(addprefix _build/,$(MLI)) $(DUCE_LIBDIR)
- install -m 644 $(addprefix _build/,$(CMI)) $(DUCE_LIBDIR)
+ install -m 644 $(addprefix $(OCAML_SRCDIR)/_build/,$(MLI)) $(DUCE_LIBDIR)
+ install -m 644 $(addprefix $(OCAML_SRCDIR)/_build/,$(CMI)) $(DUCE_LIBDIR)
installbyte: installcommon-stamp
@echo "===> Installing non-native files... <==="
- for X in $(BYT); do Y=$${X##*/}; Y=$${Y#ocaml}; install -m 755 _build/$$X $(BINDIR)/ocamlduce$$Y; done
- install -m 644 $(addprefix _build/,$(TOPCMO)) $(DUCE_LIBDIR)
- install -m 644 $(addprefix _build/,$(TOPCMA)) $(DUCE_LIBDIR)
- install -m 644 $(addprefix _build/,$(CMA)) $(DUCE_LIBDIR)
+ for X in $(BYT); do Y=$${X##*/}; Y=$${Y#ocaml}; install -m 755 $(OCAML_SRCDIR)/_build/$$X $(BINDIR)/ocamlduce$$Y; done
+ install -m 644 $(addprefix $(OCAML_SRCDIR)/_build/,$(TOPCMO)) $(DUCE_LIBDIR)
+ install -m 644 $(addprefix $(OCAML_SRCDIR)/_build/,$(TOPCMA)) $(DUCE_LIBDIR)
+ install -m 644 $(addprefix $(OCAML_SRCDIR)/_build/,$(CMA)) $(DUCE_LIBDIR)
installopt: installcommon-stamp
@echo "===> Installing native files... <==="
- for X in $(OPT); do Y=$${X##*/}; Y=$${Y#ocaml}; install -m 755 _build/$$X $(BINDIR)/ocamlduce$$Y; done
- install -m 644 $(addprefix _build/,$(CMXA)) $(DUCE_LIBDIR)
+ for X in $(OPT); do Y=$${X##*/}; Y=$${Y#ocaml}; install -m 755 $(OCAML_SRCDIR)/_build/$$X $(BINDIR)/ocamlduce$$Y; done
+ install -m 644 $(addprefix $(OCAML_SRCDIR)/_build/,$(CMXA)) $(DUCE_LIBDIR)
clean:
build/distclean.sh

View File

@ -1,3 +0,0 @@
OCamlDuce is an enhancement to OCaml that allows you to use XML types.
WWW: http://www.cduce.org/ocaml

View File

@ -1,24 +0,0 @@
%%OCAML_SITELIBDIR%%/ocamlduce/META
%%OCAML_SITELIBDIR%%/ocamlduce/cduce_types.cmi
%%OCAML_SITELIBDIR%%/ocamlduce/ocamlduce.a
%%OCAML_SITELIBDIR%%/ocamlduce/ocamlduce.cma
%%OCAML_SITELIBDIR%%/ocamlduce/ocamlduce.cmi
%%OCAML_SITELIBDIR%%/ocamlduce/ocamlduce.cmxa
%%OCAML_SITELIBDIR%%/ocamlduce/ocamlduce.mli
%%OCAML_SITELIBDIR%%/ocamlduce/topdirs.cmi
%%OCAML_SITELIBDIR%%/ocamlduce/topdirs.cmo
%%OCAML_SITELIBDIR%%/ocamlduce/topdirs.mli
%%OCAML_SITELIBDIR%%/ocamlduce/toplevellib.cma
%%OCAML_SITELIBDIR%%/ocamlduce/toploop.cmi
%%OCAML_SITELIBDIR%%/ocamlduce/toploop.cmo
%%OCAML_SITELIBDIR%%/ocamlduce/toploop.mli
%%OCAML_SITELIBDIR%%/ocamlduce/topmain.cmi
%%OCAML_SITELIBDIR%%/ocamlduce/topmain.cmo
%%OCAML_SITELIBDIR%%/ocamlduce/topmain.mli
%%OCAML_SITELIBDIR%%/ocamlduce/topstart.cmo
bin/ocamlducec
bin/ocamlduce
bin/ocamlducedep
bin/ocamlducedoc
bin/ocamlduceopt
bin/ocamlducefind