lib/inc/internal/util/freebsd/geom.hpp needs to include stdexcept to

build on GCC-based architectures.

PR:		235601
Submitted by:	Piotr Kubaj
Approved by:	portmgr (tier-2 blanket)
This commit is contained in:
Mark Linimon 2019-03-29 16:08:54 +00:00
parent 828a5a0da0
commit 6643d16017
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=497161
2 changed files with 10 additions and 8 deletions

View File

@ -12,7 +12,6 @@ LICENSE= APACHE20
LICENSE_FILE= ${WRKSRC}/LICENSE
BROKEN_DragonFly= DragonFly is not supported upstream
BROKEN_powerpc64= fails to compile: collection.cc: 'stoi' was not declared in this scope
LIB_DEPENDS= libboost_system.so:devel/boost-libs \
libcurl.so:ftp/curl \
@ -55,10 +54,4 @@ test: build
cd ${WRKSRC}/lib && bundle install --path vendor
cd ${CONFIGURE_WRKSRC} && ${MAKE_CMD} test
.include <bsd.port.pre.mk>
.if ${OPSYS} == FreeBSD && ${COMPILER_FEATURES:Mlibstdc++}
BROKEN= Build with system libstdc++ is unsupported
.endif
.include <bsd.port.post.mk>
.include <bsd.port.mk>

View File

@ -0,0 +1,9 @@
--- lib/inc/internal/util/freebsd/geom.hpp.orig 2019-02-08 14:24:43 UTC
+++ lib/inc/internal/util/freebsd/geom.hpp
@@ -4,6 +4,7 @@
*/
#pragma once
+#include <stdexcept>
#include <string>
#include <vector>