Update to the latest cvs snapshot.
- New chipset supported: S3 Savage3D (I have not tested it personally); - Improved support for already supported chipsets; - Change port versioning scheme to PORTVERSION=YYYYMMDD, because despite the promise, the project had not released its magic 1.0 version (promised to be about 3 months ago); - Catch change of the Mesa3 version.
This commit is contained in:
parent
c01aa3135c
commit
663a202941
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=31954
@ -6,7 +6,7 @@
|
||||
#
|
||||
|
||||
PORTNAME= utah-glx
|
||||
PORTVERSION= 0.9.1
|
||||
PORTVERSION= 20000824
|
||||
CATEGORIES= graphics
|
||||
MASTER_SITES= ${MASTER_SITE_LOCAL}
|
||||
MASTER_SITE_SUBDIR= sobomax
|
||||
@ -30,7 +30,7 @@ AGP_DEVICE= /dev/agpgart
|
||||
CFLAGS+= -DAGP_DEVICE=\\\"${AGP_DEVICE}\\\"
|
||||
CONFIGURE_SCRIPT=autogen.sh
|
||||
CONFIGURE_ARGS= --enable-extra \
|
||||
--with-mesa=${WRKDIRPREFIX}${.CURDIR}/../../graphics/Mesa3/work/Mesa-3.2 \
|
||||
--with-mesa=${WRKDIRPREFIX}${.CURDIR}/../../graphics/Mesa3/work/Mesa-3.2.1 \
|
||||
--sysconfdir=${PREFIX}/etc \
|
||||
--with-moduledir=${PREFIX}/lib/modules
|
||||
CONFIGURE_ENV= TCLSH="tclsh8.2"
|
||||
|
@ -1 +1 @@
|
||||
MD5 (utah-glx-0.9.1.tar.bz2) = 2d1379f6cc7a3b803df452ca189fd8a6
|
||||
MD5 (utah-glx-20000824.tar.bz2) = 2b78b159944fc3a7c54eb7f5758da424
|
||||
|
@ -1,5 +1,5 @@
|
||||
--- libGLU/Makefile.in.orig Thu Dec 16 05:30:13 1999
|
||||
+++ libGLU/Makefile.in Fri Dec 31 04:19:58 1999
|
||||
--- libGLU/Makefile.in.orig Thu Aug 24 16:53:46 2000
|
||||
+++ libGLU/Makefile.in Thu Aug 24 21:42:43 2000
|
||||
@@ -13,10 +13,10 @@
|
||||
# These define the name/version of the shared library we're building
|
||||
# ------------------------------------------------------------------
|
||||
@ -16,18 +16,18 @@
|
||||
|
||||
# FIXME: different library version for Mesa 3.2?
|
||||
@@ -104,8 +104,8 @@
|
||||
@if [ -d ${INSTALL_libdir} ]; then set +x; \
|
||||
else (set -x; ${MKDIR} ${INSTALL_libdir}); fi
|
||||
${INSTALL} ${INSTALLFLAGS} ${INSTBINFLAGS} ${GLULIB} ${INSTALL_libdir}
|
||||
- ${RM} ${INSTALL_libdir}/lib${LIBNAME}.so.${GLUREV_major} ;\
|
||||
- ${LN} ${GLULIB} ${INSTALL_libdir}/lib${LIBNAME}.so.${GLUREV_major}
|
||||
+# ${RM} ${INSTALL_libdir}/lib${LIBNAME}.so.${GLUREV_major} ;\
|
||||
+# ${LN} ${GLULIB} ${INSTALL_libdir}/lib${LIBNAME}.so.${GLUREV_major}
|
||||
${RM} ${INSTALL_libdir}/lib${LIBNAME}.so ;\
|
||||
${LN} ${GLULIB} ${INSTALL_libdir}/lib${LIBNAME}.so
|
||||
@if [ -d ${DESTDIR}${INSTALL_libdir} ]; then set +x; \
|
||||
else (set -x; ${MKDIR} ${DESTDIR}${INSTALL_libdir}); fi
|
||||
${INSTALL} ${INSTALLFLAGS} ${INSTBINFLAGS} ${GLULIB} ${DESTDIR}${INSTALL_libdir}
|
||||
- ${RM} ${DESTDIR}${INSTALL_libdir}/lib${LIBNAME}.so.${GLUREV_major} ;\
|
||||
- ${LN} ${GLULIB} ${DESTDIR}${INSTALL_libdir}/lib${LIBNAME}.so.${GLUREV_major}
|
||||
+# ${RM} ${DESTDIR}${INSTALL_libdir}/lib${LIBNAME}.so.${GLUREV_major} ;\
|
||||
+# ${LN} ${GLULIB} ${DESTDIR}${INSTALL_libdir}/lib${LIBNAME}.so.${GLUREV_major}
|
||||
${RM} ${DESTDIR}${INSTALL_libdir}/lib${LIBNAME}.so ;\
|
||||
${LN} ${GLULIB} ${DESTDIR}${INSTALL_libdir}/lib${LIBNAME}.so
|
||||
else
|
||||
@@ -128,8 +128,8 @@
|
||||
${CC} -o ./$@~ ${SHARED_LDFLAGS} -Wl,-soname,lib${LIBNAME}.so.${GLUREV_major} ${OBJS} ${MATHLIBS}
|
||||
@@ -135,8 +135,8 @@
|
||||
fi;
|
||||
${RM} $@
|
||||
${MV} $@~ $@
|
||||
- ${RM} lib${LIBNAME}.so.${GLUREV_major}
|
||||
|
@ -1,5 +1,5 @@
|
||||
--- libglut/Makefile.in.orig Thu Dec 16 05:30:14 1999
|
||||
+++ libglut/Makefile.in Fri Dec 31 04:34:53 1999
|
||||
--- libglut/Makefile.in.orig Thu Aug 24 16:53:46 2000
|
||||
+++ libglut/Makefile.in Thu Aug 24 21:44:21 2000
|
||||
@@ -13,9 +13,9 @@
|
||||
# These define the name/version of the shared library we're building
|
||||
# ------------------------------------------------------------------
|
||||
@ -13,19 +13,19 @@
|
||||
GLUTLIB = lib${LIBNAME}.so.${SOGLUTREV}
|
||||
|
||||
# Source and Object definitions
|
||||
@@ -113,8 +113,8 @@
|
||||
@if [ -d ${INSTALL_libdir} ]; then set +x; \
|
||||
else (set -x; ${MKDIR} ${INSTALL_libdir}); fi
|
||||
${INSTALL} ${INSTALLFLAGS} ${INSTBINFLAGS} ${GLUTLIB} ${INSTALL_libdir}
|
||||
- ${RM} ${INSTALL_libdir}/lib${LIBNAME}.so.${GLUTREV_major} ;\
|
||||
- ${LN} ${GLUTLIB} ${INSTALL_libdir}/lib${LIBNAME}.so.${GLUTREV_major}
|
||||
+# ${RM} ${INSTALL_libdir}/lib${LIBNAME}.so.${GLUTREV_major} ;\
|
||||
+# ${LN} ${GLUTLIB} ${INSTALL_libdir}/lib${LIBNAME}.so.${GLUTREV_major}
|
||||
${RM} ${INSTALL_libdir}/lib${LIBNAME}.so ;\
|
||||
${LN} ${GLUTLIB} ${INSTALL_libdir}/lib${LIBNAME}.so
|
||||
@@ -114,8 +114,8 @@
|
||||
@if [ -d ${DESTDIR}${INSTALL_libdir} ]; then set +x; \
|
||||
else (set -x; ${MKDIR} ${DESTDIR}${INSTALL_libdir}); fi
|
||||
${INSTALL} ${INSTALLFLAGS} ${INSTBINFLAGS} ${GLUTLIB} ${DESTDIR}${INSTALL_libdir}
|
||||
- ${RM} ${DESTDIR}${INSTALL_libdir}/lib${LIBNAME}.so.${GLUTREV_major} ;\
|
||||
- ${LN} ${GLUTLIB} ${DESTDIR}${INSTALL_libdir}/lib${LIBNAME}.so.${GLUTREV_major}
|
||||
+# ${RM} ${DESTDIR}${INSTALL_libdir}/lib${LIBNAME}.so.${GLUTREV_major} ;\
|
||||
+# ${LN} ${GLUTLIB} ${DESTDIR}${INSTALL_libdir}/lib${LIBNAME}.so.${GLUTREV_major}
|
||||
${RM} ${DESTDIR}${INSTALL_libdir}/lib${LIBNAME}.so ;\
|
||||
${LN} ${GLUTLIB} ${DESTDIR}${INSTALL_libdir}/lib${LIBNAME}.so
|
||||
else
|
||||
@@ -139,8 +139,8 @@
|
||||
${CC} -o ./$@~ ${SHARED_LDFLAGS} -Wl,-soname,lib${LIBNAME}.so.${GLUTREV_major} ${OBJS} ${MATHLIBS}
|
||||
@@ -147,8 +147,8 @@
|
||||
fi;
|
||||
${RM} $@
|
||||
${MV} $@~ $@
|
||||
- ${RM} lib${LIBNAME}.so.${GLUTREV_major}
|
||||
|
@ -1,12 +1,12 @@
|
||||
--- Makefile.in.orig Wed Mar 22 22:25:54 2000
|
||||
+++ Makefile.in Fri Apr 28 03:51:47 2000
|
||||
@@ -40,7 +40,8 @@
|
||||
( cd $$i && ${MAKE} $@ ) || exit 1; \
|
||||
--- Makefile.in.orig Thu Aug 24 16:53:45 2000
|
||||
+++ Makefile.in Thu Aug 24 21:46:36 2000
|
||||
@@ -44,7 +44,8 @@
|
||||
done
|
||||
test -s ${sysconfdir}/glx.conf || \
|
||||
- ${INSTALL} -m 644 glx.conf ${sysconfdir}/glx.conf
|
||||
+ ${INSTALL} -c -m 644 glx.conf ${sysconfdir}/glx.conf
|
||||
+ ${INSTALL} -c -m 644 glx.conf ${sysconfdir}/glx.conf.default
|
||||
${MKDIR} ${DESTDIR}${sysconfdir}
|
||||
test -s ${DESTDIR}${sysconfdir}/glx.conf || \
|
||||
- ${INSTALL} -m 644 glx.conf ${DESTDIR}${sysconfdir}/glx.conf
|
||||
+ ${INSTALL} -c -m 644 glx.conf ${DESTDIR}${sysconfdir}/glx.conf
|
||||
+ ${INSTALL} -c -m 644 glx.conf ${DESTDIR}${sysconfdir}/glx.conf.default
|
||||
|
||||
real-clean:
|
||||
${RM} config.status
|
||||
${RM} config.status config.cache config.log
|
||||
|
@ -7,9 +7,10 @@ Currently supported hardware:
|
||||
o NVIDIA Riva series
|
||||
o SiS 6326
|
||||
o S3 Virge
|
||||
o S3 Savage3D
|
||||
|
||||
Please note that some of the videocards above (e.g. i810) require kernel
|
||||
support, which at the time of this writting (May 2000) is not implemented for
|
||||
support, which at the time of this writing (May 2000) is not implemented for
|
||||
FreeBSD yet, so it may or may not work for your particular h/w.
|
||||
|
||||
WWW: http://utah-glx.sourceforge.net/
|
||||
|
@ -15,6 +15,7 @@ share/doc/utah-glx/README.i810
|
||||
share/doc/utah-glx/README.mach64
|
||||
share/doc/utah-glx/README.mga
|
||||
share/doc/utah-glx/README.nv
|
||||
share/doc/utah-glx/README.s3savage
|
||||
share/doc/utah-glx/README.s3virge
|
||||
@dirrm include/GL
|
||||
@dirrm share/doc/utah-glx
|
||||
|
Loading…
Reference in New Issue
Block a user