Don't patch away upstream -fPIC so dependent ports can link libvpopmail.a

into shared libraries.
This commit is contained in:
Tijl Coosemans 2017-02-14 17:04:02 +00:00
parent aaf382e62e
commit 6631e9bc29
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=434127
3 changed files with 3 additions and 31 deletions

View File

@ -3,7 +3,7 @@
PORTNAME= vpopmail
PORTVERSION= 5.4.33
PORTREVISION= 2
PORTREVISION= 3
CATEGORIES= mail
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}-stable/${PORTVERSION}
@ -61,7 +61,6 @@ OPTIONS_DEFINE= DOCS \
SUID_VCHKPW \
SMTP_AUTH_PATCH \
ONCHANGE_SCRIPT \
FPIC \
MAILDROP \
DOMAIN_QUOTAS \
SPAMFOLDER \
@ -78,7 +77,6 @@ OPTIONS_DEFAULT=MD5_PASSWORDS \
FILE_LOCKING \
USERS_BIG_DIR \
SEEKABLE \
FPIC \
AUTH_LOG
CDB_DESC= Auth via CDB
@ -106,7 +104,6 @@ SPAMASSASSIN_DESC= SpamAssassin support
SUID_VCHKPW_DESC= Set vchkpw setugid vpopmail:vchkpw
SMTP_AUTH_PATCH_DESC= Swap Challenge/Response for CRAM-MD5
ONCHANGE_SCRIPT_DESC= vpopmail/etc/onchange script support
FPIC_DESC= Compile with -fPIC
MAILDROP_DESC= Maildrop MDA support
DOMAIN_QUOTAS_DESC= Domain quotas support
SPAMFOLDER_DESC= Move spam to Junk (requires SA)
@ -320,10 +317,6 @@ MAILDROP_FILES= ${WRKSRC}/maildrop/maildroprc.v1 \
EXTRA_PATCHES+= ${FILESDIR}/Makefile.in-noportdocs.patch
.endif
.if ${PORT_OPTIONS:MFPIC} && ( ${ARCH} == "amd64" || ${ARCH} == "ia64" )
CFLAGS+= -fPIC
.endif
#
# Some suggestions from Gabriel Ambuehl <gabriel_ambuehl@buz.ch>
#

View File

@ -1,13 +1,12 @@
Description: Install config files with -dist, do not add -fPIC.
Description: Install config files with -dist.
Install the config files with a -dist extension.
Do not unconditionally add -fPIC, this is done only for shared libs.
Forwarded: not-needed
Author: Peter Pentchev <roam@FreeBSD.org>
Last-Update: 2010-09-13
--- Makefile.in.orig 2011-02-28 11:00:45.000000000 -0600
+++ Makefile.in 2014-04-10 11:17:21.360658218 -0500
@@ -357,13 +357,12 @@
@@ -357,9 +357,9 @@
noinst_HEADERS = md5.h vpopmail.h file_lock.h vauth.h vlimits.h maildirquota.h vcdb.h vldap.h vmysql.h voracle.h vpgsql.h vsybase.h vlog.h global.h hmac_md5.h seek.h vutil.h
COMMONSOURCES = vpopmail.c md5.c bigdir.c vauth.c file_lock.c vpalias.c seek.c vlimits.c maildirquota.c vutil.c vlistlib.c backfill.c client.c conf.c ippp.c
CONFIG_CLEAN_FILES = vauth.c cdb/conf-cc cdb/conf-ld cdb/compile cdb/load
@ -20,7 +19,3 @@ Last-Update: 2010-09-13
noinst_LIBRARIES = libvpopmail.a
libvpopmail_a_SOURCES = $(COMMONSOURCES)
libvpopmail_a_LIBADD = cdb/*.o
-libvpopmail_a_CFLAGS = -fPIC
vpopmailbindir = @vpopmaildir@/bin
vusagec_SOURCES = vusagec.c client.c conf.c ippp.c
vusagec_LDADD = libvpopmail.a @auth_libs@

View File

@ -1,16 +0,0 @@
Description: Do not unconditionally add -fPIC, this is only done for the shared libs.
Forwarded: not-needed
Author: Peter Pentchev <roam@FreeBSD.org>
Last-Update: 2009-11-26
--- a/cdb/Makefile
+++ b/cdb/Makefile
@@ -43,7 +43,7 @@
compile: \
warn-auto.sh conf-cc
( cat warn-auto.sh; \
- echo exec "`head -1 conf-cc`" -fPIC '-c $${1+"$$@"}' \
+ echo exec "`head -1 conf-cc`" '-c $${1+"$$@"}' \
) > compile
chmod 755 compile