Support stage

Fix support for DESTDIR
This commit is contained in:
Baptiste Daroussin 2014-02-28 07:09:07 +00:00
parent bada9d79aa
commit 65edb8e0ed
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=346436
4 changed files with 53 additions and 30 deletions

View File

@ -16,7 +16,4 @@ USE_XORG= xaw
USES= imake
MAKE_JOBS_UNSAFE= yes
MAN1= xdtm.1
NO_STAGE= yes
.include <bsd.port.mk>

View File

@ -0,0 +1,52 @@
--- ./Imakefile.orig 1996-03-14 14:02:00.000000000 +0100
+++ ./Imakefile 2014-02-28 08:07:51.884434658 +0100
@@ -147,6 +147,11 @@
XDTMOPTIONS = -DHAS_STRSTR -DUSE_CWD -DECHO_N -DUSE_TERMIOS
#endif
+#ifdef FreeBSDArchitecture
+ LOCAL_LDFLAGS =
+ XDTMOPTIONS = -DHAS_STRSTR -DUSE_CWD -DECHO_N -DUSE_TERMIOS
+#endif
+
#if SystemV4 /* SVR4 is mostly POSIX */
XDTMOPTIONS = -DHAS_STRSTR -DUSE_CWD -DUSE_TERMIOS
#endif
@@ -241,27 +246,28 @@
sed -e 's^\"{icon dir}\"^\"$(XDTMDIR)/icons\"^' \
xdtmrc.orig > xdtmrc
sed -e 's^iconfile^$(XDTMDIR)/new_xdtm.xbm^' Xdtm.ad.tmpl > Xdtm.ad
+ cp xdtm.sh xdtm.sh.script
XCOMM Install the xdtm execute script file, used to prevent xterms closing
XCOMM when the inferier process dies.
-InstallProgram(xdtm.sh, $(BINDIR))
+InstallScript(xdtm.sh,$(BINDIR))
XCOMM Install the helpfile, system xdtmrc, icon bitmaps and the default
XCOMM application defaults.
-MakeDirectories(install, $(XDTMDIR))
-InstallNonExec(help, $(XDTMDIR))
-InstallNonExec(perm.help, $(XDTMDIR))
-InstallNonExec(xdtmrc, $(XDTMDIR))
-InstallNonExec(bitmaps/new_xdtm.xbm, $(XDTMDIR))
-MakeDirectories(install, $(XDTMDIR)/icons)
+MakeDirectories(install,$(XDTMDIR))
+InstallNonExec(help,$(XDTMDIR))
+InstallNonExec(perm.help,$(XDTMDIR))
+InstallNonExec(xdtmrc,$(XDTMDIR))
+InstallNonExec(bitmaps/new_xdtm.xbm,$(XDTMDIR))
+MakeDirectories(install,$(XDTMDIR)/icons)
InstallAppDefaults(Xdtm)
install::
- $(CP) icons$(PATHSEP)*$(PATHSEP)*.icon $(XDTMDIR)/icons
+ $(CP) icons$(PATHSEP)*$(PATHSEP)*.icon $(DESTDIR)$(XDTMDIR)/icons
$(RM) xdtmrc
$(MV) xdtmrc.orig xdtmrc
- chmod -R a+r $(XDTMDIR)
+ chmod -R a+r $(DESTDIR)$(XDTMDIR)
XCOMM Make the emacs TAGS file

View File

@ -1,27 +0,0 @@
--- Imakefile.orig Thu Mar 14 07:02:00 1996
+++ Imakefile Mon May 31 09:22:43 1999
@@ -147,6 +147,11 @@
XDTMOPTIONS = -DHAS_STRSTR -DUSE_CWD -DECHO_N -DUSE_TERMIOS
#endif
+#ifdef FreeBSDArchitecture
+ LOCAL_LDFLAGS =
+ XDTMOPTIONS = -DHAS_STRSTR -DUSE_CWD -DECHO_N -DUSE_TERMIOS
+#endif
+
#if SystemV4 /* SVR4 is mostly POSIX */
XDTMOPTIONS = -DHAS_STRSTR -DUSE_CWD -DUSE_TERMIOS
#endif
@@ -241,10 +246,11 @@
sed -e 's^\"{icon dir}\"^\"$(XDTMDIR)/icons\"^' \
xdtmrc.orig > xdtmrc
sed -e 's^iconfile^$(XDTMDIR)/new_xdtm.xbm^' Xdtm.ad.tmpl > Xdtm.ad
+ cp xdtm.sh xdtm.sh.script
XCOMM Install the xdtm execute script file, used to prevent xterms closing
XCOMM when the inferier process dies.
-InstallProgram(xdtm.sh, $(BINDIR))
+InstallScript(xdtm.sh, $(BINDIR))
XCOMM Install the helpfile, system xdtmrc, icon bitmaps and the default
XCOMM application defaults.

View File

@ -53,5 +53,6 @@ lib/X11/xdtm/icons/x.icon
lib/X11/xdtm/icons/xdtm.icon
lib/X11/xdtm/icons/ycode.icon
lib/X11/xdtm/icons/z.icon
man/man1/xdtm.1.gz
@dirrm lib/X11/xdtm/icons
@dirrm lib/X11/xdtm