MFH: r499978 devel/py-posix_ipc: Update to 1.0.4
Changelog: http://semanchuk.com/philip/posix_ipc/history.html Approved by: ports-secteam (bugfix release(s))
This commit is contained in:
parent
60a3eb12d4
commit
658e110b8b
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/branches/2019Q2/; revision=502445
@ -2,7 +2,7 @@
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= posix_ipc
|
||||
PORTVERSION= 1.0.0
|
||||
PORTVERSION= 1.0.4
|
||||
CATEGORIES= devel python
|
||||
MASTER_SITES= CHEESESHOP
|
||||
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
|
||||
@ -19,6 +19,8 @@ USE_PYTHON= distutils autoplist
|
||||
post-install:
|
||||
${STRIP_CMD} ${STAGEDIR}/${PYTHONPREFIX_SITELIBDIR}/posix_ipc.so
|
||||
|
||||
# requires mqueuefs and sem kernel modules loaded
|
||||
|
||||
do-test:
|
||||
@cd ${WRKSRC} && ${PYTHON_CMD} ${PYDISTUTILS_SETUP} test
|
||||
|
||||
|
@ -1,2 +1,3 @@
|
||||
SHA256 (posix_ipc-1.0.0.tar.gz) = 9c93070374ca672725575e5c9874930c8cde69367fb90378b2255e048e31efcb
|
||||
SIZE (posix_ipc-1.0.0.tar.gz) = 74774
|
||||
TIMESTAMP = 1533601661
|
||||
SHA256 (posix_ipc-1.0.4.tar.gz) = ff6c9077633fc62a491d6997c43b094d885bb45a7ca1f36c9a0d647c54b74b14
|
||||
SIZE (posix_ipc-1.0.4.tar.gz) = 78325
|
||||
|
@ -1,18 +1,18 @@
|
||||
--- setup.py.orig 2016-02-21 15:13:28 UTC
|
||||
--- setup.py.orig 2018-08-07 00:29:38 UTC
|
||||
+++ setup.py
|
||||
@@ -32,6 +32,7 @@ classifiers = [ "Development Status :: 5
|
||||
"Topic :: Utilities" ]
|
||||
license = "http://creativecommons.org/licenses/BSD/"
|
||||
@@ -39,6 +39,7 @@ license = "http://creativecommons.org/licenses/BSD/"
|
||||
keywords = "ipc inter-process communication semaphore shared memory shm message queue"
|
||||
|
||||
libraries = []
|
||||
+test_suite = "tests"
|
||||
|
||||
libraries = [ ]
|
||||
d = prober.probe()
|
||||
|
||||
@@ -65,5 +66,6 @@ duc.setup(name = name,
|
||||
classifiers = classifiers,
|
||||
license = license,
|
||||
keywords = keywords,
|
||||
- ext_modules = ext_modules
|
||||
+ ext_modules = ext_modules,
|
||||
+ test_suite = test_suite,
|
||||
)
|
||||
@@ -69,5 +70,6 @@ distutools.setup(name=name,
|
||||
classifiers=classifiers,
|
||||
license=license,
|
||||
keywords=keywords,
|
||||
- ext_modules=ext_modules
|
||||
+ ext_modules=ext_modules,
|
||||
+ test_suite=test_suite
|
||||
)
|
||||
|
Loading…
Reference in New Issue
Block a user