MFH: r497993
devel/guichan: fix underlinking of external dependencies ld: error: /usr/local/lib/libguichan_allegro.so: undefined reference to destroy_font ld: error: /usr/local/lib/libguichan_opengl.so: undefined reference to glBindTexture ld: error: /usr/local/lib/libguichan_sdl.so: undefined reference to SDL_FillRect ld: error: /usr/local/lib/libguichan_sdl.so: undefined reference to IMG_Load Approved by: ports-secteam blanket
This commit is contained in:
parent
ba903a675a
commit
658bebc4c6
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/branches/2019Q2/; revision=497994
@ -3,7 +3,7 @@
|
||||
|
||||
PORTNAME= guichan
|
||||
PORTVERSION= 0.8.2
|
||||
PORTREVISION= 12
|
||||
PORTREVISION= 13
|
||||
CATEGORIES= devel games
|
||||
MASTER_SITES= http://pkgs.fedoraproject.org/repo/pkgs/guichan/${DISTFILES}/af535d7f387e774e3197cef8023ea105/
|
||||
|
||||
|
@ -1,6 +1,6 @@
|
||||
--- ./src/Makefile.in.orig 2008-07-28 14:05:22.000000000 +0200
|
||||
+++ ./src/Makefile.in 2008-07-28 14:05:32.000000000 +0200
|
||||
@@ -217,7 +217,7 @@
|
||||
--- src/Makefile.in.orig 2009-10-05 18:37:12 UTC
|
||||
+++ src/Makefile.in
|
||||
@@ -273,7 +273,7 @@ SUBDIRS = widgets @GUICHAN_EXTRADIRS@ hge openlayer co
|
||||
INCLUDES = -I$(top_srcdir)/include
|
||||
lib_LTLIBRARIES = libguichan.la
|
||||
libguichan_la_LIBADD = widgets/libguichan_widgets.la
|
||||
|
@ -1,6 +1,15 @@
|
||||
--- ./src/allegro/Makefile.in.orig 2008-07-28 14:05:53.000000000 +0200
|
||||
+++ ./src/allegro/Makefile.in 2008-07-28 14:06:01.000000000 +0200
|
||||
@@ -203,7 +203,7 @@
|
||||
--- src/allegro/Makefile.in.orig 2009-10-05 18:37:13 UTC
|
||||
+++ src/allegro/Makefile.in
|
||||
@@ -68,7 +68,7 @@ am__base_list = \
|
||||
sed '$$!N;$$!N;$$!N;$$!N;s/\n/ /g'
|
||||
am__installdirs = "$(DESTDIR)$(libdir)"
|
||||
LTLIBRARIES = $(lib_LTLIBRARIES)
|
||||
-libguichan_allegro_la_LIBADD =
|
||||
+libguichan_allegro_la_LIBADD = -lalleg
|
||||
am_libguichan_allegro_la_OBJECTS = allegro.lo allegrofont.lo \
|
||||
allegrographics.lo allegroimage.lo allegroimageloader.lo \
|
||||
allegroinput.lo
|
||||
@@ -231,7 +231,7 @@ top_builddir = @top_builddir@
|
||||
top_srcdir = @top_srcdir@
|
||||
lib_LTLIBRARIES = libguichan_allegro.la
|
||||
INCLUDES = -I$(top_srcdir)/include
|
||||
|
@ -1,6 +1,15 @@
|
||||
--- ./src/opengl/Makefile.in.orig 2008-07-28 14:08:06.000000000 +0200
|
||||
+++ ./src/opengl/Makefile.in 2008-07-28 14:08:14.000000000 +0200
|
||||
@@ -202,7 +202,7 @@
|
||||
--- src/opengl/Makefile.in.orig 2009-10-05 18:37:13 UTC
|
||||
+++ src/opengl/Makefile.in
|
||||
@@ -70,7 +70,7 @@ am__base_list = \
|
||||
sed '$$!N;$$!N;$$!N;$$!N;s/\n/ /g'
|
||||
am__installdirs = "$(DESTDIR)$(libdir)" "$(DESTDIR)$(pkgconfigdir)"
|
||||
LTLIBRARIES = $(lib_LTLIBRARIES)
|
||||
-libguichan_opengl_la_LIBADD =
|
||||
+libguichan_opengl_la_LIBADD = -lGL
|
||||
am_libguichan_opengl_la_OBJECTS = opengl.lo openglimage.lo \
|
||||
openglgraphics.lo
|
||||
libguichan_opengl_la_OBJECTS = $(am_libguichan_opengl_la_OBJECTS)
|
||||
@@ -233,7 +233,7 @@ top_builddir = @top_builddir@
|
||||
top_srcdir = @top_srcdir@
|
||||
lib_LTLIBRARIES = libguichan_opengl.la
|
||||
INCLUDES = -I$(top_srcdir)/include
|
||||
|
@ -1,6 +1,15 @@
|
||||
--- ./src/sdl/Makefile.in.orig 2008-07-28 14:05:37.000000000 +0200
|
||||
+++ ./src/sdl/Makefile.in 2008-07-28 14:05:46.000000000 +0200
|
||||
@@ -204,7 +204,7 @@
|
||||
--- src/sdl/Makefile.in.orig 2009-10-05 18:37:13 UTC
|
||||
+++ src/sdl/Makefile.in
|
||||
@@ -72,7 +72,7 @@ am__base_list = \
|
||||
sed '$$!N;$$!N;$$!N;$$!N;s/\n/ /g'
|
||||
am__installdirs = "$(DESTDIR)$(libdir)" "$(DESTDIR)$(pkgconfigdir)"
|
||||
LTLIBRARIES = $(lib_LTLIBRARIES)
|
||||
-libguichan_sdl_la_LIBADD =
|
||||
+libguichan_sdl_la_LIBADD = -lSDL -lSDL_image
|
||||
am_libguichan_sdl_la_OBJECTS = sdl.lo sdlgraphics.lo sdlimage.lo \
|
||||
sdlimageloader.lo sdlinput.lo
|
||||
libguichan_sdl_la_OBJECTS = $(am_libguichan_sdl_la_OBJECTS)
|
||||
@@ -235,7 +235,7 @@ top_builddir = @top_builddir@
|
||||
top_srcdir = @top_srcdir@
|
||||
lib_LTLIBRARIES = libguichan_sdl.la
|
||||
INCLUDES = -I$(top_srcdir)/include
|
||||
|
Loading…
Reference in New Issue
Block a user