Build tix in an ELF world.
Submitted by: Joachim Kuebart <joki@kuebart.stuttgart.netsurf.de>
This commit is contained in:
parent
2f26499967
commit
65501030ed
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=13686
@ -3,7 +3,7 @@
|
||||
# Date created: 22 December 1996
|
||||
# Whom: Thomas Gellekum <tg@freebsd.org>
|
||||
#
|
||||
# $Id: Makefile,v 1.17 1998/08/07 23:56:52 asami Exp $
|
||||
# $Id: Makefile,v 1.18 1998/09/25 10:05:14 asami Exp $
|
||||
#
|
||||
|
||||
DISTNAME= Tix4.1.0.006
|
||||
@ -32,6 +32,9 @@ MANN= BtnBox.n Balloon.n ChkList.n Destroy.n ComboBox.n Control.n \
|
||||
Select.n StdBBox.n TixIntro.n Tree.n Utils.n Wm.n compound.n \
|
||||
pixmap.n tix.n
|
||||
|
||||
TIX_LIB= libtix4180.so
|
||||
TIXSAM_LIB= libtixsam4180.so
|
||||
|
||||
pre-configure:
|
||||
@(cd ${WRKSRC}/.. && \
|
||||
CC="${CC}" ac_cv_path_CC="${CC}" CFLAGS="${CFLAGS}" \
|
||||
@ -44,8 +47,10 @@ post-install:
|
||||
${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_FLAGS} ${MAKEFILE} ${INSTALL_TARGET})
|
||||
@${MKDIR} ${PREFIX}/man/man1
|
||||
@mv ${PREFIX}/man/mann/tixwish.1 ${PREFIX}/man/man1
|
||||
@ln -sf ${PREFIX}/bin/tixwish4.1.8.0 ${PREFIX}/bin/tixwish
|
||||
${LDCONFIG} -m ${PREFIX}/lib
|
||||
${LN} -fs ${PREFIX}/bin/tixwish4.1.8.0 ${PREFIX}/bin/tixwish
|
||||
${LN} -fs ${TIX_LIB_FILE} ${PREFIX}/lib/${TIX_LIB}
|
||||
${LN} -fs ${TIXSAM_LIB_FILE} ${PREFIX}/lib/${TIXSAM_LIB}
|
||||
${SETENV} OBJFORMAT=${PORTOBJFORMAT} ${LDCONFIG} -m ${PREFIX}/lib
|
||||
.for dir in generic unix
|
||||
@${MKDIR} ${PREFIX}/include/tix/${dir}
|
||||
${INSTALL_DATA} ${WRKSRC}/../../${dir}/*.h ${PREFIX}/include/tix/${dir}
|
||||
@ -55,3 +60,11 @@ post-install:
|
||||
/bin/ln -sf ../../tix.h ${PREFIX}/include/tix/generic
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
||||
.if ${PORTOBJFORMAT} == "elf"
|
||||
TIX_LIB_FILE= ${TIX_LIB}.1
|
||||
TIXSAM_LIB_FILE=${TIXSAM_LIB}.1
|
||||
.else
|
||||
TIX_LIB_FILE= ${TIX_LIB}.1.2
|
||||
TIXSAM_LIB_FILE=${TIXSAM_LIB}.1.2
|
||||
.endif
|
||||
|
@ -1,5 +1,5 @@
|
||||
--- configure.orig Thu Sep 25 20:32:47 1997
|
||||
+++ configure Tue Dec 2 11:39:39 1997
|
||||
+++ configure Sun Oct 4 20:21:17 1998
|
||||
@@ -1060,6 +1060,7 @@
|
||||
|
||||
if test "$val" != ""; then
|
||||
@ -34,36 +34,6 @@
|
||||
|
||||
#--------------------------------------------------------------------
|
||||
# Find out the top level source directory of the Tix package.
|
||||
@@ -1227,25 +1229,25 @@
|
||||
|
||||
# The main Tix library
|
||||
#
|
||||
- eval "TIX_LIB_FILE=libtix${TCL_SHARED_LIB_SUFFIX}"
|
||||
+ eval "TIX_LIB_FILE=libtix`echo ${VERSION} | tr -d .`.so.1.2"
|
||||
TIX_MAKE_LIB="\${SHLIB_LD} -o ${TIX_LIB_FILE} \${OBJS} ${SHLIB_LD_LIBS}"
|
||||
|
||||
# The Tcl SAM library
|
||||
#
|
||||
VERSION=8.0
|
||||
- eval "TCL_SAM_FILE=libtclsam${TCL_SHARED_LIB_SUFFIX}"
|
||||
+ eval "TCL_SAM_FILE=libtclsam`echo ${VERSION} | tr -d .`.so.1.2"
|
||||
TCL_MAKE_SAM="\${SHLIB_LD} -o ${TCL_SAM_FILE} \${TCL_SAM_OBJS} ${SHLIB_LD_LIBS}"
|
||||
|
||||
# The Tk SAM library
|
||||
#
|
||||
VERSION=8.0
|
||||
- eval "TK_SAM_FILE=libtksam${TCL_SHARED_LIB_SUFFIX}"
|
||||
+ eval "TK_SAM_FILE=libtksam`echo ${VERSION} | tr -d .`.so.1.2"
|
||||
TK_MAKE_SAM="\${SHLIB_LD} -o ${TK_SAM_FILE} \${TK_SAM_OBJS} ${SHLIB_LD_LIBS}"
|
||||
|
||||
# The Tix SAM library
|
||||
#
|
||||
VERSION=${BIN_VERSION}
|
||||
- eval "TIX_SAM_FILE=libtixsam${TCL_SHARED_LIB_SUFFIX}"
|
||||
+ eval "TIX_SAM_FILE=libtixsam`echo ${VERSION} | tr -d .`.so.1.2"
|
||||
TIX_MAKE_SAM="\${SHLIB_LD} -o ${TIX_SAM_FILE} \${TIX_SAM_OBJS} ${SHLIB_LD_LIBS}"
|
||||
|
||||
else
|
||||
@@ -1707,15 +1709,15 @@
|
||||
s%@SHLIB_VERSION@%$SHLIB_VERSION%g
|
||||
s%@DL_LIBS@%$DL_LIBS%g
|
||||
|
@ -1,5 +1,5 @@
|
||||
--- Makefile.in.orig Wed Sep 24 01:57:18 1997
|
||||
+++ Makefile.in Wed Oct 1 13:23:24 1997
|
||||
--- Makefile.in.orig Thu Sep 25 20:32:45 1997
|
||||
+++ Makefile.in Sun Oct 4 20:47:11 1998
|
||||
@@ -29,7 +29,7 @@
|
||||
# Directory in which to install the library of Tix scripts and demos
|
||||
# (note: you can set the TIX_LIBRARY environment variable at run-time to
|
||||
@ -32,7 +32,7 @@
|
||||
|
||||
|
||||
#----------------------------------------------------------------
|
||||
@@ -210,29 +212,29 @@
|
||||
@@ -211,29 +211,29 @@
|
||||
# scripts of TK must be included in the fixed order.
|
||||
#----------------------------------------------------------------------
|
||||
|
||||
@ -83,3 +83,11 @@
|
||||
$(SRC_DIR)/generic/tk8.0/console.tcl
|
||||
|
||||
TIX_SCRIPTS = \
|
||||
@@ -247,6 +247,7 @@
|
||||
rm -f $(TIX_LIB_FILE)
|
||||
@TIX_MAKE_LIB@
|
||||
$(RANLIB) $(TIX_LIB_FILE)
|
||||
+ ln -fs $(TIX_LIB_FILE) `echo $(TIX_LIB_FILE) | sed -e 's/[\.0-9]*$$//'`
|
||||
|
||||
$(TCL_SAM_FILE): $(TCL_SAM_OBJS)
|
||||
rm -f $(TCL_SAM_FILE)
|
||||
|
@ -17,9 +17,11 @@ include/tix/generic/tixTList.h
|
||||
include/tix/unix/tixUnixInt.h
|
||||
include/tix/unix/tixUnixPort.h
|
||||
lib/libtix4180.so.1.2
|
||||
lib/libtix4180.so
|
||||
lib/libtixsam4180.so.1.2
|
||||
@exec /sbin/ldconfig -m %B
|
||||
@unexec /sbin/ldconfig -R
|
||||
lib/libtixsam4180.so
|
||||
@exec /usr/bin/env OBJFORMAT=%%PORTOBJFORMAT%% /sbin/ldconfig -m %B
|
||||
@unexec /usr/bin/env OBJFORMAT=%%PORTOBJFORMAT%% /sbin/ldconfig -R
|
||||
share/tix4.1/bitmaps/act_fold.gif
|
||||
share/tix4.1/bitmaps/act_fold.xbm
|
||||
share/tix4.1/bitmaps/act_fold.xpm
|
||||
|
Loading…
Reference in New Issue
Block a user