- Remove astro/gaia: broken and upstream development ceased; graphics/glosm is its successor
This commit is contained in:
parent
076a4730ae
commit
651a1788ab
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=271565
@ -19,7 +19,6 @@
|
||||
SUBDIR += ephem
|
||||
SUBDIR += fowsr
|
||||
SUBDIR += foxtrotgps
|
||||
SUBDIR += gaia
|
||||
SUBDIR += gkrellmoon
|
||||
SUBDIR += gkrellmoon2
|
||||
SUBDIR += gkrellsun
|
||||
|
@ -1,53 +0,0 @@
|
||||
# New ports collection makefile for: gaia
|
||||
# Date created: 23 November 2006
|
||||
# Whom: Stefan Esser <se@FreeBSD.org>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= gaia
|
||||
PORTVERSION= 0.1.2
|
||||
PORTREVISION= 9
|
||||
CATEGORIES= astro
|
||||
MASTER_SITES= SF/${PORTNAME}-clean/${PORTNAME}/${PORTNAME}-${PORTVERSION}
|
||||
|
||||
MAINTAINER= amdmi3@FreeBSD.org
|
||||
COMMENT= Display geographic maps with optional GPS tracking support
|
||||
|
||||
LIB_DEPENDS= curl.6:${PORTSDIR}/ftp/curl \
|
||||
jpeg.11:${PORTSDIR}/graphics/jpeg \
|
||||
png.6:${PORTSDIR}/graphics/png
|
||||
|
||||
USE_BZIP2= yes
|
||||
USE_SCONS= yes
|
||||
SCONS_BUILDENV= ${SCONS_ENV}
|
||||
SCONS_ARGS+= prefix=${PREFIX} use_env=1
|
||||
USE_SDL= sdl
|
||||
|
||||
OPTIONS= GPS "Build with GPS support" off
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if !defined(WITHOUT_GPS)
|
||||
LIB_DEPENDS+= gps.18:${PORTSDIR}/astro/gpsd
|
||||
SCONS_ARGS+= gpsd=1
|
||||
.endif
|
||||
|
||||
PLIST_FILES= bin/gaia share/gaia/font.png
|
||||
PLIST_DIRS= share/gaia
|
||||
|
||||
PORTDOCS= README
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|g' \
|
||||
-e 's|/usr/X11R6|${LOCALBASE}|g' ${WRKSRC}/SConstruct
|
||||
|
||||
.if !defined(NOPORTDOCS)
|
||||
post-install:
|
||||
${MKDIR} ${DOCSDIR}
|
||||
.for f in ${PORTDOCS}
|
||||
${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
|
||||
.endfor
|
||||
.endif
|
||||
|
||||
.include <bsd.port.post.mk>
|
@ -1,2 +0,0 @@
|
||||
SHA256 (gaia-0.1.2.tar.bz2) = 9174671fa3e88f6f10d6e5acfe1d18e8e4d6177fa0e288632b4b70f978864c95
|
||||
SIZE (gaia-0.1.2.tar.bz2) = 60241
|
@ -1,20 +0,0 @@
|
||||
--- SConstruct.orig 2006-12-05 15:31:42.000000000 +0300
|
||||
+++ SConstruct 2009-05-29 20:45:20.000000000 +0400
|
||||
@@ -8,7 +8,7 @@
|
||||
#######################################
|
||||
# OPTIONS
|
||||
#######################################
|
||||
-opts = Options(ARGUMENTS)
|
||||
+opts = Options(args = ARGUMENTS)
|
||||
# conditionally build parts of gaia
|
||||
#opts.Add(BoolOption('gaia', 'Compile gaia OpenGL client', 1));
|
||||
|
||||
@@ -25,7 +25,7 @@
|
||||
#######################################
|
||||
# ENVIRONMENT & SYSTEM_SPECIFIC CONFIGURATION
|
||||
#######################################
|
||||
-env = Environment( options = opts )
|
||||
+env = Environment( options = opts, ENV = os.environ )
|
||||
|
||||
if env['prefix'] == "":
|
||||
env['prefix'] = '.'
|
@ -1,20 +0,0 @@
|
||||
--- programs/gaia/Texture.cc.orig 2006-11-29 04:21:14.000000000 +0100
|
||||
+++ programs/gaia/Texture.cc 2010-03-29 14:33:38.000000000 +0200
|
||||
@@ -277,7 +277,7 @@
|
||||
|
||||
fread(sig, 8, 1, infile);
|
||||
|
||||
- if (!png_check_sig(sig, 8))
|
||||
+ if (png_sig_cmp(sig, 0, 8))
|
||||
throw Exception("bad PNG signature");
|
||||
|
||||
/* create structures */
|
||||
@@ -308,7 +308,7 @@
|
||||
switch (color_type) {
|
||||
case PNG_COLOR_TYPE_GRAY:
|
||||
if (bit_depth < 8)
|
||||
- png_set_gray_1_2_4_to_8(png_ptr);
|
||||
+ png_set_expand_gray_1_2_4_to_8(png_ptr);
|
||||
m_glInternalFormat = GL_LUMINANCE8;
|
||||
m_glFormat = GL_LUMINANCE;
|
||||
break;
|
@ -1,11 +0,0 @@
|
||||
--- lib/wwfetch/wwfetch_http.c.old 2009-01-24 15:12:41.000000000 +0200
|
||||
+++ lib/wwfetch/wwfetch_http.c 2009-01-24 15:15:30.000000000 +0200
|
||||
@@ -96,7 +96,7 @@
|
||||
if ((handle->lastcurlerror = curl_easy_setopt(handle->curl, CURLOPT_HTTPHEADER, handle->curlheaders)) != CURLE_OK)
|
||||
return WWFETCH_CURL_ERROR;
|
||||
|
||||
- if ((handle->lastcurlerror = curl_easy_setopt(handle->curl, CURLOPT_USERAGENT, "gaia/%s", GAIA_VERSION)) != CURLE_OK)
|
||||
+ if ((handle->lastcurlerror = curl_easy_setopt(handle->curl, CURLOPT_USERAGENT, "gaia/" GAIA_VERSION)) != CURLE_OK)
|
||||
return WWFETCH_CURL_ERROR;
|
||||
|
||||
if ((handle->lastcurlerror = curl_easy_setopt(handle->curl, CURLOPT_URL, url)) != CURLE_OK)
|
@ -1,7 +0,0 @@
|
||||
Gaia is an open, portable, customizable and extendable Earth viewer,
|
||||
currently in an early stage of development.
|
||||
|
||||
Optionally, the current position as reported by any GPS device
|
||||
supported by "gpsd" can be tracked and displayed.
|
||||
|
||||
WWW: http://www.sourceforge.net/projects/gaia-clean
|
Loading…
Reference in New Issue
Block a user