Fix problems which where there during running of the program:

- checked on 4.8
    - checked on 5.2.1 with standard libpcap
    - checked on 5.2.1 with net/libpcap

Commands checked:
    - ngrep -d fxp1
    - ngrep -d fxp1 port 80
    - ngrep -d fxp1 GET port 80
This commit is contained in:
Edwin Groothuis 2004-02-28 11:21:56 +00:00
parent a664d4c3fa
commit 650e73eb31
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=102379
4 changed files with 4 additions and 64 deletions

View File

@ -8,7 +8,7 @@
PORTNAME= ngrep
PORTVERSION= 1.40.1
PORTREVISION= 2
PORTREVISION= 3
CATEGORIES= net security
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@ -18,18 +18,16 @@ COMMENT= Network grep
WRKSRC= ${WRKDIR}/ngrep
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-pcre --with-restart
CONFIGURE_ARGS= --with-pcre --without-restart
ALL_TARGET= ngrep
MAN8= ngrep.8
PLIST_FILES= bin/ngrep
PORTDOCS= BUGS CHANGES README README.pcre USAGE
.include <bsd.port.pre.mk>
.if ${OSVERSION} > 501110
EXTRA_PATCHES= ${PATCHDIR}/patch5-configure ${PATCHDIR}/patch5-ngrep
.endif
post-install:
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}

View File

@ -1,37 +0,0 @@
--- configure.orig Sat Nov 8 15:49:02 2003
+++ configure Sat Nov 8 15:49:54 2003
@@ -1978,9 +1978,9 @@
else
echo "$ac_t""no" 1>&6
-echo $ac_n "checking for pcap_yyrestart in -lpcap""... $ac_c" 1>&6
-echo "configure:1983: checking for pcap_yyrestart in -lpcap" >&5
-ac_lib_var=`echo pcap'_'pcap_yyrestart | sed 'y%./+-%__p_%'`
+echo $ac_n "checking for pcapyyrestart in -lpcap""... $ac_c" 1>&6
+echo "configure:1983: checking for pcapyyrestart in -lpcap" >&5
+ac_lib_var=`echo pcap'_'pcapyyrestart | sed 'y%./+-%__p_%'`
if eval "test \"`echo '$''{'ac_cv_lib_$ac_lib_var'+set}'`\" = set"; then
echo $ac_n "(cached) $ac_c" 1>&6
else
@@ -1992,10 +1992,10 @@
/* Override any gcc2 internal prototype to avoid an error. */
/* We use char because int might match the return type of a gcc2
builtin and then its argument prototype would still apply. */
-char pcap_yyrestart();
+char pcapyyrestart();
int main() {
-pcap_yyrestart()
+pcapyyrestart()
; return 0; }
EOF
if { (eval echo configure:2002: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
@@ -2014,7 +2014,7 @@
if eval "test \"`echo '$ac_cv_lib_'$ac_lib_var`\" = yes"; then
echo "$ac_t""yes" 1>&6
cat >> confdefs.h <<\EOF
-#define PCAP_RESTART pcap_yyrestart
+#define PCAP_RESTART pcapyyrestart
EOF
else

View File

@ -1,19 +0,0 @@
--- ngrep.c.orig Mon Dec 31 14:11:00 2001
+++ ngrep.c Sat Nov 8 15:50:53 2003
@@ -62,6 +62,7 @@
#include "ngrep.h"
+extern FILE *pcapyyin;
static char rcsver[] = "$Revision: 1.23 $";
@@ -232,7 +233,7 @@
filter = get_filter(&argv[optind-1]);
#ifdef NEED_RESTART
- PCAP_RESTART();
+ PCAP_RESTART(pcapyyin);
#endif
if (pcap_compile(pd, &pcapfilter, filter, 0, mask.s_addr)) {
pcap_perror(pd, "pcap compile");

View File

@ -1,2 +0,0 @@
@comment $FreeBSD$
bin/ngrep