x11/phosh: update to 0.7.1

Changes:	https://source.puri.sm/Librem5/phosh/-/tags/v0.7.1
Reported by:	Repology
This commit is contained in:
Jan Beich 2020-12-19 00:32:31 +00:00
parent a54bfc704c
commit 64e702c9ca
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=558419
5 changed files with 87 additions and 7 deletions

View File

@ -2,7 +2,7 @@
PORTNAME= phosh
DISTVERSIONPREFIX= v
DISTVERSION= 0.7.0
DISTVERSION= 0.7.1
CATEGORIES= x11
MAINTAINER= jbeich@FreeBSD.org
@ -27,7 +27,7 @@ USE_GITLAB= yes
USE_GNOME= cairo gdkpixbuf2 gnomedesktop3
GL_SITE= https://source.puri.sm
GL_ACCOUNT= Librem5
GL_COMMIT= 34720663adadc6959dac293ee7371354be26cfa8
GL_COMMIT= c343fd9e4eb96796fff53a638316cb1b20b5866c
GL_TUPLE= https://gitlab.gnome.org:GNOME:libgnome-volume-control:ae1a34aafce7026b8c0f65a43c9192d756fe1057:gvc/subprojects/gvc
SHEBANG_FILES= build-aux/post_install.py
MESON_ARGS= -Dgvc:alsa=false

View File

@ -1,5 +1,5 @@
TIMESTAMP = 1607605311
SHA256 (Librem5-phosh-34720663adadc6959dac293ee7371354be26cfa8_GL0.tar.gz) = a0883ed16448004ef2d6b109c27c42f4ae6249a84b77712a1331206fdb3c1d8f
SIZE (Librem5-phosh-34720663adadc6959dac293ee7371354be26cfa8_GL0.tar.gz) = 368118
TIMESTAMP = 1608303217
SHA256 (Librem5-phosh-c343fd9e4eb96796fff53a638316cb1b20b5866c_GL0.tar.gz) = 40e174ae41a0d8f0070a7d3700716dbb9e4abb44461b07010b2f72587ed251d5
SIZE (Librem5-phosh-c343fd9e4eb96796fff53a638316cb1b20b5866c_GL0.tar.gz) = 374411
SHA256 (GNOME-libgnome-volume-control-ae1a34aafce7026b8c0f65a43c9192d756fe1057_GL0.tar.gz) = 780143bef70698e402b099f300f5c82bfbb38ef5c3b6d89b1efeb7a45a5d8dc1
SIZE (GNOME-libgnome-volume-control-ae1a34aafce7026b8c0f65a43c9192d756fe1057_GL0.tar.gz) = 45245

View File

@ -3,15 +3,17 @@ implements libnm-compatible API required by Phosh and GNOME.
meson.build:134:0: ERROR: Dependency "libnm" not found, tried pkgconfig
--- meson.build.orig 2020-08-03 08:10:28 UTC
--- meson.build.orig 2020-12-18 14:53:37 UTC
+++ meson.build
@@ -131,9 +131,9 @@ libhandy_dep = dependency('libhandy-0.0',
@@ -131,11 +131,11 @@ libhandy_dep = dependency('libhandy-1',
fallback: ['libhandy', 'libhandy_dep'],
default_options: ['introspection=disabled']
)
-libnm_dep = dependency('libnm', version: '>= 1.14')
+libnm_dep = dependency('libnm', version: '>= 1.14', required: false)
libpolkit_agent_dep = dependency('polkit-agent-1', version: '>= 0.105')
# TODO: make optional for elogind?
libsystemd_dep = dependency('libsystemd', version: '>= 241')
-network_agent_dep = dependency('libsecret-1')
+network_agent_dep = dependency('libsecret-1', required: false)
upower_glib_dep = dependency('upower-glib', version: '>=0.99.1')

View File

@ -0,0 +1,77 @@
(e)logind is Linux-only. FreeBSD supports libseat but it has a different API.
--- meson.build.orig 2020-12-18 14:53:37 UTC
+++ meson.build
@@ -134,7 +134,7 @@ libhandy_dep = dependency('libhandy-1',
libnm_dep = dependency('libnm', version: '>= 1.14', required: false)
libpolkit_agent_dep = dependency('polkit-agent-1', version: '>= 0.105')
# TODO: make optional for elogind?
-libsystemd_dep = dependency('libsystemd', version: '>= 241')
+libsystemd_dep = dependency('libsystemd', version: '>= 241', required: false)
network_agent_dep = dependency('libsecret-1', required: false)
upower_glib_dep = dependency('upower-glib', version: '>=0.99.1')
wayland_client_dep = dependency('wayland-client', version: '>=1.14')
--- src/util.c.orig 2020-12-18 14:53:37 UTC
+++ src/util.c
@@ -9,8 +9,6 @@
#include "util.h"
#include <gtk/gtk.h>
-#include <systemd/sd-login.h>
-
/* Just wraps gtk_widget_destroy so we can use it with g_clear_pointer */
void
phosh_cp_widget_destroy (void *widget)
@@ -97,51 +95,5 @@ phosh_munge_app_id (const char *app_id)
gboolean
phosh_find_systemd_session (char **session_id)
{
- int n_sessions;
-
- g_auto (GStrv) sessions = NULL;
- char *session;
- int i;
-
- n_sessions = sd_uid_get_sessions (getuid (), 0, &sessions);
-
- if (n_sessions < 0) {
- g_debug ("Failed to get sessions for user %d", getuid ());
- return FALSE;
- }
-
- session = NULL;
- for (i = 0; i < n_sessions; i++) {
- int r;
- g_autofree char *type = NULL;
- g_autofree char *desktop = NULL;
-
- r = sd_session_get_desktop (sessions[i], &desktop);
- if (r < 0) {
- g_debug ("Couldn't get desktop for session '%s': %s",
- sessions[i], strerror (-r));
- continue;
- }
-
- if (g_strcmp0 (desktop, "phosh") != 0)
- continue;
-
- r = sd_session_get_type (sessions[i], &type);
- if (r < 0) {
- g_debug ("Couldn't get type for session '%s': %s",
- sessions[i], strerror (-r));
- continue;
- }
-
- if (g_strcmp0 (type, "wayland") != 0)
- continue;
-
- session = sessions[i];
- break;
- }
-
- if (session != NULL)
- *session_id = g_strdup (session);
-
- return session != NULL;
+ return FALSE;
}

View File

@ -23,6 +23,7 @@ share/locale/fr/LC_MESSAGES/phosh.mo
share/locale/fur/LC_MESSAGES/phosh.mo
share/locale/he/LC_MESSAGES/phosh.mo
share/locale/hu/LC_MESSAGES/phosh.mo
share/locale/id/LC_MESSAGES/phosh.mo
share/locale/it/LC_MESSAGES/phosh.mo
share/locale/ja/LC_MESSAGES/phosh.mo
share/locale/ko/LC_MESSAGES/phosh.mo