Update to version 2.3.0
Approved by: antoine (implicit)
This commit is contained in:
parent
5361f64161
commit
64c3a642b6
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=517263
@ -1,7 +1,7 @@
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= bc
|
||||
PORTVERSION= 2.1.0
|
||||
PORTVERSION= 2.3.0
|
||||
CATEGORIES= math
|
||||
PKGNAMEPREFIX= gh-
|
||||
|
||||
@ -11,16 +11,25 @@ COMMENT= GNU compatible bc/dc calculator
|
||||
LICENSE= BSD2CLAUSE
|
||||
LICENSE_FILE= ${WRKSRC}/LICENSE.md
|
||||
|
||||
USES= compiler
|
||||
USE_GITHUB= yes
|
||||
GH_ACCOUNT= gavinhoward
|
||||
|
||||
HAS_CONFIGURE= yes
|
||||
CONFIGURE_SCRIPT= configure.sh
|
||||
CONFIGURE_ARGS= -G
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if ${CHOSEN_COMPILER_TYPE} == gcc && ${COMPILER_VERSION} <= 42
|
||||
CFLAGS+= --std=c99
|
||||
.endif
|
||||
|
||||
CONFLICTS_INSTALL= gnubc-[0-9]*
|
||||
|
||||
pre-build:
|
||||
${INSTALL_SCRIPT} ${WRKSRC}/gen/strgen.sh ${WRKSRC}/gen/strgen
|
||||
|
||||
do-install:
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/bin/bc ${STAGEDIR}${PREFIX}/bin/
|
||||
${LN} ${STAGEDIR}${PREFIX}/bin/bc ${STAGEDIR}${PREFIX}/bin/dc
|
||||
@ -34,4 +43,4 @@ do-install:
|
||||
do-test:
|
||||
${MAKE} -C ${WRKSRC} test
|
||||
|
||||
.include <bsd.port.mk>
|
||||
.include <bsd.port.post.mk>
|
||||
|
@ -1,3 +1,3 @@
|
||||
TIMESTAMP = 1562335308
|
||||
SHA256 (gavinhoward-bc-2.1.0_GH0.tar.gz) = bc39c11cd91d2df079f9d7a7bae90f681cfe055b7ad58010c11020625bf1d8a9
|
||||
SIZE (gavinhoward-bc-2.1.0_GH0.tar.gz) = 237162
|
||||
TIMESTAMP = 1573478768
|
||||
SHA256 (gavinhoward-bc-2.3.0_GH0.tar.gz) = c3d6d86e8ffc3c6b657d0ca1a02c4499d760aa869ba9ff813c83f731493ee8e8
|
||||
SIZE (gavinhoward-bc-2.3.0_GH0.tar.gz) = 241071
|
||||
|
@ -1,6 +1,6 @@
|
||||
--- locale_install.sh.orig 2019-05-29 01:32:06 UTC
|
||||
--- locale_install.sh.orig 2019-11-09 19:04:17 UTC
|
||||
+++ locale_install.sh
|
||||
@@ -114,6 +114,7 @@ for file in $locales_dir/*.msg; do
|
||||
@@ -193,6 +193,7 @@ for file in $locales_dir/*.msg; do
|
||||
continue
|
||||
fi
|
||||
|
||||
@ -8,11 +8,18 @@
|
||||
gencatfile "$loc" "$file"
|
||||
|
||||
done
|
||||
@@ -143,7 +144,8 @@ for file in $locales_dir/*.msg; do
|
||||
@@ -217,14 +218,13 @@ for file in $locales_dir/*.msg; do
|
||||
linkdir=$(dirname "$file")
|
||||
locale=$(basename "$link" .msg)
|
||||
linksrc=$(gen_nlspath "$nlspath" "$locale" "$main_exec")
|
||||
- relloc="${loc##$destdir/}"
|
||||
- rel=$(relpath "$linksrc" "$relloc")
|
||||
|
||||
if [ ! -f "$destdir/$linksrc" ]; then
|
||||
gencatfile "$destdir/$linksrc" "$linkdir/$link"
|
||||
fi
|
||||
|
||||
- ln -s "$linksrc" "$loc"
|
||||
- ln -fs "$rel" "$loc"
|
||||
+ echo ln "$linksrc" "$loc"
|
||||
+ ln "$linksrc" "$loc"
|
||||
fi
|
||||
|
Loading…
Reference in New Issue
Block a user