New port: math/qposases: Library for online active set strategy quadratic programming problems

This commit is contained in:
Yuri Victorovich 2018-12-09 21:01:47 +00:00
parent c0aad077ca
commit 64a4de2ab9
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=487087
6 changed files with 80 additions and 0 deletions

View File

@ -795,6 +795,7 @@
SUBDIR += qd
SUBDIR += qhull
SUBDIR += qhull5
SUBDIR += qposases
SUBDIR += qrupdate
SUBDIR += qtiplot
SUBDIR += qtiplot-doc

21
math/qposases/Makefile Normal file
View File

@ -0,0 +1,21 @@
# $FreeBSD$
PORTNAME= qpOASES
DISTVERSION= 3.2.1
CATEGORIES= math
MASTER_SITES= https://www.coin-or.org/download/source/${PORTNAME}/
PKGNAMEPREFIX= coin-or-
MAINTAINER= yuri@FreeBSD.org
COMMENT= Library for online active set strategy quadratic programming problems
LICENSE= LGPL21
LICENSE_FILE= ${WRKSRC}/LICENSE
USES= cmake:outsource tar:tgz
USE_LDCONFIG= yes
CMAKE_ON= BUILD_SHARED_LIBS
CMAKE_OFF= QPOASES_BUILD_EXAMPLES
.include <bsd.port.mk>

3
math/qposases/distinfo Normal file
View File

@ -0,0 +1,3 @@
TIMESTAMP = 1544388746
SHA256 (qpOASES-3.2.1.tgz) = 9d81a8af3f5b5ba6e90912964966f7b246f16979db166c3631eeaeca9b4d5666
SIZE (qpOASES-3.2.1.tgz) = 995713

View File

@ -0,0 +1,11 @@
--- CMakeLists.txt.orig 2018-12-09 20:53:53 UTC
+++ CMakeLists.txt
@@ -104,7 +104,7 @@ INCLUDE_DIRECTORIES(${PROJECT_SOURCE_DIR
FILE(GLOB SRC src/*.cpp)
# library
-ADD_LIBRARY(qpOASES STATIC ${SRC})
+ADD_LIBRARY(qpOASES ${SRC})
INSTALL(TARGETS qpOASES
LIBRARY DESTINATION lib
ARCHIVE DESTINATION lib

9
math/qposases/pkg-descr Normal file
View File

@ -0,0 +1,9 @@
qpOASES is an open-source C++ implementation of the recently proposed online
active set strategy for solving quadratic programming (QP) problems. It has
several theoretical features that make it particularly suited for model
predictive control (MPC) applications. Further numerical modifications have
made qpOASES a reliable QP solver, even when tackling semi-definite, ill-posed
or degenerated QP problems. Moreover, several interfaces to third-party software
make qpOASES easy-to-use even for users without knowledge of C/C++.
WWW: https://projects.coin-or.org/qpOASES

35
math/qposases/pkg-plist Normal file
View File

@ -0,0 +1,35 @@
include/qpOASES.hpp
include/qpOASES/Bounds.hpp
include/qpOASES/Bounds.ipp
include/qpOASES/Constants.hpp
include/qpOASES/ConstraintProduct.hpp
include/qpOASES/Constraints.hpp
include/qpOASES/Constraints.ipp
include/qpOASES/Flipper.hpp
include/qpOASES/Indexlist.hpp
include/qpOASES/Indexlist.ipp
include/qpOASES/LapackBlasReplacement.hpp
include/qpOASES/Matrices.hpp
include/qpOASES/MessageHandling.hpp
include/qpOASES/MessageHandling.ipp
include/qpOASES/Options.hpp
include/qpOASES/QProblem.hpp
include/qpOASES/QProblem.ipp
include/qpOASES/QProblemB.hpp
include/qpOASES/QProblemB.ipp
include/qpOASES/SQProblem.hpp
include/qpOASES/SQProblem.ipp
include/qpOASES/SQProblemSchur.hpp
include/qpOASES/SQProblemSchur.ipp
include/qpOASES/SparseSolver.hpp
include/qpOASES/SubjectTo.hpp
include/qpOASES/SubjectTo.ipp
include/qpOASES/Types.hpp
include/qpOASES/UnitTesting.hpp
include/qpOASES/Utils.hpp
include/qpOASES/Utils.ipp
include/qpOASES/extras/OQPinterface.hpp
include/qpOASES/extras/SolutionAnalysis.hpp
include/qpOASES/extras/SolutionAnalysis.ipp
lib/libqpOASES.so
lib/libqpOASES.so.3.2