Link this library symbolically so that it can be linked into executables

along with OpenSSL.  Without this, there is a symbol conflict with
MD5_Update() which can cause applications such as Evolution 1.5 to crash
when Kerberos support is enabled.

The longer-term goal is to configure Mozilla's internal NSS to be linked
symbolically which should allow us to enable OpenSSL support in gnomevfs2.
This commit is contained in:
Joe Marcus Clarke 2004-03-19 06:35:22 +00:00
parent 357d90afb4
commit 64768c1c1f
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=104589
2 changed files with 10 additions and 6 deletions

View File

@ -7,6 +7,7 @@
PORTNAME= nss
PORTVERSION= 3.9
PORTREVISION= 1
CATEGORIES= security
MASTER_SITES= ${MASTER_SITE_MOZILLA}
MASTER_SITE_SUBDIR= security/nss/releases/NSS_${PORTVERSION:S/./_/g}_RTM/src

View File

@ -1,8 +1,5 @@
$FreeBSD$
--- ../coreconf/FreeBSD.mk.orig Thu Mar 27 02:17:25 2003
+++ ../coreconf/FreeBSD.mk Fri Apr 11 00:53:38 2003
--- ../coreconf/FreeBSD.mk.orig Wed Mar 26 20:17:25 2003
+++ ../coreconf/FreeBSD.mk Fri Mar 19 01:23:30 2004
@@ -35,9 +35,9 @@
include $(CORE_DEPTH)/coreconf/UNIX.mk
@ -34,7 +31,7 @@ $FreeBSD$
endif
ARCH = freebsd
@@ -66,7 +68,7 @@
@@ -66,12 +68,12 @@
MOZ_OBJFORMAT := $(shell test -x /usr/bin/objformat && /usr/bin/objformat || echo aout)
ifeq ($(MOZ_OBJFORMAT),elf)
@ -43,3 +40,9 @@ $FreeBSD$
else
DLL_SUFFIX = so.1.0
endif
-MKSHLIB = $(CC) $(DSO_LDOPTS)
+MKSHLIB = $(CC) -Wl,-Bsymbolic $(DSO_LDOPTS)
ifdef MAPFILE
# Add LD options to restrict exported symbols to those in the map file
endif