Handle info files.

Submitted by:	Justin M. Seger <jseger@freebsd.org>
This commit is contained in:
Thomas Gellekum 1997-10-13 09:10:33 +00:00
parent 3e62e7728c
commit 643bcf78d1
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=8237
5 changed files with 158 additions and 13 deletions

View File

@ -3,7 +3,7 @@
# Date created: Wed Feb 8 01:49:11 1995
# Whom: hsu
#
# $Id: Makefile,v 1.8 1997/03/05 12:24:46 asami Exp $
# $Id: Makefile,v 1.9 1997/10/07 09:20:05 tg Exp $
#
DISTNAME= gcl-2.2.2
@ -11,7 +11,18 @@ CATEGORIES= lang
MASTER_SITES= ftp://ftp.ma.utexas.edu/pub/gcl/ \
${MASTER_SITE_GNU}
MAINTAINER= jseger@freebsd.scds.com
MAINTAINER= jseger@freebsd.org
MAKEFILE= makefile
pre-build:
${RM} -rf ${WRKSRC}/info/gcl-si.info*
post-install:
${INSTALL_DATA} ${WRKSRC}/info/gcl-si.info ${PREFIX}/info
@if [ ! -f ${PREFIX}/info/dir ]; then \
${SED} -ne '1,/Menu:/p' /usr/share/info/dir > ${PREFIX}/info/dir; \
fi
@install-info ${PREFIX}/info/gcl-si.info ${PREFIX}/info/dir
.include <bsd.port.mk>

21
lang/gcl/files/patch-aa Normal file
View File

@ -0,0 +1,21 @@
--- info/gcl-si.texi.orig Wed Mar 8 18:08:53 1995
+++ info/gcl-si.texi Sun Oct 12 17:14:04 1997
@@ -9,7 +9,6 @@
@c ! unbalanced parens in @def arguments.
@c ignore these by using 's' to scroll error messages in tex.
-
@c @smallbook
@setfilename gcl-si.info
@synindex vr fn
@@ -21,6 +20,10 @@
@setchapternewpage odd
@ifinfo
+@dircategory GNU Common Lisp
+@direntry
+* GCL Systems Internals: (gcl-si). GCL SYSTEM INTERNALS Manual
+@end direntry
This is a Texinfo GCL SYSTEM INTERNALS Manual
Copyright 1994 William F. Schelter

View File

@ -9,19 +9,17 @@
install-command:
rm -f ${PREFIX_DIR}/bin/gcl
@@ -141,21 +141,15 @@
@@ -141,21 +141,13 @@
-if [ -d "${PREFIX_DIR}/lib" ] ;then true; else mkdir ${PREFIX_DIR}/lib ; fi
-if [ -d "${PREFIX_DIR}/bin" ] ;then true; else mkdir ${PREFIX_DIR}/bin ; fi
-if [ -d "${INSTALL_LIB_DIR}" ] ; then true; else mkdir ${INSTALL_LIB_DIR} ;fi
+ -if [ -d "${PREFIX_DIR}/info" ] ; then true; else mkdir ${PREFIX_DIR}/info; fi
+ -if [ -d "${PREFIX_DIR}/info/gcl-2.2.2" ] ; then true; else mkdir ${PREFIX_DIR}/info/gcl-2.2.2; fi
make install-command "INSTALL_LIB_DIR=${INSTALL_LIB_DIR}" "PREFIX_DIR=${PREFIX_DIR}"
rm -f ${PREFIX_DIR}/bin/gcl.exe
- tar cvf - unixport/saved_gcl info/*info* doc/*.el ${LISP_LIB} \
- gcl-tk/gcl.tcl gcl-tk/gcltkaux | (cd ${INSTALL_LIB_DIR} ;tar xvf -)
+ tar cvf - unixport/saved_gcl ${LISP_LIB} \
+ | (cd ${INSTALL_LIB_DIR} ;tar xvf -)
+ (cd info; tar cvf - *si.info* | (cd ${PREFIX_DIR}/info/gcl-2.2.2 ; tar xvf -))
ln ${SYMB} ${INSTALL_LIB_DIR}/unixport/saved_gcl \
${PREFIX_DIR}/bin/gcl.exe
- -cat gcl-tk/gcltksrv | \

119
lang/gcl/files/patch-ac Normal file
View File

@ -0,0 +1,119 @@
--- info/makefile.orig Mon Dec 9 01:30:25 1996
+++ info/makefile Mon Oct 13 10:56:17 1997
@@ -3,53 +3,46 @@
INFO_DIR=/usr/local/lib/info
# begin makedefs
-GCLDIR=/home/wfs/gcl-2.2
+GCLDIR=/tmp/FreeBSD/gcl/work/gcl-2.2.2
SHELL=/bin/sh
-MACHINE=386-linux
-TK_CONFIG_PREFIX="/usr/local/lib"
-TCL_CONFIG_PREFIX="/usr/local/lib"
-TK_INCLUDE="-I/usr/local/include"
-TK_VERSION=4.2
-TCL_VERSION=7.6
-TK_LIB_SPEC=-L/usr/local/lib -ltk4.2
-TK_LIBRARY=/usr/local/lib/tk4.2
-TCL_LIBRARY=/usr/local/lib/tcl7.6
-TK_BUILD_LIB_SPEC=-L/usr/local.linux14/src/tk4.2/unix -ltk4.2
-TK_XLIBSW=-L/usr/X11R6/lib -lX11
-TK_XINCLUDES=-I/usr/X11R6/include
-TCL_LIB_SPEC=-L/usr/local/lib -ltcl7.6
-TCL_DL_LIBS=-ldl
-TCL_LIBS=-ldl -lieee -lm
-HAVE_X11=-DHAVE_X11
-
-# Machine dependent makefile definitions for intel 386,486 running linux
-
-LBINDIR=/usr/local/bin
-
-OFLAG = -O
-LIBS = -lm
-
-ODIR_DEBUG= -O4
+MACHINE=FreeBSD
+#could not find tkConfig.sh so using:
+TK_CONFIG_PREFIX="unknown"
+#could not find tclConfig.sh so using:
+TCL_CONFIG_PREFIX="unknown"
+#could not find dir so using:
+INFO_DIR="unknown"
+TK_CONFIG_PREFIX=unknown
+#could not find X11/Xos.h so using:
+TK_XINCLUDES="-Iunknown"
+# Machine dependent makefile definitions for intel 386,486 running 386bsd
+# Ported to FreeBSD 2.0 by Jeffrey Hsu (hsu@freebsd.org).
+# Hacked September-93 by Paul F. Werkowski for 386BSD 0.1 + Patchkit 0.2.4
+
+LBINDIR=${PREFIX}/bin
+
+OFLAG = -O2 -pipe
+LIBS = -lm
+ODIR_DEBUG=
+NULLFILE=../h/twelve_null
# This CC string will be used for compilation of the system,
# and also in the compiler::*cc* variable for later compilation of
# lisp files.
-# (the -pipe is just since our file system is slow..)
-CC = gcc -pipe -fwritable-strings -DVOL=volatile -I$(GCLDIR)/o -fsigned-char
-LDCC=${CC} -static
-# note for linuxaout on an elf machine add -b i486-linuxaout
-# CC = gcc -pipe -fwritable-strings -DVOL=volatile -I$(GCLDIR)/o -fsigned-char -b i486-linuxaout
+
+CC = gcc -pipe -O -fwritable-strings -fomit-frame-pointer -DVOL=volatile -I$(GCLDIR)/o -I${PREFIX}/lib/gcl-2.2.2/h -fsigned-char
+
+LDCC = $(CC) -static
+
+# Use the mp.s file on 68k machine
+MPFILES= $(MPDIR)/mpi-386.o $(MPDIR)/libmport.a
+GNULIB1=/usr/lib/libgcc.a
# Enable the fastloading mechanism which does not use ld -A
# requires c/rel_.. machine dependent code.
-
RSYM = rsym
SFASL = $(ODIR)/sfasl.o
-
-MPFILES= $(MPDIR)/mpi-386d.o $(MPDIR)/libmport.a
-
-
# When using SFASL it is good to have (si::build-symbol-table)
INITFORM=(si::build-symbol-table)
@@ -67,8 +60,8 @@
.texi.info:
rm -f $*.*gz
- makeinfo $*.texi
- - gzip $*.info-*
+ makeinfo --no-split $*.texi
+# - gzip $*.info
GCL_SI= number.texi sequence.texi character.texi list.texi io.texi \
form.texi compile.texi symbol.texi system.texi structure.texi \
@@ -82,14 +75,14 @@
install:
- if [ -d "${INFO_DIR}" ] ; then true ; else exit 0; fi
- -if fgrep gcl-si ${INFO_DIR}/dir > /dev/null ; then true ; else \
- echo "* GCL Doc: (gcl-si.info). GNU Common Lisp specific Documentation." >> ${INFO_DIR}/dir ; fi
- -if fgrep gcl-tk ${INFO_DIR}/dir > /dev/null ; then true ; else \
- echo "* GCL TK Doc: (gcl-tk.info). TK window GCL interface." >> ${INFO_DIR}/dir ; fi
- -if fgrep gcl.info ${INFO_DIR}/dir > /dev/null ; then true ; else \
- echo "* GCL Ansi Doc: (gcl.info). Ansi Common Lisp Specification." >> ${INFO_DIR}/dir ; fi
- -if [ -d "${INFO_DIR}" ] ; then cp *.info* ${INFO_DIR} ; fi
+# if [ -d "${INFO_DIR}" ] ; then true ; else exit 0; fi
+# -if fgrep gcl-si ${INFO_DIR}/dir > /dev/null ; then true ; else \
+# echo "* GCL Doc: (gcl-si.info). GNU Common Lisp specific Documentation." >> ${INFO_DIR}/dir ; fi
+# -if fgrep gcl-tk ${INFO_DIR}/dir > /dev/null ; then true ; else \
+# echo "* GCL TK Doc: (gcl-tk.info). TK window GCL interface." >> ${INFO_DIR}/dir ; fi
+# -if fgrep gcl.info ${INFO_DIR}/dir > /dev/null ; then true ; else \
+# echo "* GCL Ansi Doc: (gcl.info). Ansi Common Lisp Specification." >> ${INFO_DIR}/dir ; fi
+# -if [ -d "${INFO_DIR}" ] ; then cp *.info* ${INFO_DIR} ; fi

View File

@ -1,12 +1,9 @@
bin/gcl
bin/gcl.exe
info/gcl-2.2.2/gcl-si.info
info/gcl-2.2.2/gcl-si.info-1
info/gcl-2.2.2/gcl-si.info-2
info/gcl-2.2.2/gcl-si.info-3
info/gcl-2.2.2/gcl-si.info-4
info/gcl-2.2.2/gcl-si.info-5
info/gcl-2.2.2/gcl-si.info-6
@unexec install-info --delete %D/info/gcl-si.info %D/info/dir
info/gcl-si.info
@exec [ -f %D/info/dir ] || sed -ne '1,/Menu:/p' /usr/share/info/dir > %D/info/dir
@exec install-info %D/info/gcl-si.info %D/info/dir
lib/gcl-2.2.2/cmpnew/collectfn.o
lib/gcl-2.2.2/lsp/gprof.lsp
lib/gcl-2.2.2/lsp/info.o
@ -16,4 +13,3 @@ lib/gcl-2.2.2/unixport/saved_gcl
@dirrm lib/gcl-2.2.2/lsp
@dirrm lib/gcl-2.2.2/cmpnew
@dirrm lib/gcl-2.2.2
@dirrm info/gcl-2.2.2