- Update from 1.0 to 1.1 [1]

- Remove the indefinite article from COMMENT
- Convert USE_GMAKE to USES
- Add stage support

PR:		ports/182788
Submitted by:	Alexander Hausner <alex@hugo.bmg.gv.at> (maintainer) [1]
Approved by:	wg/culot (mentors, implicit)
This commit is contained in:
Danilo Egea Gondolfo 2013-10-07 18:44:30 +00:00
parent d3657c4a8c
commit 643ae650a1
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=329723
3 changed files with 35 additions and 24 deletions

View File

@ -2,35 +2,32 @@
# $FreeBSD$
PORTNAME= tcpproxy
PORTVERSION= 1.0
PORTREVISION= 1
PORTVERSION= 1.1
CATEGORIES= net
MASTER_SITES= http://www.spreadspace.org/tcpproxy/releases/ \
http://alex.bmg.gv.at/programs/
MAINTAINER= alex@hugo.bmg.gv.at
COMMENT= A simple TCP connection proxy for IPv4 and IPv6
COMMENT= Simple TCP connection proxy for IPv4 and IPv6
BUILD_DEPENDS= ragel:${PORTSDIR}/devel/ragel
USE_GMAKE= yes
USES= gmake
HAS_CONFIGURE= yes
USERS= _tcpproxy
GROUPS= _tcpproxy
MAN8= tcpproxy.8
USE_RC_SUBR= tcpproxy
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}/src
PLIST_FILES= bin/tcpproxy etc/tcpproxy_sample.conf
PLIST_FILES= bin/tcpproxy etc/tcpproxy_sample.conf \
man/man8/tcpproxy.8.gz
NO_STAGE= yes
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/tcpproxy ${PREFIX}/bin
${INSTALL_DATA} ${WRKDIR}/${PORTNAME}-${PORTVERSION}/contrib/example.conf ${PREFIX}/etc/tcpproxy_sample.conf
${INSTALL_MAN} ${WRKDIR}/${PORTNAME}-${PORTVERSION}/doc/${MAN8} ${PREFIX}/man/man8
${INSTALL_PROGRAM} ${WRKSRC}/tcpproxy ${STAGEDIR}${PREFIX}/bin
${INSTALL_DATA} ${WRKDIR}/${PORTNAME}-${PORTVERSION}/contrib/example.conf ${STAGEDIR}${PREFIX}/etc/tcpproxy_sample.conf
${INSTALL_MAN} ${WRKDIR}/${PORTNAME}-${PORTVERSION}/doc/tcpproxy.8 ${STAGEDIR}${PREFIX}/man/man8
.include <bsd.port.mk>

View File

@ -1,2 +1,2 @@
SHA256 (tcpproxy-1.0.tar.gz) = 8d21bca2849b87b05566549859666a8bde0e21ed1a304390a71a12929e937f70
SIZE (tcpproxy-1.0.tar.gz) = 35946
SHA256 (tcpproxy-1.1.tar.gz) = dda436a6ea260e6bf6655688f8f8da34cde6751d4fa720732766868b90858f1d
SIZE (tcpproxy-1.1.tar.gz) = 36513

View File

@ -1,13 +1,27 @@
--- configure.org 2011-05-04 20:30:40.000000000 +0200
+++ configure 2011-05-04 20:31:06.000000000 +0200
@@ -29,8 +29,8 @@
TARGET=`uname -s`
EBUILD_COMPAT=0
--- configure.orig 2013-10-07 13:59:48.000000000 +0200
+++ configure 2013-10-07 16:30:19.000000000 +0200
@@ -105,12 +105,12 @@
fi
-CFLAGS='-g -O2'
-LDFLAGS='-g -Wall -O2'
+CFLAGS="${CFLAGS} -g -O2"
+LDFLAGS="${LDFLAGS} -g -Wall -O2"
if [ $USE_CLANG -eq 0 ]; then
- CFLAGS='-g -Wall -O2'
- LDFLAGS='-g -Wall -O2'
+ CFLAGS='${CFLAGS} -g -Wall -O2'
+ LDFLAGS='${LDFLAGS} -g -Wall -O2'
COMPILER='gcc'
else
- CFLAGS='-g -O2'
- LDFLAGS='-g -O2'
+ CFLAGS='${CFLAGS} -g -O2'
+ LDFLAGS='${LDFLAGS} -g -O2'
COMPILER='clang'
fi
PREFIX='/usr/local'
BINDIR=''
@@ -151,7 +151,6 @@
# use ./configure instead
TARGET := $TARGET
-CC := $COMPILER
CFLAGS := $CFLAGS
LDFLAGS := $LDFLAGS
STRIP := strip