Add libhdhomerun 20150826, library and command line utility for
interfacing with HDHomeRun device. PR: 206409 Submitted by: sam@middling.me.uk
This commit is contained in:
parent
7d7a489196
commit
6418c819fc
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=406728
@ -181,6 +181,7 @@
|
||||
SUBDIR += libdvdnav
|
||||
SUBDIR += libdvdread
|
||||
SUBDIR += libfame
|
||||
SUBDIR += libhdhomerun
|
||||
SUBDIR += libkate
|
||||
SUBDIR += libmatroska
|
||||
SUBDIR += libmediaart
|
||||
|
25
multimedia/libhdhomerun/Makefile
Normal file
25
multimedia/libhdhomerun/Makefile
Normal file
@ -0,0 +1,25 @@
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= libhdhomerun
|
||||
PORTVERSION= 20150826
|
||||
CATEGORIES= multimedia
|
||||
MASTER_SITES= http://download.silicondust.com/hdhomerun/
|
||||
DISTNAME= ${PORTNAME}_${PORTVERSION}
|
||||
|
||||
MAINTAINER= sam@middling.me.uk
|
||||
COMMENT= Library and command line utility for interfacing with HDHomeRun device
|
||||
|
||||
LICENSE= LGPL21
|
||||
|
||||
USES= gmake tar:tgz
|
||||
USE_LDCONFIG= yes
|
||||
|
||||
WRKSRC= ${WRKDIR}/libhdhomerun
|
||||
|
||||
do-install:
|
||||
@${MKDIR} ${STAGEDIR}${PREFIX}/include/libhdhomerun
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/hdhomerun_config ${STAGEDIR}${PREFIX}/bin
|
||||
${INSTALL_LIB} ${WRKSRC}/libhdhomerun.so ${STAGEDIR}${PREFIX}/lib
|
||||
${INSTALL_DATA} ${WRKSRC}/*.h ${STAGEDIR}${PREFIX}/include/libhdhomerun
|
||||
|
||||
.include <bsd.port.mk>
|
2
multimedia/libhdhomerun/distinfo
Normal file
2
multimedia/libhdhomerun/distinfo
Normal file
@ -0,0 +1,2 @@
|
||||
SHA256 (libhdhomerun_20150826.tgz) = 907dfbd1eb82aebd8b09e7c00c21a02433e6baaacf4a4f99aa2511b1d5244baf
|
||||
SIZE (libhdhomerun_20150826.tgz) = 49169
|
11
multimedia/libhdhomerun/files/patch-Makefile
Normal file
11
multimedia/libhdhomerun/files/patch-Makefile
Normal file
@ -0,0 +1,11 @@
|
||||
--- Makefile.orig 2016-01-20 02:55:42 UTC
|
||||
+++ Makefile
|
||||
@@ -11,7 +11,7 @@ LIBSRCS += hdhomerun_pkt.c
|
||||
LIBSRCS += hdhomerun_sock_posix.c
|
||||
LIBSRCS += hdhomerun_video.c
|
||||
|
||||
-CC := $(CROSS_COMPILE)gcc
|
||||
+#CC := $(CROSS_COMPILE)gcc
|
||||
STRIP := $(CROSS_COMPILE)strip
|
||||
|
||||
CFLAGS += -Wall -O2 -Wmissing-declarations -Wmissing-prototypes -Wstrict-prototypes -Wpointer-arith
|
12
multimedia/libhdhomerun/pkg-descr
Normal file
12
multimedia/libhdhomerun/pkg-descr
Normal file
@ -0,0 +1,12 @@
|
||||
This package supports the Silicon Dust HDHomeRun,
|
||||
a networked digital TV tuner compatible with VLC and Tvheadend.
|
||||
|
||||
This utility can be used for:
|
||||
|
||||
* Discovering your tuner location and name
|
||||
* Gathering tuner settings
|
||||
* Modifying tuner settings
|
||||
* Performing scans
|
||||
* Performing firmware upgrades
|
||||
|
||||
WWW: http://www.silicondust.com/support/downloads/linux/
|
17
multimedia/libhdhomerun/pkg-plist
Normal file
17
multimedia/libhdhomerun/pkg-plist
Normal file
@ -0,0 +1,17 @@
|
||||
bin/hdhomerun_config
|
||||
include/libhdhomerun/hdhomerun.h
|
||||
include/libhdhomerun/hdhomerun_channels.h
|
||||
include/libhdhomerun/hdhomerun_channelscan.h
|
||||
include/libhdhomerun/hdhomerun_control.h
|
||||
include/libhdhomerun/hdhomerun_debug.h
|
||||
include/libhdhomerun/hdhomerun_device.h
|
||||
include/libhdhomerun/hdhomerun_device_selector.h
|
||||
include/libhdhomerun/hdhomerun_discover.h
|
||||
include/libhdhomerun/hdhomerun_os.h
|
||||
include/libhdhomerun/hdhomerun_os_posix.h
|
||||
include/libhdhomerun/hdhomerun_os_windows.h
|
||||
include/libhdhomerun/hdhomerun_pkt.h
|
||||
include/libhdhomerun/hdhomerun_sock.h
|
||||
include/libhdhomerun/hdhomerun_types.h
|
||||
include/libhdhomerun/hdhomerun_video.h
|
||||
lib/libhdhomerun.so
|
Loading…
Reference in New Issue
Block a user