databases/py-tiledb: Update to 0.12.1
- Strip shared library Changes: https://github.com/TileDB-Inc/TileDB-Py/releases
This commit is contained in:
parent
0799859022
commit
63e74029fd
@ -1,7 +1,7 @@
|
||||
# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
|
||||
|
||||
PORTNAME= tiledb
|
||||
PORTVERSION= 0.8.11
|
||||
PORTVERSION= 0.12.1
|
||||
CATEGORIES= databases python
|
||||
MASTER_SITES= CHEESESHOP
|
||||
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
|
||||
@ -16,14 +16,20 @@ NOT_FOR_ARCHS= i386
|
||||
NOT_FOR_ARCHS_REASON= is currently 64-bit only
|
||||
|
||||
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}cython>=0.27:lang/cython@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}numpy>=1.16.5,1:math/py-numpy@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}pybind11>=2.6.2:devel/py-pybind11@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}setuptools_scm>=1.5.4:devel/py-setuptools_scm@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}numpy>=1.16,1:math/py-numpy@${PY_FLAVOR} \
|
||||
tiledb>=2.2.8:databases/tiledb
|
||||
LIB_DEPENDS= libtiledb.so:databases/tiledb
|
||||
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}numpy>=1.16,1:math/py-numpy@${PY_FLAVOR}
|
||||
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}numpy>=1.19.2,1:math/py-numpy@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}packaging>=0:devel/py-packaging@${PY_FLAVOR}
|
||||
|
||||
USES= compiler:c++14-lang localbase python:3.7+
|
||||
USE_PYTHON= autoplist concurrent cython distutils
|
||||
|
||||
MAKE_ENV= TILEDB_PATH=${LOCALBASE}
|
||||
|
||||
post-install:
|
||||
${FIND} ${STAGEDIR}${PYTHON_SITELIBDIR} -name '*.so' -exec ${STRIP_CMD} {} +
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
@ -1,3 +1,3 @@
|
||||
TIMESTAMP = 1622214052
|
||||
SHA256 (tiledb-0.8.11.tar.gz) = 66a182ab76d129b6c346e435a45cf365ee47acda85683221041dd235818ec427
|
||||
SIZE (tiledb-0.8.11.tar.gz) = 212399
|
||||
TIMESTAMP = 1643971034
|
||||
SHA256 (tiledb-0.12.1.tar.gz) = 396938027d709f04506cf519ffa3979c48823c8677f67f10794698e4c5a756bb
|
||||
SIZE (tiledb-0.12.1.tar.gz) = 246015
|
||||
|
10
databases/py-tiledb/files/patch-requirements.txt
Normal file
10
databases/py-tiledb/files/patch-requirements.txt
Normal file
@ -0,0 +1,10 @@
|
||||
--- requirements.txt.orig 2022-01-25 22:10:16 UTC
|
||||
+++ requirements.txt
|
||||
@@ -1,6 +1,4 @@
|
||||
-numpy>=1.16.5 ; python_version < "3.10" and platform_machine != 'aarch64'
|
||||
-numpy>=1.19.2 ; python_version < "3.10" and platform_machine == 'aarch64'
|
||||
-numpy>=1.21.0 ; python_version >= "3.10"
|
||||
+numpy>=1.19.2
|
||||
packaging
|
||||
|
||||
contextvars ;python_version<"3.7"
|
17
databases/py-tiledb/files/patch-requirements_dev.txt
Normal file
17
databases/py-tiledb/files/patch-requirements_dev.txt
Normal file
@ -0,0 +1,17 @@
|
||||
--- requirements_dev.txt.orig 2022-01-25 22:10:16 UTC
|
||||
+++ requirements_dev.txt
|
||||
@@ -1,14 +1,8 @@
|
||||
numpy >= 1.16.5
|
||||
|
||||
-# ------------------------------------------------
|
||||
-# ** MUST sync with misc/requirements_wheel.txt **
|
||||
-# ------------------------------------------------
|
||||
-# Note 11/23/2021: the current version of the AWS sdk does not work with cmake 3.22
|
||||
-cmake >= 3.21, < 3.22
|
||||
cython >= 0.27
|
||||
pybind11 >= 2.6.2
|
||||
setuptools >= 18.0
|
||||
setuptools_scm >= 1.5.4
|
||||
-wheel >= 0.30
|
||||
contextvars ;python_version<"3.7"
|
||||
dataclasses ;python_version<"3.7"
|
@ -1,24 +1,15 @@
|
||||
--- setup.py.orig 2021-06-08 20:19:16 UTC
|
||||
--- setup.py.orig 2022-01-25 22:10:16 UTC
|
||||
+++ setup.py
|
||||
@@ -489,12 +489,9 @@ def cmake_available():
|
||||
def setup_requires():
|
||||
req = [
|
||||
"cython>=0.27",
|
||||
- "numpy==1.16.* ; python_version < '3.9' and 'arm' not in platform_machine",
|
||||
- "numpy ; python_version >= '3.9' and 'arm' not in platform_machine",
|
||||
- "numpy ; 'arm' in platform_machine",
|
||||
+ "numpy>=1.16",
|
||||
"setuptools>=18.0",
|
||||
"setuptools_scm>=1.5.4",
|
||||
- "wheel>=0.30",
|
||||
"pybind11>=2.6.2",
|
||||
]
|
||||
# Add cmake requirement if libtiledb is not found and cmake is not available.
|
||||
@@ -687,7 +684,6 @@ setup(
|
||||
setup_requires=setup_requires(),
|
||||
install_requires=[
|
||||
"numpy>=1.16",
|
||||
- "wheel>=0.30",
|
||||
"contextvars ;python_version<'3.7'",
|
||||
"dataclasses ;python_version<'3.7'",
|
||||
],
|
||||
@@ -503,12 +503,6 @@ def setup_requires():
|
||||
req = parse_requirements("requirements_dev.txt")
|
||||
req = list(filter(lambda r: not r.startswith("-r"), req))
|
||||
|
||||
- req_cmake = list(filter(lambda r: "cmake" in r, req))[0]
|
||||
-
|
||||
- # Add cmake requirement if libtiledb is not found and cmake is not available.
|
||||
- if not libtiledb_exists(LIB_DIRS) and not cmake_available():
|
||||
- req.append(req_cmake)
|
||||
-
|
||||
return req
|
||||
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user