Update neo4j to v3.3.2.
While we're here, fix up some variable names to ensure that all of the scripts work (e.g., /usr/local/etc/rc.d/neo4j). Approved by: crees Differential Revision: https://reviews.freebsd.org/D14260
This commit is contained in:
parent
4488015845
commit
63d67a6d68
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=461285
@ -1,16 +1,16 @@
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= neo4j
|
||||
DISTVERSION= 3.2.1
|
||||
PORTREVISION= 1
|
||||
DISTVERSION= 3.3.2
|
||||
CATEGORIES= databases java
|
||||
MASTER_SITES= http://dist.neo4j.org/
|
||||
DISTNAME= ${PORTNAME}-community-${DISTVERSION}-unix
|
||||
LICENSE= GPLv3
|
||||
|
||||
MAINTAINER= crees@FreeBSD.org
|
||||
MAINTAINER= jonathan@FreeBSD.org
|
||||
COMMENT= High performance graph store and database
|
||||
|
||||
LICENSE= GPLv3
|
||||
|
||||
RUN_DEPENDS= bash:shells/bash
|
||||
|
||||
WRKSRC= ${WRKDIR}/${DISTNAME:S,-unix,,}
|
||||
@ -20,11 +20,16 @@ SHEBANG_FILES= bin/cypher-shell bin/neo4j-admin bin/neo4j-shell bin/neo4j-import
|
||||
USE_JAVA= yes
|
||||
USE_RC_SUBR= ${PORTNAME}
|
||||
SUB_FILES= ${PORTNAME}.sh
|
||||
SUB_LIST= LOGDIR=${LOGDIR} RUNDIR=${RUNDIR}
|
||||
|
||||
DBDIR= /var/db/${PORTNAME}
|
||||
PLIST_SUB= DBDIR=${DBDIR} DISTVERSION=${DISTVERSION}
|
||||
|
||||
DBDIR= ${DESTDIR}/var/db/${PORTNAME}
|
||||
LOGDIR= ${DESTDIR}/var/log/${PORTNAME}
|
||||
RUNDIR= ${DESTDIR}/var/run/
|
||||
|
||||
post-patch:
|
||||
${REINPLACE_CMD} 's,%%DBDIR%%,${DBDIR},g;s,%%PREFIX%%,${PREFIX},g' \
|
||||
${REINPLACE_CMD} 's,%%DBDIR%%,${DBDIR},g;s,%%JAVA_HOME%%,${JAVA_HOME},g;s,%%LOGDIR%%,${LOGDIR},g;s,%%PREFIX%%,${PREFIX},g;s,%%RUNDIR%%,${RUNDIR},g' \
|
||||
${WRKSRC}/bin/cypher-shell ${WRKSRC}/bin/neo4j* \
|
||||
${WRKSRC}/conf/neo4j.conf
|
||||
|
||||
@ -42,5 +47,5 @@ do-install:
|
||||
${INSTALL_DATA} ${WRKSRC}/conf/$f \
|
||||
${STAGEDIR}${PREFIX}/etc/$f.sample
|
||||
.endfor
|
||||
${MKDIR} ${STAGEDIR}${DATADIR} ${STAGEDIR}${PREFIX}/etc/neo4j-certificates
|
||||
${MKDIR} ${STAGEDIR}${DBDIR} ${STAGEDIR}${PREFIX}/etc/neo4j-certificates
|
||||
.include <bsd.port.mk>
|
||||
|
@ -1,3 +1,3 @@
|
||||
TIMESTAMP = 1498754546
|
||||
SHA256 (neo4j-community-3.2.1-unix.tar.gz) = 24fd6a704e0d80c4b4f9a3d17ce0db23f258a8cdcfa1eb28d7803b7d1811ee96
|
||||
SIZE (neo4j-community-3.2.1-unix.tar.gz) = 77979397
|
||||
TIMESTAMP = 1518030659
|
||||
SHA256 (neo4j-community-3.3.2-unix.tar.gz) = 8a2a74f1270944d9b72f2af2c15cb350718e697af6e3800e67cb32a5d1605f6e
|
||||
SIZE (neo4j-community-3.3.2-unix.tar.gz) = 90614580
|
||||
|
@ -28,11 +28,11 @@ status_cmd="$command status"
|
||||
|
||||
neo4j_prestart()
|
||||
{
|
||||
NEO4J_DATA=%%DATADIR%%
|
||||
NEO4J_DATA=%%DBDIR%%
|
||||
NEO4J_LIB=%%PREFIX%%/neo4j/lib
|
||||
NEO4J_LOGS=/var/log/neo4j
|
||||
NEO4J_LOGS=%%LOGDIR%%
|
||||
NEO4J_PLUGINS=${NEO4J_LIB}/plugins
|
||||
NEO4J_RUN=/var/run/neo4j
|
||||
NEO4J_RUN=%%RUNDIR%%
|
||||
mkdir -p ${NEO4J_LOGS} ${NEO4J_RUN}
|
||||
}
|
||||
|
||||
|
@ -1,7 +1,30 @@
|
||||
--- bin/cypher-shell.orig 2017-07-04 01:59:39 UTC
|
||||
--- bin/cypher-shell.orig 2018-02-07 19:48:06 UTC
|
||||
+++ bin/cypher-shell
|
||||
@@ -72,7 +72,7 @@ build_classpath() {
|
||||
|
||||
@@ -41,7 +41,9 @@ _find_java_cmd() {
|
||||
detect_os() {
|
||||
if uname -s | grep -q Darwin; then
|
||||
DIST_OS="macosx"
|
||||
- elif [[ -e /etc/gentoo-release ]]; then
|
||||
+ elif uname -s | grep -q FreeBSD; then
|
||||
+ DIST_OS="freebsd"
|
||||
+ elif [[ -e /etc/gentoo-release ]]; then
|
||||
DIST_OS="gentoo"
|
||||
else
|
||||
DIST_OS="other"
|
||||
@@ -52,7 +54,10 @@ _find_java_home() {
|
||||
[[ "${JAVA_HOME:-}" ]] && return
|
||||
|
||||
case "${DIST_OS}" in
|
||||
- "macosx")
|
||||
+ "freebsd")
|
||||
+ JAVA_HOME="%%JAVA_HOME%%"
|
||||
+ ;;
|
||||
+ "macosx")
|
||||
JAVA_HOME="$(/usr/libexec/java_home -v 1.8)"
|
||||
;;
|
||||
"gentoo")
|
||||
@@ -72,7 +77,7 @@ build_classpath() {
|
||||
|
||||
# Then try installation directory (prefix/bin and prefix/share/cypher-shell/lib)
|
||||
if [[ -z "${JARPATH}" ]]; then
|
||||
- APP_HOME="${APP_HOME}/../share/cypher-shell"
|
||||
|
@ -1,13 +1,36 @@
|
||||
--- bin/neo4j.orig 2017-07-04 01:59:39 UTC
|
||||
--- bin/neo4j.orig 2018-02-07 19:48:06 UTC
|
||||
+++ bin/neo4j
|
||||
@@ -1,4 +1,4 @@
|
||||
-#!/usr/bin/env bash
|
||||
+#!/usr/local/bin/bash
|
||||
# Copyright (c) 2002-2016 "Neo Technology,"
|
||||
# Copyright (c) 2002-2018 "Neo Technology,"
|
||||
# Network Engine for Objects in Lund AB [http://neotechnology.com]
|
||||
#
|
||||
@@ -162,9 +162,9 @@ _show_java_help() {
|
||||
|
||||
@@ -63,7 +63,9 @@ build_classpath() {
|
||||
detect_os() {
|
||||
if uname -s | grep -q Darwin; then
|
||||
DIST_OS="macosx"
|
||||
- elif [[ -e /etc/gentoo-release ]]; then
|
||||
+ elif uname -s | grep -q FreeBSD; then
|
||||
+ DIST_OS="freebsd"
|
||||
+ elif [[ -e /etc/gentoo-release ]]; then
|
||||
DIST_OS="gentoo"
|
||||
else
|
||||
DIST_OS="other"
|
||||
@@ -146,7 +148,10 @@ _find_java_home() {
|
||||
[[ "${JAVA_HOME:-}" ]] && return
|
||||
|
||||
case "${DIST_OS}" in
|
||||
- "macosx")
|
||||
+ "freebsd")
|
||||
+ JAVA_HOME="%%JAVA_HOME%%"
|
||||
+ ;;
|
||||
+ "macosx")
|
||||
JAVA_HOME="$(/usr/libexec/java_home -v 1.8)"
|
||||
;;
|
||||
"gentoo")
|
||||
@@ -162,9 +167,9 @@ _show_java_help() {
|
||||
|
||||
_setup_calculated_paths() {
|
||||
if [[ -z "${NEO4J_HOME:-}" ]]; then
|
||||
- NEO4J_HOME="$(cd "$(dirname "$0")"/.. && pwd)"
|
||||
@ -17,4 +40,4 @@
|
||||
+ : "${NEO4J_CONF:="${NEO4J_HOME}/../etc"}"
|
||||
readonly NEO4J_HOME NEO4J_CONF
|
||||
}
|
||||
|
||||
|
||||
|
@ -1,6 +1,31 @@
|
||||
--- bin/neo4j-admin.orig 2017-07-04 01:59:39 UTC
|
||||
--- bin/neo4j-admin.orig 2018-02-07 19:48:06 UTC
|
||||
+++ bin/neo4j-admin
|
||||
@@ -140,7 +140,7 @@ _setup_calculated_paths() {
|
||||
@@ -39,7 +39,9 @@ build_classpath() {
|
||||
detect_os() {
|
||||
if uname -s | grep -q Darwin; then
|
||||
DIST_OS="macosx"
|
||||
- elif [[ -e /etc/gentoo-release ]]; then
|
||||
+ elif uname -s | grep -q FreeBSD; then
|
||||
+ DIST_OS="freebsd"
|
||||
+ elif [[ -e /etc/gentoo-release ]]; then
|
||||
DIST_OS="gentoo"
|
||||
else
|
||||
DIST_OS="other"
|
||||
@@ -122,7 +124,10 @@ _find_java_home() {
|
||||
[[ "${JAVA_HOME:-}" ]] && return
|
||||
|
||||
case "${DIST_OS}" in
|
||||
- "macosx")
|
||||
+ "freebsd")
|
||||
+ JAVA_HOME="%%JAVA_HOME%%"
|
||||
+ ;;
|
||||
+ "macosx")
|
||||
JAVA_HOME="$(/usr/libexec/java_home -v 1.8)"
|
||||
;;
|
||||
"gentoo")
|
||||
@@ -138,9 +143,9 @@ _show_java_help() {
|
||||
|
||||
_setup_calculated_paths() {
|
||||
if [[ -z "${NEO4J_HOME:-}" ]]; then
|
||||
- NEO4J_HOME="$(cd "$(dirname "$0")"/.. && pwd)"
|
||||
+ NEO4J_HOME="$(cd "$(dirname "$0")"/../neo4j && pwd)"
|
||||
@ -9,4 +34,4 @@
|
||||
+ : "${NEO4J_CONF:="${NEO4J_HOME}/../etc"}"
|
||||
readonly NEO4J_HOME NEO4J_CONF
|
||||
}
|
||||
|
||||
|
||||
|
@ -1,6 +1,27 @@
|
||||
--- bin/neo4j-import.orig 2017-07-04 01:59:39 UTC
|
||||
--- bin/neo4j-import.orig 2018-02-07 19:48:06 UTC
|
||||
+++ bin/neo4j-import
|
||||
@@ -140,7 +140,7 @@ _setup_calculated_paths() {
|
||||
@@ -39,6 +39,8 @@ build_classpath() {
|
||||
detect_os() {
|
||||
if uname -s | grep -q Darwin; then
|
||||
DIST_OS="macosx"
|
||||
+ elif uname -s | grep -q FreeBSD; then
|
||||
+ DIST_OS="freebsd"
|
||||
elif [[ -e /etc/gentoo-release ]]; then
|
||||
DIST_OS="gentoo"
|
||||
else
|
||||
@@ -122,6 +124,9 @@ _find_java_home() {
|
||||
[[ "${JAVA_HOME:-}" ]] && return
|
||||
|
||||
case "${DIST_OS}" in
|
||||
+ "freebsd")
|
||||
+ JAVA_HOME="%%JAVA_HOME%%"
|
||||
+ ;;
|
||||
"macosx")
|
||||
JAVA_HOME="$(/usr/libexec/java_home -v 1.8)"
|
||||
;;
|
||||
@@ -138,9 +143,9 @@ _show_java_help() {
|
||||
|
||||
_setup_calculated_paths() {
|
||||
if [[ -z "${NEO4J_HOME:-}" ]]; then
|
||||
- NEO4J_HOME="$(cd "$(dirname "$0")"/.. && pwd)"
|
||||
+ NEO4J_HOME="$(cd "$(dirname "$0")"/../neo4j && pwd)"
|
||||
@ -9,4 +30,4 @@
|
||||
+ : "${NEO4J_CONF:="${NEO4J_HOME}/../etc"}"
|
||||
readonly NEO4J_HOME NEO4J_CONF
|
||||
}
|
||||
|
||||
|
||||
|
@ -1,6 +1,31 @@
|
||||
--- bin/neo4j-shell.orig 2017-07-04 01:59:39 UTC
|
||||
--- bin/neo4j-shell.orig 2018-02-07 19:48:06 UTC
|
||||
+++ bin/neo4j-shell
|
||||
@@ -140,7 +140,7 @@ _setup_calculated_paths() {
|
||||
@@ -39,7 +39,9 @@ build_classpath() {
|
||||
detect_os() {
|
||||
if uname -s | grep -q Darwin; then
|
||||
DIST_OS="macosx"
|
||||
- elif [[ -e /etc/gentoo-release ]]; then
|
||||
+ elif uname -s | grep -q FreeBSD; then
|
||||
+ DIST_OS="freebsd"
|
||||
+ elif [[ -e /etc/gentoo-release ]]; then
|
||||
DIST_OS="gentoo"
|
||||
else
|
||||
DIST_OS="other"
|
||||
@@ -122,7 +124,10 @@ _find_java_home() {
|
||||
[[ "${JAVA_HOME:-}" ]] && return
|
||||
|
||||
case "${DIST_OS}" in
|
||||
- "macosx")
|
||||
+ "freebsd")
|
||||
+ JAVA_HOME="%%JAVA_HOME%%"
|
||||
+ ;;
|
||||
+ "macosx")
|
||||
JAVA_HOME="$(/usr/libexec/java_home -v 1.8)"
|
||||
;;
|
||||
"gentoo")
|
||||
@@ -138,9 +143,9 @@ _show_java_help() {
|
||||
|
||||
_setup_calculated_paths() {
|
||||
if [[ -z "${NEO4J_HOME:-}" ]]; then
|
||||
- NEO4J_HOME="$(cd "$(dirname "$0")"/.. && pwd)"
|
||||
+ NEO4J_HOME="$(cd "$(dirname "$0")"/../neo4j && pwd)"
|
||||
@ -9,4 +34,4 @@
|
||||
+ : "${NEO4J_CONF:="${NEO4J_HOME}/../etc"}"
|
||||
readonly NEO4J_HOME NEO4J_CONF
|
||||
}
|
||||
|
||||
|
||||
|
@ -1,15 +0,0 @@
|
||||
--- conf/neo4j.conf.orig 2017-05-31 21:11:19 UTC
|
||||
+++ conf/neo4j.conf
|
||||
@@ -9,9 +9,9 @@
|
||||
#dbms.active_database=graph.db
|
||||
|
||||
# Paths of directories in the installation.
|
||||
-#dbms.directories.data=data
|
||||
-#dbms.directories.plugins=plugins
|
||||
-#dbms.directories.certificates=certificates
|
||||
+dbms.directories.data=%%DBDIR%%
|
||||
+dbms.directories.plugins=%%PREFIX%%/lib/neo4j/plugins
|
||||
+dbms.directories.certificates=%%PREFIX%%/etc/neo4j-certificates
|
||||
#dbms.directories.logs=logs
|
||||
#dbms.directories.lib=lib
|
||||
#dbms.directories.run=run
|
20
databases/neo4j/files/patch-conf_neo4j.conf
Normal file
20
databases/neo4j/files/patch-conf_neo4j.conf
Normal file
@ -0,0 +1,20 @@
|
||||
--- conf/neo4j.conf.orig 2018-01-16 09:38:48 UTC
|
||||
+++ conf/neo4j.conf
|
||||
@@ -9,12 +9,12 @@
|
||||
#dbms.active_database=graph.db
|
||||
|
||||
# Paths of directories in the installation.
|
||||
-#dbms.directories.data=data
|
||||
-#dbms.directories.plugins=plugins
|
||||
-#dbms.directories.certificates=certificates
|
||||
-#dbms.directories.logs=logs
|
||||
+dbms.directories.data=%%DBDIR%%
|
||||
+dbms.directories.plugins=%%PREFIX%%/lib/neo4j/plugins
|
||||
+dbms.directories.certificates=%%PREFIX%%/etc/neo4j-certificates
|
||||
+dbms.directories.logs=%%LOGDIR%%
|
||||
#dbms.directories.lib=lib
|
||||
-#dbms.directories.run=run
|
||||
+dbms.directories.run=%%RUNDIR%%
|
||||
|
||||
# This setting constrains all `LOAD CSV` import files to be under the `import` directory. Remove or comment it out to
|
||||
# allow files to be loaded from anywhere in the filesystem; this introduces possible security problems. See the
|
@ -4,18 +4,16 @@ bin/neo4j-admin
|
||||
bin/neo4j-import
|
||||
bin/neo4j-shell
|
||||
@sample etc/neo4j.conf.sample
|
||||
neo4j/lib/asm-5.2.jar
|
||||
neo4j/lib/bcpkix-jdk15on-1.53.jar
|
||||
neo4j/lib/bcprov-jdk15on-1.53.jar
|
||||
neo4j/lib/caffeine-2.3.3.jar
|
||||
neo4j/lib/commons-beanutils-1.8.3.jar
|
||||
neo4j/lib/commons-compress-1.12.jar
|
||||
neo4j/lib/commons-configuration-1.10.jar
|
||||
neo4j/lib/commons-digester-2.1.jar
|
||||
neo4j/lib/commons-io-2.4.jar
|
||||
neo4j/lib/commons-lang-2.6.jar
|
||||
neo4j/lib/commons-lang3-3.3.2.jar
|
||||
neo4j/lib/commons-lang3-3.5.jar
|
||||
neo4j/lib/commons-logging-1.1.1.jar
|
||||
neo4j/lib/commons-text-1.1.jar
|
||||
neo4j/lib/concurrentlinkedhashmap-lru-1.4.2.jar
|
||||
neo4j/lib/jackson-core-asl-1.9.13.jar
|
||||
neo4j/lib/jackson-jaxrs-1.9.13.jar
|
||||
@ -25,14 +23,14 @@ neo4j/lib/jersey-core-1.19.jar
|
||||
neo4j/lib/jersey-multipart-1.19.jar
|
||||
neo4j/lib/jersey-server-1.19.jar
|
||||
neo4j/lib/jersey-servlet-1.19.jar
|
||||
neo4j/lib/jetty-http-9.2.9.v20150224.jar
|
||||
neo4j/lib/jetty-io-9.2.9.v20150224.jar
|
||||
neo4j/lib/jetty-security-9.2.9.v20150224.jar
|
||||
neo4j/lib/jetty-server-9.2.9.v20150224.jar
|
||||
neo4j/lib/jetty-servlet-9.2.9.v20150224.jar
|
||||
neo4j/lib/jetty-util-9.2.9.v20150224.jar
|
||||
neo4j/lib/jetty-webapp-9.2.9.v20150224.jar
|
||||
neo4j/lib/jetty-xml-9.2.9.v20150224.jar
|
||||
neo4j/lib/jetty-http-9.2.22.v20170606.jar
|
||||
neo4j/lib/jetty-io-9.2.22.v20170606.jar
|
||||
neo4j/lib/jetty-security-9.2.22.v20170606.jar
|
||||
neo4j/lib/jetty-server-9.2.22.v20170606.jar
|
||||
neo4j/lib/jetty-servlet-9.2.22.v20170606.jar
|
||||
neo4j/lib/jetty-util-9.2.22.v20170606.jar
|
||||
neo4j/lib/jetty-webapp-9.2.22.v20170606.jar
|
||||
neo4j/lib/jetty-xml-9.2.22.v20170606.jar
|
||||
neo4j/lib/jline-2.12.jar
|
||||
neo4j/lib/jsr311-api-1.1.2.r612.jar
|
||||
neo4j/lib/lucene-analyzers-common-5.5.0.jar
|
||||
@ -40,52 +38,58 @@ neo4j/lib/lucene-codecs-5.5.0.jar
|
||||
neo4j/lib/lucene-core-5.5.0.jar
|
||||
neo4j/lib/lucene-queryparser-5.5.0.jar
|
||||
neo4j/lib/mimepull-1.9.3.jar
|
||||
neo4j/lib/neo4j-bolt-3.2.1.jar
|
||||
neo4j/lib/neo4j-browser-3.0.4.jar
|
||||
neo4j/lib/neo4j-codegen-3.2.1.jar
|
||||
neo4j/lib/neo4j-collections-3.2.1.jar
|
||||
neo4j/lib/neo4j-command-line-3.2.1.jar
|
||||
neo4j/lib/neo4j-common-3.2.1.jar
|
||||
neo4j/lib/neo4j-configuration-3.2.1.jar
|
||||
neo4j/lib/neo4j-consistency-check-3.2.1.jar
|
||||
neo4j/lib/neo4j-csv-3.2.1.jar
|
||||
neo4j/lib/neo4j-cypher-3.2.1.jar
|
||||
neo4j/lib/neo4j-cypher-compiler-2.3-2.3.10.jar
|
||||
neo4j/lib/neo4j-cypher-compiler-3.1-3.1.4.jar
|
||||
neo4j/lib/neo4j-cypher-compiler-3.2-3.2.1.jar
|
||||
neo4j/lib/neo4j-cypher-frontend-2.3-2.3.10.jar
|
||||
neo4j/lib/neo4j-cypher-frontend-3.1-3.1.4.jar
|
||||
neo4j/lib/neo4j-cypher-frontend-3.2-3.2.1.jar
|
||||
neo4j/lib/neo4j-cypher-ir-3.2-3.2.1.jar
|
||||
neo4j/lib/neo4j-dbms-3.2.1.jar
|
||||
neo4j/lib/neo4j-graph-algo-3.2.1.jar
|
||||
neo4j/lib/neo4j-graph-matching-3.1.3.jar
|
||||
neo4j/lib/neo4j-graphdb-api-3.2.1.jar
|
||||
neo4j/lib/neo4j-import-tool-3.2.1.jar
|
||||
neo4j/lib/neo4j-index-3.2.1.jar
|
||||
neo4j/lib/neo4j-io-3.2.1.jar
|
||||
neo4j/lib/neo4j-jmx-3.2.1.jar
|
||||
neo4j/lib/neo4j-kernel-3.2.1.jar
|
||||
neo4j/lib/neo4j-logging-3.2.1.jar
|
||||
neo4j/lib/neo4j-lucene-index-3.2.1.jar
|
||||
neo4j/lib/neo4j-lucene-upgrade-3.2.1.jar
|
||||
neo4j/lib/neo4j-primitive-collections-3.2.1.jar
|
||||
neo4j/lib/neo4j-resource-3.2.1.jar
|
||||
neo4j/lib/neo4j-security-3.2.1.jar
|
||||
neo4j/lib/neo4j-server-3.2.1.jar
|
||||
neo4j/lib/neo4j-shell-3.2.1.jar
|
||||
neo4j/lib/neo4j-udc-3.2.1.jar
|
||||
neo4j/lib/neo4j-unsafe-3.2.1.jar
|
||||
neo4j/lib/netty-all-4.1.8.Final.jar
|
||||
neo4j/lib/neo4j-bolt-%%DISTVERSION%%.jar
|
||||
neo4j/lib/neo4j-browser-3.1.4.jar
|
||||
neo4j/lib/neo4j-codegen-%%DISTVERSION%%.jar
|
||||
neo4j/lib/neo4j-collections-%%DISTVERSION%%.jar
|
||||
neo4j/lib/neo4j-command-line-%%DISTVERSION%%.jar
|
||||
neo4j/lib/neo4j-common-%%DISTVERSION%%.jar
|
||||
neo4j/lib/neo4j-configuration-%%DISTVERSION%%.jar
|
||||
neo4j/lib/neo4j-consistency-check-%%DISTVERSION%%.jar
|
||||
neo4j/lib/neo4j-csv-%%DISTVERSION%%.jar
|
||||
neo4j/lib/neo4j-cypher-%%DISTVERSION%%.jar
|
||||
neo4j/lib/neo4j-cypher-compiler-2.3-2.3.11.jar
|
||||
neo4j/lib/neo4j-cypher-compiler-3.1-3.1.6.jar
|
||||
neo4j/lib/neo4j-cypher-compiler-3.2-3.2.8.jar
|
||||
neo4j/lib/neo4j-cypher-compiler-3.3-%%DISTVERSION%%.jar
|
||||
neo4j/lib/neo4j-cypher-frontend-2.3-2.3.11.jar
|
||||
neo4j/lib/neo4j-cypher-frontend-3.1-3.1.6.jar
|
||||
neo4j/lib/neo4j-cypher-frontend-3.2-3.2.8.jar
|
||||
neo4j/lib/neo4j-cypher-frontend-3.3-%%DISTVERSION%%.jar
|
||||
neo4j/lib/neo4j-cypher-ir-3.2-3.2.8.jar
|
||||
neo4j/lib/neo4j-cypher-ir-3.3-%%DISTVERSION%%.jar
|
||||
neo4j/lib/neo4j-cypher-logical-plans-3.3-%%DISTVERSION%%.jar
|
||||
neo4j/lib/neo4j-dbms-%%DISTVERSION%%.jar
|
||||
neo4j/lib/neo4j-graph-algo-%%DISTVERSION%%.jar
|
||||
neo4j/lib/neo4j-graph-matching-3.1.6.jar
|
||||
neo4j/lib/neo4j-graphdb-api-%%DISTVERSION%%.jar
|
||||
neo4j/lib/neo4j-import-tool-%%DISTVERSION%%.jar
|
||||
neo4j/lib/neo4j-index-%%DISTVERSION%%.jar
|
||||
neo4j/lib/neo4j-io-%%DISTVERSION%%.jar
|
||||
neo4j/lib/neo4j-jmx-%%DISTVERSION%%.jar
|
||||
neo4j/lib/neo4j-kernel-%%DISTVERSION%%.jar
|
||||
neo4j/lib/neo4j-logging-%%DISTVERSION%%.jar
|
||||
neo4j/lib/neo4j-lucene-index-%%DISTVERSION%%.jar
|
||||
neo4j/lib/neo4j-lucene-upgrade-%%DISTVERSION%%.jar
|
||||
neo4j/lib/neo4j-primitive-collections-%%DISTVERSION%%.jar
|
||||
neo4j/lib/neo4j-resource-%%DISTVERSION%%.jar
|
||||
neo4j/lib/neo4j-security-%%DISTVERSION%%.jar
|
||||
neo4j/lib/neo4j-server-%%DISTVERSION%%.jar
|
||||
neo4j/lib/neo4j-shell-%%DISTVERSION%%.jar
|
||||
neo4j/lib/neo4j-ssl-%%DISTVERSION%%.jar
|
||||
neo4j/lib/neo4j-udc-%%DISTVERSION%%.jar
|
||||
neo4j/lib/neo4j-unsafe-%%DISTVERSION%%.jar
|
||||
neo4j/lib/neo4j-values-%%DISTVERSION%%.jar
|
||||
neo4j/lib/netty-all-4.1.17.Final.jar
|
||||
neo4j/lib/opencsv-2.3.jar
|
||||
neo4j/lib/parboiled-core-1.1.7.jar
|
||||
neo4j/lib/parboiled-scala_2.11-1.1.7.jar
|
||||
neo4j/lib/rhino-1.7R4.jar
|
||||
neo4j/lib/scala-library-2.11.8.jar
|
||||
neo4j/lib/scala-reflect-2.11.8.jar
|
||||
neo4j/lib/server-api-3.2.1.jar
|
||||
neo4j/lib/scala-library-2.11.12.jar
|
||||
neo4j/lib/scala-reflect-2.11.12.jar
|
||||
neo4j/lib/server-api-3.3.2.jar
|
||||
neo4j/libexec/tools/2.x-config-migrator.jar
|
||||
neo4j/libexec/tools/cypher-shell-all.jar
|
||||
@dir neo4j/lib/plugins
|
||||
@dir %%DATADIR%%
|
||||
@dir %%DBDIR%%
|
||||
@dir etc/neo4j-certificates
|
||||
|
Loading…
Reference in New Issue
Block a user