misc/openvdb: Update 7.2.0 -> 8.0.0
Reported by: portscout
This commit is contained in:
parent
f66a966f95
commit
63a25eeb45
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=559418
@ -2,7 +2,7 @@
|
||||
|
||||
PORTNAME= openvdb
|
||||
DISTVERSIONPREFIX= v
|
||||
DISTVERSION= 7.2.0
|
||||
DISTVERSION= 8.0.0
|
||||
CATEGORIES= misc
|
||||
|
||||
MAINTAINER= yuri@FreeBSD.org
|
||||
|
@ -1,3 +1,3 @@
|
||||
TIMESTAMP = 1607816892
|
||||
SHA256 (AcademySoftwareFoundation-openvdb-v7.2.0_GH0.tar.gz) = 81ff2758e3900e5d4022fde0149d63387167db8adaf5c0ace1456dad3a012d1d
|
||||
SIZE (AcademySoftwareFoundation-openvdb-v7.2.0_GH0.tar.gz) = 2283069
|
||||
TIMESTAMP = 1609053253
|
||||
SHA256 (AcademySoftwareFoundation-openvdb-v8.0.0_GH0.tar.gz) = 04a28dc24a744f8ac8bbc5636a949628edb02b7c84db24ad795429c8c739a9ee
|
||||
SIZE (AcademySoftwareFoundation-openvdb-v8.0.0_GH0.tar.gz) = 2285328
|
||||
|
@ -1,6 +1,6 @@
|
||||
--- CMakeLists.txt.orig 2020-12-09 15:44:05 UTC
|
||||
--- CMakeLists.txt.orig 2020-12-24 17:13:14 UTC
|
||||
+++ CMakeLists.txt
|
||||
@@ -197,7 +197,7 @@ mark_as_advanced(
|
||||
@@ -199,7 +199,7 @@ mark_as_advanced(
|
||||
# @note Blosc version is currently treated as exception which must be adhered
|
||||
# to. The minimum version must be at least 1.5.0. Previous versions are incompatible.
|
||||
# Later versions (including 1.5.4), can be buggy on certain platforms.
|
||||
@ -8,13 +8,13 @@
|
||||
+set(MINIMUM_BLOSC_VERSION 1.15)
|
||||
# @note ABI always enforced so the correct deprecation messages are available.
|
||||
# OPENVDB_USE_DEPRECATED_ABI_<VERSION> should be used to circumvent this
|
||||
set(MINIMUM_OPENVDB_ABI_VERSION 5)
|
||||
@@ -218,7 +218,7 @@ if(NOT DISABLE_DEPENDENCY_VERSION_CHECKS)
|
||||
set(MINIMUM_TBB_VERSION 2017.0)
|
||||
set(MINIMUM_OPENVDB_ABI_VERSION 6)
|
||||
@@ -220,7 +220,7 @@ if(NOT DISABLE_DEPENDENCY_VERSION_CHECKS)
|
||||
set(MINIMUM_TBB_VERSION 2018.0)
|
||||
set(MINIMUM_LLVM_VERSION 6.0.0)
|
||||
|
||||
- set(MINIMUM_PYTHON_VERSION 2.7)
|
||||
+ set(MINIMUM_PYTHON_VERSION ${FREEBSD_PYTHON_VER})
|
||||
set(MINIMUM_NUMPY_VERSION 1.12.1)
|
||||
set(MINIMUM_NUMPY_VERSION 1.14.0)
|
||||
|
||||
set(MINIMUM_GOOGLETEST_VERSION 1.8)
|
||||
|
@ -1,10 +1,10 @@
|
||||
--- doc/CMakeLists.txt.orig 2020-08-13 19:15:58 UTC
|
||||
--- doc/CMakeLists.txt.orig 2020-12-24 17:13:14 UTC
|
||||
+++ doc/CMakeLists.txt
|
||||
@@ -73,5 +73,5 @@ add_custom_target(doc ALL
|
||||
)
|
||||
@@ -193,5 +193,5 @@ doxygen_add_docs(doc ${DOXY_FILES}
|
||||
COMMENT "Generating API documentation with Doxygen")
|
||||
|
||||
# Suppress "Installing..." messages for all but one of the hundreds of generated files.
|
||||
-install(FILES ${CMAKE_CURRENT_BINARY_DIR}/openvdb/doc/html/index.html DESTINATION doc/html)
|
||||
-install(DIRECTORY ${CMAKE_CURRENT_BINARY_DIR}/openvdb/doc/html DESTINATION doc MESSAGE_NEVER)
|
||||
-install(FILES ${CMAKE_CURRENT_BINARY_DIR}/html/index.html DESTINATION doc/html)
|
||||
-install(DIRECTORY ${CMAKE_CURRENT_BINARY_DIR}/html DESTINATION doc MESSAGE_NEVER)
|
||||
+install(FILES ${CMAKE_CURRENT_BINARY_DIR}/openvdb/doc/html/index.html DESTINATION share/doc/openvdb)
|
||||
+install(DIRECTORY ${CMAKE_CURRENT_BINARY_DIR}/openvdb/doc/html DESTINATION share/doc/openvdb MESSAGE_NEVER)
|
||||
|
@ -1,30 +1,21 @@
|
||||
--- openvdb/openvdb/python/CMakeLists.txt.orig 2020-08-13 19:15:58 UTC
|
||||
--- openvdb/openvdb/python/CMakeLists.txt.orig 2020-12-24 17:13:14 UTC
|
||||
+++ openvdb/openvdb/python/CMakeLists.txt
|
||||
@@ -104,9 +104,9 @@ if(${CMAKE_VERSION} VERSION_LESS 3.12)
|
||||
elseif(${CMAKE_VERSION} VERSION_LESS 3.14)
|
||||
# CMake < 3.14
|
||||
if(OPENVDB_BUILD_PYTHON_UNITTESTS)
|
||||
- find_package(Python QUIET COMPONENTS Interpreter Development)
|
||||
+ find_package(Python ${FREEBSD_PYTHON_VER} EXACT REQUIRED COMPONENTS Interpreter Development)
|
||||
else()
|
||||
- find_package(Python QUIET COMPONENTS Development)
|
||||
+ find_package(Python ${FREEBSD_PYTHON_VER} EXACT REQUIRED COMPONENTS Development)
|
||||
endif()
|
||||
OPENVDB_CHECK_PYTHON_VERSION(${Python_VERSION} ${Python_INCLUDE_DIRS})
|
||||
list(APPEND OPENVDB_PYTHON_DEPS Python::Python)
|
||||
@@ -119,16 +119,16 @@ elseif(${CMAKE_VERSION} VERSION_LESS 3.14)
|
||||
else()
|
||||
# CMake >= 3.14
|
||||
if(OPENVDB_BUILD_PYTHON_UNITTESTS)
|
||||
- find_package(Python QUIET COMPONENTS Interpreter Development)
|
||||
+ find_package(Python ${FREEBSD_PYTHON_VER} EXACT REQUIRED COMPONENTS Interpreter Development)
|
||||
else()
|
||||
- find_package(Python QUIET COMPONENTS Development)
|
||||
+ find_package(Python ${FREEBSD_PYTHON_VER} EXACT REQUIRED COMPONENTS Development)
|
||||
endif()
|
||||
@@ -85,7 +85,7 @@ if(OPENVDB_BUILD_PYTHON_UNITTESTS)
|
||||
endif()
|
||||
|
||||
if(${CMAKE_VERSION} VERSION_LESS 3.14)
|
||||
- find_package(Python QUIET COMPONENTS ${OPENVDB_PYTHON_REQUIRED_COMPONENTS})
|
||||
+ find_package(Python ${FREEBSD_PYTHON_VER} EXACT REQUIRED COMPONENTS ${OPENVDB_PYTHON_REQUIRED_COMPONENTS})
|
||||
OPENVDB_CHECK_PYTHON_VERSION(${Python_VERSION} ${Python_INCLUDE_DIRS})
|
||||
|
||||
if(USE_NUMPY)
|
||||
@@ -94,11 +94,11 @@ if(${CMAKE_VERSION} VERSION_LESS 3.14)
|
||||
list(APPEND OPENVDB_PYTHON_DEPS Python::NumPy)
|
||||
endif()
|
||||
else()
|
||||
- find_package(Python QUIET COMPONENTS ${OPENVDB_PYTHON_REQUIRED_COMPONENTS})
|
||||
+ find_package(Python ${FREEBSD_PYTHON_VER} EXACT REQUIRED COMPONENTS ${OPENVDB_PYTHON_REQUIRED_COMPONENTS})
|
||||
OPENVDB_CHECK_PYTHON_VERSION(${Python_VERSION} ${Python_INCLUDE_DIRS})
|
||||
list(APPEND OPENVDB_PYTHON_DEPS Python::Python)
|
||||
|
||||
if(USE_NUMPY)
|
||||
- find_package(Python QUIET COMPONENTS NumPy)
|
||||
|
@ -145,6 +145,6 @@ lib/cmake/OpenVDB/OpenVDBHoudiniSetup.cmake
|
||||
lib/cmake/OpenVDB/OpenVDBMayaSetup.cmake
|
||||
lib/cmake/OpenVDB/OpenVDBUtils.cmake
|
||||
lib/libopenvdb.so
|
||||
lib/libopenvdb.so.7.2
|
||||
lib/libopenvdb.so.7.2.0
|
||||
lib/libopenvdb.so.8.0
|
||||
lib/libopenvdb.so.8.0.0
|
||||
%%PYTHON%%%%PYTHON_LIBDIR%%/pyopenvdb.so
|
||||
|
Loading…
Reference in New Issue
Block a user