Add ruby-gst, Ruby bindings for the GStreamer framework.

This commit is contained in:
Akinori MUSHA 2003-06-26 05:01:46 +00:00
parent 84e37fa023
commit 6388b9b87e
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=83623
6 changed files with 76 additions and 0 deletions

View File

@ -80,6 +80,7 @@
SUBDIR += oqtplayer
SUBDIR += ppm2fli
SUBDIR += recmpeg
SUBDIR += ruby-gst
SUBDIR += slideshow
SUBDIR += smpeg
SUBDIR += smpeg-xmms

View File

@ -0,0 +1,39 @@
# New ports collection makefile for: ruby-gst
# Date created: 26 June 2003
# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
#
# $FreeBSD$
#
PORTNAME= gst
PORTVERSION= 0.1.0
CATEGORIES= multimedia ruby
MASTER_SITES= http://savannah.nongnu.org/download/ruby-gst/unstable.pkg/${PORTVERSION}/
PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
DISTNAME= ruby-${PORTNAME}-${PORTVERSION}
DIST_SUBDIR= ruby
MAINTAINER= knu@FreeBSD.org
COMMENT= Ruby bindings for the GStreamer framework
BUILD_DEPENDS= pkg-config:${PORTSDIR}/devel/pkgconfig
LIB_DEPENDS= gstreamer-0.6.1:${PORTSDIR}/multimedia/gstreamer
USE_RUBY= yes
USE_RUBY_EXTCONF= yes
INSTALL_TARGET= site-install
DOCS= AUTHORS doc/api
post-install:
.if !defined(NOPORTDOCS)
${MKDIR} ${RUBY_MODEXAMPLESDIR}
${INSTALL_DATA} ${WRKSRC}/sample/* ${RUBY_MODEXAMPLESDIR}/
${MKDIR} ${RUBY_MODDOCDIR}
.for f in ${DOCS}
${CP} -R ${WRKSRC}/${f} ${RUBY_MODDOCDIR}/
.endfor
.endif
.include <bsd.port.mk>

View File

@ -0,0 +1 @@
MD5 (ruby/ruby-gst-0.1.0.tar.gz) = 2441580e02a634d3ad19c541b1ae1e2e

View File

@ -0,0 +1,11 @@
--- extconf.rb.orig Tue Jun 10 02:38:38 2003
+++ extconf.rb Thu Jun 26 13:55:11 2003
@@ -20,7 +20,7 @@
require 'mkmf'
PKG_CONFIG = "pkg-config"
-GST_PKG = "gstreamer-libs-0.6"
+GST_PKG = "gstreamer-0.6"
def create_archive
ver = IO.readlines("VERSION").join.strip

View File

@ -0,0 +1,4 @@
This is a set of Ruby bindings for the GStreamer multimedia framework.
Author: Laurent Sansonetti <laurent@datarescue.be>
WWW: http://www.freesoftware.fsf.org/ruby-gst/

View File

@ -0,0 +1,20 @@
%%RUBY_SITEARCHLIBDIR%%/gst.so
%%PORTDOCS%%%%RUBY_MODEXAMPLESDIR%%/mp3-player.rb
%%PORTDOCS%%@dirrm %%RUBY_MODEXAMPLESDIR%%
%%PORTDOCS%%%%RUBY_MODDOCDIR%%/AUTHORS
%%PORTDOCS%%%%RUBY_MODDOCDIR%%/api/api.txt
%%PORTDOCS%%%%RUBY_MODDOCDIR%%/api/api.xml
%%PORTDOCS%%%%RUBY_MODDOCDIR%%/api/book.xml
%%PORTDOCS%%%%RUBY_MODDOCDIR%%/api/ch01.html
%%PORTDOCS%%%%RUBY_MODDOCDIR%%/api/ch02.html
%%PORTDOCS%%%%RUBY_MODDOCDIR%%/api/ch03.html
%%PORTDOCS%%%%RUBY_MODDOCDIR%%/api/ch04.html
%%PORTDOCS%%%%RUBY_MODDOCDIR%%/api/ch05.html
%%PORTDOCS%%%%RUBY_MODDOCDIR%%/api/ch06.html
%%PORTDOCS%%%%RUBY_MODDOCDIR%%/api/ch07.html
%%PORTDOCS%%%%RUBY_MODDOCDIR%%/api/ch08.html
%%PORTDOCS%%%%RUBY_MODDOCDIR%%/api/ch09.html
%%PORTDOCS%%%%RUBY_MODDOCDIR%%/api/docbook.css
%%PORTDOCS%%%%RUBY_MODDOCDIR%%/api/index.html
%%PORTDOCS%%@dirrm %%RUBY_MODDOCDIR%%/api
%%PORTDOCS%%@dirrm %%RUBY_MODDOCDIR%%