Vanubi is an Emacs-like editor implemented in Vala. It is designed to be

simple, complete, keyboard based, and implement only what users really
use and expect.

WWW: http://vanubi.github.io/vanubi/
This commit is contained in:
Olivier Duchateau 2015-07-08 17:20:09 +00:00
parent 2a1e7297f3
commit 638449fd1f
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=391579
8 changed files with 97 additions and 0 deletions

View File

@ -251,6 +251,7 @@
SUBDIR += tweak
SUBDIR += uemacs
SUBDIR += uzap
SUBDIR += vanubi
SUBDIR += vigor
SUBDIR += vile
SUBDIR += vim

33
editors/vanubi/Makefile Normal file
View File

@ -0,0 +1,33 @@
# Created by: Olivier Duchateau
# $FreeBSD$
PORTNAME= vanubi
PORTVERSION= 0.0.16
DISTVERSIONPREFIX= v
CATEGORIES= editors
MAINTAINER= olivierd@FreeBSD.org
COMMENT= Programming editor written in Vala
LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/COPYING
BUILD_DEPENDS= valac:${PORTSDIR}/lang/vala
LIB_DEPENDS= libexecinfo.so:${PORTSDIR}/devel/libexecinfo
GH_TAGNAME= eedac1d
USE_GITHUB= yes
USES= autoreconf desktop-file-utils gmake libtool pkgconfig
GNU_CONFIGURE= yes
USE_GNOME= glib20 gtk30 gtksourceview3 libwnck3 vte3
USE_LDCONFIG= yes
INSTALL_TARGET= install-strip
CONFIGURE_ARGS=--without-asciidoc --disable-static
post-patch:
${REINPLACE_CMD} -e 's|vte-2.90|vte-2.91|' \
${WRKSRC}/configure.ac
.include <bsd.port.mk>

2
editors/vanubi/distinfo Normal file
View File

@ -0,0 +1,2 @@
SHA256 (vanubi-vanubi-v0.0.16-eedac1d_GH0.tar.gz) = 20ef1d71ec62416c2e048bc829f546672c4ae7e4be8556114fd40a19eb924978
SIZE (vanubi-vanubi-v0.0.16-eedac1d_GH0.tar.gz) = 709627

View File

@ -0,0 +1,11 @@
--- configure.ac.orig 2014-12-09 10:52:31 UTC
+++ configure.ac
@@ -71,7 +71,7 @@ LIBVANUBI_VALAFLAGS="$LIBVANUBI_VALAFLAG
LIBVANUBI_CFLAGS="$LIBVANUBI_CFLAGS -w"
LIBVANUBI_LIBS="$LIBVANUBI_LIBS"
-VALA_CHECK_MODULES(VANUBI, [gtk+-3.0 >= 3.6 gio-unix-2.0 gtksourceview-3.0 vte-2.90 gdk-x11-3.0 libwnck-3.0])
+VALA_CHECK_MODULES(VANUBI, [gtk+-3.0 gio-unix-2.0 gtksourceview-3.0 vte-2.90 gdk-x11-3.0 libwnck-3.0])
dnl We ignore GTK_3_10_*
PKG_CHECK_MODULES(GTK_3_10, [gtk+-3.0 >= 3.10],
[VANUBI_VALAFLAGS="$VANUBI_VALAFLAGS -D GTK_3_10"],

View File

@ -0,0 +1,11 @@
--- gui/Makefile.am.orig 2014-12-09 10:52:31 UTC
+++ gui/Makefile.am
@@ -50,6 +50,8 @@ vanubi_SOURCES = \
vanubi_LDADD = \
../libvanubi/libvanubi@PACKAGE_SUFFIX@.la \
$(VANUBI_LIBS) \
+ -lexecinfo \
+ -lX11 \
$(NULL)
EXTRA_DIST = $(vanubi_VALASOURCES)

View File

@ -0,0 +1,17 @@
Add support of vte-2.91 instead of vte-2.90
--- gui/shellbar.vala.orig 2014-12-09 10:52:31 UTC
+++ gui/shellbar.vala
@@ -146,10 +146,10 @@ namespace Vanubi.UI {
}
Pid pid;
- term.fork_command_full (PtyFlags.DEFAULT, workdir, {shell}, null, SpawnFlags.SEARCH_PATH, null, out pid);
+ term.spawn_sync (PtyFlags.DEFAULT, workdir, {shell}, null, SpawnFlags.SEARCH_PATH, null, out pid);
term.set_data ("pid", pid);
pty_cancellable = new Cancellable ();
- read_sh.begin (term.pty_object.fd, pty_cancellable);
+ read_sh.begin (term.get_pty ().fd, pty_cancellable);
mouse_match (term, """^.+error:""");
mouse_match (term, """^.+warning:""");

5
editors/vanubi/pkg-descr Normal file
View File

@ -0,0 +1,5 @@
Vanubi is an Emacs-like editor implemented in Vala. It is designed to be
simple, complete, keyboard based, and implement only what users really
use and expect.
WWW: http://vanubi.github.io/vanubi/

17
editors/vanubi/pkg-plist Normal file
View File

@ -0,0 +1,17 @@
bin/vanubi
lib/libvanubi-0.1.so
lib/libvanubi-0.1.so.0
lib/libvanubi-0.1.so.0.0.0
share/applications/vanubi.desktop
%%DATADIR%%/css/tango.css
%%DATADIR%%/css/zen.css
%%DATADIR%%/languages/asciidoc.lang
%%DATADIR%%/languages/asm-intel.lang
%%DATADIR%%/languages/generic_comment.lang
%%DATADIR%%/languages/i386asm.lang
%%DATADIR%%/languages/nix.lang
%%DATADIR%%/languages/rpmspec.lang
%%DATADIR%%/logo/vanubi.png
%%DATADIR%%/styles/tango.xml
%%DATADIR%%/styles/zen-grep.xml
%%DATADIR%%/styles/zen.xml