- Unbreak on i386
Thanks to: tabthorpe@ for the i386 build env
This commit is contained in:
parent
db853aaf18
commit
6332627a9e
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=299730
@ -46,10 +46,6 @@ MAN1= reswrap.1 shutterbug.1 adie.1 PathFinder.1 calculator.1 \
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if ${ARCH} == i386
|
||||
BROKEN= does not build
|
||||
.endif
|
||||
|
||||
.if defined(WITHOUT_JPEG)
|
||||
CONFIGURE_ARGS+=--disable-jpeg
|
||||
.else
|
||||
|
@ -1,5 +1,5 @@
|
||||
--- lib/FXAtomic.cpp.orig 2012-04-27 18:46:09.000000000 +0200
|
||||
+++ lib/FXAtomic.cpp 2012-06-20 10:39:15.000000000 +0200
|
||||
+++ lib/FXAtomic.cpp 2012-06-21 15:22:43.000000000 +0200
|
||||
@@ -298,7 +298,7 @@
|
||||
LONGLONG duet[2]={(LONGLONG)a,(LONGLONG)b};
|
||||
return (_InterlockedCompareExchange128((LONGLONG volatile*)ptr,(LONGLONG)cmpb,(LONGLONG)cmpa,duet));
|
||||
@ -9,3 +9,12 @@
|
||||
register FXbool ret;
|
||||
__asm__ __volatile__ ("xchgl %%esi, %%ebx\n\t"
|
||||
"lock\n\t"
|
||||
@@ -308,7 +308,7 @@
|
||||
"xchgl %%esi, %%ebx\n\t" : "=a"(ret) : "D"(ptr), "a"(cmpa), "d"(cmpb), "S"(a), "c"(b) : "memory", "cc");
|
||||
return ret;
|
||||
#else
|
||||
- register TBool ret;
|
||||
+ register FXbool ret;
|
||||
__asm__ __volatile__ ("lock\n\t"
|
||||
"cmpxchg8b (%1)\n\t"
|
||||
"setz %%al\n\t"
|
||||
|
Loading…
Reference in New Issue
Block a user