Remove expired ports:

- sysutils/devcpu: Already included in base system
- mail/squirreloutlook: Based on a vulnerable version of squirrelmail,
  use mail/squirrelmail for similar functionality
This commit is contained in:
Ruslan Makhmatkhanov 2012-07-06 08:46:53 +00:00
parent 3c437e2e5e
commit 63239aeec0
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=300557
17 changed files with 2 additions and 512 deletions

2
MOVED
View File

@ -3540,3 +3540,5 @@ net-p2p/sharktorrent||2012-07-01|Relies on net-p2p/libtorrent-rasterbar-14, whic
databases/postgresql-libpqxx30|databases/postgresql-libpqxx3|2012-07-03|Port renamed to be updated to 3.1
mail/mew2|mail/mew|2012-07-06|Development of this versions ceased, superseded by mail/mew
mail/mew3|mail/mew|2012-07-06|Development of this versions ceased, superseded by mail/mew
sysutils/devcpu||2012-07-06|Already included in base system
mail/squirreloutlook||2012-07-06|Based on a vulnerable version of squirrelmail, use mail/squirrelmail for similar functionality

View File

@ -701,7 +701,6 @@
SUBDIR += squirrelmail-vlogin-plugin
SUBDIR += squirrelmail-websearch-plugin
SUBDIR += squirrelmail-wetteronline-plugin
SUBDIR += squirreloutlook
SUBDIR += sqwebmail
SUBDIR += ssmtp
SUBDIR += surblhost

View File

@ -1,111 +0,0 @@
# New ports collection makefile for: squirrelmailoutlook
# Date created: 28 December 2006
# Whom: Dennis Cabooter <freebsd@rootxs.org>
#
# $FreeBSD$
#
PORTNAME= squirreloutlook
PORTVERSION= 1.0.3
PORTREVISION= 2
CATEGORIES= mail www
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}-${PORTVERSION}/${PORTVERSION}:squirreloutlook \
SF/${PORTNAME}/locales/1.5.1-20060409:locales
DISTFILES= ${DISTNAME}${EXTRACT_SUFX}:squirreloutlook \
all_locales-1.5.1-20060409${EXTRACT_SUFX}:locales
DIST_SUBDIR= ${PORTNAME}
MAINTAINER= ports@FreeBSD.org
COMMENT= A webmail system which accesses mail over IMAP
FORBIDDEN= Based on a vulnerable version of mail/squirrelmail
DEPRECATED= Use mail/squirrelmail for similar functionality
EXPIRATION_DATE=2012-07-01
CONFLICTS= squirrelmail-1*
USE_PHP= session mhash gettext mbstring pcre openssl xml
WANT_PHP_WEB= yes
USE_GETTEXT= yes
.ifdef WITH_DATABASE
RUN_DEPENDS+= ${PREFIX}/share/pear/DB.php:${PORTSDIR}/databases/pear-DB
.endif
.ifdef WITH_LDAP
USE_PHP+= ldap
.endif
SQUIRRELDIR= ${PREFIX}/www/${PORTNAME}
PLIST_SUB= PORTVERSION=${PORTVERSION} \
SQUIRRELDIR="${SQUIRRELDIR:S,^${PREFIX}/,,}"
SUB_FILES= pkg-message pkg-install pkg-deinstall
SUB_LIST= SQUIRRELDIR=${SQUIRRELDIR}
PORTDOCS= *
CONFLICTS= squirrelmail-[0-9]*
pre-everything::
@${ECHO_CMD} "Use WITH_LDAP to ensure PHP LDAP support is installed"
@${ECHO_CMD} "Use WITH_DATABASE to ensure PEAR framework for database support is installed"
@${ECHO_CMD} " (note that this does not install the database specific PEAR support, e.g. MySQL)"
@${ECHO_CMD}
post-patch:
.ifndef PATCH_DEBUG
@${RM} -f ${WRKSRC}/config/config_default.php.orig ${WRKSRC}/functions/global.php.orig
.endif
@${REINPLACE_CMD} -e 's|ispell|${LOCALBASE}/bin/ispell|g' \
${WRKSRC}/plugins/squirrelspell/sqspell_config.php
@${RM} ${WRKSRC}/plugins/squirrelspell/sqspell_config.php.bak
# Rearrange the documentation
do-build:
.for file in AUTHORS ChangeLog COPYING INSTALL README UPGRADE
@${MV} ${WRKSRC}/${file} ${WRKSRC}/doc/
.endfor
@${MV} ${WRKSRC}/ReleaseNotes ${WRKSRC}/doc/ReleaseNotes-${PORTVERSION}.txt
@${MV} ${WRKSRC}/themes/README.themes ${WRKSRC}/doc/
@cd ${WRKSRC} ; for f in `find plugins -name "README*" -or \
-name INSTALL -or -name CHANGES -or -name HISTORY`; \
do \
${MKDIR} doc/`dirname $$f` ; \
${MV} $$f doc/`dirname $$f` ; \
done; \
${MV} doc/plugins/squirrelspell/doc/README doc/plugins/squirrelspell ; \
${RM} -rf doc/plugins/squirrelspell/doc ; \
${MV} plugins/squirrelspell/doc/* doc/plugins/squirrelspell ; \
${RM} -f doc/plugins/squirrelspell/index.php ; \
${RM} -rf plugins/squirrelspell/doc
@${ECHO} "left_refresh=300" >> ${WRKSRC}/data/default_pref
@${CP} -r ${WRKSRC}/../locale ${WRKSRC}
@${CP} -r ${WRKSRC}/../images ${WRKSRC}
@${CP} -r ${WRKSRC}/../help ${WRKSRC}
pre-install:
@${ECHO} "Your umask should be lax while installing this. Like, 022 or something."
@${SH} ${PKGINSTALL} ${PKGNAME} PRE-INSTALL
do-install:
${MKDIR} ${PREFIX}/etc/periodic/daily
${INSTALL_SCRIPT} ${FILESDIR}/111.clean-squirrelmail ${PREFIX}/etc/periodic/daily
${MKDIR} ${SQUIRRELDIR}
@${CP} -pv ${WRKSRC}/index.php ${SQUIRRELDIR}
@${CP} -pv ${WRKSRC}/configure ${SQUIRRELDIR}
.for DIR in class config data functions help images include locale plugins po src themes
@${CP} -rpv ${WRKSRC}/${DIR} ${SQUIRRELDIR}
.endfor
${CHOWN} -R ${WWWOWN}:${WWWGRP} ${SQUIRRELDIR}/data
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
@${CP} -Rv ${WRKSRC}/doc/* ${DOCSDIR}
.endif
post-install:
@${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
@${CAT} ${PKGMESSAGE}
.include <bsd.port.mk>

View File

@ -1,4 +0,0 @@
SHA256 (squirreloutlook/squirreloutlook-1.0.3.tar.gz) = f584797b2f0f72fd692d675c4c5301f60ee9a0f9f2d7e3a1ea6a55d999abaf3a
SIZE (squirreloutlook/squirreloutlook-1.0.3.tar.gz) = 2007632
SHA256 (squirreloutlook/all_locales-1.5.1-20060409.tar.gz) = c9df273a8777a14b0758d2be7fe532627496d830fb866c164a6e68cc0ef2879d
SIZE (squirreloutlook/all_locales-1.5.1-20060409.tar.gz) = 4046326

View File

@ -1,69 +0,0 @@
#!/bin/sh
#
# $FreeBSD: /tmp/pcvs/ports/mail/squirreloutlook/files/Attic/111.clean-squirrelmail,v 1.1 2007-01-08 23:03:14 miwi Exp $
#
# This script copied from /etc/periodic/daily/110.clean-tmps,v 1.6.2.4 2002/10/13 19:59:01
#
# Perform attachment directory cleaning so that long-lived systems
# don't end up with excessively old files there.
#
# Define these variables in either /etc/periodic.conf or
# /etc/periodic.conf.local to override the default values.
#
# 111.clean-squirrelmail
clean_squirrelmail_enable="NO" # Delete squirrelmail attachments
clean_squirrelmail_dirs="/var/spool/squirrelmail/attach" # Delete under here
clean_squirrelmail_days="10" # If not accessed for
clean_squirrelmail_ignore="quota.user quota.group" # Don't delete these
clean_squirrelmail_verbose="YES" # Mention files deleted
# If there is a global system configuration file, suck it in.
#
if [ -r /etc/defaults/periodic.conf ]
then
. /etc/defaults/periodic.conf
source_periodic_confs
fi
case "$clean_squirrelmail_enable" in
[Yy][Ee][Ss])
if [ -z "$clean_squirrelmail_days" ]
then
echo '$clean_squirrelmail_enable is set but' \
'$clean_squirrelmail_days is not'
rc=2
else
echo ""
echo "Removing old SquirrelOutlook Attachment files:"
set -f noglob
args="-atime +$clean_squirrelmail_days -mtime +$clean_squirrelmail_days"
args="${args} -ctime +$clean_squirrelmail_days"
[ -n "$clean_squirrelmail_ignore" ] &&
args="$args "`echo " ${clean_squirrelmail_ignore% }" |
sed 's/[ ][ ]*/ ! -name /g'`
case "$clean_squirrelmail_verbose" in
[Yy][Ee][Ss])
print=-print;;
*)
print=;;
esac
rc=$(for dir in $clean_squirrelmail_dirs
do
[ ."${dir#/}" != ."$dir" -a -d $dir ] && cd $dir && {
find -d . -type f $args -delete $print
find -d . ! -name . -type d -empty -mtime \
+$clean_squirrelmail_days -delete $print
} | sed "s,^\\., $dir,"
done | tee /dev/stderr | wc -l)
[ -z "$print" ] && rc=0
[ $rc -gt 1 ] && rc=1
set -f glob
fi;;
*) rc=0;;
esac
exit $rc

View File

@ -1,20 +0,0 @@
--- config/config_default.php.orig Wed Jun 2 10:49:41 2004
+++ config/config_default.php Wed Jun 2 10:50:21 2004
@@ -442,7 +442,7 @@
* $data_dir = SM_PATH . 'data/';
* @global string $data_dir
*/
-$data_dir = SM_PATH . 'data/';
+$data_dir = '/var/spool/squirrelmail/pref/';
/**
* Attachments directory
@@ -460,7 +460,7 @@
* + It should probably be another directory than data_dir.
* @global string $attachment_dir
*/
-$attachment_dir = $data_dir;
+$attachment_dir = '/var/spool/squirrelmail/attach/';
/**
* Hash level used for data directory.

View File

@ -1,43 +0,0 @@
#!/bin/sh
#
# $FreeBSD: /tmp/pcvs/ports/mail/squirreloutlook/files/Attic/pkg-deinstall.in,v 1.1 2007-01-08 23:03:14 miwi Exp $
#
#set -vx
PKG_BATCH=${BATCH:=NO}
PKG_PREFIX=${PKG_PREFIX:=/usr/local}
SQUIRRELDIR=%%SQUIRRELDIR%%
checkfile() {
diff -bBqw $1 $2 >/dev/null 2>&1
case $? in
0) # config file exists, but is the same
rm $1
;;
1) # config file exists and differs
;;
*) # no config file exists
;;
esac
}
case $2 in
DEINSTALL)
cd ${PKG_PREFIX}
checkfile /var/spool/squirrelmail/prefs/default_pref \
${SQUIRRELDIR}/data/default_pref
;;
POST-DEINSTALL)
if [ "${PKG_BATCH}" = "NO" ]; then
echo "If you are no longer going to use SquirrelOutlook"
echo "you should remove the /var/spool/squirrelmail"
echo "directory with:"
echo
echo " rm -rf /var/spool/squirrelmail"
fi
;;
esac

View File

@ -1,57 +0,0 @@
#!/bin/sh
#
# $FreeBSD: /tmp/pcvs/ports/mail/squirreloutlook/files/Attic/pkg-install.in,v 1.1 2007-01-08 23:03:14 miwi Exp $
#
PKG_BATCH=${BATCH:=NO}
PKG_PREFIX=${PKG_PREFIX:=/usr/local}
SQUIRRELDIR=%%SQUIRRELDIR%%
case $2 in
PRE-INSTALL)
USER=www
GROUP=${USER}
UID=80
GID=${UID}
if ! pw groupshow "${GROUP}" 2>/dev/null 1>&2; then
if pw groupadd ${GROUP} -g ${GID}; then
echo "Added group \"${GROUP}\"."
else
echo "Adding group \"${GROUP}\" failed..."
exit 1
fi
fi
if ! pw usershow "${USER}" 2>/dev/null 1>&2; then
if pw useradd ${USER} -u ${UID} -g ${GROUP} -h - \
-s "/sbin/nologin" -d "/nonexistent" \
-c "World Wide Web Owner"; \
then
echo "Added user \"${USER}\"."
else
echo "Adding user \"${USER}\" failed..."
exit 1
fi
fi
exit 0
;;
POST-INSTALL)
if [ "${PKG_BATCH}" = "NO" ]; then
install -d -o www -g www -m 0755 /var/spool/squirrelmail
install -d -o www -g www -m 0730 /var/spool/squirrelmail/attach
install -d -o www -g www -m 0750 /var/spool/squirrelmail/pref
if [ ! -f /var/spool/squirrelmail/pref/default_pref ]; then
cp -rp ${SQUIRRELDIR}/data/default_pref \
/var/spool/squirrelmail/pref/default_pref
else
echo ""
echo "An older version of default_pref exists in"
echo "/var/spool/squirrelmail/pref, you may want to"
echo "compare it with the one in ${SQUIRRELDIR}/data"
fi
fi
;;
esac

View File

@ -1,18 +0,0 @@
You now need to add an alias to apache's httpd.conf pointing to
%%SQUIRRELDIR%% in order to access SquirrelOutlook from
your web browser, or create a VirtualHost with DocumentRoot set
to that directory.
For SquirrelOutlook to work properly you will need to make sure the
following option is set in your php.ini file:
file_uploads = On
If you have problems with SquirrelOutlook saying "you must login" after
you just have, the following php.ini option may help:
session.auto_start = 1
In order to do your administrative configuration you need to
cd %%SQUIRRELDIR%% && ./configure
SquirrelOutlook will not work until this has been done.

View File

@ -1,9 +0,0 @@
SquirrelOutlook is a standards-based webmail package written in PHP4. It
includes built-in pure PHP support for the IMAP and SMTP protocols, and
all pages render in pure HTML 4.0 (with no Javascript) for maximum
compatibility across browsers. It has very few requirements and is very
easy to configure and install. SquirrelOutlook has a all the functionality
you would want from an email client, including strong MIME support,
address books, and folder manipulation
WWW: http://sourceforge.net/projects/squirreloutlook/

View File

@ -166,7 +166,6 @@
SUBDIR += desktopbsd-tools
SUBDIR += detach
SUBDIR += detox
SUBDIR += devcpu
SUBDIR += devcpu-data
SUBDIR += devstat
SUBDIR += dfc

View File

@ -1,81 +0,0 @@
# New ports collection makefile for: devcpu
# Date created: 2006-08-16
# Whom: stas
#
# $FreeBSD$
#
PORTNAME= devcpu
PORTVERSION= 0.8.3
PORTREVISION= 0
CATEGORIES= sysutils kld
MASTER_SITES= ftp://ftp.SpringDaemons.com/soft/
MAINTAINER= ports@FreeBSD.org
COMMENT= Kernel module that provides access to i386 MSRs and cpuid info
RUN_DEPENDS= ${STAMPFILE}:${PORTSDIR}/sysutils/devcpu-data
DEPRECATED= Already included in base system
EXPIRATION_DATE=2012-07-01
USE_BZIP2= yes
USE_RC_SUBR= devcpu
USE_RUBY= yes
RUBY_NO_BUILD_DEPENDS= yes
RUBY_NO_RUN_DEPENDS= yes
ONLY_FOR_ARCHS= i386 amd64
NO_PACKAGE= depends on kernel
PLIST_SUB= KMODDIR="${KMODDIR:C,^/,,}"
KMODDIR= /boot/modules
MAKE_ENV+= KMODDIR="${KMODDIR}" BINDIR="${PREFIX}/bin"
STAMPFILE= ${LOCALBASE}/share/${PORTNAME}/.do_not_delete
OPTIONS= EXTRACTOR "Install Award Bios microcode extracting utility" off
MAN4= cpu.4
MAN8= cpu_microcode_tool.8
.include <bsd.port.pre.mk>
.if ${OSVERSION} >= 701102
IGNORE= already included into base system
.endif
.if defined(WITH_EXTRACTOR)
RUN_DEPENDS+= ${RUBY_SITEARCHLIBDIR}/mmap.so:${PORTSDIR}/devel/ruby-mmap \
${RUBY_SITEARCHLIBDIR}/lhalib.so:${PORTSDIR}/archivers/ruby-lha
PLIST_SUB+= EXTRACTOR=""
.else
PLIST_SUB+= EXTRACTOR="@comment "
.endif
.if !exists(${SRC_BASE}/sys/Makefile)
IGNORE= requires kernel source to be installed
.endif
post-patch:
${REINPLACE_CMD} -e "s,%%PREFIX%%,${PREFIX},g" \
${WRKSRC}/cpu_microcode_tool/cpu_microcode_tool.8
post-install:
${INSTALL_DATA} ${WRKSRC}/cpu/cpu.h ${PREFIX}/include/
${INSTALL_MAN} ${WRKSRC}/cpu/cpu.4 ${PREFIX}/man/man4/
${INSTALL_MAN} ${WRKSRC}/cpu_microcode_tool/cpu_microcode_tool.8 \
${PREFIX}/man/man8/
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}/
${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}/
.endif
.if defined(WITH_EXTRACTOR)
${INSTALL_SCRIPT} ${WRKSRC}/tools/extract_mcodes.rb ${PREFIX}/libexec/
.endif
@${CAT} ${PKGMESSAGE}
.include <bsd.port.post.mk>

View File

@ -1,2 +0,0 @@
SHA256 (devcpu-0.8.3.tar.bz2) = 6631e0341e46a2378eeaa3674c87309cdee38c064e3da7297f872d40beade2d6
SIZE (devcpu-0.8.3.tar.bz2) = 13385

View File

@ -1,54 +0,0 @@
#!/bin/sh
#
# $FreeBSD$
#
# PROVIDE: devcpu
# REQUIRE: root mountcritlocal
# KEYWORD: nojail
#
# Add the following line to /etc/rc.conf to enable flow-capture:
# devcpu_enable (bool): Set it to "YES" to update cpucodes on startup
# Set to "NO" by default.
# devcpu_datadir (str): Directory, cpucode updates stored in.
# Default is "%%DATADIR%%"
# devcpu_cpus (str): A list of cpus to update on startup, or "-a" for all.
# Example: devcpu_cpus="cpu0 /dev/cpu1"
# Set to "-a" by default.
. /etc/rc.subr
name="devcpu"
rcvar=devcpu_enable
stop_cmd=":"
start_precmd="devcpu_prepare"
start_cmd="devcpu_start"
requires_modules="cpu"
CMT="%%PREFIX%%/bin/cpu_microcode_tool"
devcpu_prepare()
{
if ! kldstat -q -m cpu; then
if ! kldload cpu > /dev/null 2>&1; then
warn "Can't load cpu module."
return 1
fi
fi
}
devcpu_start()
{
echo "Updating cpucodes."
${CMT} -I "${devcpu_datadir}" ${devcpu_cpus}
}
load_rc_config $name
# Set default values
: ${devcpu_enable="NO"}
: ${devcpu_datadir="%%DATADIR%%"}
: ${devcpu_cpus="-a"}
run_rc_command "$1"

View File

@ -1,9 +0,0 @@
This kernel module provides access to i386/amd64 CPUs MSR (Model Specific
Register) registers and cpuid info through /dev/cpu%d devices, where %d
corresponds to cpu number.
It can be used with x86info to retrive information available from MSR registers.
Additionally, this module can be used to update/replace microcode of cpus.
Author: Stanislav Sedov <stas@FreeBSD.org>

View File

@ -1,25 +0,0 @@
=============================================================================
CPU kernel module was installed.
To load it, issue
% kldload cpu
Then you can access MSR registers or cpuid info via /dev/cpu%d or using
3d-party programs, e.g. x86info.
For information regarding microcode update features refer to
cpu_microcode_tool(4) manpage.
You might be interested in enabling automatic microcode update on startup.
This can be achieved by adding the line devcpu_enable="YES" to /etc/rc.conf.
Refer to rcNG devcpu script for additional info.
You can also use extract_mcodes.rb utility to extract cpucode updates
from vendor-supplied BIOS updates. The utility currently supports only
Award/Phoenix-compatible BIOS images.
Please, report any problems to maintainer. Thanks!
=============================================================================

View File

@ -1,8 +0,0 @@
bin/cpu_microcode_tool
include/cpu.h
%%EXTRACTOR%%libexec/extract_mcodes.rb
%%PORTDOCS%%%%DOCSDIR%%/README
%%PORTDOCS%%@dirrm %%DOCSDIR%%
@cwd /
%%KMODDIR%%/cpu.ko
@unexec kldxref /%%KMODDIR%%