finance/moneymanagerx: Upgrade version 0.9.9.0 => 1.0.0.0

The PR was modified.  The PORTDATA change was not accepted.  The
rewrapping of pkg-descr from 75 to 72 character width was not accepted.
USE_AUTOTOOLS did get added and I kept it because I couldn't make
USES=autoreconf work out of the box.  It's needs some customization and
I'm not familar enough with automake to get it to work, so check-sanity
squawks but it passes the build.

While here, add a patch to support DragonFly

PR:		199228
Submitted by:	ports fury
This commit is contained in:
John Marino 2015-10-10 13:52:43 +00:00
parent fc116369c1
commit 630b5a689e
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=398995
4 changed files with 85 additions and 103 deletions

View File

@ -2,31 +2,46 @@
# $FreeBSD$
PORTNAME= mmex
PORTVERSION= 0.9.9.0
PORTREVISION= 2
PORTVERSION= 1.0.0.0
CATEGORIES= finance
MASTER_SITES= http://www.codelathe.com/${PORTNAME}/installer/linux/ \
SF/moneymanagerex/moneymanagerex/Version%20${PORTVERSION}
DISTNAME= ${PORTNAME}_${PORTVERSION}_src
MASTER_SITES= SF/moneymanagerex/moneymanagerex/Version%20${PORTVERSION} \
https://github.com/vslavik/bakefile/releases/download/v0.2.9/:bakefile
DISTFILES= mmex_${PORTVERSION}_src.tar.bz2 \
bakefile-0.2.9.tar.gz:bakefile
MAINTAINER= ports@FreeBSD.org
COMMENT= Free, open-source, easy-to-use personal finance software
LICENSE= GPLv2
BUILD_DEPENDS= ${LOCALBASE}/include/boost/version.hpp:${PORTSDIR}/devel/boost-libs
NO_WRKSUBDIR= yes
USES= gettext-tools tar:bzip2
USES= compiler:c++11-lib gettext gmake tar:bzip2
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-wx-config=${WX_CONFIG}
USE_WX= 2.8+
USE_WX= 3.0
WX_UNICODE= yes
WX_CONF_ARGS= absolute
USE_AUTOTOOLS= aclocal autoconf
ACLOCAL_ARGS= -I m4 -I bakefile-0.2.9/autoconf \
--automake-acdir=${ACLOCAL_DIR}
INSTALLS_ICONS= yes
WRKSRC= ${WRKDIR}/${PORTNAME}_${PORTVERSION}
CPPFLAGS+= -I${LOCALBASE}/include # helps to find boost
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
PORTDOCS= *
OPTIONS_DEFINE= DOCS
post-patch:
@${REINPLACE_CMD} -e '/man1/s,$$(datadir),${MANPREFIX},' \
${WRKSRC}/Makefile.in
@${REINPLACE_CMD} -e \
's|$$(datadir)/man|$$(prefix)/man|' ${WRKSRC}/Makefile.in
@${REINPLACE_CMD} -e \
's|\[noext\]|[]|' ${WRKSRC}/configure.ac
@${REINPLACE_CMD} -e \
's| -g0 -O2||' ${WRKSRC}/m4/wxpresets.m4
pre-configure:
@(cd ${WRKSRC} && ${SH} update_revision.sh)
.include <bsd.port.mk>

View File

@ -1,2 +1,4 @@
SHA256 (mmex_0.9.9.0_src.tar.bz2) = 9973c7010f8989ab9582576549ea3a7516a65f32e9f21d1c50b680886512a2ac
SIZE (mmex_0.9.9.0_src.tar.bz2) = 9667919
SHA256 (mmex_1.0.0.0_src.tar.bz2) = c28761bf9bef5f75cb25b887e89439f8e107957688004697b28e914f5d5ccb69
SIZE (mmex_1.0.0.0_src.tar.bz2) = 11077632
SHA256 (bakefile-0.2.9.tar.gz) = 9f3c65411ad3932027e3c3e765337d89be2f9cf5ee9a204da80e92a8c2d76ca5
SIZE (bakefile-0.2.9.tar.gz) = 775528

View File

@ -0,0 +1,18 @@
--- bakefile-0.2.9/autoconf/bakefile.m4.orig 2011-02-02 15:06:48 UTC
+++ bakefile-0.2.9/autoconf/bakefile.m4
@@ -444,6 +444,7 @@ AC_DEFUN([AC_BAKEFILE_SHARED_LD],
powerpc-apple-macos* | \
*-*-freebsd* | *-*-openbsd* | *-*-netbsd* | *-*-k*bsd*-gnu | \
+ *-*-dragonfly* | \
*-*-mirbsd* | \
*-*-sunos4* | \
*-*-osf* | \
@@ -495,6 +496,7 @@ AC_DEFUN([AC_BAKEFILE_SHARED_VERSIONS],
case "${BAKEFILE_HOST}" in
*-*-linux* | *-*-freebsd* | *-*-openbsd* | *-*-netbsd* | \
+ *-*-dragonfly* | \
*-*-k*bsd*-gnu | *-*-mirbsd* )
if test "x$SUNCXX" = "xyes"; then
SONAME_FLAG="-h "

View File

@ -1,93 +1,40 @@
bin/mmex
man/man1/mmex.1.gz
share/applications/mmex.desktop
share/doc/mmex/contrib.txt
share/doc/mmex/help/budget.html
share/doc/mmex/help/budget_editor.png
share/doc/mmex/help/budget_entry_details.png
share/doc/mmex/help/budget_grid.png
share/doc/mmex/help/custom_sql_reports.html
share/doc/mmex/help/french/account.jpg
share/doc/mmex/help/french/add_acc_wizard1.jpg
share/doc/mmex/help/french/add_acc_wizard2.jpg
share/doc/mmex/help/french/add_acc_wizard3.jpg
share/doc/mmex/help/french/index.html
share/doc/mmex/help/french/investment.html
share/doc/mmex/help/french/main_screen.jpg
share/doc/mmex/help/french/mmex_concept.png
share/doc/mmex/help/german/read.me
share/doc/mmex/help/index.html
share/doc/mmex/help/investment.html
share/doc/mmex/help/italian/custom_sql_reports.html
share/doc/mmex/help/italian/index.html
share/doc/mmex/help/italian/investment.html
share/doc/mmex/help/italian/mmex_concept.png
share/doc/mmex/help/italian/stock_dialog.jpg
share/doc/mmex/help/italian/stock_options.jpg
share/doc/mmex/help/italian/stock_view.jpg
share/doc/mmex/help/mmex_concept.png
share/doc/mmex/help/mmex_db_structure.png
share/doc/mmex/help/polish/budget.html
share/doc/mmex/help/polish/budget_editor.png
share/doc/mmex/help/polish/budget_entry_details.png
share/doc/mmex/help/polish/budget_grid.png
share/doc/mmex/help/polish/custom_sql_reports.html
share/doc/mmex/help/polish/index.html
share/doc/mmex/help/polish/investment.html
share/doc/mmex/help/polish/mmex_concept.png
share/doc/mmex/help/polish/mmex_structure.jpg
share/doc/mmex/help/polish/stock_dialog.jpg
share/doc/mmex/help/polish/stock_options.jpg
share/doc/mmex/help/polish/stock_view.jpg
share/doc/mmex/help/russian/custom_sql_reports.html
share/doc/mmex/help/russian/index.html
share/doc/mmex/help/russian/investment.html
share/doc/mmex/help/russian/mmex_concept.png
share/doc/mmex/help/russian/stock_dialog.png
share/doc/mmex/help/spanish/budget.html
share/doc/mmex/help/spanish/custom_sql_reports.html
share/doc/mmex/help/spanish/index.html
share/doc/mmex/help/spanish/investment.html
share/doc/mmex/help/stock_dialog.png
share/doc/mmex/help/stock_options.png
share/doc/mmex/help/stock_view.png
share/doc/mmex/license.txt
share/doc/mmex/version.txt
share/icons/hicolor/scalable/apps/mmex.svg
share/mmex/po/arabic.mo
share/mmex/po/bulgarian.mo
share/mmex/po/chinese_chs.mo
share/mmex/po/chinese_zh.mo
share/mmex/po/croatian.mo
share/mmex/po/czech.mo
share/mmex/po/dutch.mo
share/mmex/po/dutch_be.mo
share/mmex/po/english-uk.mo
share/mmex/po/english.mo
share/mmex/po/french.mo
share/mmex/po/german.mo
share/mmex/po/greek.mo
share/mmex/po/hebrew.mo
share/mmex/po/hungarian.mo
share/mmex/po/indonesian.mo
share/mmex/po/italian.mo
share/mmex/po/latvian.mo
share/mmex/po/norwegian.mo
share/mmex/po/polish.mo
share/mmex/po/portuguese.mo
share/mmex/po/portuguese_portugal.mo
share/mmex/po/romanian.mo
share/mmex/po/russian.mo
share/mmex/po/serbian.mo
share/mmex/po/serbo-croatian.mo
share/mmex/po/slovak.mo
share/mmex/po/slovenian.mo
share/mmex/po/spanish.mo
share/mmex/po/swedish.mo
share/mmex/po/tamil.mo
share/mmex/po/turkish.mo
share/mmex/po/ukrainian.mo
share/mmex/po/vietnamese.mo
share/mmex/res/currency_seed.db3
share/mmex/res/kaching.wav
share/mmex/res/mmex.ico
%%DATADIR%%/po/en/arabic.mo
%%DATADIR%%/po/en/bulgarian.mo
%%DATADIR%%/po/en/chinese_chs.mo
%%DATADIR%%/po/en/chinese_zh.mo
%%DATADIR%%/po/en/croatian.mo
%%DATADIR%%/po/en/czech.mo
%%DATADIR%%/po/en/dutch.mo
%%DATADIR%%/po/en/dutch_be.mo
%%DATADIR%%/po/en/english-uk.mo
%%DATADIR%%/po/en/english.mo
%%DATADIR%%/po/en/french.mo
%%DATADIR%%/po/en/german.mo
%%DATADIR%%/po/en/greek.mo
%%DATADIR%%/po/en/hebrew.mo
%%DATADIR%%/po/en/hungarian.mo
%%DATADIR%%/po/en/indonesian.mo
%%DATADIR%%/po/en/italian.mo
%%DATADIR%%/po/en/latvian.mo
%%DATADIR%%/po/en/norwegian.mo
%%DATADIR%%/po/en/polish.mo
%%DATADIR%%/po/en/portuguese.mo
%%DATADIR%%/po/en/portuguese_portugal.mo
%%DATADIR%%/po/en/romanian.mo
%%DATADIR%%/po/en/russian.mo
%%DATADIR%%/po/en/serbian.mo
%%DATADIR%%/po/en/serbo-croatian.mo
%%DATADIR%%/po/en/slovak.mo
%%DATADIR%%/po/en/slovenian.mo
%%DATADIR%%/po/en/spanish.mo
%%DATADIR%%/po/en/swedish.mo
%%DATADIR%%/po/en/tamil.mo
%%DATADIR%%/po/en/turkish.mo
%%DATADIR%%/po/en/ukrainian.mo
%%DATADIR%%/po/en/vietnamese.mo
%%DATADIR%%/res/kaching.wav
%%DATADIR%%/res/mmex.ico