Fix build on powerpc and arm

PR:		241588
Submitted by:	pkubaj
This commit is contained in:
Alex Dupre 2019-10-30 14:58:41 +00:00
parent fe651f81a6
commit 62de9fdf70
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=516062
2 changed files with 13 additions and 10 deletions

View File

@ -11,7 +11,7 @@ COMMENT= Libraries and utilities to access smart cards
LICENSE= LGPL21
USES= autoreconf compiler gmake libtool pkgconfig ssl
USES= autoreconf compiler:c11 gmake libtool pkgconfig ssl
OPTIONS_SINGLE= BACKEND
OPTIONS_SINGLE_BACKEND=PCSC OPENCT CTAPI
@ -70,12 +70,4 @@ CONFIGURE_ENV+= XSLTPROC="${FALSE}"
CONFIGURE_ARGS+=--without-xsl-stylesheetsdir
.endif
.include <bsd.port.pre.mk>
.if ${CHOSEN_COMPILER_TYPE} == gcc
post-patch:
${REINPLACE_CMD} -e '/-Wno-unused-but-set-variable/d' \
${WRKSRC}/src/tools/Makefile.am
.endif
.include <bsd.port.post.mk>
.include <bsd.port.mk>

View File

@ -0,0 +1,11 @@
--- src/tests/p11test/p11test.c.orig 2019-10-30 14:56:38 UTC
+++ src/tests/p11test/p11test.c
@@ -49,7 +49,7 @@ void display_usage() {
}
int main(int argc, char** argv) {
- char command;
+ signed char command;
const struct CMUnitTest readonly_tests_without_initialization[] = {
/* Test card events on slot */
cmocka_unit_test_setup_teardown(wait_test,