- Update to build16

This commit is contained in:
Dmitry Marakasov 2011-05-25 04:56:48 +00:00
parent a6d9ccdd58
commit 62cd6c45db
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=274606
9 changed files with 76 additions and 76 deletions

View File

@ -6,50 +6,45 @@
#
PORTNAME= widelands
DISTVERSION= build13
PORTREVISION= 8
DISTVERSION= build16
CATEGORIES= games
MASTER_SITES= SF/${PORTNAME}/Old%20releases%20%21%21%21/build-13/
DISTNAME= ${PORTNAME:C/^w/W/}-${DISTVERSION:C/^b/B/}-src
MASTER_SITES= http://launchpadlibrarian.net/69520494/
DISTNAME= ${PORTNAME}-${DISTVERSION}-src
MAINTAINER= amdmi3@FreeBSD.org
COMMENT= Realtime strategy game inspired by Settlers II
LIB_DEPENDS= png.6:${PORTSDIR}/graphics/png \
boost_thread.4:${PORTSDIR}/devel/boost-libs
LIB_DEPENDS= ggzcore.9:${PORTSDIR}/games/ggz-client-libs \
png.6:${PORTSDIR}/graphics/png \
GLEW.1:${PORTSDIR}/graphics/glew
BUILD_DEPENDS= ${LOCALBASE}/include/boost/shared_ptr.hpp:${PORTSDIR}/devel/boost-libs
USE_BZIP2= yes
USE_GETTEXT= yes
USE_PYTHON_BUILD=2.5+
USE_CMAKE= yes
CMAKE_OUTSOURCE=yes
CMAKE_ARGS= -DWL_INSTALL_PREFIX="${PREFIX}" \
-DWL_INSTALL_DATADIR="share/widelands" \
-DWL_INSTALL_BINDIR="bin" \
-DWL_VERSION="${DISTVERSION}"
USE_LUA= 5.1+
USE_SDL= sdl mixer image net ttf gfx
USE_GCC= 4.2+
USE_PYTHON_BUILD=2.4+
MAKE_JOBS_SAFE= yes
PLIST_FILES= bin/widelands
WRKSRC= ${WRKDIR}/widelands-${DISTVERSION:C/build/b/}
USE_SCONS= yes
SCONS_ARGS= install_prefix=${PREFIX} bindir=bin datadir=share/widelands \
localedir=share/widelands/locale build=release \
sdlconfig=${SDL_CONFIG}
MAKE_JOBS_SAFE= yes
DESKTOP_ENTRIES="Widelands" \
"Realtime strategy game inspired by Settlers II" \
"${DATADIR}/pics/wl-ico-32.png" \
"${DATADIR}/pics/wl-ico-64.png" \
"widelands" \
"Game;StrategyGame;" \
false
post-patch:
@${REINPLACE_CMD} -e '/prefer_localdata/ s|True|False|' \
${WRKSRC}/worlds/SConscript
@${REINPLACE_CMD} -e '/ifndef/ s|__APPLE__|__FreeBSD__|' \
${WRKSRC}/src/backtrace.cc
@${REINPLACE_CMD} -e 's|/usr/bin/python|${PYTHON_CMD}|' \
${WRKSRC}/utils/buildlocale.py
@${REINPLACE_CMD} -e 's|revstring=.*|return "${DISTVERSION}-FreeBSD"|' \
${WRKSRC}/build/scons-tools/detect_revision.py
@${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|' \
${WRKSRC}/cmake/Modules/*.cmake
post-install:
@${FIND} ${DATADIR} -type f | \

View File

@ -1,3 +1,2 @@
MD5 (Widelands-Build13-src.tar.bz2) = 5e39f80b668d303abf693c48afa0c4bc
SHA256 (Widelands-Build13-src.tar.bz2) = acbb4f6405e7429a8510eae5414a51cff198c1d4bef374303e3b4a47aae930b3
SIZE (Widelands-Build13-src.tar.bz2) = 59030617
SHA256 (widelands-build16-src.tar.bz2) = d8db3c15c30314cb220c6d79d93d3d31e7bce2722c93d2c385d643c3c669625d
SIZE (widelands-build16-src.tar.bz2) = 137808494

View File

@ -0,0 +1,11 @@
--- CMakeLists.txt.orig 2011-04-15 22:40:26.000000000 +0400
+++ CMakeLists.txt 2011-05-25 01:12:54.000000000 +0400
@@ -204,7 +204,7 @@
set (CMAKE_CXX_FLAGS_DEBUG "-g -DDEBUG -DNOPARACHUTE${WL_COMPILERFLAG_OLDSTYLECAST}${WL_COMPILERFLAG_GENERICWARNINGS}${WL_COMPILERFLAG_EXTRAWARNINGS}${WL_COMPILERFLAG_STRICT}" CACHE STRING "Set by widelands CMakeLists.txt" FORCE)
# CMAKE defines "-O3 -DNDEBUG", but we better say -O2 (see gcc manual)
-set (CMAKE_CXX_FLAGS_RELEASE "-O2 -DNDEBUG" CACHE STRING "Set by widelands CMakeLists.txt" FORCE)
+set (CMAKE_CXX_FLAGS_RELEASE "-DNDEBUG" CACHE STRING "Set by widelands CMakeLists.txt" FORCE)
#If building with MSVC, then check for 3rdparty libs
if (DEFINED MSVC)

View File

@ -1,19 +0,0 @@
--- SConstruct.orig 2008-10-06 21:43:03.000000000 +0400
+++ SConstruct 2009-06-05 20:38:30.000000000 +0400
@@ -101,7 +101,7 @@
opts=cli_options()
-env=Environment(options=opts)
+env=Environment(options=opts, ENV=os.environ, **dict((k, v.split()) for k, v in ARGUMENTS.iteritems()))
env.Tool("ctags", toolpath=['build/scons-tools'])
env.Tool("PNGShrink", toolpath=['build/scons-tools'])
env.Tool("astyle", toolpath=['build/scons-tools'])
@@ -195,7 +195,6 @@
install=env.Install('installtarget', 'build-widelands.sh') # the second argument is a (neccessary) dummy
Alias('install', install)
AlwaysBuild(install)
-env.AddPreAction(install, Action(buildlocale))
uninstall=env.Uninstall('uninstalltarget', 'build-widelands.sh') # the second argument is a (neccessary) dummy
Alias('uninstall', uninstall)

View File

@ -1,29 +0,0 @@
--- build/scons-tools/scons_configure.py.orig 2008-10-05 18:59:26.000000000 +0400
+++ build/scons-tools/scons_configure.py 2008-11-10 01:24:38.000000000 +0300
@@ -439,16 +439,16 @@
conf.CheckCompilerFlag('-fbounds-check', env)
conf.CheckCompilerFlag('-pipe', env)
- if env.optimize:
- # !!!! -fomit-frame-pointer breaks execeptions !!!!
- conf.CheckCompilerFlag('-fexpensive-optimizations', env)
- conf.CheckCompilerFlag('-finline-functions', env)
- conf.CheckCompilerFlag('-ffast-math', env)
- conf.CheckCompilerFlag('-funroll-loops', env)
- conf.CheckCompilerFlag('-O3', env)
- else:
- conf.CheckCompilerFlag('-O0', env)
- conf.CheckCompilerFlag('-funit-at-a-time', env)
+# if env.optimize:
+# # !!!! -fomit-frame-pointer breaks execeptions !!!!
+# conf.CheckCompilerFlag('-fexpensive-optimizations', env)
+# conf.CheckCompilerFlag('-finline-functions', env)
+# conf.CheckCompilerFlag('-ffast-math', env)
+# conf.CheckCompilerFlag('-funroll-loops', env)
+# conf.CheckCompilerFlag('-O3', env)
+# else:
+# conf.CheckCompilerFlag('-O0', env)
+# conf.CheckCompilerFlag('-funit-at-a-time', env)
if env.profile:
conf.CheckCompilerFlag('-pg', env)

View File

@ -0,0 +1,8 @@
--- doc/CMakeLists.txt.orig 2011-04-15 22:40:26.000000000 +0400
+++ doc/CMakeLists.txt 2011-05-25 01:42:25.000000000 +0400
@@ -1,5 +1,4 @@
IF (NOT WIN32)
- find_package(Doxygen)
if (DOXYGEN_FOUND)
include(Documentation)
file(MAKE_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR}/sourcecode)

View File

@ -0,0 +1,16 @@
--- src/io/filesystem/disk_filesystem.cc.orig 2011-04-15 22:40:26.000000000 +0400
+++ src/io/filesystem/disk_filesystem.cc 2011-05-25 00:53:00.000000000 +0400
@@ -436,10 +436,10 @@
int file = 0;
void * data = 0;
-#ifdef __APPLE__
- file = open(fullname.c_str(), O_RDONLY);
-#else
+#ifdef __linux__
file = open(fullname.c_str(), O_RDONLY|O_NOATIME);
+#else
+ file = open(fullname.c_str(), O_RDONLY);
#endif
length = lseek(file, 0, SEEK_END);
lseek(file, 0, SEEK_SET);

View File

@ -0,0 +1,19 @@
--- src/wlapplication.cc.orig 2011-04-15 22:40:26.000000000 +0400
+++ src/wlapplication.cc 2011-05-25 08:48:45.000000000 +0400
@@ -963,12 +963,12 @@
int result = -1;
//add default video mode
-#ifdef linux
- videomode.push_back("x11");
-#elif WIN32
+#if defined WIN32
videomode.push_back("windib");
-#elif __APPLE__
+#elif defined __APPLE__
videomode.push_back("Quartz");
+#else
+ videomode.push_back("x11");
#endif
//if a video mode is given on the command line, add that one first
const char * videodrv;

View File

@ -6,4 +6,4 @@ war against your opponents.
The game is playable and great fun already, but it is also still under heavy
development, so do not be surprised if it crashes on you.
WWW: http://www.widelands.org/
WWW: http://www.widelands.org/