MFH: r468181

security/py-obfsproxy-tor: Fix runtime dependency error

- Change runtime dependency entry point Twisted_Core back to Twisted
- Update checksum for CHEESESHOP
- Add test target

Reviewed by:	cs, koobs
Approved by:	cs (maintainer), koobs (ports)
Differential Revision:	https://reviews.freebsd.org/D13452

Approved by:	ports-secteam (riggs)
This commit is contained in:
Fukang Chen 2018-04-27 08:33:43 +00:00
parent 75ca5eabe5
commit 627bb8dfe8
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/branches/2018Q2/; revision=468406
3 changed files with 10 additions and 15 deletions

View File

@ -20,6 +20,7 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pyptlib>=0.0.5:security/py-pyptlib@${FLAVOR}
${PYTHON_PKGNAMEPREFIX}pycrypto>=2.1:security/py-pycrypto@${FLAVOR} \
${PYTHON_PKGNAMEPREFIX}twisted>=0:devel/py-twisted@${FLAVOR} \
${PYTHON_PKGNAMEPREFIX}yaml>=0:devel/py-yaml@${FLAVOR}
TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest>0:devel/py-pytest@${FLAVOR}
USES= python:2.7
USE_PYTHON= distutils autoplist
@ -28,4 +29,7 @@ NO_ARCH= yes
PYDISTUTILS_PKGNAME= obfsproxy
do-test:
@(cd ${TEST_WRKSRC} && ${SETENV} ${TEST_ENV} ${PYTHON_CMD} -m pytest)
.include <bsd.port.mk>

View File

@ -1,3 +1,3 @@
TIMESTAMP = 1519975368
SHA256 (obfsproxy-0.2.13.tar.gz) = c29582f2f5b0316cbc7184e0529a5b246dfeeabd4e6c4dcb05b800256d6c9dd6
SIZE (obfsproxy-0.2.13.tar.gz) = 95813
TIMESTAMP = 1512989600
SHA256 (obfsproxy-0.2.13.tar.gz) = 1e26c2faef1cfcf856ddf60e9647058a7c78fb0d47f05b58a0f847ed7cc41a66
SIZE (obfsproxy-0.2.13.tar.gz) = 93435

View File

@ -1,19 +1,10 @@
--- setup.py.orig 2014-12-31 15:34:31 UTC
--- setup.py.orig 2014-08-21 09:28:57 UTC
+++ setup.py
@@ -31,12 +31,14 @@ setup(
install_requires = [
@@ -32,7 +32,6 @@ setup(
'setuptools',
'PyCrypto',
- 'Twisted',
'Twisted',
- 'argparse',
+ 'Twisted_Core',
'pyptlib >= 0.0.6',
'pyyaml'
],
+ #if sys.version_info < (2, 7):
+ # install_requires.append('argparse')
+
extras_require = {
'SOCKS': ["txsocksx"]
}