Repair a linkage problem, whereis the ssh port was trying to
specify the location of system libs. Reviewed by: Mark Murray, David O'Brien
This commit is contained in:
parent
b78ea479a5
commit
62728f8f6f
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=13098
@ -1,186 +1,121 @@
|
||||
*** Makefile.in.orig Thu Jun 11 07:01:13 1998
|
||||
--- Makefile.in Thu Jun 11 20:48:59 1998
|
||||
***************
|
||||
*** 287,298 ****
|
||||
SHELL = /bin/sh
|
||||
|
||||
GMPDIR = gmp-2.0.2-ssh-2
|
||||
! GMPLIBS = -L$(GMPDIR) -lgmp
|
||||
! GMPDEP = $(GMPDIR)/gmp.h $(GMPDIR)/libgmp.a
|
||||
|
||||
ZLIBDIR = zlib-1.0.4
|
||||
! ZLIBDEP = $(ZLIBDIR)/libz.a
|
||||
! ZLIBLIBS = -L$(ZLIBDIR) -lz
|
||||
|
||||
RSAREFDIR = rsaref2
|
||||
RSAREFSRCDIR = $(RSAREFDIR)/source
|
||||
--- 287,303 ----
|
||||
SHELL = /bin/sh
|
||||
|
||||
GMPDIR = gmp-2.0.2-ssh-2
|
||||
! # We have the same libgmp in the system, so use it instead
|
||||
! GMPINCDIR = /usr/include
|
||||
! GMPLIBDIR = /usr/lib
|
||||
! GMPLIBS = -L$(GMPLIBDIR) -lgmp
|
||||
! GMPDEP = $(GMPINCDIR)/gmp.h $(GMPLIBDIR)/libgmp.a
|
||||
|
||||
ZLIBDIR = zlib-1.0.4
|
||||
! ZLIBINCDIR = /usr/include
|
||||
! ZLIBLIBDIR = /usr/lib
|
||||
! ZLIBDEP = $(ZLIBINCDIR)/libz.a
|
||||
! ZLIBLIBS = -L$(ZLIBLIBDIR) -lz
|
||||
|
||||
RSAREFDIR = rsaref2
|
||||
RSAREFSRCDIR = $(RSAREFDIR)/source
|
||||
***************
|
||||
*** 397,403 ****
|
||||
$(CC) -o rfc-pg rfc-pg.o
|
||||
|
||||
.c.o:
|
||||
! $(CC) -c -I. $(KERBEROS_INCS) -I$(srcdir)/$(GMPDIR) -I$(srcdir)/$(ZLIBDIR) $(DEFS) -DHOST_KEY_FILE=\"$(HOST_KEY_FILE)\" -DHOST_CONFIG_FILE=\"$(HOST_CONFIG_FILE)\" -DSERVER_CONFIG_FILE=\"$(SERVER_CONFIG_FILE)\" -DSSH_PROGRAM=\"$(SSH_PROGRAM)\" -DETCDIR=\"$(etcdir)\" -DPIDDIR=\"$(piddir)\" -DSSH_BINDIR=\"$(bindir)\" -DTIS_MAP_FILE=\"$(TIS_MAP_FILE)\" $(CFLAGS) $(X_CFLAGS) $<
|
||||
|
||||
sshd: $(SSHD_OBJS) $(GMPDEP) $(RSAREFDEP) $(ZLIBDEP)
|
||||
-rm -f sshd
|
||||
--- 402,408 ----
|
||||
$(CC) -o rfc-pg rfc-pg.o
|
||||
|
||||
.c.o:
|
||||
! $(CC) -c -I. $(KERBEROS_INCS) -I$(srcdir)/$(GMPINCDIR) -I$(srcdir)/$(ZLIBINCDIR) $(DEFS) -DHOST_KEY_FILE=\"$(HOST_KEY_FILE)\" -DHOST_CONFIG_FILE=\"$(HOST_CONFIG_FILE)\" -DSERVER_CONFIG_FILE=\"$(SERVER_CONFIG_FILE)\" -DSSH_PROGRAM=\"$(SSH_PROGRAM)\" -DETCDIR=\"$(etcdir)\" -DPIDDIR=\"$(piddir)\" -DSSH_BINDIR=\"$(bindir)\" -DTIS_MAP_FILE=\"$(TIS_MAP_FILE)\" $(CFLAGS) $(X_CFLAGS) $<
|
||||
|
||||
sshd: $(SSHD_OBJS) $(GMPDEP) $(RSAREFDEP) $(ZLIBDEP)
|
||||
-rm -f sshd
|
||||
***************
|
||||
*** 440,458 ****
|
||||
sed "s#&PERL&#$(PERL)#" <$(srcdir)/make-ssh-known-hosts.pl >make-ssh-known-hosts
|
||||
chmod +x make-ssh-known-hosts
|
||||
|
||||
! GMP_COPY_SOURCES = mpz_gcd.c mpz_powm.c mpz_pow_ui.c mpz_add.c mpz_sub.c \
|
||||
! mpz_mul.c mpz_cmp.c mpz_sqrtrem.c
|
||||
! $(GMPDIR)/libgmp.a:
|
||||
! cd $(GMPDIR); $(MAKE)
|
||||
!
|
||||
! $(ZLIBDEP):
|
||||
! -if test '!' -d $(ZLIBDIR); then \
|
||||
! mkdir $(ZLIBDIR); \
|
||||
! cp $(srcdir)/$(ZLIBDIR)/Makefile $(ZLIBDIR); \
|
||||
! fi
|
||||
! cd $(ZLIBDIR); $(MAKE) VPATH=$(srcdir)/$(ZLIBDIR):../$(srcdir)/$(ZLIBDIR) \
|
||||
! CC="$(CC)" CFLAGS="$(CFLAGS) -I. -I$(srcdir)/$(ZLIBDIR) \
|
||||
! -I../$(srcdir)/$(GMPDIR)" RANLIB="$(RANLIB)" libz.a
|
||||
|
||||
$(RSAREFSRCDIR)/librsaref.a:
|
||||
-if test '!' -d $(RSAREFDIR); then \
|
||||
--- 445,463 ----
|
||||
sed "s#&PERL&#$(PERL)#" <$(srcdir)/make-ssh-known-hosts.pl >make-ssh-known-hosts
|
||||
chmod +x make-ssh-known-hosts
|
||||
|
||||
! #GMP_COPY_SOURCES = mpz_gcd.c mpz_powm.c mpz_pow_ui.c mpz_add.c mpz_sub.c \
|
||||
! # mpz_mul.c mpz_cmp.c mpz_sqrtrem.c
|
||||
! #$(GMPDIR)/libgmp.a:
|
||||
! # cd $(GMPDIR); $(MAKE)
|
||||
! #
|
||||
! #$(ZLIBDEP):
|
||||
! # -if test '!' -d $(ZLIBDIR); then \
|
||||
! # mkdir $(ZLIBDIR); \
|
||||
! # cp $(srcdir)/$(ZLIBDIR)/Makefile $(ZLIBDIR); \
|
||||
! # fi
|
||||
! # cd $(ZLIBDIR); $(MAKE) VPATH=$(srcdir)/$(ZLIBDIR):../$(srcdir)/$(ZLIBDIR) \
|
||||
! # CC="$(CC)" CFLAGS="$(CFLAGS) -I. -I$(srcdir)/$(ZLIBDIR) \
|
||||
! # -I../$(srcdir)/$(GMPDIR)" RANLIB="$(RANLIB)" libz.a
|
||||
|
||||
$(RSAREFSRCDIR)/librsaref.a:
|
||||
-if test '!' -d $(RSAREFDIR); then \
|
||||
***************
|
||||
*** 509,515 ****
|
||||
# (otherwise it can only log in as the user it runs as, and must be
|
||||
# bound to a non-privileged port). Also, password authentication may
|
||||
# not be available if non-root and using shadow passwords.
|
||||
! install: $(PROGRAMS) make-dirs generate-host-key install-configs
|
||||
-rm -f $(install_prefix)$(bindir)/ssh1.old
|
||||
-mv $(install_prefix)$(bindir)/ssh1 $(install_prefix)$(bindir)/ssh1.old
|
||||
-chmod 755 $(install_prefix)$(bindir)/ssh1.old
|
||||
--- 514,520 ----
|
||||
# (otherwise it can only log in as the user it runs as, and must be
|
||||
# bound to a non-privileged port). Also, password authentication may
|
||||
# not be available if non-root and using shadow passwords.
|
||||
! install: $(PROGRAMS) make-dirs install-configs
|
||||
-rm -f $(install_prefix)$(bindir)/ssh1.old
|
||||
-mv $(install_prefix)$(bindir)/ssh1 $(install_prefix)$(bindir)/ssh1.old
|
||||
-chmod 755 $(install_prefix)$(bindir)/ssh1.old
|
||||
***************
|
||||
*** 665,679 ****
|
||||
|
||||
clean:
|
||||
-rm -f *.o gmon.out *core $(PROGRAMS) rfc-pg
|
||||
! cd $(GMPDIR); $(MAKE) clean
|
||||
# cd $(RSAREFSRCDIR); rm -f *.o *.a
|
||||
! cd $(ZLIBDIR); $(MAKE) clean
|
||||
|
||||
distclean: clean
|
||||
-rm -f Makefile config.status config.cache config.log config.h
|
||||
-rm -f ssh.1 sshd.8 make-ssh-known-hosts.1
|
||||
! cd $(GMPDIR); $(MAKE) distclean
|
||||
! cd $(ZLIBDIR); $(MAKE) distclean
|
||||
|
||||
dist: dist-commercial
|
||||
|
||||
--- 670,684 ----
|
||||
|
||||
clean:
|
||||
-rm -f *.o gmon.out *core $(PROGRAMS) rfc-pg
|
||||
! # cd $(GMPDIR); $(MAKE) clean
|
||||
# cd $(RSAREFSRCDIR); rm -f *.o *.a
|
||||
! # cd $(ZLIBDIR); $(MAKE) clean
|
||||
|
||||
distclean: clean
|
||||
-rm -f Makefile config.status config.cache config.log config.h
|
||||
-rm -f ssh.1 sshd.8 make-ssh-known-hosts.1
|
||||
! # cd $(GMPDIR); $(MAKE) distclean
|
||||
! # cd $(ZLIBDIR); $(MAKE) distclean
|
||||
|
||||
dist: dist-commercial
|
||||
|
||||
***************
|
||||
*** 702,713 ****
|
||||
-mkdir $(DISTNAME)
|
||||
cp $(DISTFILES) $(DISTNAME)
|
||||
for i in $(DISTSRCS); do cp $(srcdir)/$$i $(DISTNAME); done
|
||||
! (cd $(GMPDIR); make dist)
|
||||
! gzip -cd $(GMPDIR)/$(GMPDIR).tar.gz | (cd $(DISTNAME); tar pxf - )
|
||||
# tar cf - $(RSAREFDIR) | (cd $(DISTNAME); tar xf -)
|
||||
# cd $(DISTNAME)/$(RSAREFSRCDIR); rm -f *.o *.a
|
||||
! (cd $(srcdir); tar pcf - $(ZLIBDIR) )| (cd $(DISTNAME); tar pxf -)
|
||||
! cd $(DISTNAME)/$(ZLIBDIR); rm -f *.o *.a; rm -rf CVS
|
||||
|
||||
#ifdef F_SECURE_COMMERCIAL
|
||||
#
|
||||
--- 707,718 ----
|
||||
-mkdir $(DISTNAME)
|
||||
cp $(DISTFILES) $(DISTNAME)
|
||||
for i in $(DISTSRCS); do cp $(srcdir)/$$i $(DISTNAME); done
|
||||
! # (cd $(GMPDIR); make dist)
|
||||
! # gzip -cd $(GMPDIR)/$(GMPDIR).tar.gz | (cd $(DISTNAME); tar pxf - )
|
||||
# tar cf - $(RSAREFDIR) | (cd $(DISTNAME); tar xf -)
|
||||
# cd $(DISTNAME)/$(RSAREFSRCDIR); rm -f *.o *.a
|
||||
! # (cd $(srcdir); tar pcf - $(ZLIBDIR) )| (cd $(DISTNAME); tar pxf -)
|
||||
! # cd $(DISTNAME)/$(ZLIBDIR); rm -f *.o *.a; rm -rf CVS
|
||||
|
||||
#ifdef F_SECURE_COMMERCIAL
|
||||
#
|
||||
***************
|
||||
*** 735,741 ****
|
||||
(echo "s/\.$$old_version\"/.$$new_version\"/g"; echo w; echo q) | ed $(srcdir)/version.h >/dev/null
|
||||
|
||||
depend:
|
||||
! $(MAKEDEP) -I$(srcdir) -I. -I$(GMPDIR) -I$(ZLIBDIR) $(DEFS) $(SRCS)
|
||||
|
||||
tags:
|
||||
-rm -f TAGS
|
||||
--- 740,746 ----
|
||||
(echo "s/\.$$old_version\"/.$$new_version\"/g"; echo w; echo q) | ed $(srcdir)/version.h >/dev/null
|
||||
|
||||
depend:
|
||||
! $(MAKEDEP) -I$(srcdir) -I. $(DEFS) $(SRCS)
|
||||
|
||||
tags:
|
||||
-rm -f TAGS
|
||||
--- Makefile.in.orig Wed Jul 8 12:40:39 1998
|
||||
+++ Makefile.in Sun Sep 13 12:38:43 1998
|
||||
@@ -294,12 +294,17 @@
|
||||
SHELL = /bin/sh
|
||||
|
||||
GMPDIR = gmp-2.0.2-ssh-2
|
||||
-GMPLIBS = -L$(GMPDIR) -lgmp
|
||||
-GMPDEP = $(GMPDIR)/gmp.h $(GMPDIR)/libgmp.a
|
||||
+# We have the same libgmp in the system, so use it instead
|
||||
+GMPINCDIR = /usr/include
|
||||
+GMPLIBDIR = /usr/lib
|
||||
+GMPLIBS = -lgmp
|
||||
+GMPDEP = $(GMPINCDIR)/gmp.h $(GMPLIBDIR)/libgmp.a
|
||||
|
||||
ZLIBDIR = zlib-1.0.4
|
||||
-ZLIBDEP = $(ZLIBDIR)/libz.a
|
||||
-ZLIBLIBS = -L$(ZLIBDIR) -lz
|
||||
+ZLIBINCDIR = /usr/include
|
||||
+ZLIBLIBDIR = /usr/lib
|
||||
+ZLIBDEP = $(ZLIBINCDIR)/libz.a
|
||||
+ZLIBLIBS = -lz
|
||||
|
||||
RSAREFDIR = rsaref2
|
||||
RSAREFSRCDIR = $(RSAREFDIR)/source
|
||||
@@ -404,7 +409,7 @@
|
||||
$(CC) -o rfc-pg rfc-pg.o
|
||||
|
||||
.c.o:
|
||||
- $(CC) -c -I. $(KERBEROS_INCS) -I$(srcdir)/$(GMPDIR) -I$(srcdir)/$(ZLIBDIR) $(DEFS) -DHOST_KEY_FILE=\"$(HOST_KEY_FILE)\" -DHOST_CONFIG_FILE=\"$(HOST_CONFIG_FILE)\" -DSERVER_CONFIG_FILE=\"$(SERVER_CONFIG_FILE)\" -DSSH_PROGRAM=\"$(SSH_PROGRAM)\" -DETCDIR=\"$(etcdir)\" -DPIDDIR=\"$(piddir)\" -DSSH_BINDIR=\"$(bindir)\" -DTIS_MAP_FILE=\"$(TIS_MAP_FILE)\" $(CFLAGS) $(X_CFLAGS) $<
|
||||
+ $(CC) -c -I. $(KERBEROS_INCS) -I$(srcdir)/$(GMPINCDIR) -I$(srcdir)/$(ZLIBINCDIR) $(DEFS) -DHOST_KEY_FILE=\"$(HOST_KEY_FILE)\" -DHOST_CONFIG_FILE=\"$(HOST_CONFIG_FILE)\" -DSERVER_CONFIG_FILE=\"$(SERVER_CONFIG_FILE)\" -DSSH_PROGRAM=\"$(SSH_PROGRAM)\" -DETCDIR=\"$(etcdir)\" -DPIDDIR=\"$(piddir)\" -DSSH_BINDIR=\"$(bindir)\" -DTIS_MAP_FILE=\"$(TIS_MAP_FILE)\" $(CFLAGS) $(X_CFLAGS) $<
|
||||
|
||||
sshd: $(SSHD_OBJS) $(GMPDEP) $(RSAREFDEP) $(ZLIBDEP)
|
||||
-rm -f sshd
|
||||
@@ -447,19 +452,19 @@
|
||||
sed "s#&PERL&#$(PERL)#" <$(srcdir)/make-ssh-known-hosts.pl >make-ssh-known-hosts
|
||||
chmod +x make-ssh-known-hosts
|
||||
|
||||
-GMP_COPY_SOURCES = mpz_gcd.c mpz_powm.c mpz_pow_ui.c mpz_add.c mpz_sub.c \
|
||||
- mpz_mul.c mpz_cmp.c mpz_sqrtrem.c
|
||||
-$(GMPDIR)/libgmp.a:
|
||||
- cd $(GMPDIR); $(MAKE)
|
||||
-
|
||||
-$(ZLIBDEP):
|
||||
- -if test '!' -d $(ZLIBDIR); then \
|
||||
- mkdir $(ZLIBDIR); \
|
||||
- cp $(srcdir)/$(ZLIBDIR)/Makefile $(ZLIBDIR); \
|
||||
- fi
|
||||
- cd $(ZLIBDIR); $(MAKE) VPATH=$(srcdir)/$(ZLIBDIR):../$(srcdir)/$(ZLIBDIR) \
|
||||
- CC="$(CC)" CFLAGS="$(CFLAGS) -I. -I$(srcdir)/$(ZLIBDIR) \
|
||||
- -I../$(srcdir)/$(GMPDIR)" RANLIB="$(RANLIB)" libz.a
|
||||
+#GMP_COPY_SOURCES = mpz_gcd.c mpz_powm.c mpz_pow_ui.c mpz_add.c mpz_sub.c \
|
||||
+# mpz_mul.c mpz_cmp.c mpz_sqrtrem.c
|
||||
+#$(GMPDIR)/libgmp.a:
|
||||
+# cd $(GMPDIR); $(MAKE)
|
||||
+#
|
||||
+#$(ZLIBDEP):
|
||||
+# -if test '!' -d $(ZLIBDIR); then \
|
||||
+# mkdir $(ZLIBDIR); \
|
||||
+# cp $(srcdir)/$(ZLIBDIR)/Makefile $(ZLIBDIR); \
|
||||
+# fi
|
||||
+# cd $(ZLIBDIR); $(MAKE) VPATH=$(srcdir)/$(ZLIBDIR):../$(srcdir)/$(ZLIBDIR) \
|
||||
+# CC="$(CC)" CFLAGS="$(CFLAGS) -I. -I$(srcdir)/$(ZLIBDIR) \
|
||||
+# -I../$(srcdir)/$(GMPDIR)" RANLIB="$(RANLIB)" libz.a
|
||||
|
||||
$(RSAREFSRCDIR)/librsaref.a:
|
||||
-if test '!' -d $(RSAREFDIR); then \
|
||||
@@ -516,7 +521,7 @@
|
||||
# (otherwise it can only log in as the user it runs as, and must be
|
||||
# bound to a non-privileged port). Also, password authentication may
|
||||
# not be available if non-root and using shadow passwords.
|
||||
-install: $(PROGRAMS) make-dirs generate-host-key install-configs
|
||||
+install: $(PROGRAMS) make-dirs install-configs
|
||||
-rm -f $(install_prefix)$(bindir)/ssh1.old
|
||||
-chmod 755 $(install_prefix)$(bindir)/ssh1
|
||||
-chmod 755 $(install_prefix)$(bindir)/ssh
|
||||
@@ -672,15 +677,15 @@
|
||||
|
||||
clean:
|
||||
-rm -f *.o gmon.out *core $(PROGRAMS) rfc-pg
|
||||
- cd $(GMPDIR); $(MAKE) clean
|
||||
+# cd $(GMPDIR); $(MAKE) clean
|
||||
# cd $(RSAREFSRCDIR); rm -f *.o *.a
|
||||
- cd $(ZLIBDIR); $(MAKE) clean
|
||||
+# cd $(ZLIBDIR); $(MAKE) clean
|
||||
|
||||
distclean: clean
|
||||
-rm -f Makefile config.status config.cache config.log config.h
|
||||
-rm -f ssh.1 sshd.8 make-ssh-known-hosts.1
|
||||
- cd $(GMPDIR); $(MAKE) distclean
|
||||
- cd $(ZLIBDIR); $(MAKE) distclean
|
||||
+# cd $(GMPDIR); $(MAKE) distclean
|
||||
+# cd $(ZLIBDIR); $(MAKE) distclean
|
||||
|
||||
dist: dist-free
|
||||
|
||||
@@ -709,12 +714,12 @@
|
||||
-mkdir $(DISTNAME)
|
||||
cp $(DISTFILES) $(DISTNAME)
|
||||
for i in $(DISTSRCS); do cp $(srcdir)/$$i $(DISTNAME); done
|
||||
- (cd $(GMPDIR); make dist)
|
||||
- gzip -cd $(GMPDIR)/$(GMPDIR).tar.gz | (cd $(DISTNAME); tar pxf - )
|
||||
+# (cd $(GMPDIR); make dist)
|
||||
+# gzip -cd $(GMPDIR)/$(GMPDIR).tar.gz | (cd $(DISTNAME); tar pxf - )
|
||||
# tar cf - $(RSAREFDIR) | (cd $(DISTNAME); tar xf -)
|
||||
# cd $(DISTNAME)/$(RSAREFSRCDIR); rm -f *.o *.a
|
||||
- (cd $(srcdir); tar pcf - $(ZLIBDIR) )| (cd $(DISTNAME); tar pxf -)
|
||||
- cd $(DISTNAME)/$(ZLIBDIR); rm -f *.o *.a; rm -rf CVS
|
||||
+# (cd $(srcdir); tar pcf - $(ZLIBDIR) )| (cd $(DISTNAME); tar pxf -)
|
||||
+# cd $(DISTNAME)/$(ZLIBDIR); rm -f *.o *.a; rm -rf CVS
|
||||
|
||||
#ifdef F_SECURE_COMMERCIAL
|
||||
#
|
||||
@@ -742,7 +747,7 @@
|
||||
(echo "s/\.$$old_version\"/.$$new_version\"/g"; echo w; echo q) | ed $(srcdir)/version.h >/dev/null
|
||||
|
||||
depend:
|
||||
- $(MAKEDEP) -I$(srcdir) -I. -I$(GMPDIR) -I$(ZLIBDIR) $(DEFS) $(SRCS)
|
||||
+ $(MAKEDEP) -I$(srcdir) -I. $(DEFS) $(SRCS)
|
||||
|
||||
tags:
|
||||
-rm -f TAGS
|
||||
|
@ -1,186 +1,121 @@
|
||||
*** Makefile.in.orig Thu Jun 11 07:01:13 1998
|
||||
--- Makefile.in Thu Jun 11 20:48:59 1998
|
||||
***************
|
||||
*** 287,298 ****
|
||||
SHELL = /bin/sh
|
||||
|
||||
GMPDIR = gmp-2.0.2-ssh-2
|
||||
! GMPLIBS = -L$(GMPDIR) -lgmp
|
||||
! GMPDEP = $(GMPDIR)/gmp.h $(GMPDIR)/libgmp.a
|
||||
|
||||
ZLIBDIR = zlib-1.0.4
|
||||
! ZLIBDEP = $(ZLIBDIR)/libz.a
|
||||
! ZLIBLIBS = -L$(ZLIBDIR) -lz
|
||||
|
||||
RSAREFDIR = rsaref2
|
||||
RSAREFSRCDIR = $(RSAREFDIR)/source
|
||||
--- 287,303 ----
|
||||
SHELL = /bin/sh
|
||||
|
||||
GMPDIR = gmp-2.0.2-ssh-2
|
||||
! # We have the same libgmp in the system, so use it instead
|
||||
! GMPINCDIR = /usr/include
|
||||
! GMPLIBDIR = /usr/lib
|
||||
! GMPLIBS = -L$(GMPLIBDIR) -lgmp
|
||||
! GMPDEP = $(GMPINCDIR)/gmp.h $(GMPLIBDIR)/libgmp.a
|
||||
|
||||
ZLIBDIR = zlib-1.0.4
|
||||
! ZLIBINCDIR = /usr/include
|
||||
! ZLIBLIBDIR = /usr/lib
|
||||
! ZLIBDEP = $(ZLIBINCDIR)/libz.a
|
||||
! ZLIBLIBS = -L$(ZLIBLIBDIR) -lz
|
||||
|
||||
RSAREFDIR = rsaref2
|
||||
RSAREFSRCDIR = $(RSAREFDIR)/source
|
||||
***************
|
||||
*** 397,403 ****
|
||||
$(CC) -o rfc-pg rfc-pg.o
|
||||
|
||||
.c.o:
|
||||
! $(CC) -c -I. $(KERBEROS_INCS) -I$(srcdir)/$(GMPDIR) -I$(srcdir)/$(ZLIBDIR) $(DEFS) -DHOST_KEY_FILE=\"$(HOST_KEY_FILE)\" -DHOST_CONFIG_FILE=\"$(HOST_CONFIG_FILE)\" -DSERVER_CONFIG_FILE=\"$(SERVER_CONFIG_FILE)\" -DSSH_PROGRAM=\"$(SSH_PROGRAM)\" -DETCDIR=\"$(etcdir)\" -DPIDDIR=\"$(piddir)\" -DSSH_BINDIR=\"$(bindir)\" -DTIS_MAP_FILE=\"$(TIS_MAP_FILE)\" $(CFLAGS) $(X_CFLAGS) $<
|
||||
|
||||
sshd: $(SSHD_OBJS) $(GMPDEP) $(RSAREFDEP) $(ZLIBDEP)
|
||||
-rm -f sshd
|
||||
--- 402,408 ----
|
||||
$(CC) -o rfc-pg rfc-pg.o
|
||||
|
||||
.c.o:
|
||||
! $(CC) -c -I. $(KERBEROS_INCS) -I$(srcdir)/$(GMPINCDIR) -I$(srcdir)/$(ZLIBINCDIR) $(DEFS) -DHOST_KEY_FILE=\"$(HOST_KEY_FILE)\" -DHOST_CONFIG_FILE=\"$(HOST_CONFIG_FILE)\" -DSERVER_CONFIG_FILE=\"$(SERVER_CONFIG_FILE)\" -DSSH_PROGRAM=\"$(SSH_PROGRAM)\" -DETCDIR=\"$(etcdir)\" -DPIDDIR=\"$(piddir)\" -DSSH_BINDIR=\"$(bindir)\" -DTIS_MAP_FILE=\"$(TIS_MAP_FILE)\" $(CFLAGS) $(X_CFLAGS) $<
|
||||
|
||||
sshd: $(SSHD_OBJS) $(GMPDEP) $(RSAREFDEP) $(ZLIBDEP)
|
||||
-rm -f sshd
|
||||
***************
|
||||
*** 440,458 ****
|
||||
sed "s#&PERL&#$(PERL)#" <$(srcdir)/make-ssh-known-hosts.pl >make-ssh-known-hosts
|
||||
chmod +x make-ssh-known-hosts
|
||||
|
||||
! GMP_COPY_SOURCES = mpz_gcd.c mpz_powm.c mpz_pow_ui.c mpz_add.c mpz_sub.c \
|
||||
! mpz_mul.c mpz_cmp.c mpz_sqrtrem.c
|
||||
! $(GMPDIR)/libgmp.a:
|
||||
! cd $(GMPDIR); $(MAKE)
|
||||
!
|
||||
! $(ZLIBDEP):
|
||||
! -if test '!' -d $(ZLIBDIR); then \
|
||||
! mkdir $(ZLIBDIR); \
|
||||
! cp $(srcdir)/$(ZLIBDIR)/Makefile $(ZLIBDIR); \
|
||||
! fi
|
||||
! cd $(ZLIBDIR); $(MAKE) VPATH=$(srcdir)/$(ZLIBDIR):../$(srcdir)/$(ZLIBDIR) \
|
||||
! CC="$(CC)" CFLAGS="$(CFLAGS) -I. -I$(srcdir)/$(ZLIBDIR) \
|
||||
! -I../$(srcdir)/$(GMPDIR)" RANLIB="$(RANLIB)" libz.a
|
||||
|
||||
$(RSAREFSRCDIR)/librsaref.a:
|
||||
-if test '!' -d $(RSAREFDIR); then \
|
||||
--- 445,463 ----
|
||||
sed "s#&PERL&#$(PERL)#" <$(srcdir)/make-ssh-known-hosts.pl >make-ssh-known-hosts
|
||||
chmod +x make-ssh-known-hosts
|
||||
|
||||
! #GMP_COPY_SOURCES = mpz_gcd.c mpz_powm.c mpz_pow_ui.c mpz_add.c mpz_sub.c \
|
||||
! # mpz_mul.c mpz_cmp.c mpz_sqrtrem.c
|
||||
! #$(GMPDIR)/libgmp.a:
|
||||
! # cd $(GMPDIR); $(MAKE)
|
||||
! #
|
||||
! #$(ZLIBDEP):
|
||||
! # -if test '!' -d $(ZLIBDIR); then \
|
||||
! # mkdir $(ZLIBDIR); \
|
||||
! # cp $(srcdir)/$(ZLIBDIR)/Makefile $(ZLIBDIR); \
|
||||
! # fi
|
||||
! # cd $(ZLIBDIR); $(MAKE) VPATH=$(srcdir)/$(ZLIBDIR):../$(srcdir)/$(ZLIBDIR) \
|
||||
! # CC="$(CC)" CFLAGS="$(CFLAGS) -I. -I$(srcdir)/$(ZLIBDIR) \
|
||||
! # -I../$(srcdir)/$(GMPDIR)" RANLIB="$(RANLIB)" libz.a
|
||||
|
||||
$(RSAREFSRCDIR)/librsaref.a:
|
||||
-if test '!' -d $(RSAREFDIR); then \
|
||||
***************
|
||||
*** 509,515 ****
|
||||
# (otherwise it can only log in as the user it runs as, and must be
|
||||
# bound to a non-privileged port). Also, password authentication may
|
||||
# not be available if non-root and using shadow passwords.
|
||||
! install: $(PROGRAMS) make-dirs generate-host-key install-configs
|
||||
-rm -f $(install_prefix)$(bindir)/ssh1.old
|
||||
-mv $(install_prefix)$(bindir)/ssh1 $(install_prefix)$(bindir)/ssh1.old
|
||||
-chmod 755 $(install_prefix)$(bindir)/ssh1.old
|
||||
--- 514,520 ----
|
||||
# (otherwise it can only log in as the user it runs as, and must be
|
||||
# bound to a non-privileged port). Also, password authentication may
|
||||
# not be available if non-root and using shadow passwords.
|
||||
! install: $(PROGRAMS) make-dirs install-configs
|
||||
-rm -f $(install_prefix)$(bindir)/ssh1.old
|
||||
-mv $(install_prefix)$(bindir)/ssh1 $(install_prefix)$(bindir)/ssh1.old
|
||||
-chmod 755 $(install_prefix)$(bindir)/ssh1.old
|
||||
***************
|
||||
*** 665,679 ****
|
||||
|
||||
clean:
|
||||
-rm -f *.o gmon.out *core $(PROGRAMS) rfc-pg
|
||||
! cd $(GMPDIR); $(MAKE) clean
|
||||
# cd $(RSAREFSRCDIR); rm -f *.o *.a
|
||||
! cd $(ZLIBDIR); $(MAKE) clean
|
||||
|
||||
distclean: clean
|
||||
-rm -f Makefile config.status config.cache config.log config.h
|
||||
-rm -f ssh.1 sshd.8 make-ssh-known-hosts.1
|
||||
! cd $(GMPDIR); $(MAKE) distclean
|
||||
! cd $(ZLIBDIR); $(MAKE) distclean
|
||||
|
||||
dist: dist-commercial
|
||||
|
||||
--- 670,684 ----
|
||||
|
||||
clean:
|
||||
-rm -f *.o gmon.out *core $(PROGRAMS) rfc-pg
|
||||
! # cd $(GMPDIR); $(MAKE) clean
|
||||
# cd $(RSAREFSRCDIR); rm -f *.o *.a
|
||||
! # cd $(ZLIBDIR); $(MAKE) clean
|
||||
|
||||
distclean: clean
|
||||
-rm -f Makefile config.status config.cache config.log config.h
|
||||
-rm -f ssh.1 sshd.8 make-ssh-known-hosts.1
|
||||
! # cd $(GMPDIR); $(MAKE) distclean
|
||||
! # cd $(ZLIBDIR); $(MAKE) distclean
|
||||
|
||||
dist: dist-commercial
|
||||
|
||||
***************
|
||||
*** 702,713 ****
|
||||
-mkdir $(DISTNAME)
|
||||
cp $(DISTFILES) $(DISTNAME)
|
||||
for i in $(DISTSRCS); do cp $(srcdir)/$$i $(DISTNAME); done
|
||||
! (cd $(GMPDIR); make dist)
|
||||
! gzip -cd $(GMPDIR)/$(GMPDIR).tar.gz | (cd $(DISTNAME); tar pxf - )
|
||||
# tar cf - $(RSAREFDIR) | (cd $(DISTNAME); tar xf -)
|
||||
# cd $(DISTNAME)/$(RSAREFSRCDIR); rm -f *.o *.a
|
||||
! (cd $(srcdir); tar pcf - $(ZLIBDIR) )| (cd $(DISTNAME); tar pxf -)
|
||||
! cd $(DISTNAME)/$(ZLIBDIR); rm -f *.o *.a; rm -rf CVS
|
||||
|
||||
#ifdef F_SECURE_COMMERCIAL
|
||||
#
|
||||
--- 707,718 ----
|
||||
-mkdir $(DISTNAME)
|
||||
cp $(DISTFILES) $(DISTNAME)
|
||||
for i in $(DISTSRCS); do cp $(srcdir)/$$i $(DISTNAME); done
|
||||
! # (cd $(GMPDIR); make dist)
|
||||
! # gzip -cd $(GMPDIR)/$(GMPDIR).tar.gz | (cd $(DISTNAME); tar pxf - )
|
||||
# tar cf - $(RSAREFDIR) | (cd $(DISTNAME); tar xf -)
|
||||
# cd $(DISTNAME)/$(RSAREFSRCDIR); rm -f *.o *.a
|
||||
! # (cd $(srcdir); tar pcf - $(ZLIBDIR) )| (cd $(DISTNAME); tar pxf -)
|
||||
! # cd $(DISTNAME)/$(ZLIBDIR); rm -f *.o *.a; rm -rf CVS
|
||||
|
||||
#ifdef F_SECURE_COMMERCIAL
|
||||
#
|
||||
***************
|
||||
*** 735,741 ****
|
||||
(echo "s/\.$$old_version\"/.$$new_version\"/g"; echo w; echo q) | ed $(srcdir)/version.h >/dev/null
|
||||
|
||||
depend:
|
||||
! $(MAKEDEP) -I$(srcdir) -I. -I$(GMPDIR) -I$(ZLIBDIR) $(DEFS) $(SRCS)
|
||||
|
||||
tags:
|
||||
-rm -f TAGS
|
||||
--- 740,746 ----
|
||||
(echo "s/\.$$old_version\"/.$$new_version\"/g"; echo w; echo q) | ed $(srcdir)/version.h >/dev/null
|
||||
|
||||
depend:
|
||||
! $(MAKEDEP) -I$(srcdir) -I. $(DEFS) $(SRCS)
|
||||
|
||||
tags:
|
||||
-rm -f TAGS
|
||||
--- Makefile.in.orig Wed Jul 8 12:40:39 1998
|
||||
+++ Makefile.in Sun Sep 13 12:38:43 1998
|
||||
@@ -294,12 +294,17 @@
|
||||
SHELL = /bin/sh
|
||||
|
||||
GMPDIR = gmp-2.0.2-ssh-2
|
||||
-GMPLIBS = -L$(GMPDIR) -lgmp
|
||||
-GMPDEP = $(GMPDIR)/gmp.h $(GMPDIR)/libgmp.a
|
||||
+# We have the same libgmp in the system, so use it instead
|
||||
+GMPINCDIR = /usr/include
|
||||
+GMPLIBDIR = /usr/lib
|
||||
+GMPLIBS = -lgmp
|
||||
+GMPDEP = $(GMPINCDIR)/gmp.h $(GMPLIBDIR)/libgmp.a
|
||||
|
||||
ZLIBDIR = zlib-1.0.4
|
||||
-ZLIBDEP = $(ZLIBDIR)/libz.a
|
||||
-ZLIBLIBS = -L$(ZLIBDIR) -lz
|
||||
+ZLIBINCDIR = /usr/include
|
||||
+ZLIBLIBDIR = /usr/lib
|
||||
+ZLIBDEP = $(ZLIBINCDIR)/libz.a
|
||||
+ZLIBLIBS = -lz
|
||||
|
||||
RSAREFDIR = rsaref2
|
||||
RSAREFSRCDIR = $(RSAREFDIR)/source
|
||||
@@ -404,7 +409,7 @@
|
||||
$(CC) -o rfc-pg rfc-pg.o
|
||||
|
||||
.c.o:
|
||||
- $(CC) -c -I. $(KERBEROS_INCS) -I$(srcdir)/$(GMPDIR) -I$(srcdir)/$(ZLIBDIR) $(DEFS) -DHOST_KEY_FILE=\"$(HOST_KEY_FILE)\" -DHOST_CONFIG_FILE=\"$(HOST_CONFIG_FILE)\" -DSERVER_CONFIG_FILE=\"$(SERVER_CONFIG_FILE)\" -DSSH_PROGRAM=\"$(SSH_PROGRAM)\" -DETCDIR=\"$(etcdir)\" -DPIDDIR=\"$(piddir)\" -DSSH_BINDIR=\"$(bindir)\" -DTIS_MAP_FILE=\"$(TIS_MAP_FILE)\" $(CFLAGS) $(X_CFLAGS) $<
|
||||
+ $(CC) -c -I. $(KERBEROS_INCS) -I$(srcdir)/$(GMPINCDIR) -I$(srcdir)/$(ZLIBINCDIR) $(DEFS) -DHOST_KEY_FILE=\"$(HOST_KEY_FILE)\" -DHOST_CONFIG_FILE=\"$(HOST_CONFIG_FILE)\" -DSERVER_CONFIG_FILE=\"$(SERVER_CONFIG_FILE)\" -DSSH_PROGRAM=\"$(SSH_PROGRAM)\" -DETCDIR=\"$(etcdir)\" -DPIDDIR=\"$(piddir)\" -DSSH_BINDIR=\"$(bindir)\" -DTIS_MAP_FILE=\"$(TIS_MAP_FILE)\" $(CFLAGS) $(X_CFLAGS) $<
|
||||
|
||||
sshd: $(SSHD_OBJS) $(GMPDEP) $(RSAREFDEP) $(ZLIBDEP)
|
||||
-rm -f sshd
|
||||
@@ -447,19 +452,19 @@
|
||||
sed "s#&PERL&#$(PERL)#" <$(srcdir)/make-ssh-known-hosts.pl >make-ssh-known-hosts
|
||||
chmod +x make-ssh-known-hosts
|
||||
|
||||
-GMP_COPY_SOURCES = mpz_gcd.c mpz_powm.c mpz_pow_ui.c mpz_add.c mpz_sub.c \
|
||||
- mpz_mul.c mpz_cmp.c mpz_sqrtrem.c
|
||||
-$(GMPDIR)/libgmp.a:
|
||||
- cd $(GMPDIR); $(MAKE)
|
||||
-
|
||||
-$(ZLIBDEP):
|
||||
- -if test '!' -d $(ZLIBDIR); then \
|
||||
- mkdir $(ZLIBDIR); \
|
||||
- cp $(srcdir)/$(ZLIBDIR)/Makefile $(ZLIBDIR); \
|
||||
- fi
|
||||
- cd $(ZLIBDIR); $(MAKE) VPATH=$(srcdir)/$(ZLIBDIR):../$(srcdir)/$(ZLIBDIR) \
|
||||
- CC="$(CC)" CFLAGS="$(CFLAGS) -I. -I$(srcdir)/$(ZLIBDIR) \
|
||||
- -I../$(srcdir)/$(GMPDIR)" RANLIB="$(RANLIB)" libz.a
|
||||
+#GMP_COPY_SOURCES = mpz_gcd.c mpz_powm.c mpz_pow_ui.c mpz_add.c mpz_sub.c \
|
||||
+# mpz_mul.c mpz_cmp.c mpz_sqrtrem.c
|
||||
+#$(GMPDIR)/libgmp.a:
|
||||
+# cd $(GMPDIR); $(MAKE)
|
||||
+#
|
||||
+#$(ZLIBDEP):
|
||||
+# -if test '!' -d $(ZLIBDIR); then \
|
||||
+# mkdir $(ZLIBDIR); \
|
||||
+# cp $(srcdir)/$(ZLIBDIR)/Makefile $(ZLIBDIR); \
|
||||
+# fi
|
||||
+# cd $(ZLIBDIR); $(MAKE) VPATH=$(srcdir)/$(ZLIBDIR):../$(srcdir)/$(ZLIBDIR) \
|
||||
+# CC="$(CC)" CFLAGS="$(CFLAGS) -I. -I$(srcdir)/$(ZLIBDIR) \
|
||||
+# -I../$(srcdir)/$(GMPDIR)" RANLIB="$(RANLIB)" libz.a
|
||||
|
||||
$(RSAREFSRCDIR)/librsaref.a:
|
||||
-if test '!' -d $(RSAREFDIR); then \
|
||||
@@ -516,7 +521,7 @@
|
||||
# (otherwise it can only log in as the user it runs as, and must be
|
||||
# bound to a non-privileged port). Also, password authentication may
|
||||
# not be available if non-root and using shadow passwords.
|
||||
-install: $(PROGRAMS) make-dirs generate-host-key install-configs
|
||||
+install: $(PROGRAMS) make-dirs install-configs
|
||||
-rm -f $(install_prefix)$(bindir)/ssh1.old
|
||||
-chmod 755 $(install_prefix)$(bindir)/ssh1
|
||||
-chmod 755 $(install_prefix)$(bindir)/ssh
|
||||
@@ -672,15 +677,15 @@
|
||||
|
||||
clean:
|
||||
-rm -f *.o gmon.out *core $(PROGRAMS) rfc-pg
|
||||
- cd $(GMPDIR); $(MAKE) clean
|
||||
+# cd $(GMPDIR); $(MAKE) clean
|
||||
# cd $(RSAREFSRCDIR); rm -f *.o *.a
|
||||
- cd $(ZLIBDIR); $(MAKE) clean
|
||||
+# cd $(ZLIBDIR); $(MAKE) clean
|
||||
|
||||
distclean: clean
|
||||
-rm -f Makefile config.status config.cache config.log config.h
|
||||
-rm -f ssh.1 sshd.8 make-ssh-known-hosts.1
|
||||
- cd $(GMPDIR); $(MAKE) distclean
|
||||
- cd $(ZLIBDIR); $(MAKE) distclean
|
||||
+# cd $(GMPDIR); $(MAKE) distclean
|
||||
+# cd $(ZLIBDIR); $(MAKE) distclean
|
||||
|
||||
dist: dist-free
|
||||
|
||||
@@ -709,12 +714,12 @@
|
||||
-mkdir $(DISTNAME)
|
||||
cp $(DISTFILES) $(DISTNAME)
|
||||
for i in $(DISTSRCS); do cp $(srcdir)/$$i $(DISTNAME); done
|
||||
- (cd $(GMPDIR); make dist)
|
||||
- gzip -cd $(GMPDIR)/$(GMPDIR).tar.gz | (cd $(DISTNAME); tar pxf - )
|
||||
+# (cd $(GMPDIR); make dist)
|
||||
+# gzip -cd $(GMPDIR)/$(GMPDIR).tar.gz | (cd $(DISTNAME); tar pxf - )
|
||||
# tar cf - $(RSAREFDIR) | (cd $(DISTNAME); tar xf -)
|
||||
# cd $(DISTNAME)/$(RSAREFSRCDIR); rm -f *.o *.a
|
||||
- (cd $(srcdir); tar pcf - $(ZLIBDIR) )| (cd $(DISTNAME); tar pxf -)
|
||||
- cd $(DISTNAME)/$(ZLIBDIR); rm -f *.o *.a; rm -rf CVS
|
||||
+# (cd $(srcdir); tar pcf - $(ZLIBDIR) )| (cd $(DISTNAME); tar pxf -)
|
||||
+# cd $(DISTNAME)/$(ZLIBDIR); rm -f *.o *.a; rm -rf CVS
|
||||
|
||||
#ifdef F_SECURE_COMMERCIAL
|
||||
#
|
||||
@@ -742,7 +747,7 @@
|
||||
(echo "s/\.$$old_version\"/.$$new_version\"/g"; echo w; echo q) | ed $(srcdir)/version.h >/dev/null
|
||||
|
||||
depend:
|
||||
- $(MAKEDEP) -I$(srcdir) -I. -I$(GMPDIR) -I$(ZLIBDIR) $(DEFS) $(SRCS)
|
||||
+ $(MAKEDEP) -I$(srcdir) -I. $(DEFS) $(SRCS)
|
||||
|
||||
tags:
|
||||
-rm -f TAGS
|
||||
|
Loading…
Reference in New Issue
Block a user