Add mod_auth_external 2.1.11, an Apache module that enables the use

of external mechanisms for user authentication.

PR:		27321
Submitted by:	Anders Nordby <anders@fix.no>
This commit is contained in:
Will Andrews 2001-05-20 03:16:09 +00:00
parent f16ad320ac
commit 6262db5109
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=42780
8 changed files with 187 additions and 0 deletions

View File

@ -115,6 +115,7 @@
SUBDIR += mod_access_identd
SUBDIR += mod_access_referer
SUBDIR += mod_auth_any
SUBDIR += mod_auth_external
SUBDIR += mod_auth_mysql
SUBDIR += mod_auth_pam
SUBDIR += mod_auth_pgsql

View File

@ -0,0 +1,39 @@
# New ports collection makefile for: mod_auth_external
# Date created: 14 May 2001
# Whom: Anders Nordby <anders@fix.no>
#
# $FreeBSD$
#
PORTNAME= mod_auth_external
PORTVERSION= 2.1.11
CATEGORIES= www
MASTER_SITES= http://www.wwnet.net/~janc/software/ \
ftp://ftp.nuug.no/pub/anders/distfiles/
MAINTAINER= anders@fix.no
BUILD_DEPENDS= ${APXS}:${PORTSDIR}/www/apache13
RUN_DEPENDS= ${APXS}:${PORTSDIR}/www/apache13
APXS?= ${LOCALBASE}/sbin/apxs
DOCDIR= ${PREFIX}/share/doc/${PORTNAME}
DOCS= AUTHENTICATORS CHANGES INSTALL README TODO
do-build:
@cd ${WRKSRC} && ${APXS} -c mod_auth_external.c
do-install:
${APXS} -i -A -n auth_external ${WRKSRC}/mod_auth_external.so
.if !defined(NOPORTDOCS)
${INSTALL} -d -o root -g wheel -m 0755 ${DOCDIR}/examples
cd ${WRKSRC} && ${TAR} -chf - pwauth radius sybase test \
| ${TAR} -xf - -C ${DOCDIR}/examples
.for f in ${DOCS}
${INSTALL_DATA} ${WRKSRC}/${f} ${DOCDIR}/
.endfor
.endif
${CAT} ${PKGMESSAGE}
.include <bsd.port.mk>

View File

@ -0,0 +1 @@
MD5 (mod_auth_external-2.1.11.tar.gz) = ac9ae5236f1597f66f96aefd6ad76e3a

View File

@ -0,0 +1,84 @@
--- mod_auth_external.c.orig Tue May 15 00:49:04 2001
+++ mod_auth_external.c Tue May 15 00:50:55 2001
@@ -239,7 +239,7 @@
* Structure for the module itself
*/
-module external_auth_module;
+module auth_external_module;
/*
* Data types for per-dir and server configuration
@@ -303,7 +303,7 @@
extauth_server_config_rec *sc_rec;
sc_rec= ap_get_module_config( cmd->server->module_config,
- &external_auth_module);
+ &auth_external_module);
ap_table_set( sc_rec->auth_extpath, keyword, path );
@@ -323,7 +323,7 @@
extauth_server_config_rec *sc_rec;
sc_rec= ap_get_module_config( cmd->server->module_config,
- &external_auth_module);
+ &auth_external_module);
ap_table_set( sc_rec->group_extpath, keyword, path );
@@ -343,7 +343,7 @@
extauth_server_config_rec *sc_rec;
sc_rec= ap_get_module_config( cmd->server->module_config,
- &external_auth_module);
+ &auth_external_module);
ap_table_set( sc_rec->auth_extmethod, keyword, method );
@@ -361,7 +361,7 @@
extauth_server_config_rec *sc_rec;
sc_rec= ap_get_module_config( cmd->server->module_config,
- &external_auth_module);
+ &auth_external_module);
ap_table_set( sc_rec->group_extmethod, keyword, method );
@@ -565,11 +565,11 @@
{
extauth_dir_config_rec *dir_config_rec=
(extauth_dir_config_rec *)ap_get_module_config(r->per_dir_config,
- &external_auth_module);
+ &auth_external_module);
extauth_server_config_rec *server_config_rec=
(extauth_server_config_rec *)ap_get_module_config(r->server->module_config,
- &external_auth_module);
+ &auth_external_module);
const char *sent_pw;
int res, code= 1;
@@ -679,11 +679,11 @@
{
extauth_dir_config_rec *dir_config_rec=
(extauth_dir_config_rec *)ap_get_module_config(r->per_dir_config,
- &external_auth_module);
+ &auth_external_module);
extauth_server_config_rec *server_config_rec=
(extauth_server_config_rec *)ap_get_module_config(r->server->module_config,
- &external_auth_module);
+ &auth_external_module);
conn_rec *c= r->connection;
@@ -787,7 +787,7 @@
return AUTH_REQUIRED;
}
-module external_auth_module= {
+module auth_external_module= {
STANDARD_MODULE_STUFF,
NULL, /* initializer */
create_extauth_dir_config, /* dir config creater */

View File

@ -0,0 +1 @@
Enables the use of external mechanisms for user authentication

View File

@ -0,0 +1,11 @@
Mod_Auth_External is an Apache module used for authentication. The Apache
HTTP Daemon can be configured to require users to supply logins and passwords
before accessing pages in some directories. Authentication is the process
of checking if the password given is correct for a user. Apache has standard
modules for authenticating out of several different kinds of databases.
Mod_Auth_External is a flexible tool for creating authentication systems
based on other databases.
WWW: http://www.wwnet.net/~janc/mod_auth_external.html
- Anders Nordby <anders@fix.no>

View File

@ -0,0 +1,16 @@
************************************************************
You've installed mod_auth_external, an Apache authentication
module enabling the use of external mechanisms for user
authentication.
Edit your apache.conf or httpd.conf to enable and setup this
module. Have a look at the files in
${PREFIX}/share/doc/mod_auth_external for information on how
to configure it, example authentication programs, etc.
Then do this to make it work effective:
# apachectl configtest (see if there are any config errors)
# apachectl restart
************************************************************

View File

@ -0,0 +1,34 @@
libexec/apache/mod_auth_external.so
@exec %D/sbin/apxs -e -A -n auth_external %D/%F
@unexec %D/sbin/apxs -e -A -n auth_external %D/%F
%%PORTDOCS%%share/doc/mod_auth_external/examples/pwauth/pwauth.c
%%PORTDOCS%%share/doc/mod_auth_external/examples/pwauth/config.h
%%PORTDOCS%%share/doc/mod_auth_external/examples/pwauth/README
%%PORTDOCS%%share/doc/mod_auth_external/examples/pwauth/INSTALL
%%PORTDOCS%%share/doc/mod_auth_external/examples/pwauth/Makefile
%%PORTDOCS%%share/doc/mod_auth_external/examples/pwauth/FORM_AUTH
%%PORTDOCS%%share/doc/mod_auth_external/examples/radius/CHANGES
%%PORTDOCS%%share/doc/mod_auth_external/examples/radius/md5-radius.c
%%PORTDOCS%%share/doc/mod_auth_external/examples/radius/md5-radius.h
%%PORTDOCS%%share/doc/mod_auth_external/examples/radius/mod-radfuncs.c
%%PORTDOCS%%share/doc/mod_auth_external/examples/radius/mod-radius.h
%%PORTDOCS%%share/doc/mod_auth_external/examples/radius/mod_auth_external_radius.c
%%PORTDOCS%%share/doc/mod_auth_external/examples/radius/README
%%PORTDOCS%%share/doc/mod_auth_external/examples/sybase/mod_auth_external_sybase.c
%%PORTDOCS%%share/doc/mod_auth_external/examples/sybase/README
%%PORTDOCS%%share/doc/mod_auth_external/examples/test/test.pipe
%%PORTDOCS%%share/doc/mod_auth_external/examples/test/test.env
%%PORTDOCS%%share/doc/mod_auth_external/examples/test/testgroup.env
%%PORTDOCS%%share/doc/mod_auth_external/examples/test/testgroup.pipe
%%PORTDOCS%%share/doc/mod_auth_external/examples/test/README
%%PORTDOCS%%share/doc/mod_auth_external/AUTHENTICATORS
%%PORTDOCS%%share/doc/mod_auth_external/CHANGES
%%PORTDOCS%%share/doc/mod_auth_external/INSTALL
%%PORTDOCS%%share/doc/mod_auth_external/README
%%PORTDOCS%%share/doc/mod_auth_external/TODO
%%PORTDOCS%%@dirrm share/doc/mod_auth_external/examples/pwauth
%%PORTDOCS%%@dirrm share/doc/mod_auth_external/examples/radius
%%PORTDOCS%%@dirrm share/doc/mod_auth_external/examples/sybase
%%PORTDOCS%%@dirrm share/doc/mod_auth_external/examples/test
%%PORTDOCS%%@dirrm share/doc/mod_auth_external/examples
%%PORTDOCS%%@dirrm share/doc/mod_auth_external