x11/havoc: Add new port
havoc is a minimal terminal emulator supporting wayland only.
This commit is contained in:
parent
5002fbdb8f
commit
62567fc57f
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=548731
@ -96,6 +96,7 @@
|
||||
SUBDIR += gtkterm2
|
||||
SUBDIR += guake
|
||||
SUBDIR += gxkb
|
||||
SUBDIR += havoc
|
||||
SUBDIR += hhpc
|
||||
SUBDIR += hs-xmobar
|
||||
SUBDIR += hsetroot
|
||||
|
48
x11/havoc/Makefile
Normal file
48
x11/havoc/Makefile
Normal file
@ -0,0 +1,48 @@
|
||||
# Created by: Emmanuel Vadot <manu@FreeBSD.org>
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= havoc
|
||||
PORTVERSION= 0.3.1
|
||||
CATEGORIES= x11
|
||||
|
||||
PATCH_SITES= https://github.com/ii8/havoc/commit/
|
||||
PATCH_DIST_STRIP= -p1
|
||||
|
||||
MAINTAINER= manu@FreeBSD.org
|
||||
COMMENT= Minimal terminal emulator for Wayland
|
||||
|
||||
LICENSE= MIT
|
||||
LICENSE_FILE= ${WRKSRC}/LICENSE
|
||||
|
||||
BUILD_DEPENDS= wayland-protocols>0:graphics/wayland-protocols \
|
||||
libxkbcommon>0:x11/libxkbcommon
|
||||
LIB_DEPENDS= libepoll-shim.so:devel/libepoll-shim \
|
||||
libwayland-client.so:graphics/wayland \
|
||||
libxkbcommon.so:x11/libxkbcommon
|
||||
RUN_DEPENDS= ${LOCALBASE}/share/fonts/dejavu/DejaVuSansMono.ttf:x11-fonts/dejavu
|
||||
|
||||
USES= gmake pkgconfig
|
||||
USE_GITHUB= yes
|
||||
GH_ACCOUNT= ii8
|
||||
GH_PROJECT= havoc
|
||||
|
||||
PATCHFILES+= be024469f0.patch # https://github.com/ii8/havoc/pull/32
|
||||
PATCHFILES+= 4fe53499c6.patch # https://github.com/ii8/havoc/pull/32
|
||||
PATCHFILES+= f7bcc3d158.patch # https://github.com/ii8/havoc/pull/32
|
||||
PATCHFILES+= ef6eff8681.patch # https://github.com/ii8/havoc/pull/32
|
||||
|
||||
PLIST_FILES= bin/havoc \
|
||||
share/examples/havoc/havoc.cfg
|
||||
|
||||
SUB_FILES= pkg-message
|
||||
|
||||
do-build:
|
||||
(cd ${WRKSRC} && ${MAKE_CMD} havoc)
|
||||
|
||||
do-install:
|
||||
(cd ${WRKSRC} && ${MAKE_CMD} PREFIX=${STAGEDIR}${PREFIX} install)
|
||||
${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
|
||||
${INSTALL_DATA} ${WRKSRC}/havoc.cfg ${STAGEDIR}${EXAMPLESDIR}/havoc.cfg
|
||||
${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/havoc
|
||||
|
||||
.include <bsd.port.mk>
|
11
x11/havoc/distinfo
Normal file
11
x11/havoc/distinfo
Normal file
@ -0,0 +1,11 @@
|
||||
TIMESTAMP = 1600174676
|
||||
SHA256 (ii8-havoc-0.3.1_GH0.tar.gz) = c4e18de62435a6338c8453d0b6e84b5f284dbd179f608ec74326b39e2cb36e87
|
||||
SIZE (ii8-havoc-0.3.1_GH0.tar.gz) = 93931
|
||||
SHA256 (be024469f0.patch) = 61a34f614d72bb3a7245c173054c17e78c0c2d6fa188788bab311676b72654e1
|
||||
SIZE (be024469f0.patch) = 761
|
||||
SHA256 (4fe53499c6.patch) = fbcf884409b9d7377ff1972ceeb5e05f8808ffe64615291f1818a67af40e4cc5
|
||||
SIZE (4fe53499c6.patch) = 1257
|
||||
SHA256 (f7bcc3d158.patch) = 83d2026b2be62aee5a5068dbe8d300da7f23f904391f62849b28bdf3edc1056a
|
||||
SIZE (f7bcc3d158.patch) = 1154
|
||||
SHA256 (ef6eff8681.patch) = f7efcbacfa3b611dad39163a56ac0e7703482c5cfe2887cb3255599aea08e1a0
|
||||
SIZE (ef6eff8681.patch) = 699
|
27
x11/havoc/files/patch-Makefile
Normal file
27
x11/havoc/files/patch-Makefile
Normal file
@ -0,0 +1,27 @@
|
||||
--- Makefile.orig 2020-09-15 12:40:25 UTC
|
||||
+++ Makefile
|
||||
@@ -8,6 +8,7 @@ VERSION="0.3.1"
|
||||
|
||||
CFLAGS ?= -Wall -Wextra -Wno-unused-parameter -Wno-parentheses
|
||||
CFLAGS += `pkg-config --cflags xkbcommon` \
|
||||
+ `pkg-config --cflags epoll-shim` \
|
||||
`pkg-config --cflags wayland-client` \
|
||||
`pkg-config --cflags wayland-cursor`
|
||||
override CFLAGS += -DVERSION=\"$(VERSION)\"
|
||||
@@ -15,6 +16,7 @@ override CFLAGS += -DVERSION=\"$(VERSION)\"
|
||||
VPATH=$(WAYLAND_PROTOCOLS_DIR)/stable/xdg-shell
|
||||
LIBS=-lrt -lm -lutil -lwayland-client -lwayland-cursor -lxkbcommon -Ltsm -lhtsm
|
||||
LIBS+=`pkg-config --libs xkbcommon` \
|
||||
+ `pkg-config --libs epoll-shim` \
|
||||
`pkg-config --libs wayland-client` \
|
||||
`pkg-config --libs wayland-cursor`
|
||||
|
||||
@@ -25,7 +27,7 @@ havoc: tsm $(OBJ)
|
||||
$(CC) $(LDFLAGS) -o $@ $(OBJ) $(LIBS)
|
||||
|
||||
install: havoc
|
||||
- install -D -t $(DESTDIR)$(BINDIR) havoc
|
||||
+ install havoc $(DESTDIR)$(BINDIR)
|
||||
|
||||
uninstall:
|
||||
rm -f $(DESTDIR)$(BINDIR)/havoc
|
19
x11/havoc/files/patch-havoc.cfg
Normal file
19
x11/havoc/files/patch-havoc.cfg
Normal file
@ -0,0 +1,19 @@
|
||||
--- havoc.cfg.orig 2020-09-15 12:50:19 UTC
|
||||
+++ havoc.cfg
|
||||
@@ -1,6 +1,6 @@
|
||||
[child]
|
||||
# program to run in child process
|
||||
-program=bash
|
||||
+program=sh
|
||||
|
||||
[window]
|
||||
# opacity of background from 0 (fully transparent) to 255 (fully opaque)
|
||||
@@ -22,7 +22,7 @@ scrollback=1000
|
||||
size=18
|
||||
|
||||
# absolute path to a truetype font
|
||||
-path=/usr/share/fonts/TTF/DejaVuSansMono.ttf
|
||||
+path=/usr/local/share/fonts/dejavu/DejaVuSansMono.ttf
|
||||
|
||||
[bind]
|
||||
# bind keys to actions
|
14
x11/havoc/files/pkg-message.in
Normal file
14
x11/havoc/files/pkg-message.in
Normal file
@ -0,0 +1,14 @@
|
||||
[
|
||||
{ type: install
|
||||
message: <<EOM
|
||||
Havoc is installed
|
||||
|
||||
Before using this program, copy
|
||||
|
||||
%%EXAMPLESDIR%%/havoc.cfg
|
||||
|
||||
in $HOME/.config/ and edit it based on your needs.
|
||||
|
||||
EOM
|
||||
}
|
||||
]
|
3
x11/havoc/pkg-descr
Normal file
3
x11/havoc/pkg-descr
Normal file
@ -0,0 +1,3 @@
|
||||
Havoc is a minimal terminal emulator for wayland environment.
|
||||
|
||||
WWW: https://github.com/ii8/havoc
|
Loading…
Reference in New Issue
Block a user