- Add plugin support back (off by default). [1]

- Add PHP sockets module in depends for ping works. [2]

PR:		ports/110649 [1], ports/110500 [2]
Submitted by:	Timur I. Bakeyev <timur@gnu.org> [1], edwin [2]
This commit is contained in:
Sergey Matveychuk 2007-03-29 09:52:15 +00:00
parent eb09611248
commit 61f3adc3dc
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=188724
18 changed files with 128 additions and 50 deletions

View File

@ -7,28 +7,27 @@
PORTNAME= cacti
PORTVERSION= 0.8.6j${PATCHLEVEL}
PORTREVISION= 1
PORTREVISION= 2
CATEGORIES= net www
MASTER_SITES= http://www.cacti.net/downloads/
DISTNAME= ${PORTNAME}-${SITEDISTVERSION}
MAINTAINER= sem@FreeBSD.org
COMMENT= Web-driven graphing interface for RRDTool
DISTFILES= ${PORTNAME}-${SITEDISTVERSION}${EXTRACT_SUFX}
# Vendor's patches
PATCH_SITES= http://www.cacti.net/downloads/patches/${SITEDISTVERSION}/
PATCHFILES= ping_php_version4_snmpgetnext.patch \
tree_console_missing_hosts.patch \
thumbnail_graphs_not_working.patch
PATCHLEVEL= .3
SITEDISTVERSION= ${PORTVERSION:S/${PATCHLEVEL}$//}
PATCH_DIST_STRIP= -p1
PATCH_DIST_STRIP=-p1
MAINTAINER= sem@FreeBSD.org
COMMENT= Web-driven graphing interface for RRDTool
RUN_DEPENDS= rrdtool:${PORTSDIR}/net/rrdtool
PATCHLEVEL= .3
PATCH_STRIP= -p1
USE_MYSQL= yes
USE_PHP= mysql pcre session snmp xml
USE_PHP= mysql pcre session sockets snmp xml
WANT_PHP_WEB= yes
NO_BUILD= yes
PKGMESSAGE= ${WRKDIR}/pkg-message
@ -38,11 +37,32 @@ SUB_FILES= pkg-message pkg-install
CACTIDIR?= share/cacti
CACTIUSER?= cacti
CACTIGROUP?= ${CACTIUSER}
WRKSRC= ${WRKDIR}/${PORTNAME}-${SITEDISTVERSION}
OPTIONS= PLUGIN_ARCH "With plugin architecture" Off
.include <bsd.port.pre.mk>
SITEDISTVERSION= ${PORTVERSION:S/${PATCHLEVEL}$//}
# Extra patches
.if defined(WITH_PLUGIN_ARCH)
MASTER_SITES+= http://cactiusers.net/downloads/plugins/:plugin
DISTFILES+= cacti-plugin-arch.tar.gz:plugin
EXTRA_PATCHES+= ${WRKDIR}/${PORTNAME}-plugin-${SITEDISTVERSION}.diff
PLIST_SUB+= PLUGIN=""
.else
PLIST_SUB+= PLUGIN="@comment "
.endif
PLIST_SUB+= CACTIDIR=${CACTIDIR}
SUB_LIST+= CACTIDIR=${CACTIDIR} CACTIUSER=${CACTIUSER} \
CACTIGROUP=${CACTIGROUP}
.include <bsd.port.pre.mk>
.if defined(WITH_PLUGIN_ARCH)
post-extract:
@${CP} ${WRKDIR}/cacti-plugin-arch/${PORTNAME}-plugin-${SITEDISTVERSION}.diff ${WRKDIR}
.endif
post-patch:
@${FIND} ${WRKSRC} -name \*.orig -delete; \
@ -50,7 +70,7 @@ post-patch:
${MV} ${WRKSRC}/include/config.php ${WRKSRC}/include/config.php.orig
pre-install:
@${SH} ${PKGINSTALL} ${PKGNAME} PRE-INSTALL; \
@${SH} ${PKGINSTALL} ${PKGNAME} PRE-INSTALL
do-install:
@${MKDIR} ${PREFIX}/${CACTIDIR}; \

View File

@ -1,6 +1,9 @@
MD5 (cacti-0.8.6j.tar.gz) = 29436be46b289d13dfce48e7618129e2
SHA256 (cacti-0.8.6j.tar.gz) = 0ddf8a740a5725de67eeea71c38433447ff75388e6e399ce92ccadc36d25bd46
SIZE (cacti-0.8.6j.tar.gz) = 1126337
MD5 (cacti-plugin-arch.tar.gz) = baaf01f3a863148d6a76510ffc53986d
SHA256 (cacti-plugin-arch.tar.gz) = 9d9600912f5bb347cd82a51f966438469676e01748b4b598fd193a1599feed4c
SIZE (cacti-plugin-arch.tar.gz) = 263447
MD5 (ping_php_version4_snmpgetnext.patch) = bedf583646e59dd628d4aced7e83fdf3
SHA256 (ping_php_version4_snmpgetnext.patch) = 1e19110c696eb56c6de68247c926c5ec7a2e7554df222f39a663556241644170
SIZE (ping_php_version4_snmpgetnext.patch) = 1262

View File

@ -1,5 +1,5 @@
--- include/config.php.orig Fri Jan 6 00:27:51 2006
+++ include/config.php Fri Jan 6 00:28:39 2006
--- cacti-0.8.6j/include/config.php.orig Fri Jan 6 00:27:51 2006
+++ cacti-0.8.6j/include/config.php Fri Jan 6 00:28:39 2006
@@ -24,7 +24,11 @@
+-------------------------------------------------------------------------+
*/

View File

@ -1,5 +1,5 @@
--- /dev/null Tue Jun 21 16:31:36 2005
+++ include/db-settings.php Tue Jun 21 16:29:15 2005
+++ cacti-0.8.6j/include/db-settings.php Tue Jun 21 16:29:15 2005
@@ -0,0 +1,9 @@
+<?php
+/* make sure these values refect your actual database/host/user/password */

View File

@ -1,5 +1,5 @@
--- scripts/diskfree.pl.orig Wed Jan 4 06:08:30 2006
+++ scripts/diskfree.pl Fri Jan 6 00:16:58 2006
--- cacti-0.8.6j/scripts/diskfree.pl.orig Wed Jan 4 06:08:30 2006
+++ cacti-0.8.6j/scripts/diskfree.pl Fri Jan 6 00:16:58 2006
@@ -1,5 +1,5 @@
#!/usr/bin/perl
-open(PROCESS,"df --block-size=1024 -P $ARGV[0] | grep -v Filesystem |");

View File

@ -1,5 +1,5 @@
--- scripts/ping.pl.orig Sat Apr 15 22:26:44 2006
+++ scripts/ping.pl Sat Apr 15 22:27:16 2006
--- cacti-0.8.6j/scripts/ping.pl.orig Sat Apr 15 22:26:44 2006
+++ cacti-0.8.6j/scripts/ping.pl Sat Apr 15 22:27:16 2006
@@ -1,6 +1,6 @@
#!/usr/bin/perl

View File

@ -3,10 +3,10 @@
PW=/usr/sbin/pw
UID=107
GID=${UID}
CACTIUSER=%%CACTIUSER%%
CACTIGROUP=%%CACTIGROUP%%
CACTIDIR=%%CACTIDIR%%
PREFIX=%%PREFIX%%
CACTIUSER="%%CACTIUSER%%"
CACTIGROUP="%%CACTIGROUP%%"
CACTIDIR="%%CACTIDIR%%"
PREFIX="%%PREFIX%%"
case $2 in
@ -39,9 +39,10 @@ PRE-INSTALL)
POST-INSTALL)
chown ${CACTIUSER}:${CACTIGROUP} ${PREFIX}/${CACTIDIR}/rra/
chown -R ${CACTIUSER}:${CACTIGROUP} ${PREFIX}/${CACTIDIR}/log/
chmod -R a+r ${PREFIX}/${CACTIDIR}/scripts/
chown ${CACTIUSER}:${CACTIGROUP} "${PREFIX}/${CACTIDIR}/rra/"
[ -d "${PREFIX}/${CACTIDIR}/log/" ] || mkdir -p "${PREFIX}/${CACTIDIR}/log/"
chown -R ${CACTIUSER}:${CACTIGROUP} "${PREFIX}/${CACTIDIR}/log/"
chmod -R a+r "${PREFIX}/${CACTIDIR}/scripts/"
;;
*)
exit 1

View File

@ -20,4 +20,16 @@ Alias /cacti "%%PREFIX%%/%%CACTIDIR%%/"
If you update cacti, open a login page, an updating process
will start automatically.
If you are using PLUGIN option set, in file
%%PREFIX%%/%%CACTIDIR%%/include/config.php
change the follow line
$config["url_path"] = '/';
with location where your cacti is available. E.g.:
$config["url_path"] = '/cacti/';
if your URL is http://yoursite.com/cacti
=======================================================================

View File

@ -144,6 +144,8 @@
@unexec cmp -s %D/%%CACTIDIR%%/include/db-settings.php.orig %D/%%CACTIDIR%%/include/db-settings.php && rm -f %D/%%CACTIDIR%%/include/db-settings.php || true
%%CACTIDIR%%/include/db-settings.php.orig
@exec [ -f %D/%%CACTIDIR%%/include/db-settings.php ] || cp %D/%%CACTIDIR%%/include/db-settings.php.orig %D/%%CACTIDIR%%/include/db-settings.php
%%PLUGIN%%%%CACTIDIR%%/include/plugins.php
%%PLUGIN%%%%CACTIDIR%%/plugins/index.php
%%CACTIDIR%%/include/html/inc_data_source_filter_table.php
%%CACTIDIR%%/include/html/inc_data_template_filter_table.php
%%CACTIDIR%%/include/html/inc_device_filter_table.php
@ -418,6 +420,7 @@
@dirrm %%CACTIDIR%%/include/jscalendar
@dirrm %%CACTIDIR%%/include/html
@dirrmtry %%CACTIDIR%%/include
%%PLUGIN%%@dirrmtry %%CACTIDIR%%/plugins
@dirrm %%CACTIDIR%%/images
@dirrm %%CACTIDIR%%/docs/text
@dirrm %%CACTIDIR%%/docs/pdf

View File

@ -7,28 +7,27 @@
PORTNAME= cacti
PORTVERSION= 0.8.6j${PATCHLEVEL}
PORTREVISION= 1
PORTREVISION= 2
CATEGORIES= net www
MASTER_SITES= http://www.cacti.net/downloads/
DISTNAME= ${PORTNAME}-${SITEDISTVERSION}
MAINTAINER= sem@FreeBSD.org
COMMENT= Web-driven graphing interface for RRDTool
DISTFILES= ${PORTNAME}-${SITEDISTVERSION}${EXTRACT_SUFX}
# Vendor's patches
PATCH_SITES= http://www.cacti.net/downloads/patches/${SITEDISTVERSION}/
PATCHFILES= ping_php_version4_snmpgetnext.patch \
tree_console_missing_hosts.patch \
thumbnail_graphs_not_working.patch
PATCHLEVEL= .3
SITEDISTVERSION= ${PORTVERSION:S/${PATCHLEVEL}$//}
PATCH_DIST_STRIP= -p1
PATCH_DIST_STRIP=-p1
MAINTAINER= sem@FreeBSD.org
COMMENT= Web-driven graphing interface for RRDTool
RUN_DEPENDS= rrdtool:${PORTSDIR}/net/rrdtool
PATCHLEVEL= .3
PATCH_STRIP= -p1
USE_MYSQL= yes
USE_PHP= mysql pcre session snmp xml
USE_PHP= mysql pcre session sockets snmp xml
WANT_PHP_WEB= yes
NO_BUILD= yes
PKGMESSAGE= ${WRKDIR}/pkg-message
@ -38,11 +37,32 @@ SUB_FILES= pkg-message pkg-install
CACTIDIR?= share/cacti
CACTIUSER?= cacti
CACTIGROUP?= ${CACTIUSER}
WRKSRC= ${WRKDIR}/${PORTNAME}-${SITEDISTVERSION}
OPTIONS= PLUGIN_ARCH "With plugin architecture" Off
.include <bsd.port.pre.mk>
SITEDISTVERSION= ${PORTVERSION:S/${PATCHLEVEL}$//}
# Extra patches
.if defined(WITH_PLUGIN_ARCH)
MASTER_SITES+= http://cactiusers.net/downloads/plugins/:plugin
DISTFILES+= cacti-plugin-arch.tar.gz:plugin
EXTRA_PATCHES+= ${WRKDIR}/${PORTNAME}-plugin-${SITEDISTVERSION}.diff
PLIST_SUB+= PLUGIN=""
.else
PLIST_SUB+= PLUGIN="@comment "
.endif
PLIST_SUB+= CACTIDIR=${CACTIDIR}
SUB_LIST+= CACTIDIR=${CACTIDIR} CACTIUSER=${CACTIUSER} \
CACTIGROUP=${CACTIGROUP}
.include <bsd.port.pre.mk>
.if defined(WITH_PLUGIN_ARCH)
post-extract:
@${CP} ${WRKDIR}/cacti-plugin-arch/${PORTNAME}-plugin-${SITEDISTVERSION}.diff ${WRKDIR}
.endif
post-patch:
@${FIND} ${WRKSRC} -name \*.orig -delete; \
@ -50,7 +70,7 @@ post-patch:
${MV} ${WRKSRC}/include/config.php ${WRKSRC}/include/config.php.orig
pre-install:
@${SH} ${PKGINSTALL} ${PKGNAME} PRE-INSTALL; \
@${SH} ${PKGINSTALL} ${PKGNAME} PRE-INSTALL
do-install:
@${MKDIR} ${PREFIX}/${CACTIDIR}; \

View File

@ -1,6 +1,9 @@
MD5 (cacti-0.8.6j.tar.gz) = 29436be46b289d13dfce48e7618129e2
SHA256 (cacti-0.8.6j.tar.gz) = 0ddf8a740a5725de67eeea71c38433447ff75388e6e399ce92ccadc36d25bd46
SIZE (cacti-0.8.6j.tar.gz) = 1126337
MD5 (cacti-plugin-arch.tar.gz) = baaf01f3a863148d6a76510ffc53986d
SHA256 (cacti-plugin-arch.tar.gz) = 9d9600912f5bb347cd82a51f966438469676e01748b4b598fd193a1599feed4c
SIZE (cacti-plugin-arch.tar.gz) = 263447
MD5 (ping_php_version4_snmpgetnext.patch) = bedf583646e59dd628d4aced7e83fdf3
SHA256 (ping_php_version4_snmpgetnext.patch) = 1e19110c696eb56c6de68247c926c5ec7a2e7554df222f39a663556241644170
SIZE (ping_php_version4_snmpgetnext.patch) = 1262

View File

@ -1,5 +1,5 @@
--- include/config.php.orig Fri Jan 6 00:27:51 2006
+++ include/config.php Fri Jan 6 00:28:39 2006
--- cacti-0.8.6j/include/config.php.orig Fri Jan 6 00:27:51 2006
+++ cacti-0.8.6j/include/config.php Fri Jan 6 00:28:39 2006
@@ -24,7 +24,11 @@
+-------------------------------------------------------------------------+
*/

View File

@ -1,5 +1,5 @@
--- /dev/null Tue Jun 21 16:31:36 2005
+++ include/db-settings.php Tue Jun 21 16:29:15 2005
+++ cacti-0.8.6j/include/db-settings.php Tue Jun 21 16:29:15 2005
@@ -0,0 +1,9 @@
+<?php
+/* make sure these values refect your actual database/host/user/password */

View File

@ -1,5 +1,5 @@
--- scripts/diskfree.pl.orig Wed Jan 4 06:08:30 2006
+++ scripts/diskfree.pl Fri Jan 6 00:16:58 2006
--- cacti-0.8.6j/scripts/diskfree.pl.orig Wed Jan 4 06:08:30 2006
+++ cacti-0.8.6j/scripts/diskfree.pl Fri Jan 6 00:16:58 2006
@@ -1,5 +1,5 @@
#!/usr/bin/perl
-open(PROCESS,"df --block-size=1024 -P $ARGV[0] | grep -v Filesystem |");

View File

@ -1,5 +1,5 @@
--- scripts/ping.pl.orig Sat Apr 15 22:26:44 2006
+++ scripts/ping.pl Sat Apr 15 22:27:16 2006
--- cacti-0.8.6j/scripts/ping.pl.orig Sat Apr 15 22:26:44 2006
+++ cacti-0.8.6j/scripts/ping.pl Sat Apr 15 22:27:16 2006
@@ -1,6 +1,6 @@
#!/usr/bin/perl

View File

@ -3,10 +3,10 @@
PW=/usr/sbin/pw
UID=107
GID=${UID}
CACTIUSER=%%CACTIUSER%%
CACTIGROUP=%%CACTIGROUP%%
CACTIDIR=%%CACTIDIR%%
PREFIX=%%PREFIX%%
CACTIUSER="%%CACTIUSER%%"
CACTIGROUP="%%CACTIGROUP%%"
CACTIDIR="%%CACTIDIR%%"
PREFIX="%%PREFIX%%"
case $2 in
@ -39,9 +39,10 @@ PRE-INSTALL)
POST-INSTALL)
chown ${CACTIUSER}:${CACTIGROUP} ${PREFIX}/${CACTIDIR}/rra/
chown -R ${CACTIUSER}:${CACTIGROUP} ${PREFIX}/${CACTIDIR}/log/
chmod -R a+r ${PREFIX}/${CACTIDIR}/scripts/
chown ${CACTIUSER}:${CACTIGROUP} "${PREFIX}/${CACTIDIR}/rra/"
[ -d "${PREFIX}/${CACTIDIR}/log/" ] || mkdir -p "${PREFIX}/${CACTIDIR}/log/"
chown -R ${CACTIUSER}:${CACTIGROUP} "${PREFIX}/${CACTIDIR}/log/"
chmod -R a+r "${PREFIX}/${CACTIDIR}/scripts/"
;;
*)
exit 1

View File

@ -20,4 +20,16 @@ Alias /cacti "%%PREFIX%%/%%CACTIDIR%%/"
If you update cacti, open a login page, an updating process
will start automatically.
If you are using PLUGIN option set, in file
%%PREFIX%%/%%CACTIDIR%%/include/config.php
change the follow line
$config["url_path"] = '/';
with location where your cacti is available. E.g.:
$config["url_path"] = '/cacti/';
if your URL is http://yoursite.com/cacti
=======================================================================

View File

@ -144,6 +144,8 @@
@unexec cmp -s %D/%%CACTIDIR%%/include/db-settings.php.orig %D/%%CACTIDIR%%/include/db-settings.php && rm -f %D/%%CACTIDIR%%/include/db-settings.php || true
%%CACTIDIR%%/include/db-settings.php.orig
@exec [ -f %D/%%CACTIDIR%%/include/db-settings.php ] || cp %D/%%CACTIDIR%%/include/db-settings.php.orig %D/%%CACTIDIR%%/include/db-settings.php
%%PLUGIN%%%%CACTIDIR%%/include/plugins.php
%%PLUGIN%%%%CACTIDIR%%/plugins/index.php
%%CACTIDIR%%/include/html/inc_data_source_filter_table.php
%%CACTIDIR%%/include/html/inc_data_template_filter_table.php
%%CACTIDIR%%/include/html/inc_device_filter_table.php
@ -418,6 +420,7 @@
@dirrm %%CACTIDIR%%/include/jscalendar
@dirrm %%CACTIDIR%%/include/html
@dirrmtry %%CACTIDIR%%/include
%%PLUGIN%%@dirrmtry %%CACTIDIR%%/plugins
@dirrm %%CACTIDIR%%/images
@dirrm %%CACTIDIR%%/docs/text
@dirrm %%CACTIDIR%%/docs/pdf