Fix DivX/XviD support breakage.

This commit is contained in:
MANTANI Nobutaka 2009-03-01 04:36:56 +00:00
parent e61a14e103
commit 61e7541eea
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=229269
2 changed files with 8 additions and 7 deletions

View File

@ -7,6 +7,7 @@
PORTNAME= xine
PORTVERSION= 1.1.16.2
PORTREVISION= 1
CATEGORIES= multimedia ipv6
MASTER_SITES= SF
PKGNAMEPREFIX= lib
@ -50,7 +51,8 @@ CONFIGURE_ENV= CFLAGS="${CFLAGS} -fno-force-addr -I${LOCALBASE}/include -I${LOCA
EXTRA_X_LIBS="-lGL -lGLU -lXext -lX11 -lm"
CONFIGURE_ARGS= --with-w32-path=${LOCALBASE}/lib/win32 --enable-ipv6 \
--with-external-libmad \
--with-external-libdts --with-libflac --disable-v4l
--with-external-libdts --with-libflac --disable-v4l \
--with-external-ffmpeg=no
OPTIONS= ARTS "Enable aRts support" off \
CACA "Enable libcaca support" off \

View File

@ -1,12 +1,11 @@
--- src/combined/ffmpeg/Makefile.in.orig 2009-02-22 09:21:57.000000000 +0900
+++ src/combined/ffmpeg/Makefile.in 2009-02-22 09:51:00.000000000 +0900
@@ -889,8 +889,8 @@
--- src/combined/ffmpeg/Makefile.in.orig 2009-03-01 12:02:37.000000000 +0900
+++ src/combined/ffmpeg/Makefile.in 2009-03-01 12:36:05.000000000 +0900
@@ -890,7 +890,8 @@
avcodec_audio.list avcodec_video.list:
echo '#include "$(srcdir)/ffmpeg_decoder.h"' | $(AV_CPP) - |\
- sed -e $(AV_CODECS)'! d; s/^\s*//; s/[=,].*//; /^$$/ d' |\
sed -e $(AV_CODECS)'! d; s/^\s*//; s/[=,].*//; /^$$/ d' |\
- head -n -1 >$@
+ sed -e $(AV_CODECS)'! d; s/^\s*//; s/[=,].*//; /^$$/ d' >$@
+ $(PERL) -pe "s/^\s*//" > $@
+ sed -i.bak -e '$$d' $@
# Generate the mappings. These are #included where needed.