Fix a problem where the doxygen-generated LaTeX file could no longer

be compiled by LaTeX 3 as it was attempted to convert it to PDF
instead of DVI now.  This eventually caused the entire build to fall
over, as the EPS picture files to be included were no longer be looked
up by the .eps suffix.

Also, now that avr-binutils and avr-gcc can handle the newer AVR
devices (ATmega48/88/168, ATtiny13/2313, AT90CAN128, ATmega325/3250,
ATmega645/6450), the configure script automatically causes crt*.o
files for these devices to be compiled and installed, so reflect this
in the pkg-plist.  This makes these new device types fully supported
in the FreeBSD AVR toolchain (as they are in the popular WinAVR
toolchain already).

The new doxygen version present in the ports also causes a slightly
different directory layout for the generated docs, so adapt
pkg-plist.doc accordingly.
This commit is contained in:
Joerg Wunsch 2005-03-11 21:43:37 +00:00
parent d527cebbdb
commit 61ba11cc00
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=130945
4 changed files with 109 additions and 0 deletions

View File

@ -7,6 +7,7 @@
PORTNAME= avr-libc
PORTVERSION= 1.2.3
PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_SAVANNAH}

View File

@ -0,0 +1,67 @@
--- doc/api/doxygen.config.in.orig Mon Dec 20 22:47:48 2004
+++ doc/api/doxygen.config.in Fri Mar 11 22:20:37 2005
@@ -679,7 +679,7 @@
# contain links (just like the HTML output) instead of page references
# This makes the output suitable for online browsing using a pdf viewer.
-PDF_HYPERLINKS = YES
+PDF_HYPERLINKS = NO
# If the USE_PDFLATEX tag is set to YES, pdflatex will be used instead of
# plain latex in the generated Makefile. Set this option to YES to get a
--- doc/api/Makefile.am.orig Mon Dec 20 22:47:48 2004
+++ doc/api/Makefile.am Fri Mar 11 22:21:14 2005
@@ -144,7 +144,7 @@
doxygen doxygen.config
cd latex_src && \
sed -e '/tocdepth/s/1/2/' \
- -e '/usepackage{times}/s/$$/\\usepackage{longtable}/' \
+ -e '/usepackage{doxygen}/s/$$/\\usepackage{longtable}/' \
refman.tex > tmp.$$ && \
mv -f tmp.$$ refman.tex
cd latex_src && \
@@ -164,7 +164,7 @@
doxygen doxygen-pdf.config
cd latex_pdf_src && \
sed -e '/tocdepth/s/1/3/' \
- -e '/usepackage{times}/s/$$/\\usepackage{longtable}/' \
+ -e '/usepackage{doxygen}/s/$$/\\usepackage{longtable}/' \
refman.tex > tmp.$$ && \
mv -f tmp.$$ refman.tex
cd latex_pdf_src && \
@@ -190,6 +190,7 @@
-e '/LATEX_OUTPUT/s/latex_src/latex_pdf_src/' \
-e '/GENERATE_HTML/s/YES/NO/' \
-e '/GENERATE_MAN/s/YES/NO/' \
+ -e '/PDF_HYPERLINKS/s/NO/YES/' \
doxygen.config > doxygen-pdf.config
# XXX currently, HTML and LaTeX documentation will always be built
--- doc/api/Makefile.in.orig Tue Feb 15 15:58:15 2005
+++ doc/api/Makefile.in Fri Mar 11 22:21:24 2005
@@ -331,7 +331,7 @@
doxygen doxygen.config
cd latex_src && \
sed -e '/tocdepth/s/1/2/' \
- -e '/usepackage{times}/s/$$/\\usepackage{longtable}/' \
+ -e '/usepackage{doxygen}/s/$$/\\usepackage{longtable}/' \
refman.tex > tmp.$$ && \
mv -f tmp.$$ refman.tex
cd latex_src && \
@@ -351,7 +351,7 @@
doxygen doxygen-pdf.config
cd latex_pdf_src && \
sed -e '/tocdepth/s/1/3/' \
- -e '/usepackage{times}/s/$$/\\usepackage{longtable}/' \
+ -e '/usepackage{doxygen}/s/$$/\\usepackage{longtable}/' \
refman.tex > tmp.$$ && \
mv -f tmp.$$ refman.tex
cd latex_pdf_src && \
@@ -377,6 +377,7 @@
-e '/LATEX_OUTPUT/s/latex_src/latex_pdf_src/' \
-e '/GENERATE_HTML/s/YES/NO/' \
-e '/GENERATE_MAN/s/YES/NO/' \
+ -e '/PDF_HYPERLINKS/s/NO/YES/' \
doxygen.config > doxygen-pdf.config
# XXX currently, HTML and LaTeX documentation will always be built

View File

@ -79,9 +79,11 @@ avr/lib/avr3/libprintf_flt.a
avr/lib/avr3/libprintf_min.a
avr/lib/avr3/libscanf_flt.a
avr/lib/avr3/libscanf_min.a
avr/lib/avr4/crtm48.o
avr/lib/avr4/crtm8.o
avr/lib/avr4/crtm8515.o
avr/lib/avr4/crtm8535.o
avr/lib/avr4/crtm88.o
avr/lib/avr4/libc.a
avr/lib/avr4/libm.a
avr/lib/avr4/libprintf_flt.a
@ -89,15 +91,21 @@ avr/lib/avr4/libprintf_min.a
avr/lib/avr4/libscanf_flt.a
avr/lib/avr4/libscanf_min.a
avr/lib/avr5/crtat94k.o
avr/lib/avr5/crtcan128.o
avr/lib/avr5/crtm128.o
avr/lib/avr5/crtm16.o
avr/lib/avr5/crtm161.o
avr/lib/avr5/crtm162.o
avr/lib/avr5/crtm163.o
avr/lib/avr5/crtm168.o
avr/lib/avr5/crtm169.o
avr/lib/avr5/crtm32.o
avr/lib/avr5/crtm323.o
avr/lib/avr5/crtm325.o
avr/lib/avr5/crtm3250.o
avr/lib/avr5/crtm64.o
avr/lib/avr5/crtm645.o
avr/lib/avr5/crtm6450.o
avr/lib/avr5/libc.a
avr/lib/avr5/libm.a
avr/lib/avr5/libprintf_flt.a
@ -118,8 +126,10 @@ avr/lib/crts8515.o
avr/lib/crts8535.o
avr/lib/crttn11.o
avr/lib/crttn12.o
avr/lib/crttn13.o
avr/lib/crttn15.o
avr/lib/crttn22.o
avr/lib/crttn2313.o
avr/lib/crttn26.o
avr/lib/crttn28.o
avr/lib/libc.a

View File

@ -6,6 +6,22 @@ share/doc/avr-libc/avr-libc-user-manual/annotated.html
share/doc/avr-libc/avr-libc-user-manual/assembler.html
share/doc/avr-libc/avr-libc-user-manual/classes.html
share/doc/avr-libc/avr-libc-user-manual/demo.png
share/doc/avr-libc/avr-libc-user-manual/dir_000000.html
share/doc/avr-libc/avr-libc-user-manual/dir_000001.html
share/doc/avr-libc/avr-libc-user-manual/dir_000002.html
share/doc/avr-libc/avr-libc-user-manual/dir_000003.html
share/doc/avr-libc/avr-libc-user-manual/dir_000004.html
share/doc/avr-libc/avr-libc-user-manual/dir_000005.html
share/doc/avr-libc/avr-libc-user-manual/dir_000006.html
share/doc/avr-libc/avr-libc-user-manual/dir_000007.html
share/doc/avr-libc/avr-libc-user-manual/dir_000008.html
share/doc/avr-libc/avr-libc-user-manual/dir_000009.html
share/doc/avr-libc/avr-libc-user-manual/dir_000010.html
share/doc/avr-libc/avr-libc-user-manual/dir_000011.html
share/doc/avr-libc/avr-libc-user-manual/dir_000012.html
share/doc/avr-libc/avr-libc-user-manual/dir_000013.html
share/doc/avr-libc/avr-libc-user-manual/dir_000014.html
share/doc/avr-libc/avr-libc-user-manual/dirs.html
share/doc/avr-libc/avr-libc-user-manual/dox.css
share/doc/avr-libc/avr-libc-user-manual/doxygen.png
share/doc/avr-libc/avr-libc-user-manual/ftv2blank.png
@ -110,6 +126,21 @@ share/doc/avr-libc/man/man3/_delay_loop_1.3
share/doc/avr-libc/man/man3/_delay_loop_2.3
share/doc/avr-libc/man/man3/_delay_ms.3
share/doc/avr-libc/man/man3/_delay_us.3
share/doc/avr-libc/man/man3/_tmp_avr-libc_work_avr-libc-1.2.3_doc_.3
share/doc/avr-libc/man/man3/_tmp_avr-libc_work_avr-libc-1.2.3_doc_examples_.3
share/doc/avr-libc/man/man3/_tmp_avr-libc_work_avr-libc-1.2.3_doc_examples_demo_.3
share/doc/avr-libc/man/man3/_tmp_avr-libc_work_avr-libc-1.2.3_doc_examples_twitest_.3
share/doc/avr-libc/man/man3/_tmp_avr-libc_work_avr-libc-1.2.3_include_.3
share/doc/avr-libc/man/man3/_tmp_avr-libc_work_avr-libc-1.2.3_include_avr_.3
share/doc/avr-libc/man/man3/_tmp_avr-libc_work_avr-libc-1.2.3_include_compat_.3
share/doc/avr-libc/man/man3/_tmp_avr-libc_work_avr-libc-1.2.3_libc_.3
share/doc/avr-libc/man/man3/_tmp_avr-libc_work_avr-libc-1.2.3_libc_misc_.3
share/doc/avr-libc/man/man3/_tmp_avr-libc_work_avr-libc-1.2.3_libc_pmstring_.3
share/doc/avr-libc/man/man3/_tmp_avr-libc_work_avr-libc-1.2.3_libc_stdio_.3
share/doc/avr-libc/man/man3/_tmp_avr-libc_work_avr-libc-1.2.3_libc_stdlib_.3
share/doc/avr-libc/man/man3/_tmp_avr-libc_work_avr-libc-1.2.3_libc_string_.3
share/doc/avr-libc/man/man3/_tmp_avr-libc_work_avr-libc-1.2.3_libm_.3
share/doc/avr-libc/man/man3/_tmp_avr-libc_work_avr-libc-1.2.3_libm_fplib_.3
share/doc/avr-libc/man/man3/abort.3
share/doc/avr-libc/man/man3/abs.3
share/doc/avr-libc/man/man3/acks.3