Update to 9.06. Changes include:

- PDF/A-2 - pdfwrite now supports the creation of PDF/A-2 files.
   Simply specifying "-dPDFA" continues to have the old behaviour of creating
   PDF/A-1b files. For PDF/A-2 the command line should include "-dPDFA=2".

 - pdfwrite "Server mode" - pdfwrite can now be run in "server mode" which
   allows the device to be closed without closing the interpreter. This means
   it is no longer necessary to terminate GS before starting a new PDF
   conversion.

Feature safe:	yes
This commit is contained in:
Hiroki Sato 2012-10-13 18:07:14 +00:00
parent 72c887c31c
commit 6193fde9d8
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=305844
5 changed files with 43 additions and 35 deletions

View File

@ -1,13 +1,7 @@
# New ports collection makefile for: ghostscript9
# Date created: 17 May, 2011
# Whom: hrs
#
# $FreeBSD$
#
PORTNAME= ghostscript
PORTVERSION= 9.05
PORTREVISION= 5
PORTVERSION= 9.06
CATEGORIES= print
MASTER_SITES= http://downloads.ghostscript.com/public/:gs_srcs \
SF/ghostscript/GPL%20Ghostscript/${PORTVERSION}:gs_srcs \
@ -125,14 +119,14 @@ CONFIGURE_ARGS+= --without-libpaper
.endif
.if ${PORT_OPTIONS:MFONTCONFIG}
LIB_DEPENDS+= fontconfig.1:${PORTSDIR}/x11-fonts/fontconfig
LIB_DEPENDS+= fontconfig:${PORTSDIR}/x11-fonts/fontconfig
CONFIGURE_ARGS+= --enable-fontconfig
.else
CONFIGURE_ARGS+= --disable-fontconfig
.endif
# FT_BRIDGE=1 by default
LIB_DEPENDS+= freetype.9:${PORTSDIR}/print/freetype2
LIB_DEPENDS+= freetype:${PORTSDIR}/print/freetype2
MAKE_ENV+= FT_BRIDGE=1
ALL_TARGET= so

View File

@ -1,4 +1,4 @@
SHA256 (ghostscript/ghostscript-9.05.tar.bz2) = 0f41212af3a5a552ab2302cd90606dc8245be34490a699726dc95ed3cd89ceac
SIZE (ghostscript/ghostscript-9.05.tar.bz2) = 28279634
SHA256 (ghostscript/ghostscript-9.06.tar.bz2) = 05acd1b576899572ef8ecbc25637cf73cbd0be267e651732db3012db33088e04
SIZE (ghostscript/ghostscript-9.06.tar.bz2) = 29246039
SHA256 (ghostscript/epag-3.09.tar.gz) = ad10eca44c781a5851d5a8993dcd95b2e2b99392cbf2c8372a5a658f3b991b3b
SIZE (ghostscript/epag-3.09.tar.gz) = 12858

View File

@ -1,11 +1,11 @@
--- base/gs.mak.orig 2010-05-23 15:46:23.000000000 +0900
+++ base/gs.mak 2010-05-23 15:57:37.000000000 +0900
@@ -415,7 +415,7 @@
--- base/gs.mak.orig 2012-08-08 17:01:36.000000000 +0900
+++ base/gs.mak 2012-10-14 02:29:03.000000000 +0900
@@ -437,7 +437,7 @@
ld_tr=$(GLGENDIR)$(D)ld.tr
$(ld_tr) : \
$(GS_MAK) $(TOP_MAKEFILES) $(GLSRCDIR)$(D)version.mak $(GENCONF_XE) $(ECHOGS_XE) $(devs_tr) $(DEVS_ALL) $(GLGENDIR)$(D)libcore.dev
- $(EXP)$(GENCONF_XE) $(devs_tr) -h $(gconfig_h) $(CONFILES) $(CONFLDTR) $(ld_tr)
+ $(EXP)$(GENCONF_XE) $(devs_tr) -h /dev/stdout $(CONFILES) $(CONFLDTR) $(ld_tr) | awk 'BEGIN{j=0; p=1;} /jpeg_device/ {if(j++ > 0) p=0;} // {if(p==1) { print; } else { p=1 } }' > $(gconfig_h)
$(EXP)$(ECHOGS_XE) -a $(gconfig_h) $(GCONFIG_EXTRAS)
- $(EXP)$(GENCONF_XE) $(devs_tr) -h $(gconfxx_h) $(CONFILES) $(CONFLDTR) $(ld_tr)
+ $(EXP)$(GENCONF_XE) $(devs_tr) -h /dev/stdout $(gconfxx_h) $(CONFILES) $(CONFLDTR) $(ld_tr) | awk 'BEGIN{j=0; p=1;} /jpeg_device/ {if(j++ > 0) p=0;} // { if(p==1) { print; } else { p=1 } }' > $(gconfxx_h)
$(EXP)$(ECHOGS_XE) -a $(gconfxx_h) $(GCONFIG_EXTRAS)
$(gconfig_h) : $(ld_tr)
$(gconfxx_h) : $(ld_tr)

View File

@ -1,6 +1,6 @@
--- base/unix-gcc.mak.orig 2011-08-05 20:12:20.000000000 +0900
+++ base/unix-gcc.mak 2011-12-06 15:26:48.000000000 +0900
@@ -21,16 +21,17 @@
--- base/unix-gcc.mak.orig 2012-08-08 17:01:36.000000000 +0900
+++ base/unix-gcc.mak 2012-10-14 02:32:51.000000000 +0900
@@ -22,16 +22,17 @@
# source, generated intermediate file, and object directories
# for the graphics library (GL) and the PostScript/PDF interpreter (PS).
@ -27,7 +27,7 @@
# Do not edit the next group of lines.
@@ -49,11 +50,10 @@
@@ -50,11 +51,10 @@
# the directories also define the default search path for the
# initialization files (gs_*.ps) and the fonts.
@ -42,7 +42,7 @@
exec_prefix = $(prefix)
bindir = $(exec_prefix)/bin
scriptdir = $(bindir)
@@ -103,7 +103,7 @@
@@ -104,7 +104,7 @@
# This uses the more secure temporary file creation call
# Enable this if it is available on your platform.
@ -51,7 +51,7 @@
# Define the name of the executable file.
@@ -137,7 +137,7 @@
@@ -139,7 +139,7 @@
# some older JPEG streams that violate the standard. If the JPEG
# library built from local sources, the patch will be applied.
@ -60,7 +60,7 @@
JPEG_NAME=jpeg
# Define the directory where the PNG library sources are stored,
@@ -151,13 +151,13 @@
@@ -153,13 +153,13 @@
# what its name is.
# See gs.mak and Make.htm for more information.
@ -76,7 +76,7 @@
TIFFSRCDIR=tiff
TIFFPLATFORM=unix
TIFFCONFIG_SUFFIX=.unix
@@ -172,15 +172,23 @@
@@ -174,15 +174,23 @@
# what its name is (usually libz, but sometimes libgz).
# See gs.mak and Make.htm for more information.
@ -102,7 +102,7 @@
# Define the directory where the icclib source are stored.
# See icclib.mak for more information
ICCSRCDIR=icclib
@@ -226,7 +234,7 @@
@@ -223,7 +231,7 @@
# Define the name of the C compiler.
@ -111,7 +111,7 @@
# Define the name of the linker for the final link step.
# Normally this is the same as the C compiler.
@@ -243,7 +251,7 @@
@@ -240,7 +248,7 @@
# Define the added flags for standard, debugging, profiling
# and shared object builds.
@ -120,7 +120,7 @@
CFLAGS_DEBUG=-g -O0
CFLAGS_PROFILE=-pg -O2
CFLAGS_SO=-fPIC
@@ -259,7 +267,8 @@
@@ -256,7 +264,8 @@
# We don't include -ansi, because this gets in the way of the platform-
# specific stuff that <math.h> typically needs; nevertheless, we expect
# gcc to accept ANSI-style function prototypes and function definitions.
@ -130,7 +130,7 @@
CFLAGS=$(CFLAGS_STANDARD) $(GCFLAGS) $(XCFLAGS)
@@ -270,7 +279,7 @@
@@ -267,7 +276,7 @@
# -R /usr/local/xxx/lib:/usr/local/lib
# giving the full path names of the shared library directories.
# XLDFLAGS can be set from the command line.
@ -139,7 +139,7 @@
LDFLAGS=$(XLDFLAGS)
@@ -281,7 +290,7 @@
@@ -278,7 +287,7 @@
# Solaris may need -lnsl -lsocket -lposix4.
# (Libraries required by individual drivers are handled automatically.)
@ -148,7 +148,7 @@
# Define the standard libraries to search at the end of linking.
# Most platforms require -lpthread for the POSIX threads library;
@@ -303,7 +312,7 @@
@@ -300,7 +309,7 @@
# Note that x_.h expects to find the header files in $(XINCLUDE)/X11,
# not in $(XINCLUDE).
@ -157,7 +157,7 @@
# Define the directory/ies and library names for the X11 library files.
# XLIBDIRS is for ld and should include -L; XLIBDIR is for LD_RUN_PATH
@@ -318,26 +327,26 @@
@@ -315,29 +324,29 @@
#XLIBS=Xt SM ICE Xext X11
#XLIBDIRS=-L/usr/local/X/lib
@ -175,6 +175,9 @@
-#SYNC=posync
+SYNC=posync
# define the file name extension for a shared lib
DYNANIC_LIB_EXT=so
# Default is No sync primitives since some platforms don't have it (HP-UX)
-SYNC=nosync
+#SYNC=nosync

View File

@ -1,5 +1,4 @@
@comment $FreeBSD: /tmp/pcvs/ports/print/ghostscript9/pkg-plist,v 1.5 2012-02-12 18:10:49 hrs Exp $
bin/dumphint
bin/dvipdf
bin/eps2eps
%%GS_dmprt%%bin/ert
@ -271,8 +270,10 @@ lib/libgs.so.%%GS_VERSION%%
%%DATADIR%%/%%GS_VERSION%%/iccprofiles/sgray.icc
%%DATADIR%%/%%GS_VERSION%%/iccprofiles/srgb.icc
%%DATADIR%%/%%GS_VERSION%%/doc/API.htm
%%DATADIR%%/%%GS_VERSION%%/doc/AUTHORS
%%DATADIR%%/%%GS_VERSION%%/doc/C-style.htm
%%DATADIR%%/%%GS_VERSION%%/doc/Changes.htm
%%DATADIR%%/%%GS_VERSION%%/doc/COPYING
%%DATADIR%%/%%GS_VERSION%%/doc/Commprod.htm
%%DATADIR%%/%%GS_VERSION%%/doc/DLL.htm
%%DATADIR%%/%%GS_VERSION%%/doc/Deprecated.htm
@ -283,6 +284,8 @@ lib/libgs.so.%%GS_VERSION%%
%%DATADIR%%/%%GS_VERSION%%/doc/Devices.htm
%%DATADIR%%/%%GS_VERSION%%/doc/Drivers.htm
%%DATADIR%%/%%GS_VERSION%%/doc/Fonts.htm
%%DATADIR%%/%%GS_VERSION%%/doc/GS9_Color_Management.pdf
%%DATADIR%%/%%GS_VERSION%%/doc/GS9_Color_Management.tex
%%DATADIR%%/%%GS_VERSION%%/doc/Helpers.htm
%%DATADIR%%/%%GS_VERSION%%/doc/Hershey.htm
%%DATADIR%%/%%GS_VERSION%%/doc/History1.htm
@ -304,15 +307,21 @@ lib/libgs.so.%%GS_VERSION%%
%%DATADIR%%/%%GS_VERSION%%/doc/Ps-style.htm
%%DATADIR%%/%%GS_VERSION%%/doc/Ps2epsi.htm
%%DATADIR%%/%%GS_VERSION%%/doc/Ps2pdf.htm
%%DATADIR%%/%%GS_VERSION%%/doc/Ps2ps2.htm
%%DATADIR%%/%%GS_VERSION%%/doc/Psfiles.htm
%%DATADIR%%/%%GS_VERSION%%/doc/Readme.htm
%%DATADIR%%/%%GS_VERSION%%/doc/Release.htm
%%DATADIR%%/%%GS_VERSION%%/doc/Source.htm
%%DATADIR%%/%%GS_VERSION%%/doc/Unix-lpr.htm
%%DATADIR%%/%%GS_VERSION%%/doc/Use.htm
%%DATADIR%%/%%GS_VERSION%%/doc/WhatIsGS.htm
%%DATADIR%%/%%GS_VERSION%%/doc/Xfonts.htm
%%DATADIR%%/%%GS_VERSION%%/doc/gs.css
%%DATADIR%%/%%GS_VERSION%%/doc/gs-vms.hlp
%%DATADIR%%/%%GS_VERSION%%/doc/gsdoc.el
%%DATADIR%%/%%GS_VERSION%%/doc/index.html
%%DATADIR%%/%%GS_VERSION%%/doc/pscet_status.txt
%%DATADIR%%/%%GS_VERSION%%/doc/thirdparty.htm
%%DATADIR%%/%%GS_VERSION%%/examples/cjk/all_ac1.ps
%%DATADIR%%/%%GS_VERSION%%/examples/cjk/all_aj1.ps
%%DATADIR%%/%%GS_VERSION%%/examples/cjk/all_ak1.ps
@ -335,7 +344,10 @@ lib/libgs.so.%%GS_VERSION%%
%%DATADIR%%/%%GS_VERSION%%/examples/grayalph.ps
%%DATADIR%%/%%GS_VERSION%%/examples/ridt91.eps
%%DATADIR%%/%%GS_VERSION%%/examples/snowflak.ps
%%DATADIR%%/%%GS_VERSION%%/examples/text_graph_image_cmyk_rgb.pdf
%%DATADIR%%/%%GS_VERSION%%/examples/text_graphic_image.pdf
%%DATADIR%%/%%GS_VERSION%%/examples/tiger.eps
%%DATADIR%%/%%GS_VERSION%%/examples/transparency_example.ps
%%DATADIR%%/%%GS_VERSION%%/examples/vasarely.ps
%%DATADIR%%/%%GS_VERSION%%/examples/waterfal.ps
%%DATADIR%%/%%GS_VERSION%%/Resource/Init/FAPIcidfmap
@ -420,7 +432,6 @@ lib/libgs.so.%%GS_VERSION%%
%%DATADIR%%/%%GS_VERSION%%/lib/cid2code.ps
%%DATADIR%%/%%GS_VERSION%%/lib/decrypt.ps
%%DATADIR%%/%%GS_VERSION%%/lib/docie.ps
%%DATADIR%%/%%GS_VERSION%%/lib/dumphint.ps
%%DATADIR%%/%%GS_VERSION%%/lib/font2c.ps
%%DATADIR%%/%%GS_VERSION%%/lib/font2pcl.ps
%%DATADIR%%/%%GS_VERSION%%/lib/gslp.ps