Update to cURL 7.15.5 and integrate Scot Hetzel's patch for
really making OpenSSL support optional. Now OpenSSL and GnuTLS are on level ground, both controlled by the OPTIONS setting. Fortunately, it turned out that the curl_multi_socket() API change does not affect any of the ports that use ftp/curl. PR: 102871, 103126 Submitted by: pav, vd, Scot Hetzel <swhetzel@gmail.com>
This commit is contained in:
parent
223b0801dd
commit
612f6589b5
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=173317
@ -6,7 +6,7 @@
|
||||
#
|
||||
|
||||
PORTNAME= curl
|
||||
PORTVERSION= 7.15.4
|
||||
PORTVERSION= 7.15.5
|
||||
CATEGORIES= ftp ipv6 www
|
||||
MASTER_SITES= http://curl.haxx.se/download/ \
|
||||
${MASTER_SITE_SOURCEFORGE} \
|
||||
@ -24,10 +24,10 @@ MAN3= curl_easy_cleanup.3 curl_easy_duphandle.3 \
|
||||
curl_easy_init.3 curl_easy_perform.3 curl_easy_reset.3 \
|
||||
curl_easy_setopt.3 curl_easy_strerror.3 curl_easy_unescape.3 \
|
||||
curl_escape.3 \
|
||||
curl_unescape.3 curl_formadd.3 curl_formfree.3 curl_free.3 \
|
||||
curl_unescape.3 curl_formadd.3 curl_formget.3 curl_formfree.3 curl_free.3 \
|
||||
curl_getdate.3 curl_getenv.3 curl_global_init.3 \
|
||||
curl_global_init_mem.3 curl_global_cleanup.3 curl_mprintf.3 \
|
||||
curl_multi_add_handle.3 curl_multi_cleanup.3 \
|
||||
curl_multi_add_handle.3 curl_multi_assign.3 curl_multi_cleanup.3 \
|
||||
curl_multi_fdset.3 curl_multi_info_read.3 curl_multi_init.3 \
|
||||
curl_multi_perform.3 curl_multi_remove_handle.3 \
|
||||
curl_multi_setopt.3 curl_multi_socket.3 \
|
||||
@ -38,7 +38,7 @@ MAN3= curl_easy_cleanup.3 curl_easy_duphandle.3 \
|
||||
curl_version_info.3 libcurl.3 libcurl-easy.3 libcurl-errors.3 \
|
||||
libcurl-multi.3 libcurl-share.3 libcurl-tutorial.3
|
||||
|
||||
INSTALLS_SHLIB= yes
|
||||
USE_LDCONFIG= yes
|
||||
SHLIB_VER= 3
|
||||
|
||||
MAKE_ENV= SHLIB_VER="${SHLIB_VER}"
|
||||
@ -51,23 +51,20 @@ CONFIGURE_ARGS= --mandir=${PREFIX}/man
|
||||
|
||||
OPTIONS= CARES "Asynchronous DNS resolution via c-ares" off \
|
||||
CURL_DEBUG "Enable curl diagnostic output" off \
|
||||
GNUTLS "Use GNU TLS if WITHOUT_SSL is specified" off \
|
||||
GNUTLS "Use GNU TLS if OPENSSL is OFF" off \
|
||||
IPV6 "IPv6 support" on \
|
||||
KERBEROS4 "Kerberos 4 authentication" off \
|
||||
LIBIDN "Internationalized Domain Names via libidn" off \
|
||||
NTLM "NTLM authentication" off
|
||||
|
||||
.if !defined(WITHOUT_SSL)
|
||||
USE_OPENSSL= yes
|
||||
.endif
|
||||
NTLM "NTLM authentication" off \
|
||||
OPENSSL "OpenSSL support" on
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if defined(WITH_GNUTLS) && !defined(WITHOUT_SSL)
|
||||
IGNORE= may only use GNU TLS if WITHOUT_SSL is defined
|
||||
.if defined(WITH_GNUTLS) && defined(WITH_OPENSSL)
|
||||
IGNORE= may only use GNU TLS if OpenSSL support is disabled
|
||||
.endif
|
||||
|
||||
.if defined(WITH_NTLM) && defined(WITHOUT_SSL)
|
||||
.if defined(WITH_NTLM) && !defined(WITH_OPENSSL)
|
||||
IGNORE= only supports NTLM with OpenSSL
|
||||
.endif
|
||||
|
||||
@ -75,7 +72,8 @@ IGNORE= only supports NTLM with OpenSSL
|
||||
IGNORE= does not support both c-ares and IPv6 - disable one of them
|
||||
.endif
|
||||
|
||||
.if !defined(WITHOUT_SSL)
|
||||
.if !defined(WITHOUT_OPENSSL)
|
||||
.include "${PORTSDIR}/Mk/bsd.openssl.mk"
|
||||
CONFIGURE_ARGS+= --with-ssl=${OPENSSLBASE}
|
||||
.else
|
||||
CONFIGURE_ARGS+= --without-ssl
|
||||
@ -95,7 +93,7 @@ CONFIGURE_ARGS+=--with-gnutls=${LOCALBASE}
|
||||
CONFIGURE_ARGS+=--without-gnutls
|
||||
.endif
|
||||
|
||||
.if !defined(WITHOUT_SSL) || defined(WITH_GNUTLS)
|
||||
.if defined(WITH_OPENSSL) || defined(WITH_GNUTLS)
|
||||
PLIST_SUB+= SSL=""
|
||||
.else
|
||||
PLIST_SUB+= SSL="@comment "
|
||||
|
@ -1,3 +1,3 @@
|
||||
MD5 (curl-7.15.4.tar.bz2) = d9345a55c8bc67eafcd37fa1b728e00e
|
||||
SHA256 (curl-7.15.4.tar.bz2) = 11521127e175eb633c046a2c6ed11f97e81816d3aec9e8cac560763457a8e623
|
||||
SIZE (curl-7.15.4.tar.bz2) = 1519792
|
||||
MD5 (curl-7.15.5.tar.bz2) = 594142c7d53bbdd988e8cef6354eeeff
|
||||
SHA256 (curl-7.15.5.tar.bz2) = 2980815e53f4caeafc5e35d183d9379bcaaec49f759be1a4ac628cfb6c392fe0
|
||||
SIZE (curl-7.15.5.tar.bz2) = 1543007
|
||||
|
@ -1,15 +0,0 @@
|
||||
--- ltmain.sh.orig Wed Dec 10 15:20:29 2003
|
||||
+++ ltmain.sh Wed Dec 10 15:20:39 2003
|
||||
@@ -5425,10 +5425,12 @@
|
||||
fi
|
||||
|
||||
# Install the pseudo-library for information purposes.
|
||||
+ if /usr/bin/false ; then
|
||||
name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
|
||||
instname="$dir/$name"i
|
||||
$show "$install_prog $instname $destdir/$name"
|
||||
$run eval "$install_prog $instname $destdir/$name" || exit $?
|
||||
+ fi
|
||||
|
||||
# Maybe install the static library, too.
|
||||
test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"
|
@ -9,6 +9,7 @@ include/curl/stdcheaders.h
|
||||
include/curl/types.h
|
||||
@dirrm include/curl
|
||||
lib/libcurl.a
|
||||
lib/libcurl.la
|
||||
lib/libcurl.so
|
||||
lib/libcurl.so.%%SHLIB_VER%%
|
||||
libdata/pkgconfig/libcurl.pc
|
||||
@ -129,6 +130,9 @@ libdata/pkgconfig/libcurl.pc
|
||||
%%PORTDOCS%%%%DOCSDIR%%/libcurl/curl_formfree.3
|
||||
%%PORTDOCS%%%%DOCSDIR%%/libcurl/curl_formfree.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/libcurl/curl_formfree.pdf
|
||||
%%PORTDOCS%%%%DOCSDIR%%/libcurl/curl_formget.3
|
||||
%%PORTDOCS%%%%DOCSDIR%%/libcurl/curl_formget.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/libcurl/curl_formget.pdf
|
||||
%%PORTDOCS%%%%DOCSDIR%%/libcurl/curl_free.3
|
||||
%%PORTDOCS%%%%DOCSDIR%%/libcurl/curl_free.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/libcurl/curl_free.pdf
|
||||
@ -153,6 +157,9 @@ libdata/pkgconfig/libcurl.pc
|
||||
%%PORTDOCS%%%%DOCSDIR%%/libcurl/curl_multi_add_handle.3
|
||||
%%PORTDOCS%%%%DOCSDIR%%/libcurl/curl_multi_add_handle.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/libcurl/curl_multi_add_handle.pdf
|
||||
%%PORTDOCS%%%%DOCSDIR%%/libcurl/curl_multi_assign.3
|
||||
%%PORTDOCS%%%%DOCSDIR%%/libcurl/curl_multi_assign.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/libcurl/curl_multi_assign.pdf
|
||||
%%PORTDOCS%%%%DOCSDIR%%/libcurl/curl_multi_cleanup.3
|
||||
%%PORTDOCS%%%%DOCSDIR%%/libcurl/curl_multi_cleanup.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/libcurl/curl_multi_cleanup.pdf
|
||||
|
Loading…
Reference in New Issue
Block a user