New port: devel/py-minio: Minio library for Amazon S3 compatible cloud storage

PR:		226877
Submitted by:	jhixson@gmail.com
This commit is contained in:
Yuri Victorovich 2018-03-23 20:01:36 +00:00
parent 8d5bc3ff00
commit 60cfc6b9fa
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=465401
5 changed files with 42 additions and 0 deletions

View File

@ -4615,6 +4615,7 @@
SUBDIR += py-microversion-parse
SUBDIR += py-mimeparse
SUBDIR += py-minimongo
SUBDIR += py-minio
SUBDIR += py-mock
SUBDIR += py-mongoengine
SUBDIR += py-mongokit

23
devel/py-minio/Makefile Normal file
View File

@ -0,0 +1,23 @@
# $FreeBSD$
PORTNAME= minio
DISTVERSION= 3.0.4
CATEGORIES= devel python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= jhixson@gmail.com
COMMENT= Minio library for Amazon S3 compatible cloud storage
LICENSE= APACHE20
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}certifi>=0:security/py-certifi@${FLAVOR} \
${PYTHON_PKGNAMEPREFIX}dateutil>0:devel/py-dateutil@${FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pytz>=0:devel/py-pytz@${FLAVOR} \
${PYTHON_PKGNAMEPREFIX}urllib3>0:net/py-urllib3@${FLAVOR}
USES= python
USE_PYTHON= distutils autoplist
NO_ARCH= yes
.include <bsd.port.mk>

3
devel/py-minio/distinfo Normal file
View File

@ -0,0 +1,3 @@
TIMESTAMP = 1521833363
SHA256 (minio-3.0.4.tar.gz) = 5d4d086726bb7800570a86a040c607793235e190299f0d18aa0d2277492f393b
SIZE (minio-3.0.4.tar.gz) = 42720

View File

@ -0,0 +1,11 @@
--- setup.py.orig 2018-03-23 19:57:54 UTC
+++ setup.py
@@ -64,7 +64,7 @@ setup(
packages=packages,
install_requires=requires,
tests_require=tests_requires,
- setup_requires=['nose>=1.0'],
+ #setup_requires=['nose>=1.0'],
license='Apache License 2.0',
classifiers=[
'Development Status :: 5 - Production/Stable',

4
devel/py-minio/pkg-descr Normal file
View File

@ -0,0 +1,4 @@
The Minio Python Client SDK provides simple APIs to access any Amazon
S3 compatible object storage server.
WWW: https://github.com/minio/minio-py