Update to signing-party 2.3

http://anonscm.debian.org/viewvc/pgp-tools/trunk/debian/changelog?view=markup
Remove patch that is now included upstream
This commit is contained in:
Johan van Selst 2016-04-27 12:47:35 +00:00
parent 94f4282f63
commit 60c378bdc7
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=414107
3 changed files with 3 additions and 18 deletions

View File

@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= signing-party
PORTVERSION= 2.2
PORTVERSION= 2.3
CATEGORIES= security
MASTER_SITES= ftp://ftp.stack.nl/pub/users/johans/signing-party/ \
DEBIAN

View File

@ -1,2 +1,2 @@
SHA256 (signing-party_2.2.orig.tar.gz) = ad5d06c6c58de17aee104b9cf2f3a954cd9b854e5a77c1a8b62cf0a67c63168f
SIZE (signing-party_2.2.orig.tar.gz) = 237612
SHA256 (signing-party_2.3.orig.tar.gz) = ea208ccfa7a430daeb9d6de1e49bad7cdb65b299a287f8b6fe5ce41cded0e7db
SIZE (signing-party_2.3.orig.tar.gz) = 196864

View File

@ -1,15 +0,0 @@
Avoid construct that only works in perl 5.20
--- caff/caff.orig 2015-04-27 21:19:22.000000000 +0200
+++ caff/caff 2015-04-27 21:19:28.000000000 +0200
@@ -714,7 +714,9 @@ sub readwrite_gpg($%) {
# ignore direct and dup handles
my @infhs = grep {defined $opts{$_} and !$handles->options($_)->{direct} and $handles->{$_} !~ /^[<>]&/} qw/stdin passphrase command/;
my @outfhs = grep {defined $handles->{$_} and !$handles->options($_)->{direct} and $handles->{$_} !~ /^[<>]&/} qw/stdout stderr status logger/;
- my %fh = reverse %$handles{@infhs, @outfhs};
+ my %fh;
+ $fh{$_} = $handles->{$_} foreach (@infhs, @outfhs);
+ %fh = reverse %fh;
my %offset = map {$_ => 0} @infhs;
my %output = map {$_ => ''} @outfhs;