sysutils/synergy: Update 2.0.0 -> 1.13.0
This commit is contained in:
parent
6322cb9ed9
commit
6096a8538f
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=559686
@ -2,9 +2,9 @@
|
||||
|
||||
PORTNAME= synergy
|
||||
DISTVERSIONPREFIX= v
|
||||
DISTVERSION= 2.0.0
|
||||
DISTVERSION= 1.13.0
|
||||
DISTVERSIONSUFFIX= -stable
|
||||
PORTREVISION= 4
|
||||
PORTEPOCH= 1
|
||||
CATEGORIES= sysutils
|
||||
|
||||
MAINTAINER= yuri@FreeBSD.org
|
||||
@ -13,22 +13,27 @@ COMMENT= Mouse and keyboard sharing utility
|
||||
LICENSE= GPLv2
|
||||
LICENSE_FILE= ${WRKSRC}/LICENSE
|
||||
|
||||
LIB_DEPENDS= libcurl.so:ftp/curl
|
||||
LIB_DEPENDS= libcurl.so:ftp/curl \
|
||||
libdns_sd.so:net/mDNSResponder
|
||||
|
||||
USES= cmake compiler:c++14-lang cpe ssl xorg
|
||||
USES= cmake compiler:c++14-lang cpe qt:5 ssl xorg
|
||||
CPE_VENDOR= synergy-foss
|
||||
USE_XORG= ice xtst x11 sm xext xinerama xrandr xi
|
||||
USE_QT= core network widgets buildtools_build linguisttools_build qmake_build
|
||||
|
||||
USE_GITHUB= yes
|
||||
GH_ACCOUNT= symless
|
||||
GH_PROJECT= synergy-core
|
||||
USE_XORG= ice xtst x11 sm xext xinerama xrandr xi
|
||||
GH_TUPLE= google:googletest:18f8200e3079b0e54fa00cb7ac55d4c39dcf6da6:google_googletest/ext/googletest
|
||||
|
||||
CONFLICTS= synergy-1
|
||||
|
||||
CMAKE_ARGS= -DSYNERGY_REVISION:STRING=${PORTVERSION:S/.//g}00000 # it expects a 7-digit hash
|
||||
CMAKE_ARGS= -DSYNERGY_REVISION:STRING=${PORTVERSION:S/.//g}0000 # it expects a 8-digit hash
|
||||
|
||||
CFLAGS+= -I${LOCALBASE}/include -L${LOCALBASE}/lib
|
||||
LDFLAGS+= -ldns_sd
|
||||
|
||||
MAKE_JOBS_UNSAFE=yes
|
||||
#MAKE_JOBS_UNSAFE=yes
|
||||
|
||||
PORTEXAMPLES= synergy.conf.example synergy.conf.example-basic \
|
||||
synergy.conf.example-advanced
|
||||
@ -41,11 +46,9 @@ post-patch:
|
||||
@${REINPLACE_CMD} -e 's|/etc/synergy.conf|${PREFIX}/etc/synergy.conf|' \
|
||||
${WRKSRC}/doc/synergys.man
|
||||
|
||||
do-install:
|
||||
.for f in synergyc synergys synergy-core
|
||||
${INSTALL_PROGRAM} ${BUILD_WRKSRC}/bin/${f} ${STAGEDIR}${PREFIX}/bin
|
||||
.endfor
|
||||
do-install: # https://github.com/symless/synergy-core/issues/6895
|
||||
.for f in synergyc synergys
|
||||
${INSTALL_PROGRAM} ${BUILD_WRKSRC}/bin/${f} ${STAGEDIR}${PREFIX}/bin
|
||||
${INSTALL_MAN} ${WRKSRC}/doc/${f}.man \
|
||||
${STAGEDIR}${MANPREFIX}/man/man1/${f}.1
|
||||
.endfor
|
||||
|
@ -1,3 +1,5 @@
|
||||
TIMESTAMP = 1519524199
|
||||
SHA256 (symless-synergy-core-v2.0.0-stable_GH0.tar.gz) = d4afbbde2c819da44588afbf66ebb3376494d627f6bc4efaf0144b3fb3a41905
|
||||
SIZE (symless-synergy-core-v2.0.0-stable_GH0.tar.gz) = 5892923
|
||||
TIMESTAMP = 1609366645
|
||||
SHA256 (symless-synergy-core-v1.13.0-stable_GH0.tar.gz) = a57989dd2d3ae30657f2b95cba3cae112c189f9bbbc3d1b25b3874859afeb94d
|
||||
SIZE (symless-synergy-core-v1.13.0-stable_GH0.tar.gz) = 8657662
|
||||
SHA256 (google-googletest-18f8200e3079b0e54fa00cb7ac55d4c39dcf6da6_GH0.tar.gz) = d518c1c146c5a87cdedbee8535a396f95d91e8b39baa539fd4c50bd62148d199
|
||||
SIZE (google-googletest-18f8200e3079b0e54fa00cb7ac55d4c39dcf6da6_GH0.tar.gz) = 876756
|
||||
|
@ -1,11 +0,0 @@
|
||||
--- CMakeLists.txt.orig 2018-02-25 02:25:11 UTC
|
||||
+++ CMakeLists.txt
|
||||
@@ -299,7 +299,7 @@ elseif (${CMAKE_SYSTEM_NAME} MATCHES "Da
|
||||
${OPENSSL_ROOT}/lib/libssl.a
|
||||
${OPENSSL_ROOT}/lib/libcrypto.a
|
||||
)
|
||||
-elseif (${CMAKE_SYSTEM_NAME} MATCHES "Linux")
|
||||
+elseif (${CMAKE_SYSTEM_NAME} MATCHES "Linux|.*BSD")
|
||||
set (OPENSSL_LIBS ssl crypto)
|
||||
else()
|
||||
message (FATAL_ERROR "Couldn't find OpenSSL")
|
@ -1,9 +0,0 @@
|
||||
--- src/lib/arch/CMakeLists.txt.orig 2018-02-25 02:17:23 UTC
|
||||
+++ src/lib/arch/CMakeLists.txt
|
||||
@@ -40,5 +40,5 @@ endif()
|
||||
add_library(arch STATIC ${sources})
|
||||
|
||||
if (UNIX)
|
||||
- target_link_libraries(arch dl ${libs})
|
||||
+ target_link_libraries(arch ${CMAKE_DL_LIBS} ${libs})
|
||||
endif()
|
@ -1,11 +0,0 @@
|
||||
--- src/lib/net/SecureSocket.cpp.orig 2018-03-01 20:07:30 UTC
|
||||
+++ src/lib/net/SecureSocket.cpp
|
||||
@@ -807,7 +807,7 @@ SecureSocket::showSecureCipherInfo()
|
||||
showCipherStackDesc(sStack);
|
||||
}
|
||||
|
||||
-#if OPENSSL_VERSION_NUMBER < 0x10100000L
|
||||
+#if OPENSSL_VERSION_NUMBER < 0x10100000L || defined(LIBRESSL_VERSION_NUMBER)
|
||||
// m_ssl->m_ssl->session->ciphers is not forward compatable,
|
||||
// In future release of OpenSSL, it's not visible,
|
||||
STACK_OF(SSL_CIPHER) * cStack = m_ssl->m_ssl->session->ciphers;
|
@ -1,6 +1,5 @@
|
||||
bin/synergyc
|
||||
bin/synergys
|
||||
bin/synergy-core
|
||||
man/man1/synergyc.1.gz
|
||||
man/man1/synergys.1.gz
|
||||
@sample etc/synergy.conf.sample
|
||||
|
Loading…
Reference in New Issue
Block a user