- Update osmium to 2.10.3 and rename to libosmium
This commit is contained in:
parent
c6575e46c5
commit
603e165af1
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=426943
1
MOVED
1
MOVED
@ -8806,3 +8806,4 @@ devel/extra-cmake-modules|devel/kf5-extra-cmake-modules|2016-11-14|Renamed to ma
|
||||
net/vnc||2016-11-14|Has expired: Distfiles no longer available.
|
||||
sysutils/gosa||2016-11-20|Has expired: this version of gosa cannot be fixed (requires PHP < 5.4)
|
||||
security/krb5-112||2016-11-20|Has expired: EOL twelve months after release of krb5-1.14
|
||||
astro/osmium|astro/libosmium|2016-11-23|Rename according to upstream
|
||||
|
@ -34,6 +34,7 @@
|
||||
SUBDIR += libgal
|
||||
SUBDIR += libkgeomap
|
||||
SUBDIR += libnova
|
||||
SUBDIR += libosmium
|
||||
SUBDIR += libosmpbf
|
||||
SUBDIR += luna
|
||||
SUBDIR += marble
|
||||
@ -45,7 +46,6 @@
|
||||
SUBDIR += nightfall
|
||||
SUBDIR += opencpn
|
||||
SUBDIR += openuniverse
|
||||
SUBDIR += osmium
|
||||
SUBDIR += osmosis
|
||||
SUBDIR += p5-Astro
|
||||
SUBDIR += p5-Astro-ADS
|
||||
|
41
astro/libosmium/Makefile
Normal file
41
astro/libosmium/Makefile
Normal file
@ -0,0 +1,41 @@
|
||||
# Created by: Dmitry Marakasov <amdmi3@FreeBSD.org>
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= libosmium
|
||||
PORTVERSION= 2.10.3
|
||||
DISTVERSIONPREFIX= v
|
||||
CATEGORIES= astro geography devel
|
||||
|
||||
MAINTAINER= amdmi3@FreeBSD.org
|
||||
COMMENT= Fast and flexible C++ library for working with OpenStreetMap data
|
||||
|
||||
LICENSE= BSL
|
||||
LICENSE_FILE= ${WRKSRC}/LICENSE.txt
|
||||
|
||||
LIB_DEPENDS= libgdal.so:graphics/gdal \
|
||||
libboost_regex.so:devel/boost-libs \
|
||||
libgeos.so:graphics/geos \
|
||||
libexpat.so:textproc/expat2
|
||||
BUILD_DEPENDS= sparsehash>=0:devel/sparsehash
|
||||
|
||||
USE_GITHUB= yes
|
||||
GH_ACCOUNT= osmcode
|
||||
|
||||
USES= cmake compiler:c++11-lib
|
||||
CMAKE_ARGS= -DBUILD_EXAMPLES:BOOL=OFF
|
||||
|
||||
# though it build tests, the library itself it header-only
|
||||
NO_ARCH= yes
|
||||
|
||||
PORTDOCS= *
|
||||
|
||||
OPTIONS_DEFINE= TEST DOCS
|
||||
OPTIONS_DEFAULT= TEST
|
||||
TEST_TEST_TARGET= test
|
||||
TEST_CMAKE_BOOL= BUILD_TESTING
|
||||
|
||||
post-install-DOCS-on:
|
||||
@${MKDIR} ${STAGEDIR}${DOCSDIR}
|
||||
${INSTALL_DATA} ${WRKSRC}/CHANGELOG.md ${WRKSRC}/README.md ${STAGEDIR}${DOCSDIR}
|
||||
|
||||
.include <bsd.port.mk>
|
3
astro/libosmium/distinfo
Normal file
3
astro/libosmium/distinfo
Normal file
@ -0,0 +1,3 @@
|
||||
TIMESTAMP = 1479910332
|
||||
SHA256 (osmcode-libosmium-v2.10.3_GH0.tar.gz) = 9254a276d5e2c1b172c3bdd11d284f3ef5ffcfc296e685c57e59233d641fd229
|
||||
SIZE (osmcode-libosmium-v2.10.3_GH0.tar.gz) = 428643
|
13
astro/libosmium/files/patch-include_osmium_util_endian.hpp
Normal file
13
astro/libosmium/files/patch-include_osmium_util_endian.hpp
Normal file
@ -0,0 +1,13 @@
|
||||
--- include/osmium/util/endian.hpp.orig 2016-11-20 16:25:23 UTC
|
||||
+++ include/osmium/util/endian.hpp
|
||||
@@ -35,7 +35,9 @@ DEALINGS IN THE SOFTWARE.
|
||||
|
||||
// Windows is only available for little endian architectures
|
||||
// http://stackoverflow.com/questions/6449468/can-i-safely-assume-that-windows-installations-will-always-be-little-endian
|
||||
-#if !defined(_WIN32) && !defined(__APPLE__)
|
||||
+#if defined(__FreeBSD__)
|
||||
+# include <sys/endian.h>
|
||||
+#elif !defined(_WIN32) && !defined(__APPLE__)
|
||||
# include <endian.h>
|
||||
#else
|
||||
# define __LITTLE_ENDIAN 1234
|
11
astro/libosmium/pkg-descr
Normal file
11
astro/libosmium/pkg-descr
Normal file
@ -0,0 +1,11 @@
|
||||
The Osmium Library has extensive support for all types of OSM
|
||||
entities: nodes, ways, relations, and changesets. It allows reading
|
||||
from and writing to OSM files in XML and PBF formats, including
|
||||
change files and full history files. Osmium can store OSM data in
|
||||
memory and on disk in various formats and using various indexes.
|
||||
Its easy to use handler interface allows you to quickly write data
|
||||
filtering and conversion functions. Osmium can create WKT, WKB,
|
||||
OGR, GEOS and GeoJSON geometries for easy conversion into many GIS
|
||||
formats and it can assemble multipolygons from ways and relations.
|
||||
|
||||
WWW: http://osmcode.org/libosmium/
|
177
astro/libosmium/pkg-plist
Normal file
177
astro/libosmium/pkg-plist
Normal file
@ -0,0 +1,177 @@
|
||||
include/osmium/area/assembler.hpp
|
||||
include/osmium/area/detail/node_ref_segment.hpp
|
||||
include/osmium/area/detail/proto_ring.hpp
|
||||
include/osmium/area/detail/segment_list.hpp
|
||||
include/osmium/area/detail/vector.hpp
|
||||
include/osmium/area/multipolygon_collector.hpp
|
||||
include/osmium/area/problem_reporter.hpp
|
||||
include/osmium/area/problem_reporter_exception.hpp
|
||||
include/osmium/area/problem_reporter_ogr.hpp
|
||||
include/osmium/area/problem_reporter_stream.hpp
|
||||
include/osmium/area/stats.hpp
|
||||
include/osmium/builder/attr.hpp
|
||||
include/osmium/builder/builder.hpp
|
||||
include/osmium/builder/builder_helper.hpp
|
||||
include/osmium/builder/osm_object_builder.hpp
|
||||
include/osmium/diff_handler.hpp
|
||||
include/osmium/diff_iterator.hpp
|
||||
include/osmium/diff_visitor.hpp
|
||||
include/osmium/dynamic_handler.hpp
|
||||
include/osmium/experimental/flex_reader.hpp
|
||||
include/osmium/fwd.hpp
|
||||
include/osmium/geom/coordinates.hpp
|
||||
include/osmium/geom/factory.hpp
|
||||
include/osmium/geom/geojson.hpp
|
||||
include/osmium/geom/geos.hpp
|
||||
include/osmium/geom/haversine.hpp
|
||||
include/osmium/geom/mercator_projection.hpp
|
||||
include/osmium/geom/ogr.hpp
|
||||
include/osmium/geom/projection.hpp
|
||||
include/osmium/geom/rapid_geojson.hpp
|
||||
include/osmium/geom/relations.hpp
|
||||
include/osmium/geom/tile.hpp
|
||||
include/osmium/geom/util.hpp
|
||||
include/osmium/geom/wkb.hpp
|
||||
include/osmium/geom/wkt.hpp
|
||||
include/osmium/handler.hpp
|
||||
include/osmium/handler/chain.hpp
|
||||
include/osmium/handler/check_order.hpp
|
||||
include/osmium/handler/disk_store.hpp
|
||||
include/osmium/handler/dump.hpp
|
||||
include/osmium/handler/node_locations_for_ways.hpp
|
||||
include/osmium/handler/object_relations.hpp
|
||||
include/osmium/index/bool_vector.hpp
|
||||
include/osmium/index/detail/create_map_with_fd.hpp
|
||||
include/osmium/index/detail/mmap_vector_anon.hpp
|
||||
include/osmium/index/detail/mmap_vector_base.hpp
|
||||
include/osmium/index/detail/mmap_vector_file.hpp
|
||||
include/osmium/index/detail/tmpfile.hpp
|
||||
include/osmium/index/detail/vector_map.hpp
|
||||
include/osmium/index/detail/vector_multimap.hpp
|
||||
include/osmium/index/id_set.hpp
|
||||
include/osmium/index/index.hpp
|
||||
include/osmium/index/map.hpp
|
||||
include/osmium/index/map/all.hpp
|
||||
include/osmium/index/map/dense_file_array.hpp
|
||||
include/osmium/index/map/dense_mem_array.hpp
|
||||
include/osmium/index/map/dense_mmap_array.hpp
|
||||
include/osmium/index/map/dummy.hpp
|
||||
include/osmium/index/map/sparse_file_array.hpp
|
||||
include/osmium/index/map/sparse_mem_array.hpp
|
||||
include/osmium/index/map/sparse_mem_map.hpp
|
||||
include/osmium/index/map/sparse_mem_table.hpp
|
||||
include/osmium/index/map/sparse_mmap_array.hpp
|
||||
include/osmium/index/multimap.hpp
|
||||
include/osmium/index/multimap/all.hpp
|
||||
include/osmium/index/multimap/hybrid.hpp
|
||||
include/osmium/index/multimap/sparse_file_array.hpp
|
||||
include/osmium/index/multimap/sparse_mem_array.hpp
|
||||
include/osmium/index/multimap/sparse_mem_multimap.hpp
|
||||
include/osmium/index/multimap/sparse_mmap_array.hpp
|
||||
include/osmium/index/node_locations_map.hpp
|
||||
include/osmium/io/any_compression.hpp
|
||||
include/osmium/io/any_input.hpp
|
||||
include/osmium/io/any_output.hpp
|
||||
include/osmium/io/bzip2_compression.hpp
|
||||
include/osmium/io/compression.hpp
|
||||
include/osmium/io/debug_output.hpp
|
||||
include/osmium/io/detail/debug_output_format.hpp
|
||||
include/osmium/io/detail/input_format.hpp
|
||||
include/osmium/io/detail/o5m_input_format.hpp
|
||||
include/osmium/io/detail/opl_input_format.hpp
|
||||
include/osmium/io/detail/opl_output_format.hpp
|
||||
include/osmium/io/detail/opl_parser_functions.hpp
|
||||
include/osmium/io/detail/output_format.hpp
|
||||
include/osmium/io/detail/pbf.hpp
|
||||
include/osmium/io/detail/pbf_decoder.hpp
|
||||
include/osmium/io/detail/pbf_input_format.hpp
|
||||
include/osmium/io/detail/pbf_output_format.hpp
|
||||
include/osmium/io/detail/protobuf_tags.hpp
|
||||
include/osmium/io/detail/queue_util.hpp
|
||||
include/osmium/io/detail/read_thread.hpp
|
||||
include/osmium/io/detail/read_write.hpp
|
||||
include/osmium/io/detail/string_table.hpp
|
||||
include/osmium/io/detail/string_util.hpp
|
||||
include/osmium/io/detail/write_thread.hpp
|
||||
include/osmium/io/detail/xml_input_format.hpp
|
||||
include/osmium/io/detail/xml_output_format.hpp
|
||||
include/osmium/io/detail/zlib.hpp
|
||||
include/osmium/io/error.hpp
|
||||
include/osmium/io/file.hpp
|
||||
include/osmium/io/file_compression.hpp
|
||||
include/osmium/io/file_format.hpp
|
||||
include/osmium/io/gzip_compression.hpp
|
||||
include/osmium/io/header.hpp
|
||||
include/osmium/io/input_iterator.hpp
|
||||
include/osmium/io/o5m_input.hpp
|
||||
include/osmium/io/opl_input.hpp
|
||||
include/osmium/io/opl_output.hpp
|
||||
include/osmium/io/output_iterator.hpp
|
||||
include/osmium/io/overwrite.hpp
|
||||
include/osmium/io/pbf_input.hpp
|
||||
include/osmium/io/pbf_output.hpp
|
||||
include/osmium/io/reader.hpp
|
||||
include/osmium/io/reader_iterator.hpp
|
||||
include/osmium/io/writer.hpp
|
||||
include/osmium/io/writer_options.hpp
|
||||
include/osmium/io/xml_input.hpp
|
||||
include/osmium/io/xml_output.hpp
|
||||
include/osmium/memory/buffer.hpp
|
||||
include/osmium/memory/collection.hpp
|
||||
include/osmium/memory/item.hpp
|
||||
include/osmium/memory/item_iterator.hpp
|
||||
include/osmium/object_pointer_collection.hpp
|
||||
include/osmium/opl.hpp
|
||||
include/osmium/osm.hpp
|
||||
include/osmium/osm/area.hpp
|
||||
include/osmium/osm/box.hpp
|
||||
include/osmium/osm/changeset.hpp
|
||||
include/osmium/osm/crc.hpp
|
||||
include/osmium/osm/diff_object.hpp
|
||||
include/osmium/osm/entity.hpp
|
||||
include/osmium/osm/entity_bits.hpp
|
||||
include/osmium/osm/item_type.hpp
|
||||
include/osmium/osm/location.hpp
|
||||
include/osmium/osm/node.hpp
|
||||
include/osmium/osm/node_ref.hpp
|
||||
include/osmium/osm/node_ref_list.hpp
|
||||
include/osmium/osm/object.hpp
|
||||
include/osmium/osm/object_comparisons.hpp
|
||||
include/osmium/osm/relation.hpp
|
||||
include/osmium/osm/segment.hpp
|
||||
include/osmium/osm/tag.hpp
|
||||
include/osmium/osm/timestamp.hpp
|
||||
include/osmium/osm/types.hpp
|
||||
include/osmium/osm/types_from_string.hpp
|
||||
include/osmium/osm/undirected_segment.hpp
|
||||
include/osmium/osm/way.hpp
|
||||
include/osmium/relations/collector.hpp
|
||||
include/osmium/relations/detail/member_meta.hpp
|
||||
include/osmium/relations/detail/relation_meta.hpp
|
||||
include/osmium/tags/filter.hpp
|
||||
include/osmium/tags/regex_filter.hpp
|
||||
include/osmium/tags/taglist.hpp
|
||||
include/osmium/thread/function_wrapper.hpp
|
||||
include/osmium/thread/pool.hpp
|
||||
include/osmium/thread/queue.hpp
|
||||
include/osmium/thread/util.hpp
|
||||
include/osmium/util/cast.hpp
|
||||
include/osmium/util/compatibility.hpp
|
||||
include/osmium/util/config.hpp
|
||||
include/osmium/util/delta.hpp
|
||||
include/osmium/util/double.hpp
|
||||
include/osmium/util/endian.hpp
|
||||
include/osmium/util/endian.hpp.orig
|
||||
include/osmium/util/file.hpp
|
||||
include/osmium/util/iterator.hpp
|
||||
include/osmium/util/memory.hpp
|
||||
include/osmium/util/memory_mapping.hpp
|
||||
include/osmium/util/minmax.hpp
|
||||
include/osmium/util/misc.hpp
|
||||
include/osmium/util/options.hpp
|
||||
include/osmium/util/progress_bar.hpp
|
||||
include/osmium/util/string.hpp
|
||||
include/osmium/util/timer.hpp
|
||||
include/osmium/util/verbose_output.hpp
|
||||
include/osmium/version.hpp
|
||||
include/osmium/visitor.hpp
|
@ -1,61 +0,0 @@
|
||||
# Created by: Dmitry Marakasov <amdmi3@FreeBSD.org>
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= osmium
|
||||
PORTVERSION= git20130522
|
||||
PORTREVISION= 15
|
||||
CATEGORIES= astro geography devel
|
||||
|
||||
MAINTAINER= amdmi3@FreeBSD.org
|
||||
COMMENT= C++/Javascript framework for working with OSM files
|
||||
|
||||
LICENSE= GPLv3 LGPL3
|
||||
LICENSE_COMB= dual
|
||||
|
||||
LIB_DEPENDS= libgdal.so:graphics/gdal \
|
||||
libboost_regex.so:devel/boost-libs \
|
||||
libsqlite3.so:databases/sqlite3 \
|
||||
libexpat.so:textproc/expat2 \
|
||||
libgeos.so:graphics/geos \
|
||||
libprotobuf.so:devel/protobuf
|
||||
BUILD_DEPENDS= sparsehash>=2.0.2:devel/sparsehash
|
||||
RUN_DEPENDS= sparsehash>=2.0.2:devel/sparsehash
|
||||
|
||||
USE_GITHUB= yes
|
||||
GH_ACCOUNT= joto
|
||||
GH_TAGNAME= 1a5bb26
|
||||
|
||||
CXXFLAGS+= -I${LOCALBASE}/include \
|
||||
-L${LOCALBASE}/lib
|
||||
|
||||
NO_ARCH= yes
|
||||
PORTDOCS= *
|
||||
|
||||
OPTIONS_DEFINE= JAVASCRIPT DOXYGEN DOCS
|
||||
OPTIONS_DEFAULT=JAVASCRIPT
|
||||
JAVASCRIPT_DESC=Enable javascript support
|
||||
|
||||
JAVASCRIPT_LIB_DEPENDS= libv8.so:lang/v8 \
|
||||
libshp.so:devel/shapelib \
|
||||
libicuuc.so:devel/icu
|
||||
|
||||
DOXYGEN_IMPLIES= DOCS
|
||||
DOXYGEN_BUILD_DEPENDS= doxygen:devel/doxygen
|
||||
|
||||
do-build-DOXYGEN-on:
|
||||
cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} \
|
||||
${MAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKR_ARGS} doc
|
||||
|
||||
do-install:
|
||||
cd ${WRKSRC}/include && ${COPYTREE_SHARE} '${PORTNAME} ${PORTNAME}.hpp' \
|
||||
${STAGEDIR}${PREFIX}/include/
|
||||
${MKDIR} ${STAGEDIR}${DOCSDIR}
|
||||
${INSTALL_DATA} ${WRKSRC}/README ${WRKSRC}/THANKS \
|
||||
${WRKSRC}/NOTES_FOR_DEVELOPERS ${STAGEDIR}${DOCSDIR}/
|
||||
do-install-DOXYGEN-on:
|
||||
cd ${WRKSRC}/doc && ${COPYTREE_SHARE} html ${STAGEDIR}${DOCSDIR}/
|
||||
|
||||
do-test:
|
||||
cd ${WRKSRC}/test && ${SETENV} ${MAKE_ENV} ${SH} run_tests.sh
|
||||
|
||||
.include <bsd.port.mk>
|
@ -1,2 +0,0 @@
|
||||
SHA256 (joto-osmium-git20130522-1a5bb26_GH0.tar.gz) = 27f45cbf05d2f7de83452505d1bf5dbef22c1d413c97e327bdbfa706977e91e2
|
||||
SIZE (joto-osmium-git20130522-1a5bb26_GH0.tar.gz) = 149373
|
@ -1,15 +0,0 @@
|
||||
--- test/run_tests.sh.orig 2013-05-09 15:20:50 UTC
|
||||
+++ test/run_tests.sh
|
||||
@@ -10,8 +10,10 @@
|
||||
|
||||
set -e
|
||||
|
||||
-CXX="g++"
|
||||
-CXXFLAGS="-g -Wall -Wextra -Wredundant-decls -Wdisabled-optimization -pedantic -Wctor-dtor-privacy -Wnon-virtual-dtor -Woverloaded-virtual -Wsign-promo -Wno-long-long"
|
||||
+if [ -z "$CXX" ]; then
|
||||
+ CXX="g++"
|
||||
+fi
|
||||
+CXXFLAGS="$CXXFLAGS -g -Wall -Wextra -Wredundant-decls -Wdisabled-optimization -pedantic -Wctor-dtor-privacy -Wnon-virtual-dtor -Woverloaded-virtual -Wsign-promo -Wno-long-long"
|
||||
COMPILE="$CXX -I../include -I. $CXXFLAGS -o tests"
|
||||
|
||||
if [ "x$1" = "x-v" ]; then
|
@ -1,5 +0,0 @@
|
||||
Osmium is a C++ framework for working with OSM data files. Osmium
|
||||
can read OSM data in XML or binary format (PBF) and can call different
|
||||
handlers for each OSM object.
|
||||
|
||||
WWW: http://wiki.openstreetmap.org/wiki/Osmium
|
@ -1,79 +0,0 @@
|
||||
include/osmium.hpp
|
||||
include/osmium/debug.hpp
|
||||
include/osmium/export.hpp
|
||||
include/osmium/export/csv.hpp
|
||||
include/osmium/export/shapefile.hpp
|
||||
include/osmium/geometry.hpp
|
||||
include/osmium/geometry/from_way.hpp
|
||||
include/osmium/geometry/geos.hpp
|
||||
include/osmium/geometry/haversine.hpp
|
||||
include/osmium/geometry/linestring.hpp
|
||||
include/osmium/geometry/multipolygon.hpp
|
||||
include/osmium/geometry/null.hpp
|
||||
include/osmium/geometry/ogr.hpp
|
||||
include/osmium/geometry/ogr_multipolygon.hpp
|
||||
include/osmium/geometry/point.hpp
|
||||
include/osmium/geometry/polygon.hpp
|
||||
include/osmium/geometry/shplib.hpp
|
||||
include/osmium/handler.hpp
|
||||
include/osmium/handler/coordinates_for_ways.hpp
|
||||
include/osmium/handler/debug.hpp
|
||||
include/osmium/handler/endtime.hpp
|
||||
include/osmium/handler/find_bbox.hpp
|
||||
include/osmium/handler/progress.hpp
|
||||
include/osmium/handler/range_from_history.hpp
|
||||
include/osmium/input.hpp
|
||||
include/osmium/input/pbf.hpp
|
||||
include/osmium/input/xml.hpp
|
||||
include/osmium/javascript.hpp
|
||||
include/osmium/javascript/handler.hpp
|
||||
include/osmium/javascript/template.hpp
|
||||
include/osmium/javascript/unicode.hpp
|
||||
include/osmium/javascript/wrapper/export_csv.hpp
|
||||
include/osmium/javascript/wrapper/export_shapefile.hpp
|
||||
include/osmium/javascript/wrapper/geometry.hpp
|
||||
include/osmium/javascript/wrapper/osm.hpp
|
||||
include/osmium/javascript/wrapper/position.hpp
|
||||
include/osmium/multipolygon/assembler.hpp
|
||||
include/osmium/multipolygon/builder.hpp
|
||||
include/osmium/osm.hpp
|
||||
include/osmium/osm/area.hpp
|
||||
include/osmium/osm/bounds.hpp
|
||||
include/osmium/osm/meta.hpp
|
||||
include/osmium/osm/node.hpp
|
||||
include/osmium/osm/object.hpp
|
||||
include/osmium/osm/position.hpp
|
||||
include/osmium/osm/relation.hpp
|
||||
include/osmium/osm/relation_member.hpp
|
||||
include/osmium/osm/relation_member_list.hpp
|
||||
include/osmium/osm/segment.hpp
|
||||
include/osmium/osm/tag.hpp
|
||||
include/osmium/osm/tag_list.hpp
|
||||
include/osmium/osm/tag_ostream.hpp
|
||||
include/osmium/osm/types.hpp
|
||||
include/osmium/osm/undirected_segment.hpp
|
||||
include/osmium/osm/way.hpp
|
||||
include/osmium/osm/way_node.hpp
|
||||
include/osmium/osm/way_node_list.hpp
|
||||
include/osmium/osmfile.hpp
|
||||
include/osmium/output.hpp
|
||||
include/osmium/output/pbf.hpp
|
||||
include/osmium/output/xml.hpp
|
||||
include/osmium/relations/assembler.hpp
|
||||
include/osmium/relations/relation_info.hpp
|
||||
include/osmium/smart_ptr.hpp
|
||||
include/osmium/storage/byid.hpp
|
||||
include/osmium/storage/byid/fixed_array.hpp
|
||||
include/osmium/storage/byid/mmap_anon.hpp
|
||||
include/osmium/storage/byid/mmap_file.hpp
|
||||
include/osmium/storage/byid/sparse_table.hpp
|
||||
include/osmium/storage/byid/vector.hpp
|
||||
include/osmium/storage/objectstore.hpp
|
||||
include/osmium/tags/key_filter.hpp
|
||||
include/osmium/tags/key_value_filter.hpp
|
||||
include/osmium/tags/regex_filter.hpp
|
||||
include/osmium/tags/to_string.hpp
|
||||
include/osmium/utils/delta.hpp
|
||||
include/osmium/utils/filter_and_accumulate.hpp
|
||||
include/osmium/utils/stringtable.hpp
|
||||
include/osmium/utils/timestamp.hpp
|
Loading…
Reference in New Issue
Block a user