- Update to 0.6.2
PR: ports/128892 Submitted by: Yi-Jheng Lin <yzlin@cs.nctu.edu.tw> Approved by: Artyom Nosov <chip-set@mail.ru> (maintainer)
This commit is contained in:
parent
8e64067d36
commit
6030b27802
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=224339
@ -6,8 +6,7 @@
|
||||
#
|
||||
|
||||
PORTNAME= wput
|
||||
PORTVERSION= 0.6.1
|
||||
PORTREVISION= 2
|
||||
PORTVERSION= 0.6.2
|
||||
CATEGORIES= ftp
|
||||
MASTER_SITES= SF
|
||||
EXTRACT_SUFX= .tgz
|
||||
@ -15,40 +14,48 @@ EXTRACT_SUFX= .tgz
|
||||
MAINTAINER= chip-set@mail.ru
|
||||
COMMENT= Uploads files or directories to a ftpserver with support of resuming
|
||||
|
||||
LIB_DEPENDS= gnutls.26:${PORTSDIR}/security/gnutls
|
||||
|
||||
PORTDOCS= ABOUT-NLS COPYING ChangeLog INSTALL TODO
|
||||
PORTEXAMPLES= USAGE.examples USAGE.resumehandling USAGE.urlhandling \
|
||||
passwordfile wputrc
|
||||
|
||||
USE_GETTEXT= yes
|
||||
USE_AUTOTOOLS= autoconf:262
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ENV= LIBS="${LDFLAGS}"
|
||||
CONFIGURE_ENV= CFLAGS="-I${LOCALBASE}/include" \
|
||||
LDFLAGS="${LDFLAGS}" \
|
||||
LIBS="${LDFLAGS}"
|
||||
|
||||
OPTIONS= TLS "Enable TLS support" on \
|
||||
MEM_DEBUG "Enable memory debugging" off \
|
||||
DEBUG "Enable debug support" on
|
||||
OPTIONS= TLS "Enable TLS support" On \
|
||||
NLS "Native Language Support with gettext" On
|
||||
|
||||
MAN1= wput.1
|
||||
MAN1= wdel.1 wput.1
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if defined(WITHOUT_TLS)
|
||||
.if !defined(WITHOUT_TLS)
|
||||
LIB_DEPENDS+= gnutls.26:${PORTSDIR}/security/gnutls
|
||||
CONFIGURE_ARGS+= --with-ssl
|
||||
.else
|
||||
CONFIGURE_ARGS+= --without-ssl
|
||||
.endif
|
||||
.if defined(WITH_MEM_DEBUG)
|
||||
CONFIGURE_ARGS+= --enable-memdbg
|
||||
.endif
|
||||
.if defined(WITHOUT_DEBUG)
|
||||
CONFIGURE_ARGS+= --disable-g-switch
|
||||
|
||||
.if !defined(WITHOUT_NLS)
|
||||
USE_ICONV= yes
|
||||
USE_GETTEXT= yes
|
||||
CONFIGURE_ARGS+= --enable-nls \
|
||||
--with-libintl-prefix=${LOCALBASE} \
|
||||
--with-libiconv-prefix=${LOCALBASE}
|
||||
PLIST_SUB+= NLS=""
|
||||
.else
|
||||
CONFIGURE_ARGS+= --disable-nls --without-libiconv-prefix
|
||||
PLIST_SUB= NLS="@comment "
|
||||
.endif
|
||||
|
||||
pre-configure:
|
||||
@${REINPLACE_CMD} -e 's|malloc.h|stdlib.h|' ${WRKSRC}/src/socketlib.c
|
||||
@${REINPLACE_CMD} -e 's|malloc.h|stdlib.h|' \
|
||||
${WRKSRC}/src/memdbg.c \
|
||||
${WRKSRC}/src/socketlib.c
|
||||
|
||||
post-install:
|
||||
@${INSTALL_MAN} ${WRKSRC}/doc/${MAN1} ${MANPREFIX}/man/man1/
|
||||
@${INSTALL_MAN} ${MAN1:S,^,${WRKSRC}/doc/,} ${MANPREFIX}/man/man1/
|
||||
|
||||
.if !defined(NOPORTDOCS)
|
||||
@${INSTALL} -d ${DOCSDIR}
|
||||
|
@ -1,3 +1,3 @@
|
||||
MD5 (wput-0.6.1.tgz) = 92b41efed4db8eb4f3443c23bf7ceecf
|
||||
SHA256 (wput-0.6.1.tgz) = 67125acab1d520e5d2a0429cd9cf7fc379987f30d5bbed0b0e97b92b554fcc13
|
||||
SIZE (wput-0.6.1.tgz) = 312342
|
||||
MD5 (wput-0.6.2.tgz) = a14c4c13d91d04d6119bdc977e8a8bdf
|
||||
SHA256 (wput-0.6.2.tgz) = 229d8bb7d045ca1f54d68de23f1bc8016690dc0027a16586712594fbc7fad8c7
|
||||
SIZE (wput-0.6.2.tgz) = 368510
|
||||
|
@ -1,6 +1,14 @@
|
||||
--- Makefile.in.orig 2007-12-12 08:30:04.000000000 -0900
|
||||
+++ Makefile.in 2008-01-17 14:17:36.000000000 -0900
|
||||
@@ -9,7 +9,6 @@
|
||||
--- Makefile.in.orig 2008-09-27 12:31:23.000000000 +0200
|
||||
+++ Makefile.in 2008-12-17 17:12:36.000000000 +0100
|
||||
@@ -2,14 +2,13 @@
|
||||
PACKAGE = @PACKAGE@
|
||||
prefix = @prefix@
|
||||
datadir = $(prefix)/share
|
||||
-mandir = $(datadir)/man/man1
|
||||
+mandir = $(prefix)/man/man1
|
||||
exec_prefix = @exec_prefix@
|
||||
bindir=@bindir@
|
||||
|
||||
all clean:
|
||||
cd po && $(MAKE) $(MAKEDEFS) $@
|
||||
cd src && $(MAKE) $(MAKEDEFS) $@
|
||||
@ -8,17 +16,20 @@
|
||||
|
||||
win-clean:
|
||||
cd src && $(MAKE) $(MAKEDEFS) $@
|
||||
@@ -17,7 +16,6 @@
|
||||
install: all
|
||||
cd po && $(MAKE) $(MAKEDEFS) $@
|
||||
@@ -19,9 +18,7 @@
|
||||
mkdir -p $(bindir)
|
||||
mkdir -p $(mandir)
|
||||
install -m0755 wput $(bindir)
|
||||
- install -m0644 doc/wput.1.gz $(mandir)
|
||||
ln -s $(bindir)/wput $(bindir)/wdel
|
||||
- install -m0644 doc/wdel.1.gz $(mandir)
|
||||
@echo "----------------"
|
||||
@echo "Wput installed. See 'wput -h' or 'man wput' for usage information."
|
||||
@echo "Further documentation is located in the doc/USAGE.* files."
|
||||
@@ -27,5 +25,4 @@
|
||||
@echo "----------------"
|
||||
@echo "Wput and Wdel installed. See 'wput/wdel -h' or 'man wput/wdel' for"
|
||||
@echo "usage information."
|
||||
@@ -33,6 +30,4 @@
|
||||
uninstall:
|
||||
rm -f $(bindir)/wput
|
||||
rm -f $(bindir)/wdel
|
||||
- rm -f $(mandir)/wput.1.gz
|
||||
- rm -f $(mandir)/wdel.1.gz
|
||||
|
||||
|
@ -1,7 +1,15 @@
|
||||
bin/wdel
|
||||
bin/wput
|
||||
share/locale/de/LC_MESSAGES/wput.mo
|
||||
share/locale/it/LC_MESSAGES/wput.mo
|
||||
share/locale/nl/LC_MESSAGES/wput.mo
|
||||
share/locale/ru/LC_MESSAGES/wput.mo
|
||||
share/locale/tr/LC_MESSAGES/wput.mo
|
||||
share/locale/zh/LC_MESSAGES/wput.mo
|
||||
%%NLS%%share/locale/da/LC_MESSAGES/wput.mo
|
||||
%%NLS%%share/locale/de/LC_MESSAGES/wput.mo
|
||||
%%NLS%%share/locale/el/LC_MESSAGES/wput.mo
|
||||
%%NLS%%share/locale/es/LC_MESSAGES/wput.mo
|
||||
%%NLS%%share/locale/fi/LC_MESSAGES/wput.mo
|
||||
%%NLS%%share/locale/fr/LC_MESSAGES/wput.mo
|
||||
%%NLS%%share/locale/it/LC_MESSAGES/wput.mo
|
||||
%%NLS%%share/locale/nl/LC_MESSAGES/wput.mo
|
||||
%%NLS%%share/locale/pl/LC_MESSAGES/wput.mo
|
||||
%%NLS%%share/locale/ru/LC_MESSAGES/wput.mo
|
||||
%%NLS%%share/locale/sv/LC_MESSAGES/wput.mo
|
||||
%%NLS%%share/locale/tr/LC_MESSAGES/wput.mo
|
||||
%%NLS%%share/locale/zh/LC_MESSAGES/wput.mo
|
||||
|
Loading…
Reference in New Issue
Block a user