Upgrade to 1.3.12.

This commit is contained in:
Munechika SUMIKAWA 2000-07-19 16:17:01 +00:00
parent 6f7ab93684
commit 60200dd42a
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=30894
5 changed files with 73 additions and 23 deletions

View File

@ -6,7 +6,7 @@
#
PORTNAME= apache+ipv6
PORTVERSION= 1.3.11
PORTVERSION= 1.3.12
CATEGORIES= www ipv6
MASTER_SITES= http://www.apache.org/dist/ \
ftp://ftp.ccs.neu.edu/net/mirrors/ftp.apache.org/apache/dist/ \
@ -23,16 +23,14 @@ MASTER_SITES= http://www.apache.org/dist/ \
ftp://ftp.mtnranch.net/pub/apache/dist/ \
ftp://ftp.iodynamics.com/pub/mirror/apache/dist/ \
ftp://apache.nextpath.com/pub/apache/dist/
DISTNAME= apache_1.3.11
DISTNAME= apache_${PORTVERSION}
#put the below patch as patch-am
#PATCH_SITES= http://www.apache.org/info/css-security/
#PATCHFILES= apache_1.3.11_css_patch.txt
PATCH_SITES= ftp://ftp.kame.net/pub/kame/misc/
PATCHFILES= apache-1.3.11-v6-20000220a.diff.gz
PATCHFILES= apache-1.3.12-v6-20000524a.diff.gz
PATCH_DIST_STRIP= -p1
MAINTAINER= sumikawa@FreeBSD.org
Y2K= http://www.apache.org/docs/misc/FAQ.html#year2000
#
@ -79,6 +77,9 @@ pre-configure:
post-install:
@if [ ! -f ${PREFIX}/etc/rc.d/apache.sh ]; then \
${ECHO} "Installing ${PREFIX}/etc/rc.d/apache.sh startup file."; \
${INSTALL_SCRIPT} -m 751 ${FILESDIR}/apache.sh ${PREFIX}/etc/rc.d/apache.sh; \
${ECHO} "#!/bin/sh" > ${PREFIX}/etc/rc.d/apache.sh; \
${ECHO} "[ -x ${PREFIX}/sbin/apachectl ] && ${PREFIX}/sbin/apachectl start > /dev/null && ${ECHO} -n ' apache'" >> ${PREFIX}/etc/rc.d/apache.sh; \
${CHMOD} 751 ${PREFIX}/etc/rc.d/apache.sh; \
fi
.include <bsd.port.post.mk>

View File

@ -1,2 +1,2 @@
MD5 (apache_1.3.11.tar.gz) = 8e0e4c9b410d4d4c4f5832fc0662b9e1
MD5 (apache-1.3.11-v6-20000220a.diff.gz) = 70c4aaf1c79fa6d933e31b9e0a54e018
MD5 (apache_1.3.12.tar.gz) = de3ccff384b0d4ab94c3251cb85d49d2
MD5 (apache-1.3.12-v6-20000524a.diff.gz) = fd8f418724e916e862131f7b76ee1e47

View File

@ -1,6 +1,30 @@
--- conf/httpd.conf-dist.orig Thu May 6 00:17:59 1999
+++ conf/httpd.conf-dist Fri Sep 3 15:42:56 1999
@@ -467,7 +467,7 @@
--- conf/httpd.conf-dist.orig Mon Feb 21 08:30:46 2000
+++ conf/httpd.conf-dist Mon May 29 16:48:49 2000
@@ -354,7 +354,22 @@
# directory index. Separate multiple entries with spaces.
#
<IfModule mod_dir.c>
- DirectoryIndex index.html
+ <IfModule mod_php3.c>
+ <IfModule mod_php4.c>
+ DirectoryIndex index.php index.php3 index.html
+ </IfModule>
+ <IfModule !mod_php4.c>
+ DirectoryIndex index.php3 index.html
+ </IfModule>
+ </IfModule>
+ <IfModule !mod_php3.c>
+ <IfModule mod_php4.c>
+ DirectoryIndex index.php index.html
+ </IfModule>
+ <IfModule !mod_php4.c>
+ DirectoryIndex index.html
+ </IfModule>
+ </IfModule>
</IfModule>
#
@@ -473,7 +488,7 @@
# define per-<VirtualHost> access logfiles, transactions will be
# logged therein and *not* in this file.
#
@ -9,7 +33,7 @@
#
# If you would like to have agent and referer logfiles, uncomment the
@@ -480,7 +480,7 @@
@@ -486,7 +501,7 @@
# If you prefer a single logfile with access, agent, and referer information
# (Combined Logfile Format) you can use the following directive.
#
@ -18,3 +42,25 @@
#
# Optionally add a line containing the server version and virtual host
@@ -708,13 +723,17 @@
# For example, the PHP 3.x module (not part of the Apache distribution - see
# http://www.php.net) will typically use:
#
- #AddType application/x-httpd-php3 .php3
- #AddType application/x-httpd-php3-source .phps
+ <IfModule mod_php3.c>
+ AddType application/x-httpd-php3 .php3
+ AddType application/x-httpd-php3-source .php3s
+ </IfModule>
#
# And for PHP 4.x, use:
#
- #AddType application/x-httpd-php .php
- #AddType application/x-httpd-php-source .phps
+ <IfModule mod_php4.c>
+ AddType application/x-httpd-php .php
+ AddType application/x-httpd-php-source .phps
+ </IfModule>
AddType application/x-tar .tgz

View File

@ -1,15 +1,6 @@
Apache
Version 1.0 (and up)
What is it?
-----------
Apache is an HTTP server designed as a plug-in replacement for the NCSA
server version 1.3 (or 1.4). It fixes numerous bugs in the NCSA server and
includes many frequently requested new features, and has an API which
allows it to be extended to meet users' needs more easily.
Documentation
-------------
All the documentation is on-line on the WWW, via the URL http://www.apache.org
WWW: http://www.apache.org/

View File

@ -1,14 +1,19 @@
bin/dbmmanage
bin/htdigest
bin/htpasswd
@unexec if cmp -s %D/etc/apache/access.conf %D/etc/apache/access.conf.default; then rm -f %D/etc/apache/access.conf; fi
etc/apache/access.conf.default
@exec [ ! -f %B/access.conf ] && cp %B/%f %B/access.conf
@unexec if cmp -s %D/etc/apache/httpd.conf %D/etc/apache/httpd.conf.default; then rm -f %D/etc/apache/httpd.conf; fi
etc/apache/httpd.conf.default
@exec [ ! -f %B/httpd.conf ] && cp %B/%f %B/httpd.conf
@unexec if cmp -s %D/etc/apache/magic %D/etc/apache/magic.default; then rm -f %D/etc/apache/magic; fi
etc/apache/magic.default
@exec [ ! -f %B/magic ] && cp %B/%f %B/magic
@unexec if cmp -s %D/etc/apache/mime.types %D/etc/apache/mime.types.default; then rm -f %D/etc/apache/mime.types; fi
etc/apache/mime.types.default
@exec [ ! -f %B/mime.types ] && cp %B/%f %B/mime.types
@unexec if cmp -s %D/etc/apache/srm.conf %D/etc/apache/srm.conf.default; then rm -f %D/etc/apache/srm.conf; fi
etc/apache/srm.conf.default
@exec [ ! -f %B/srm.conf ] && cp %B/%f %B/srm.conf
etc/rc.d/apache.sh
@ -40,7 +45,9 @@ include/apache/multithread.h
include/apache/os-inline.c
include/apache/os.h
include/apache/rfc1413.h
include/apache/sa_len.h
include/apache/scoreboard.h
include/apache/sockaddr_storage.h
include/apache/util_date.h
include/apache/util_md5.h
include/apache/util_script.h
@ -91,9 +98,12 @@ share/doc/apache/index.html.en
share/doc/apache/index.html.es
share/doc/apache/index.html.fr
share/doc/apache/index.html.it
share/doc/apache/index.html.ja.jis
share/doc/apache/index.html.lu
share/doc/apache/index.html.nl
share/doc/apache/index.html.po.iso-pl
share/doc/apache/index.html.pt
share/doc/apache/index.html.pt-br
share/doc/apache/index.html.se
share/doc/apache/manual/LICENSE
share/doc/apache/manual/bind.html
@ -337,6 +347,8 @@ www/icons/uuencoded.gif
www/icons/world1.gif
www/icons/world2.gif
@exec mkdir -p %D/www/proxy
@unexec if [ -L %D/www/cgi-bin ]; then rm -f %D/www/cgi-bin; fi
@unexec if [ -L %D/www/data ]; then rm -f %D/www/data; fi
@dirrm etc/apache
@dirrm include/apache/xml
@dirrm include/apache