MFH: r484963 r485093
Fix build on FreeBSD 13+ Reported by: pkg-fallout Approved by: ports-secteam (blanket)
This commit is contained in:
parent
0f8f3ac6b3
commit
601bb12e52
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/branches/2018Q4/; revision=485095
@ -33,7 +33,7 @@ WRKSRC= ${WRKDIR}/pyFltk-${PORTVERSION}
|
||||
OPTIONS_DEFINE= DOCS EXAMPLES
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -e "s|/usr/X11R6|${LOCALBASE}|g;s|package_data.*},||g;s|sunos5|dragonfly4', 'freebsd8', 'freebsd9', 'freebsd10', 'freebsd11', 'freebsd12|g" ${WRKSRC}/setup.py
|
||||
@${REINPLACE_CMD} -e 's|/usr/X11R6|${LOCALBASE}|g' ${WRKSRC}/setup.py
|
||||
|
||||
post-build:
|
||||
${REINPLACE_CMD} -e "s|\.\./docs|${DOCSDIR}/html|g" ${WRKSRC}/fltk/test/help.py
|
||||
|
19
x11-toolkits/py-fltk/files/patch-setup.py
Normal file
19
x11-toolkits/py-fltk/files/patch-setup.py
Normal file
@ -0,0 +1,19 @@
|
||||
--- setup.py.orig 2016-12-29 09:36:33 UTC
|
||||
+++ setup.py
|
||||
@@ -106,7 +106,7 @@ elif sys.platform.startswith('linux'):
|
||||
compile_arg_list.append('-Werror=format-security')
|
||||
lib_dir_list = [fltk_lib_dir, '/usr/lib']
|
||||
lib_list = ["fltk"]
|
||||
-elif sys.platform in ['freebsd4','freebsd5','freebsd6','freebsd7', 'sunos5']:
|
||||
+elif sys.platform[0:7] == 'freebsd':
|
||||
print("Building for: %s"%sys.platform)
|
||||
def_list = [('UNIX', '1')]
|
||||
lib_dir_list = [fltk_lib_dir,'/usr/X11R6/lib','/usr/lib']
|
||||
@@ -323,7 +323,6 @@ setup (name = 'pyFltk',
|
||||
description = 'This is a Python wrapper for the FLTK',
|
||||
ext_modules = [module1],
|
||||
packages = ['fltk'],
|
||||
- package_data={'fltk': ['test/*.*', 'docs/*.*']},
|
||||
)
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user