- Update to 0.8.2

This commit is contained in:
Martin Wilke 2006-11-19 13:58:38 +00:00
parent 7a6f7df4c6
commit 60055c62e0
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=177567
3 changed files with 10 additions and 16 deletions

View File

@ -6,7 +6,7 @@
#
PORTNAME= xslt
PORTVERSION= 0.8.1
PORTVERSION= 0.8.2
CATEGORIES= textproc ruby
MASTER_SITES= http://gregoire.lejeune.free.fr/
PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
@ -22,10 +22,15 @@ USE_RUBY_EXTCONF= yes
WRKSRC= ${WRKDIR}/ruby-${PORTNAME}
.include <bsd.port.pre.mk>
post-install:
.if !defined(NOPORTDOCS)
${MKDIR} ${RUBY_MODDOCDIR}
${INSTALL_DATA} ${WRKSRC}/README ${RUBY_MODDOCDIR}
.endif
.include <bsd.port.mk>
.if ${OSVERSION} < 500000
BROKEN= Does not compile on 4.x
.endif
.include <bsd.port.post.mk>

View File

@ -1,3 +1,3 @@
MD5 (ruby/ruby-xslt_0.8.1.tar.gz) = 28cc6a296564178c890ae202ba9aaccf
SHA256 (ruby/ruby-xslt_0.8.1.tar.gz) = b7e989e711ee3322676358fe228945bb9dce8cb880fdb58b24b95b4687b4ae81
SIZE (ruby/ruby-xslt_0.8.1.tar.gz) = 21189
MD5 (ruby/ruby-xslt_0.8.2.tar.gz) = 603615dd4f31fe0981aff7b1bee2a0a6
SHA256 (ruby/ruby-xslt_0.8.2.tar.gz) = 7e7b8c4fdd4f9e4e414e9817ba8e32fea032204902eb2f1f6b9468df081d07a1
SIZE (ruby/ruby-xslt_0.8.2.tar.gz) = 23566

View File

@ -1,11 +0,0 @@
--- extfunc.h.orig Mon Mar 28 21:48:01 2005
+++ extfunc.h Tue Aug 9 17:04:58 2005
@@ -21,7 +21,7 @@
/* this stores function names and the ids of the objects they belong to, indexed by name and namespace */
static xmlHashTablePtr pExtFunctionsHashTable = NULL;
-void deallocateCallback( void *, xmlChar * ATTRIBUTE_UNUSED );
+void deallocateCallback( void *payload, xmlChar *name ATTRIBUTE_UNUSED );
VALUE xpathObj2value( xmlXPathObjectPtr, xmlDocPtr );
xmlXPathObjectPtr value2xpathObj( VALUE );
void xmlXPathFuncCallback( xmlXPathParserContextPtr, int );